Zählen der Anzahl eindeutiger Werte unter Duplikaten

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Angenommen, finden Sie heraus, wie viele eindeutigen Text- oder Zahlenwerte, die es in einem Bereich werden soll. Angenommen, eine Spalte Text Werte Bradley "," David "," David "," David, es gibt zwei eindeutige Werte – Bradley und David. Wenn der Bereich die Zahlen 5, 6, 7 und 6enthält, werden die eindeutigen Werte 5, 6 und 7.

Um nur eindeutige Werte zu zählen, verwenden Sie eine Kombination der folgenden Funktionen, wie im Beispielarbeitsblatt unten dargestellt:

  • Verwenden Sie die Funktion WENN, um jeder Bedingung, die WAHR ist, den Wert "1" zuzuweisen.

  • Verwenden Sie die Funktion SUMME, um alle eindeutigen Werte zu addieren.

  • Verwenden Sie die Funktion HÄUFIGKEIT, um die Anzahl der eindeutigen Werte zu zählen. Diese Funktion ignoriert Text- und Nullwerte. Für das erste Vorkommen eines bestimmten Werts wird eine Zahl zurückgegeben, die der Anzahl der Vorkommen dieses Werts entspricht. Für jedes auf das erste folgende Vorkommen des gleichen Werts gibt die Funktion "0" zurück.

  • Verwenden Sie die Funktion VERGLEICH, um die Position eines Textwerts in einem Bereich zurückzugeben. Die Funktion HÄUFIGKEIT verwendet den sich ergebenden Wert, um die entsprechenden Textwerte auszuwerten.

  • Verwenden Sie die Funktion LÄNGE, um leere Zellen zu finden. Leere Zellen haben die Länge (Zeichenanzahl) 0.

Beispiel

Kopieren Sie die Tabelle in die Zelle A1 auf einem leeren Excel-Arbeitsblatt, damit Sie mit diesen Beispielen für Formeln arbeiten können, in denen Funktionen verwendet werden.

Daten

Daten

986

Bauer

David

563

67

789

235

Bauer

David

689

789

David

143

56

237

67

235

Formel

Beschreibung (Ergebnis)

=SUMME(WENN(HÄUFIGKEIT(A2:A10;A2:A10)>0;1))

Zählt die Anzahl der eindeutigen Zahlenwerte in den Zellen A2:A10, zählt dabei aber keine leeren Zellen oder Textwerte (4)

=SUMME(WENN(HÄUFIGKEIT(VERGLEICH(B2:B10;B2:B10;0),VERGLEICH(B2:B10;B2:B10;0))>0;1))

Zählt die Anzahl der eindeutigen Text- und Zahlenwerte in den Zellen B2:B10 (die keine leeren Zellen enthalten dürfen) (7)

=SUMME(WENN(HÄUFIGKEIT(WENN(LÄNGE(A2:A10)>0;VERGLEICH(A2:A10;A2:A10;0);""); WENN(LÄNGE(A2:A10)>0;VERGLEICH(A2:A10;A2:A10;0);""))>0;1))

Zählt die Anzahl der eindeutigen Text- und Zahlenwerte in den Zellen A2:A10, zählt dabei aber keine leeren Zellen oder Textwerte (6)

Hinweise : 

  • Die Formeln in diesem Beispiel müssen als Matrixformeln eingegeben werden. Wählen Sie jede Zelle, die eine Formel enthält, drücken Sie F2, und drücken Sie dann STRG + UMSCHALT + EINGABETASTE.

  • Wählen Sie zum schrittweisen Anzeigen der Funktionsauswertung die Zelle mit der Formel aus, und klicken Sie dann auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Formel auswerten.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×