Zählen der Anzahl eindeutiger Werte unter Duplikaten

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Angenommen, finden Sie heraus, wie viele eindeutigen Text- oder Zahlenwerte, die es in einem Bereich werden soll. Angenommen, eine Spalte Text Werte Bauer "," David "," David "," David, es gibt zwei eindeutige Werte – Bauer und David. Wenn der Bereich die Zahlen 5, 6, 7 und 6enthält, werden die eindeutigen Werte 5, 6 und 7.

Um nur eindeutige Werte zu zählen, verwenden Sie eine Kombination der folgenden Funktionen, wie im Beispielarbeitsblatt unten dargestellt:

  • Verwenden Sie die Funktion Wenn zum Zuweisen des Werts 1 zu jeder Bedingung, die als WAHR AUSGEWERTET wird.

  • Verwenden Sie die Funktion Summe zum Addieren alle eindeutigen Werte.

  • Verwenden Sie die Häufigkeit-Funktion zum zählen der Anzahl eindeutiger Werte. Diese Funktion ignoriert Text und Nullwerte. Nach dem ersten Vorkommen der einen bestimmten Wert gibt es eine Zahl gleich der Anzahl von Vorkommen des Werts. Für jede Wiederholung des Werts nach dem ersten gibt diese Funktion den Wert 0 zurück.

  • Verwenden Sie die Vergleich (Funktion) , um die Position des einen Textwert in einem Bereich zurück. Die Häufigkeit-Funktion verwendet den Ergebniswert für die entsprechenden Textwerte ausgewertet werden soll.

  • Verwenden Sie die LEN-Funktion , um leere Zellen zu finden. Leere Zellen enthalten die Länge 0 (Anzahl der Zeichen).

Beispiel

Kopieren Sie die Tabelle in die Zelle A1 auf einem leeren Excel-Arbeitsblatt, damit Sie mit diesen Beispielen für Formeln arbeiten können, in denen Funktionen verwendet werden.

Daten

Daten

986

Bauer

David

563

67

789

235

Bauer

David

689

789

David

143

56

237

67

235

Formel

Beschreibung (Ergebnis)

=SUMME(WENN(HÄUFIGKEIT(A2:A10;A2:A10)>0;1))

Zählt die Anzahl der eindeutigen Zahlenwerte in den Zellen A2:A10, zählt dabei aber keine leeren Zellen oder Textwerte (4)

=SUMME(WENN(HÄUFIGKEIT(VERGLEICH(B2:B10;B2:B10;0),VERGLEICH(B2:B10;B2:B10;0))>0;1))

Zählt die Anzahl der eindeutigen Text- und Zahlenwerte in den Zellen B2:B10 (die keine leeren Zellen enthalten dürfen) (7)

=SUMME(WENN(HÄUFIGKEIT(WENN(LÄNGE(A2:A10)>0;VERGLEICH(A2:A10;A2:A10;0);""); WENN(LÄNGE(A2:A10)>0;VERGLEICH(A2:A10;A2:A10;0);""))>0;1))

Zählt die Anzahl der eindeutigen Text- und Zahlenwerte in den Zellen A2:A10, zählt dabei aber keine leeren Zellen oder Textwerte (6)

Hinweise: 

  • Die Formeln in diesem Beispiel müssen als Matrixformeln eingegeben werden. Wählen Sie jede Zelle, die eine Formel enthält, drücken Sie F2, und drücken Sie dann STRG + UMSCHALT + EINGABETASTE.

  • Wählen Sie zum schrittweisen Anzeigen der Funktionsauswertung die Zelle mit der Formel aus, und klicken Sie dann auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Formel auswerten.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×