ZÄHLENWENNS (Funktion)

Die Funktion ZÄHLENWENNS wendet Kriterien auf Zellen in mehreren Bereichen an und zählt, wie oft alle Kriterien zutreffen.

Ihr Browser unterstützt kein Video. Installieren von Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Dieses Video ist Teil des Schulungskurses Erweiterte WENN-Funktionen.

Syntax

ZÄHLENWENNS(Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2]…)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

  • Kriterienbereich1    Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.

  • Kriterien1    Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.

  • Kriterienbereich2;Kriterien2; ...    Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich/Kriterien-Paare zulässig.

Wichtig : Jeder zusätzliche Bereich muss dieselbe Anzahl von Zeilen und Spalten wie das Argument Kriterienbereich1 haben. Die Bereiche müssen nicht direkt nebeneinander liegen.

Hinweise

  • Die Kriterien der einzelnen Bereiche werden jeweils auf eine Zelle angewendet. Wenn alle ersten Zellen den zugehörigen Kriterien entsprechen, erhöht sich die Anzahl um 1. Wenn alle zweiten Zellen den zugehörigen Kriterien entsprechen, erhöht sich die Anzahl nochmals um 1 usw. bis alle Zellen ausgewertet sind.

  • Wenn ein "Kriterien"-Argument ein Bezug auf eine leere Zelle ist, wird die leere Zelle von der Funktion ZÄHLENWENNS als Nullwert (0) behandelt.

  • Eine als Kriterien angegebene Zeichenfolge darf die Platzhalterzeichen Fragezeichen (?) und Sternchen (*) enthalten. Ein Fragezeichen ersetzt ein Zeichen, und ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor das zu suchende Zeichen setzen.

Beispiel 1

Kopieren Sie die Beispieldaten in den folgenden Tabellen, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Verkäufer

Überschrittenes Kontingent für Q1

Überschrittenes Kontingent für Q2

Überschrittenes Kontingent für Q3

Kadenbach

Ja

Nein

Nein

Kutzsche

Ja

Ja

Nein

Endemann

Ja

Ja

Ja

Loetzsch

Nein

Ja

Ja

Formel

Beschreibung

Ergebnis

=ZÄHLENWENNS(B2:D2;"=Ja")

Zählt, wie oft Kadenbach ein Verkaufskontingent für die Zeiträume Q1, Q2 und Q3 überschritten hat (nur in Q1).

1

=ZÄHLENWENNS(B2:B5;"=Ja";C2:C5;"=Ja")

Zählt, wie viele Verkäufer sowohl das Kontingent für Q1 als auch für Q2 überschritten haben (Kutzsche und Endemann).

2

=ZÄHLENWENNS(B5:D5;"=Ja";B3:D3;"=Ja")

Zählt, wie oft Loetzsch und Kutzsche dasselbe Kontingent für die Zeiträume Q1, Q2 und Q3 überschritten haben (nur in Q2).

1

Beispiel 2

Daten

 

1

01.05.2011

2

02.05.2011

3

03.05.2011

4

04.05.2011

5

05.05.2011

6

06.05.2011

Formel

Beschreibung

Ergebnis

=ZÄHLENWENNS(A2:A7;"<6";A2:A7;">1")

Zählt, wie viele Zahlen zwischen 1 und 6 (1 und 6 nicht eingeschlossen) in den Zellen A2 bis A7 enthalten sind.

4

=ZÄHLENWENNS(A2:A7;"<5";B2:B7;"<03.05.2011")

Zählt, wie viele Zeilen in den Zellen A2 bis A7 Zahlen enthalten, die kleiner sind als 5, und außerdem in den Zellen B2 bis B7 Daten aufweisen, die vor dem 03.05.2011 liegen.

2

=ZÄHLENWENNS(A2:A7;"<"&A6;B2:B7;"<"&B4)

Die gleiche Beschreibung wie beim vorherigen Beispiel, jedoch mit Zellbezügen anstelle von Konstanten in den Kriterien.

2

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Zählen von nicht leeren Zellen mit der Funktion ANZAHL2

Zählen von Zellen mit einem einzelnen Kriterium mit der Funktion ZÄHLENWENN

Mit der Funktion SUMMEWENN werden nur die Werte addiert, die einem einzelnen Kriterium entsprechen

Mit der Funktion SUMMEWENNS werden nur die Werte addiert, die mehreren Kriterien entsprechen

Funktion WENNS (Office 365, Excel 2016 und höher)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Statistische Funktionen

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×