Wegweiser: Anzeigen einer mit Daten verbundenen Visio-Zeichnung in einem SharePoint-Webpart

Wenn Sie vielen Personen ausführliche Informationen schnell präsentieren müssen, erstellen Sie ein Visio-Diagramm als SharePoint-Webpart, das einen grafischen Bericht bereitstellt. Visio 2010 ermöglicht es Ihnen, Daten aus externen Quellen wie Excel Services, SQL Server, SharePoint-Listen oder anderen OLE DB- oder ODBC-Datenbanken abzurufen. Anschließend können Sie Datengrafiken auf die Shapes in Ihrer Zeichnung anwenden, um diese externen Daten zu visualisieren, die Zeichnung auf einer SharePoint-Website veröffentlichen und dann das Diagramm mithilfe eines Visio Web Access-Webparts auf der SharePoint-Website anzeigen.

Dies ist ideal zum Erstellen von benutzerdefinierten Dashboards für hilfreiche Business Intelligence-Lösungen. Entscheidungsträger können eine grafische Darstellung der Unternehmensleistung auf einen Blick sehen und aufgrund dieser Informationen schnell handeln. Weitere Informationen zur Verwendung von SharePoint für Business Intelligence finden Sie im Artikel Was ist SharePoint Business Intelligence?

Herunterladen des visuellen Handbuchs

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Inhalt dieses Artikels

Anforderungen

Herunterladen der Vorlage

Schritt 1: Importieren von Daten in die Visio-Zeichnung

Schritt 2: Anwenden von Datengrafiken auf Shapes

Schritt 3: Anzeigen des Diagramms in einem SharePoint-Webpart

Optional: Interaktives Gestalten des Visio Web Access-Webparts

Anforderungen

Das Visio Web Access-Webpart ist ein Feature von Visio Services, einem in Microsoft SharePoint Server 2010 integrierten Service. Um Visio Services verwenden zu können, müssen Sie über die Microsoft SharePoint Server 2010 Enterprise-Clientzugriffslizenz (Enterprise Client Access License, ECAL) verfügen, und Visio Services muss bereitgestellt werden.

Außerdem müssen Sie über Microsoft Visio Professional 2010 oder Microsoft Visio Premium 2010 verfügen, um ein Diagramm auf einer SharePoint-Website speichern zu können.

Weitere Informationen zu den erforderlichen Schritten, die Sie zum Aktivieren von Visio Services auf einer SharePoint-Website ausführen müssen, finden Sie unter Visio-Grafikdienstverwaltung.

Seitenanfang

Herunterladen der Vorlage

Sie können die im Video vorgestellte Vorlage und das oben genannte visuelle Handbuch herunterladen und verwenden. Die Vorlage enthält die Beispieldaten und Datengrafiken, die in den Beispielen verwendet werden.

Herunterladen des Beispieldiagramms und der Beispieldaten

Seitenanfang

Schritt 1: Importieren von Daten in die Visio-Zeichnung

  1. Klicken Sie in Visio auf der Registerkarte Daten in der Gruppe Externe Daten auf Daten mit Shapes verknüpfen.

Wählen Sie auf der ersten Seite des Assistenten für die Datenauswahl die gewünschte Datenquelle aus.

Wichtig :  Access Services kann nicht als Datenquelle für eine Visio Services-Webzeichnung verwendet werden. Einige Diagrammtypen, z. B. Pivotdiagramme, sind nicht aktualisierbar, wenn sie auf der SharePoint-Website veröffentlicht werden. Sorgen Sie deshalb zur Erzielung optimaler Ergebnisse dafür, dass Ihre Datenquelle auf derselben SharePoint-Website wie das Visio Services-Webpart gespeichert wird.

  1. Führen Sie die Anweisungen im Assistenten für die Datenauswahl aus.

  2. Nachdem Sie auf der letzten Seite des Assistenten für die Datenauswahl auf Fertig stellen geklickt haben, wird das Fenster Externe Daten mit den importierten Daten in einer Tabelle angezeigt.

  3. Wenn Sie Daten aus der externen Quelle auf ein Shape in Ihrer Zeichnung anwenden möchten, ziehen Sie eine Zeile aus dem Fenster Externe Daten auf das Shape.

Weitere Informationen zum Importieren von Daten aus einer externen Datenquelle in Visio finden Sie unter Importieren von Daten aus Excel, SQL Server, SharePoint und anderen externen Quellen.

Seitenanfang

Schritt 2: Anwenden von Datengrafiken auf Shapes

Gehen Sie folgendermaßen vor, um eine neue Datengrafik zu erstellen:

  1. Klicken Sie in Visio auf der Registerkarte Daten in der Gruppe Daten anzeigen auf Datengrafiken und dann auf Neue Datengrafik erstellen.

  2. Führen Sie im Dialogfeld Neues Element eine der folgenden Aktionen aus:

    1. Klicken Sie unter Anzeige in der Liste Datenfeld auf das Feld Shape-Daten, das grafisch dargestellt werden soll.

    2. Wählen Sie außerdem unter Anzeige in der Liste Angezeigt als die Grafik aus, die das Datenfeld am besten darstellt (Text, Datenbalken, Symbolsatz oder Farbe nach Wert.)

    3. Und wählen Sie unter Anzeige in der Liste Format das gewünschte Grafikformat aus. (Wenn Sie Farbe nach Wert als Grafiktyp auswählen, ist dies die Liste Färbmethode.)

    4. Passen Sie die Grafik unter Details nach Bedarf an.

    5. Klicken Sie auf OK, um die Bearbeitung des Grafikelements abzuschließen.

  3. Wiederholen Sie den vorherigen Schritt so oft, bis Sie für jedes anzuzeigende Shape-Datenfeld ein Element erstellt haben.

Gehen Sie folgendermaßen vor, um eine Datengrafik auf Shapes in der Zeichnung anzuwenden:

  1. Wählen Sie auf dem Zeichenblatt das Shape aus, auf das die Datengrafik angewendet werden soll.

Hinweis :  Halten Sie STRG gedrückt, um mehrere Shapes auf dem Zeichenblatt auszuwählen. Wählen Sie dann jedes einzelne Shape aus, auf das die Datengrafik angewendet werden soll.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Daten anzeigen auf Datengrafiken und dann unter Verfügbare Datengrafiken auf die gewünschte Grafik.

Weitere Informationen zum Erstellen und Anwenden von Datengrafiken finden Sie unter Erweitern von Daten mit Datengrafiken.

Seitenanfang

Schritt 3: Anzeigen des Diagramms in einem SharePoint-Webpart

  1. Klicken Sie auf der Seite der SharePoint-Website, auf der Sie das Webpart hinzufügen möchten, auf die Registerkarte Seite und dann in der Gruppe Bearbeiten auf Bearbeiten.

  2. Klicken Sie unter Bearbeitungstools auf der Registerkarte Einfügen in der Gruppe Webparts auf Webpart. Führen Sie dann die folgenden Aktionen aus:

    1. Klicken Sie unter Kategorien auf Geschäftsdaten.

    2. Klicken Sie unter Webparts auf Visio Web Access.

    3. Klicken Sie auf Hinzufügen.

  3. Klicken Sie im Visio Web Access-Webpart auf den Link zum Öffnen des Toolbereichs.

  4. Erweitern Sie im Toolbereich die Option Webzeichnungsanzeige. Wechseln Sie dann im Feld Webzeichnungs-URL zu der Visio-Webzeichnung, die angezeigt werden soll.

Wichtig :  Bevor Sie ein Diagramm mithilfe von Visio Web Access in einem Webpart anzeigen können, müssen Sie die Visio-Datei auf der SharePoint-Website als Webzeichnung veröffentlichen. Weitere Informationen zum Veröffentlichen einer Visio-Webzeichnung auf einer SharePoint-Website finden Sie unter Wegweiser: Veröffentlichen von Visio-Zeichnungen auf einer SharePoint-Website.

  1. Klicken Sie unten im Toolbereich auf Übernehmen und dann auf OK.

Weitere Informationen zum Anzeigen einer Visio-Webzeichnung in einem Webpart finden Sie unter Anzeigen einer Visio-Webzeichnung in einem Webpart.

Seitenanfang

Optional: Interaktives Gestalten des Visio Web Access-Webparts

Wenn Sie in ECMAScript programmieren können, können Sie das Visio Web Access-Webpart anpassen, um grafische Überlagerungen einzuschließen. In diesen werden zusätzliche Informationen zu den Shapes in der Visio-Zeichnung angezeigt.

Weitere Informationen zum Programmieren eines interaktiven Elements für eine Visio-Zeichnung auf einer Webpartseite finden Sie unter MSDN: Erstellen einer ECMAScript Mashup-Zeichnung in Visio 2010 zum Anzeigen in SharePoint Server 2010.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×