WVERWEIS (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion WVERWEIS in Microsoft Excel beschrieben.

Beschreibung

Sucht in der obersten Zeile einer Tabelle oder einer Matrix (Array) nach Werten und gibt dann in der gleichen Spalte einen Wert aus einer Zeile zurück, die Sie in der Tabelle oder Matrix angeben. Verwenden Sie WVERWEIS, wenn sich die Vergleichswerte in einer Zeile am Anfang einer Datentabelle befinden und Sie eine bestimmte Anzahl von Spalten nach unten durchsuchen möchten. Verwenden Sie SVERWEIS, wenn sich die Vergleichswerte in einer Spalte links neben den Daten befinden, die Sie durchsuchen möchten.

Das "W" in WVERWEIS steht für "Waagerecht".

Syntax

WVERWEIS(Suchkriterium;Matrix;Zeilenindex;[Bereich_Verweis])

Die Syntax der Funktion WVERWEIS weist die folgenden Argumente auf:

  • Suchkriterium    Erforderlich. Der Wert, der in der ersten Zeile der Tabelle gefunden werden soll. "Suchkriterium" kann ein Wert, ein Bezug oder eine Zeichenfolge sein.

  • Matrix    Erforderlich. Eine Tabelle mit Informationen, in der Daten gesucht werden. Verwenden Sie einen Bezug auf einen Bereich oder einen Bereichsnamen.

    • Bei den Werten in der ersten Zeile von "Matrix" kann es sich um Text, Zahlen oder Wahrheitswerte handeln.

    • Wenn "Bereich_Verweis" WAHR ist, müssen die Werte in der ersten Zeile von "Matrix" in aufsteigender Reihenfolge angeordnet werden: ..., -2, -1, 0, 1, 2, ..., A-Z, FALSCH, WAHR; andernfalls gibt WVERWEIS möglicherweise nicht den richtigen Wert zurück. Wenn "Bereich_Verweis" FALSCH ist, muss "Matrix" nicht sortiert werden.

    • Bei Zeichenfolgen (Texten) wird nicht zwischen Groß- und Kleinbuchstaben unterschieden.

    • Sortieren Sie die Werte in aufsteigender Reihenfolge von links nach rechts. Weitere Informationen finden Sie unter Sortieren von Daten in einem Bereich oder einer Tabelle.

  • Zeilenindex    Erforderlich. Die Nummer der Zeile in "Matrix", aus der der entsprechende Wert zurückgegeben wird. Ein Zeilenindex von 1 gibt den ersten Zeilenwert in "Matrix" zurück, ein Zeilenindex von 2 gibt den zweiten Zeilenwert in "Matrix" zurück usw. Wenn "Zeilenindex" kleiner als 1 ist, gibt WVERWEIS den Fehlerwert #WERT! zurück; wenn "Zeilenindex" größer als die Anzahl der Zeilen in "Matrix" ist, gibt WVERWEIS den Fehlerwert #BEZUG! zurück.

  • Bereich_Verweis    Optional. Ein Wahrheitswert, der angibt, ob WVERWEIS eine genaue Entsprechung oder eine ungefähre Entsprechung suchen soll. Wenn dieser Parameter WAHR ist oder weggelassen wird, wird eine ungefähre Entsprechung zurückgegeben. Anders ausgedrückt, wird der nächstgrößere Wert zurückgegeben, der kleiner als "Suchkriterium" ist, wenn keine genaue Entsprechung gefunden wird. Ist der Parameter FALSCH, sucht WVERWEIS eine genaue Entsprechung. Wenn keine gefunden wird, wird der Fehlerwert #NV zurückgegeben.

Hinweis

  • Wenn WVERWEIS das Suchkriterium nicht finden kann und "Bereich_Verweis" WAHR ist, wird der größte Wert verwendet, der kleiner als "Suchkriterium" ist.

  • Wenn "Suchkriterium kleiner als der kleinste Wert in der ersten Zeile von "Matrix" ist, gibt WVERWEIS den Fehlerwert #NV zurück.

  • Wird "Bereich_Verweis" als FALSCH ausgewertet, und ist als Suchkriterium eine Zeichenfolge angegeben, können Sie im Suchkriterium Platzhalterzeichen, Fragezeichen und Sternchen (*) verwenden. Ein Fragezeichen ersetzt ein Zeichen; ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor das zu suchende Zeichen setzen.

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Achsen

Getriebe

Schrauben

4

4

9

5

7

10

6

8

11

Formel

Beschreibung

Ergebnis

=WVERWEIS("Achsen";A1:C4;2;WAHR)

Sucht "Achsen" in Zeile 1 und gibt den Wert aus Zeile 2 zurück, der in derselben Spalte (Spalte A) steht.

4

=WVERWEIS("Getriebe";A1:C4;3;FALSCH)

Sucht "Getriebe" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte (Spalte B) steht.

7

=WVERWEIS("B";A1:C4;3;WAHR)

Sucht "B" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte steht. Da für "B" keine genaue Entsprechung gefunden wird, wird der höchste Wert in Zeile 1 verwendet, der kleiner ist als "B": "Achsen" in Spalte A.

5

=WVERWEIS("Schrauben";A1:C4;4)

Sucht "Schrauben" in Zeile 1 und gibt den Wert aus Zeile 4 zurück, der in derselben Spalte (Spalte C) steht.

11

=WVERWEIS(3;{1.2.3;"a"."b"."c";"d"."e"."f"};2;WAHR)

Sucht die Zahl 3 in der dreizeiligen Matrixkonstanten und gibt den Wert aus Zeile 2 in derselben Spalte (in diesem Fall der dritten Spalte) zurück. Die Matrixkonstante umfasst drei Zeilen, die jeweils durch ein Semikolon (;) getrennt sind. Da "c" in Zeile 2 und in derselben Spalte wie 3 gefunden wird, wird "c" zurückgegeben.

c

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×