WENNFEHLER (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion WENNFEHLER in Microsoft Excel beschrieben.

Beschreibung

Gibt einen von Ihnen festgelegten Wert zurück, wenn eine Formel einen Fehler ergibt. Andernfalls wird das Ergebnis der Formel ausgegeben. Verwenden Sie die Funktion WENNFEHLER, um Fehler in einer Formel aufzufangen und zu verarbeiten.

Syntax

WENNFEHLER(Wert;Wert_falls_Fehler)

Die Syntax der Funktion WENNFEHLER weist die folgenden Argumente auf:

  • Wert    Erforderlich. Das Argument, das auf einen Fehler geprüft wird

  • Wert_falls_Fehler    Erforderlich. Der Wert, der zurückgegeben wird, wenn die Formel einen Fehler ergibt. Die folgenden Fehlertypen werden ausgewertet: #NV, #WERT!, #BEZUG!, #DIV/0!, #ZAHL!, #NAME? oder #NULL!.

Hinweise

  • Wenn "Wert" oder "Wert_falls_Fehler" eine leere Zelle darstellt, behandelt WENNFEHLER diese als leeren Zeichenfolgenwert ("").

  • Wenn "Wert" eine Matrixformel ist, gibt WENNFEHLER für jede Zelle im Bereich, der in "Wert" angegeben ist, eine Matrix von Ergebnissen zurück. Betrachten Sie hierzu das zweite Beispiel unten.

Beispiele

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Kontingent

Verkaufte Einheiten

210

35

55

0

23

Formel

Beschreibung

Ergebnis

=WENNFEHLER(A2/B2;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument (210 durch 35 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

6

=WENNFEHLER(A3/B3;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument (55 durch 0 dividieren), findet den Fehler "Division durch 0", und gibt dann den "Wert_falls_Fehler" zurück.

Berechnungsfehler

=WENNFEHLER(A4/B4;"Berechnungsfehler")

Sucht in der Formel nach einem Fehler im ersten Argument ("" durch 23 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

0

Beispiel 2

Kontingent

Verkaufte Einheiten

Verhältnis

210

35

6

55

0

Berechnungsfehler

23

0

Formel

Beschreibung

Ergebnis

=C2

Sucht in der Formel nach einem Fehler im ersten Argument des ersten Elements der Matrix (A2/B2 oder 210 durch 35 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

6

=C3

Sucht in der Formel nach einem Fehler im ersten Argument des zweiten Elements der Matrix (A3/B3 oder 55 durch 0 dividieren), findet den Fehler "Division durch 0" und gibt dann "Wert_falls_Fehler" zurück.

Berechnungsfehler

=C4

Sucht in der Formel nach einem Fehler im ersten Argument des dritten Elements der Matrix (A4/B4 oder "" durch 23 dividieren), findet keinen Fehler, und gibt dann das Ergebnis der Formel zurück.

0

Hinweis: Die Formel im Beispiel muss als Matrixformel eingegeben werden. Nachdem Sie das Beispiel in ein leeres Arbeitsblatt kopiert haben, markieren Sie den Bereich C2:C4, drücken Sie F2, und drücken Sie dann STRG+UMSCHALT+EINGABE.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×