WENN-Funktion

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Die WENN-Funktion ist eine der am häufigsten verwendeten Funktionen in Excel. Sie ermöglicht den logischen Vergleich zwischen einem aktuellen Wert und einem erwarteten Wert. In ihrer einfachsten Form besagt die WENN-Funktion Folgendes:

  • WENN(ein Wert wahr ist, tue dieses, andernfalls tue etwas anderes)

Daher kann eine WENN-Anweisung zwei Ergebnisse haben. Das erste Ergebnis wird ausgegeben, wenn der Vergleich wahr ist, das zweite, wenn der Vergleich falsch ist.

Wenn Sie mit mehreren WENN-Anweisungen arbeiten möchten, lesen Sie: Erweiterte WENN-Funktionen – Arbeiten mit geschachtelten Formeln und Vermeiden von Fallgruben.

Verwenden Sie die Funktion WENN, eine der logischen Funktionen, um einen Wert zurückzugeben, wenn eine Bedingung erfüllt ist, und ein anderen Wert, wenn die Bedingung nicht erfüllt ist.

Syntax

WENN(Prüfung;Dann_Wert;[Sonst_Wert])

Beispiel:

  • =WENN(A2>B2;"Budget überschritten";"OK")

  • =WENN(A2=B2;B4-A4;"")

Argumentname

Beschreibung

Prüfung    (erforderlich)

Die zu prüfende Bedingung.

Dann_Wert    (erforderlich)

Der Wert, der zurückgegeben werden soll, wenn das Ergebnis der Prüfung WAHR ist.

Sonst_Wert    (optional)

Der Wert, der zurückgegeben werden soll, wenn das Ergebnis der Prüfung FALSCH ist.

Einfache Beispiele für die WENN-Funktion

Zelle D2 enthält die Formel =WENN(C2="Ja";1;2)
  • =WENN(C2="JA";1;2)

Im vorstehenden Beispiel lautet die Anweisung in Zelle D2: WENN(C2 = Ja, gib 1 zurück, andernfalls gib 2 zurück)

Zelle D2 enthält die Formel =WENN(C2=1;"JA";"NEIN")
  • =WENN(C2=1;"Ja";"Nein")

In diesem Beispiel lautet die Formel in Zelle D2 wie folgt: WENN(C2 = 1 ist, gib "Ja" zurück, andernfalls "Nein")

Wie Sie sehen, kann die WENN-Funktion zum Auswerten von Text und Werten verwendet werden. Sie kann auch zum Auswerten von Fehlern verwendet werden. Sie sind nicht darauf beschränkt zu prüfen, ob ein Wert gleich einem anderen ist, sodass ein einziges Ergebnis zurückgegeben wird, Sie können auch mathematische Operatoren verwenden und abhängig von Ihren Kriterien weitere Berechnungen anstellen. Sie können auch mehrere WENN-Funktionen schachteln, um mehrere Vergleiche anzustellen.

Hinweis : Wenn Sie Text in Formeln verwenden, müssen Sie den Text in Anführungszeichen setzen (z. B. "Text"). Die einzige Ausnahme ist die Verwendung von WAHR und FALSCH, was von Excel automatisch verstanden wird.

Erste Schritte

Die beste Methode, um mit dem Schreiben einer WENN-Funktion zu beginnen, besteht darin zu überlegen, was Sie erreichen möchten. Welchen Vergleich möchten Sie anstellen? In vielen Fällen kann das Schreiben einer WENN-Anweisung ganz einfach und logisch sein, wenn Sie sich die folgende Frage stellen: "Was soll passieren, wenn diese Bedingung zutrifft, und was, wenn sie nicht zutrifft?" Sie sollten immer sicherstellen, dass Ihre Schritte einen logischen Fortgang nehmen, andernfalls führt die Formel möglicherweise nicht zum erwarteten Ergebnis. Dies ist besonders bei komplexen (geschachtelten) WENN-Anweisungen wichtig.

Weitere Beispiele für die WENN-Funktion

Die Formel in Zelle D2 lautet =WENN(C2>B2;"Über Budget";"In Budget")
  • =WENN(C2>B2;"Budget überschritten";"In Budget")

Im vorstehenden Beispiel besagt die WENN-Funktion in D2 Folgendes: WENN(C2 größer als B2 ist, gib "Budget überschritten" zurück, andernfalls "In Budget")

Die Formel in Zelle E2 lautet =WENN(C2>B2;C2-B2;"")
  • =WENN(C2>B2;C2-B2;0)

In der vorstehenden Abbildung wird anstelle eines Textergebnisses eine mathematische Berechnung zurückgegeben. Die Formel in E2 besagt also: WENN(der aktuelle Wert größer als der budgetierte Wert ist, subtrahiere den budgetierten Wert vom aktuellen Wert, andernfalls gib nichts zurück).

Die Formel in Zelle F7 lautet WENN(E7="Ja";F5*0,0825;0)
  • =WENN(E7="Ja";F5*0,0825;0)

In diesem Beispiel besagt die Formel in F7 Folgendes: WENN(E7 gleich "Ja" ist, multipliziere die Gesamtsumme in F5 mit 8,25%. Andernfalls ist keine Umsatzsteuer fällig, also gib 0 zurück).

Bewährte Methoden – Konstanten

Im letzten Beispiel wurden sowohl "Ja" als auch die Umsatzsteuerrate (0,0825) direkt in die Formel eingegeben. Im Allgemeinen ist es nicht zu empfehlen, Literalkonstanten (Werte, die sich von Zeit zu Zeit ändern können) direkt in Formeln einzugeben, denn sie sind möglicherweise schwer zu finden und erschweren damit zukünftige Änderungen. Es ist besser, Konstanten in eigene Zellen einzugeben, in denen sie offensichtlich sind und damit einfach gefunden und geändert werden können. In diesem Fall ist das in Ordnung, denn es gibt nur eine WENN-Funktion, und die Umsatzsteuerrate wird nur selten geändert. Und auch wenn sie sich ändert, kann sie in der Formel einfach angepasst werden.

Berechnungsoperatoren

Wenn Sie weitere Informationen zu den verschiedenen Berechnungsoperatoren in Formeln können möchten (< kleiner als Wert größer als = gleich ><> nicht gleich, zu usw.), finden Sie im Artikel: Berechnung-Operatoren und Rangfolge.

Verwenden von WENN, um zu prüfen, ob eine Zelle leer ist

Manchmal müssen Sie prüfen, ob eine Zelle leer ist, in der Regel, weil Sie nicht möchten, dass eine Formel ein Ergebnis ohne Eingabe anzeigt.

Die Formel in Zelle E2 lautet =WENN(D2=1;"Ja";WENN(D2=2;"Nein";"Vielleicht"))

In diesem Fall verwenden wir IST mit der ISTLEER :

  • =WENN(ISTLEER(D2);"Leer";"Nicht Leer")

Die Formel besagt Folgendes: WENN(D2 leer ist, gib "Leer" zurück, andernfalls gib "Nicht Leer" zurück). Sie können auch ganz einfach eine eigene Formel für die "Nicht Leer"-Bedingung verwenden. Im nächsten Beispiel verwenden wir "" anstelle von ISTLEER. Das "" bedeutet im Wesentlichen "nichts".

Überprüfen, ob eine Zelle leer ist – die Formel in Zelle E2 lautet =WENN(ISTLEER(D2);"Leer";"Nicht Leer")
  • =WENN(D3="";"Leer";"Nicht Leer")

Diese Formel besagt Folgendes: WENN(D3 nichts ist, gib "Leer" zurück, andernfalls "Nicht leer"). Nachfolgend ein Beispiel für eine sehr häufige Methode zur Verwendung von "" zur Verhinderung der Berechnung einer Formel, wenn eine abhängige Zelle leer ist:

  • =WENN(D3="";"";IhreFormel())

    WENN(D3 nichts ist, gib nichts zurück, andernfalls berechne die Formel).

Beispiel für eine geschachtelte WENN-Funktion

Eine einfache WENN-Funktion hat nur zwei Ergebnisse (WAHR und FALSCH), geschachtelte WENN-Funktionen können jedoch zwischen drei und 64 Ergebnisse aufweisen.

Verwenden von "", um auf eine leere Zelle zu überprüfen – die Formel in E3 lautet =WENN(D3="";"Leer";"Nicht Leer")
  • =WENN(D2=1;"JA";WENN(D2=2;"Nein";"Vielleicht"))

In der obigen Abbildung, die Formel in E2 besagt: IF (D2 gleich 1 dann zurückgegeben "Ja", andernfalls, WENN (D2 gleich 2 und Absenderadresse "Nein", andernfalls zurück "Vielleicht")). Hinweis: Es werden zwei schließende runde Klammern am Ende der Formel. Führen Sie die beiden WENN-Funktionen erforderlich sind, und wenn Sie versuchen, geben Sie die Formel, ohne die schließende runde Klammern beide, versucht Excel, die für Sie zu beheben.

Seien Sie vorsichtig!

Excel ermöglicht zwar das Schachteln von bis zu 64 unterschiedlichen WENN-Funktionen, dennoch ist das nicht ratsam. Warum?

  • Mehrere WENN-Anweisungen erfordern ein hohes Maß an Konzentration, um korrekt erstellt zu werden und um sicherzustellen, dass deren Logik über jede Bedingung bis zum Schluss ordnungsgemäß berechnet wird. Werden die WENN-Anweisungen nicht zu 100 % korrekt geschachtelt, funktioniert die Formel möglicherweise nur zu 75 % und gibt in 25 % der Fälle unerwartete Ergebnisse zurück. Unglücklicherweise ist es fast unmöglich, diese problematischen 25 % abzufangen.

  • Mehrere WENN-Anweisungen sind ggf. sehr schwierig zu verwalten, besonders, wenn Sie später noch einmal darauf zurückkommen und versuchen herauszufinden, was Sie, oder – noch schlimmer – eine andere Person hiermit erreichen wollten.

  • Mehrere IF-Anweisungen erfordern mehrere öffnen "und" schließenden Klammern (), die kann schwierig sein, je nachdem, wie komplex die Formel wird verwalten.

Häufig auftretende Probleme

Problem

Ursache

0 (Null) in der Zelle

Es ist entweder für Dann_Wert oder für Sonst_Wert kein Argument angegeben. Damit der richtige Wert zurückgegeben wird, fügen Sie Argumenttext zu den beiden Argumenten hinzu, oder geben Sie WAHR oder FALSCH für das Argument an.

#NAME? in der Zelle

Dies bedeutet normalerweise, dass die Formel falsch geschrieben wurde.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Video zum Verwenden der WENN-Funktion anzeigen

WENNS-Funktion (Office 365, Excel 2016 und höher)

Erweiterte WENN-Funktionen – Arbeiten mit geschachtelten Formeln und Vermeiden von Fallgruben

Schulungsvideos: Erweiterte WENN-Funktionen

Die Funktion ZÄHLENWENN zählt Werte basierend auf einem einzigen Kriterium

Die Funktion ZÄHLENWENN zählt Werte basierend auf mehreren Kriterien

Die Funktion SUMMEWENN addiert Summen basierend auf einem einzigen Kriterium

Die Funktion SUMMEWENNS addiert Summen basierend auf mehreren Kriterien

UND-Funktion

ODER-Funktion

SVERWEIS-Funktion

Übersicht über Formeln in Excel

Vermeiden von fehlerhaften Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Logikfunktionen

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×