Verwenden von verschachtelten Funktionen in einer Formel

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Die Verwendung einer Funktion als eines der Argumente in einer Formel, die eine Funktion verwendet, wird "Verschachteln" genannt und die entsprechende Funktion als "verschachtelte Funktion" bezeichnet. Bei der folgenden Formel wird beispielsweise durch Verschachteln der Funktionen MITTELWERT und SUMME in den Argumenten der Funktion WENN eine Gruppe von Zahlen "(G2:G5)" nur dann addiert, wenn der Mittelwert einer anderen Gruppe von Zahlen "(F2:F5)" größer ist als 50. Andernfalls wird "0" zurückgegeben.

Verschachtelte Funktionen

Die Funktionen MITTELWERT und SUMME werden in der Funktion WENN verschachtelt.

Sie können Funktionen in einer Formel auf bis zu 64 Ebenen verschachteln.

  1. Klicken Sie auf die Zelle, in der Sie die Formel eingeben möchten.

  2. Wenn Sie die Formel mit der Funktion beginnen möchten, klicken Sie in der Bearbeitungsleiste Schaltflächensymbol auf Funktion einfügen  Schaltflächensymbol .

    Von Excel wird automatisch das Gleichheitszeichen (=) eingefügt.

  3. Klicken Sie im Feld Kategorie auswählen auf Alle.

    Wenn Sie mit den Funktionskategorien vertraut sind, können Sie auch eine Kategorie auswählen.

    Wenn Sie nicht sicher sind, welche Funktion zu verwenden ist, können Sie eine Frage zur gewünschten Funktion in das Feld Funktion suchen eingeben (z. B. gibt "Zahlen addieren" die Funktion SUMME zurück).

  4. Wenn Sie eine andere Funktion als Argument eingeben möchten, geben Sie diese in das gewünschte Argumentfeld ein.

    Die Teile der Formel, die im Dialogfeld Funktionsargumente angezeigt werden, geben die von Ihnen im vorherigen Schritt ausgewählte Funktion wieder.

    Wenn Sie auf WENN geklickt haben, werden im Dialogfeld Funktionsargumente die Argumente für die Funktion WENN angezeigt. Um eine weitere Funktion zu verschachteln, können Sie diese in das Argumentfeld eingeben. Beispielsweise können Sie SUMME(G2:G5) in das Feld Dann_Wert der Funktion WENN eingeben.

  5. Geben Sie zusätzliche Argumente ein, die zum Vervollständigen der Formel erforderlich sind.

    Statt Zellbezüge einzugeben, können Sie auch die Zellen markieren, auf die verwiesen werden soll. Klicken Sie auf Schaltflächensymbol , um das Dialogfeld zu minimieren, markieren Sie die Zellen, auf die verweisen werden soll, und klicken Sie dann auf Schaltflächensymbol , um das Dialogfeld wieder zu erweitern.

    Tipp: Weitere Informationen zur Funktion und ihren Argumenten erhalten Sie, wenn Sie auf Hilfe für diese Funktion klicken.

  6. Nachdem Sie die Argumente für die Formel vervollständigt haben, klicken Sie auf OK.

  1. Klicken Sie auf die Zelle, in der Sie die Formel eingeben möchten.

  2. Wenn Sie die Formel mit der Funktion beginnen möchten, klicken Sie in der Bearbeitungsleiste Schaltflächensymbol auf Funktion einfügen  Schaltflächensymbol .

  3. Wählen Sie im Dialogfeld "Funktion einfügen" im Feld Kategorie auswählen die Option Alle aus.

    Wenn Sie mit den Funktionskategorien vertraut sind, können Sie auch eine Kategorie auswählen.

  4. Wenn Sie eine andere Funktion als Argument eingeben möchten, geben Sie diese in das Argumentfeld im Formel-Generator oder direkt in die Zelle ein.

  5. Geben Sie zusätzliche Argumente ein, die zum Vervollständigen der Formel erforderlich sind.

  6. Nachdem Sie die Argumente für die Formel vervollständigt haben, drücken Sie die EINGABETASTE.

Beispiele

Die folgende Abbildung zeigt ein Beispiel für die Verwendung von geschachtelten WENN-Funktionen, um einer Testpunktzahl eine Einstufung zuzuweisen.

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Punktzahl

45

90

78

Formel

Beschreibung

Ergebnis

'=WENN(A2>89;"A";WENN(A2>79;"B";WENN(A2>69;"C";WENN(A2>59;"D";"F"))))

Verwendet verschachtelte WENN-Bedingungen, um der Punktzahl in Zelle A2 eine Einstufung zuzuordnen.

=WENN(A2>89;"A";WENN(A2>79;"B";WENN(A2>69;"C";WENN(A2>59;"D";"F"))))

'=WENN(A3>89;"A";WENN(A3>79;"B";WENN(A3>69;"C";WENN(A3>59;"D";"F"))))

Verwendet verschachtelte WENN-Bedingungen, um der Punktzahl in Zelle A3 eine Einstufung zuzuordnen.

=WENN(A3>89;"A";WENN(A3>79;"B";WENN(A3>69;"C";WENN(A3>59;"D";"F"))))

'=WENN(A4>89;"A";WENN(A4>79;"B";WENN(A4>69;"C";WENN(A4>59;"D";"F"))))

Verwendet verschachtelte WENN-Bedingungen, um der Punktzahl in Zelle A4 eine Einstufung zuzuordnen.

=WENN(A4>89;"A";WENN(A4>79;"B";WENN(A4>69;"C";WENN(A4>59;"D";"F"))))

Tipps: 

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Video: Geschachtelte WENN-Funktionen

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×