Verwenden von strukturierten Verweisen in Formeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Hinweis : Dieser Artikel hat seine Aufgabe erfüllt und wird bald zurückgezogen. Um Probleme vom Typ "Seite nicht gefunden" zu vermeiden, entfernen wir Links, die uns bekannt sind. Wenn Sie Links zu dieser Seite erstellt haben, entfernen Sie diese. Gemeinsam sorgen wir für funktionierende Verbindungen mit dem Internet.

Strukturierte Verweise machen Sie es einfacher und weitere für die Arbeit mit Tabellendaten, wenn Sie Formeln verwenden, in denen eine Tabelle – verwiesen intuitive entweder Teile einer Tabelle oder die gesamte Tabelle. Sie sind besonders hilfreich, da Tabellendatenbereiche häufig ändern und die Zellbezüge für strukturierte Verweise automatisch angepasst. Dadurch wird die Formeln neu zu schreiben, wie Zeilen und Spalten hinzugefügt oder in einer Tabelle gelöscht werden, oder beim Aktualisieren von externer Daten müssen minimiert

Sie können aus guten Gründen diesem strukturierten Verweis

den Vorzug vor diesem Zellbezug geben

=SUMME(DailyExercise[CardioTraining])

=SUMME(C2:C7)

Bestandteile eines strukturierten Verweises

Zum effektiven Arbeiten mit Tabellen und strukturierten Verweisen müssen Sie verstehen, wie Sie die Syntax strukturierter Verweise beim Erstellen von Formeln erzeugen. Die Komponenten eines strukturierten Verweises werden im folgenden Beispiel einer Formel zum Berechnen der durchschnittlichen Minutenanzahl in "CardioTraining" veranschaulicht:

=MITTELWERT(DailyExercise[[#Data],[CardioTraining]])

Legende 1 Geben Sie einen aussagekräftigen Namen in Bezug auf die eigentlichen Tabellendaten, wie DailyExercise (und schließen Sie die Kopf- und Summenzeilen, sofern vorhanden).

Schaltflächensymbol #Data ist ein Bezeichner für besondere Elemente, der auf einen bestimmten Teil der Tabelle (die Daten) verweist.

Legende 3 CardioTraining ist ein Spaltenbezeichner, der von der Spaltenüberschrift abgeleitet wird. 

Schritt 4  Der Tabellenbezeichner besteht aus sowohl die Bezeichner für besondere Elemente und dem Spaltenbezeichner in einen weiteren Satz Klammern eingeschlossen.

Legende 5  Der Tabellenname, Spalte, und Bezeichner für besondere Elemente bilden zusammen einen strukturierten Verweis.

Hinweis : Wenn Sie strukturierte Verweise innerhalb einer Tabelle verwenden, müssen Sie nicht den Namen der Tabelle oder die Klammern der Tabellenbezeichner einbezogen werden sollen. Dies ist einen nicht qualifizierten Bezug bezeichnet. Für die oben genannten Beispiel ist nicht qualifizierte Bezug =AVERAGE([#Data],[CardioTraining]). Es ist Ihre strukturierten Verweise qualifizieren Gewohnheit, für den Fall, dass Sie eine Formel außerhalb der Tabelle verschieben möchten.

Bezeichner für besondere Elemente

Mithilfe von Bezeichnern für besondere Elemente können Sie sich auf genau die gewünschten Zeilen beziehen, ohne die Zeilennummern kennen zu müssen.

Besondere Elemente Spaltenbezeichner

Verweist auf

#All

Die gesamte Tabelle, einschließlich der Spaltenüberschriften, Daten und Summen.

#Data

Nur die Datenzeilen.

#Headers

Nur die Kopfzeile.

#Totals

Nur die Summenzeile. Falls sie nicht vorhanden ist, wird null zurückgegeben.

"#This Row" oder "@"

Nur die Zellen in der gleichen Zeile wie die Formel. Dieser Bezeichner kann nicht mit anderen Bezeichnern für besondere Elemente kombiniert werden.

Syntaxregeln für strukturierte Verweise

Befolgen Sie diese Regeln, um sicherzugehen, dass Ihre strukturierten Verweise von Excel verstanden werden.

  • Sie müssen alle Bezeichner für Tabellen, Spalten und besondere Elemente in eckige Klammern einschließen.

  • Spaltenüberschriften – und daher auch Spaltenbezeichner – stellen immer Textzeichenfolgen dar, auch wenn sie Zahlen enthalten. Dies bedeutet, dass Sie die Daten in diesen Zellen nicht zusammen mit mathematischen Ausdrücken verwenden können.

  • Wenn eine Spaltenüberschrift bestimmte Sonderzeichen enthält, muss ihr Spaltenbezeichner in einen zusätzlichen Satz eckiger Klammern eingeschlossen werden. Dies betrifft diese Zeichen: Leerzeichen, Tabulator, Zeilenvorschub, Wagenrücklauf, Semikolon (;), Doppelpunkt (:), Punkt (.), eckige Klammer links ([), eckige Klammer rechts (]), Nummernzeichen (#), Hochkomma ('), doppeltes Anführungszeichen ("), geschweifte Klammer links ({), geschweifte Klammer rechts (}), Dollarzeichen ($), Caretzeichen (^), kaufmännisches Und-Zeichen (&), Sternchen (*), Pluszeichen (+), Gleichheitszeichen (=), Minuszeichen (-), Größer-als-Symbol (>), Kleiner-als-Symbol (<) und das Divisionszeichen (/). Die einzige Ausnahme bildet das Leerzeichen, wenn es als einziges Sonderzeichen auftritt.

  • Die folgenden Zeichen haben eine besondere Bedeutung und erfordern die Verwendung eines einzelnen Anführungszeichens (') als Escapezeichen: linke eckige Klammer ([), rechte eckige Klammer (]), Gatterzeichen (#) und einzelnes Anführungszeichen ('). Für eine Spalte mit der Überschrift "Item#" gilt also dieser Spaltenbezeichner : "[Item'#]".

  • Um die Lesbarkeit von strukturierten Verweisen zu verbessern, dürfen Sie an drei Stellen Leerzeichen in den Verweis einfügen: unmittelbar hinter der ersten linken eckigen Klammer ([), unmittelbar vor der letzten rechten eckigen Klammer (]) und hinter Kommas.

Beispiele für strukturierte Verweise

Diese Beispiele für strukturierte Verweise sind für die Verwendung innerhalb von Formeln bestimmt – eigenständig funktionieren sie nicht.

Dieser strukturierte Verweis

Verweist auf

DailyExercise[[#All],[StrengthTraining]]

Alle Zellen in der Spalte "StrengthTraining", einschließlich der Kopfzeile, der Daten und der Ergebniszeile.

DailyExercise[[#Headers],[CardioTraining]:[StrengthTraining]]

Die Kopfzeilen zwischen den Spalten "CardioTraining" und "StrengthTraining", beide einschließlich.

DailyExercise[[#Totals],[StrengthTraining]]

Die Summe der Spalte "StrengthTraining". Falls keine Summenspalte vorhanden ist, wird #BEZUG! zurückgegeben.

DailyExercise[[#Data],[CardioTraining]:[StrengthTraining]]

Die Daten zwischen den Spalten "CardioTraining" und "StrengthTraining", beide eingeschlossen.

DailyExercise[[#Headers],[#Data],[StrengthTraining]]

Die Kopfzeile und die Daten in der Spalte "StrengthTraining". Wenn die Zeilenüberschriften deaktiviert sind, wird #BEZUG! zurückgegeben.

DailyExercise[[#This Row],[CardioTraining]]

oder eine bestimmte

DailyExercise[@CardioTraining]

Die Zelle am Schnittpunkt der aktuellen Zeile mit der Spalte "CardioTraining". Wird dieser Verweis in einer Kopf- oder Summenzeile angewendet, gibt er #WERT! zurück.

Hinweis :  Wenn Sie die längere Form dieses strukturierten Verweises eingeben, ersetzt Excel sie durch die kürzere Form "@". Sie funktionieren gleich.

Siehe auch

Eingeben einer Formel

Verwenden von Namen in Formeln

Erstellen oder Löschen einer Excel-Tabelle

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×