Verwenden von strukturierten Verweisen in Formeln

Strukturierte Verweise machen das Arbeiten mit Tabellendaten viel einfacher und intuitiver, wenn Formeln angewendet werden, die auf eine Tabelle verweisen – entweder auf Teile einer Tabelle oder auf eine gesamte Tabelle. Sie sind insbesondere deshalb nützlich, weil sich Datenbereiche in Tabellen häufig ändern und die Zellbezüge für strukturierte Verweise automatisch angepasst werden. Dadurch wird die Notwendigkeit, Formeln umzuschreiben, wenn Zeilen und Spalten hinzugefügt oder gelöscht oder externe Daten aktualisiert werden, auf ein Minimum reduziert.

Sie können aus guten Gründen diesem strukturierten Verweis

den Vorzug vor diesem Zellbezug geben

=SUMME(DailyExercise[CardioTraining])

=SUMME(C2:C7)

Komponenten von strukturierten Verweisen

Zum effektiven Arbeiten mit Tabellen und strukturierten Verweisen müssen Sie verstehen, wie Sie die Syntax strukturierter Verweise beim Erstellen von Formeln erzeugen. Die Komponenten eines strukturierten Verweises werden im folgenden Beispiel einer Formel zum Berechnen der durchschnittlichen Minutenanzahl in "CardioTraining" veranschaulicht:

=MITTELWERT(DailyExercise[[#Data],[CardioTraining]])

Legende 1 Geben Sie einen aussagekräftigen Namen für den Verweis auf die eigentlichen Tabellendaten, wie DailyExercise an (und schließen Sie die Kopf- und Summenzeilen aus, sofern vorhanden).

Schaltflächensymbol #Data ist ein Bezeichner für besondere Elemente, der auf einen bestimmten Teil der Tabelle (die Daten) verweist.

Legende 3   CardioTraining ist ein Spaltenbezeichner, der aus der Spaltenüberschrift abgeleitet wird.

Schritt 4  Der Tabellenbezeichner besteht einerseits aus dem Bezeichner des besonderen Elements und dem Spaltenbezeichner, der in einen weiteren Satz eckiger Klammern eingeschlossen ist. 

Legende 5  Der Tabellenname, die Spalte und der Bezeichner bilden zusammen einen strukturierten Verweis.

Hinweis :  Wenn strukturierte Verweise innerhalb einer Tabelle verwendet werden, müssen der Tabellenname oder die eckigen Klammern um den Tabellenbezeichner nicht angegeben werden. Dies wird als nicht qualifizierter Verweis bezeichnet. Für das Beispiel oben lautet der nicht qualifizierte Verweis =MITTELWERT([#Data],[CardioTraining]). Es ist jedoch eine gute Angewohnheit, strukturierte Verweise zu qualifizieren, falls Sie sich einmal entschließen, eine Formel nach außerhalb einer Tabelle zu verschieben.

Bezeichner für besondere Elemente

Mithilfe von Bezeichnern für besondere Elemente können Sie sich auf genau die gewünschten Zeilen beziehen, ohne die Zeilennummern kennen zu müssen.

Bezeichner für besondere Elemente

Verweist auf

#All

Die gesamte Tabelle, einschließlich der Spaltenüberschriften, Daten und Summen.

#Data

Nur die Datenzeilen.

#Headers

Nur die Kopfzeile.

#Totals

Nur die Summenzeile. Falls keine vorhanden ist, wird null zurückgegeben.

"#This Row" oder "@"

Nur die Zellen in der gleichen Zeile wie die Formel. Dieser Bezeichner kann nicht mit anderen Bezeichnern für besondere Elemente kombiniert werden.

Syntaxregeln für strukturierte Verweise

Befolgen Sie diese Regeln, um sicherzugehen, dass Ihre strukturierten Verweise von Excel verstanden werden.

  • Sie müssen alle Bezeichner für Tabellen, Spalten und besondere Elemente in eckige Klammern einschließen.

  • Spaltenüberschriften – und daher auch Spaltenbezeichner – stellen immer Textzeichenfolgen dar, auch wenn sie Zahlen enthalten. Dies bedeutet, dass Sie die Daten in diesen Zellen nicht zusammen mit mathematischen Ausdrücken verwenden können.

  • Wenn eine Spaltenüberschrift bestimmte Sonderzeichen enthält, muss ihr Spaltenbezeichner in einen zusätzlichen Satz eckiger Klammern eingeschlossen werden. Dies betrifft diese Zeichen: Leerzeichen, Tabulator, Zeilenvorschub, Wagenrücklauf, Semikolon (;), Doppelpunkt (:), Punkt (.), eckige Klammer links ([), eckige Klammer rechts (]), Nummernzeichen (#), Hochkomma ('), doppeltes Anführungszeichen ("), geschweifte Klammer links ({), geschweifte Klammer rechts (}), Dollarzeichen ($), Caretzeichen (^), kaufmännisches Und-Zeichen (&), Sternchen (*), Pluszeichen (+), Gleichheitszeichen (=), Minuszeichen (-), Größer-als-Symbol (>), Kleiner-als-Symbol (<) und das Divisionszeichen (/). Die einzige Ausnahme bildet das Leerzeichen, wenn es als einziges Sonderzeichen auftritt.

  • Die folgenden Zeichen haben eine besondere Bedeutung und erfordern die Verwendung eines einzelnen Anführungszeichens (') als Escapezeichen: linke eckige Klammer ([), rechte eckige Klammer (]), Gatterzeichen (#) und einzelnes Anführungszeichen ('). Für eine Spalte mit der Überschrift "Item#" gilt also dieser Spaltenbezeichner : "[Item'#]".

  • Um die Lesbarkeit von strukturierten Verweisen zu verbessern, dürfen Sie an drei Stellen Leerzeichen in den Verweis einfügen: unmittelbar hinter der ersten linken eckigen Klammer ([), unmittelbar vor der letzten rechten eckigen Klammer (]) und hinter Kommas.

Beispiele für strukturierte Verweise

Diese Beispiele für strukturierte Verweise sind für die Verwendung innerhalb von Formeln bestimmt – eigenständig funktionieren sie nicht.

Dieser strukturierte Verweis

Verweist auf

DailyExercise[[#All],[StrengthTraining]]

Alle Zellen in der Spalte "StrengthTraining", einschließlich der Kopfzeile, der Daten und der Ergebniszeile.

DailyExercise[[#Headers],[CardioTraining]:[StrengthTraining]]

Die Kopfzeilen zwischen den Spalten "CardioTraining" und "StrengthTraining", beide einschließlich.

DailyExercise[[#Totals],[StrengthTraining]]

Die Summe der Spalte "StrengthTraining". Falls keine Summenspalte vorhanden ist, wird #BEZUG! zurückgegeben.

DailyExercise[[#Data],[CardioTraining]:[StrengthTraining]]

Die Daten zwischen den Spalten "CardioTraining" und "StrengthTraining", beide eingeschlossen.

DailyExercise[[#Headers],[#Data],[StrengthTraining]]

Die Kopfzeile und die Daten in der Spalte "StrengthTraining". Wenn die Zeilenüberschriften deaktiviert sind, wird #BEZUG! zurückgegeben.

DailyExercise[[#This Row],[CardioTraining]]

oder

DailyExercise[@CardioTraining]

Die Zelle am Schnittpunkt der aktuellen Zeile mit der Spalte "CardioTraining". Wird dieser Verweis in einer Kopf- oder Summenzeile angewendet, gibt er #WERT! zurück.

Hinweis :  Wenn Sie die längere Form dieses strukturierten Verweises eingeben, ersetzt Excel sie durch die kürzere Form "@". Sie funktionieren gleich.

Siehe auch

Eingeben einer Formel

Verwenden von Namen in Formeln

Erstellen oder Löschen einer Excel-Tabelle

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×