Verwenden von Werten aus einer SQL-Datenbank zum Auffüllen eines Listenfelds, eines Dropdown-Listenfelds oder eines Kombinationsfelds

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können ein Listenfeld, ein Dropdown-Listenfeld oder ein Kombinationsfeld mit Daten aus einer Abfragedatenverbindung mit einer Microsoft SQL Server-Datenbank auffüllen.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Schritt 2: Konfigurieren des Steuerelements

Übersicht

In einem Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld werden Elemente angezeigt, die ein Benutzer beim Ausfüllen eines auf der Formularvorlage basierenden Formulars auswählen kann. Sie können diese Steuerelementtypen so konfigurieren, dass die Daten aus einer sekundären Datenverbindung mit einer Microsoft SQL Server-Datenbank angezeigt werden. Eine sekundäre Datenverbindung ist eine beliebige Datenverbindung mit einer externen Datenquelle, die Sie zu einer Formularvorlage hinzufügen, sodass Benutzer, die auf dieser Formularvorlage basierende Formulare ausfüllen, Daten aus einer externen Datenquelle (wie beispielsweise ein Webdienst) abrufen oder an diese übermitteln können.

Wenn Sie eine sekundäre Datenquelle, die in Abfragen von Daten zur Formularvorlage, Microsoft Office InfoPath erstellt eine sekundäre Datenquelle mit Datenfelder und Gruppen hinzufügen, die die Daten so entspricht, werden in der Datenbank gespeichert. Die Verbindung zum Abfragen von Daten Ruft Daten aus dem Webdienst ab und speichert die Daten in der sekundäre Datenquelle des Formulars. Standardmäßig ist die Daten in der sekundäre Datenquelle verfügbar, während der Benutzer mit einem Netzwerk verbunden sind. Sie können konfigurieren, dass die sekundäre Datenquelle, um die Ergebnisse der Abfrage auf den Computern der Benutzer zu speichern, damit sie haben Zugriff auf die Daten, wenn ihre Form nicht mit einem Netzwerk verbunden ist.

Sicherheitshinweis : Wenn Sie eine sekundäre Datenverbindung verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, sollten Sie diese Funktion eventuell deaktivieren, um die Daten vor unberechtigter Verwendung zu schützen, falls der Computer verloren geht oder gestohlen wird. Wenn Sie diese Funktion deaktivieren, sind die Daten nur verfügbar, falls der Benutzer mit dem Netzwerk verbunden ist.

Da die Datenstruktur der sekundären Datenquelle mit der Speicherungsart der Daten in der Datenbank übereinstimmen muss, können in der sekundären Datenquelle vorhandene Felder oder Gruppen nicht geändert werden. Sie finden Verknüpfungen mit weiteren Informationen zu Datenverbindungen und Datenquellen im Abschnitt Siehe auch.

Seitenanfang

Vorbemerkung

Bevor Sie Werte aus einer SQL Server-Datenbank zum Auffüllen eines Steuerelements in der Formularvorlage verwenden können, benötigen Sie die folgenden Informationen vom Datenbankadministrator:

  • Den Namen des Servers mit der Datenbank, die mit der Formularvorlage verwendet wird.

  • Den Namen der Datenbank, die mit der Formularvorlage verwendet wird.

  • Die für die Datenbank erforderliche Authentifizierung. Von der Datenbank kann entweder Microsoft Windows-Authentifizierung oder SQL Server-Authentifizierung verwendet werden, um zu bestimmen, wie Benutzer auf die Datenbank zugreifen können.

  • Der Name der Tabelle mit den Daten, die an das Formular gesendet werden sollen. Hierbei handelt es sich um die primäre Tabelle. Wenn mehr als eine Tabelle in der Datenbank verwendet werden soll, werden die Namen der anderen untergeordneten Tabellen benötigt. Sie benötigen auch die Namen der Felder in den untergeordneten Tabellen, die über Beziehungen zu den Feldern in der primären Tabelle verfügen.

  • Informationen dazu, ob die Abfrageergebnisse zur Offlineverwendung sicher auf Benutzercomputern gespeichert werden können.

Seitenanfang

Schritt 1: Hinzufügen einer Abfragedatenverbindung

Wenn Sie nicht mit eine bestehenden Verbindung zum Abfragen von Daten verfügen, die Sie in der Formularvorlage verwenden können, folgendermaßen Sie vor, um eine sekundäre Datenquelle zur Formularvorlage diese Daten Abfragen hinzuzufügen. Weist die Formularvorlage bereits eine sekundäre Datenquelle, die Sie verwenden können, können Sie diesen Abschnitt überspringen und wechseln Sie zu Schritt2: Konfigurieren des Steuerelements.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.

  7. Klicken auf der nächsten Seite des Assistenten in der Liste Zu welchem Datenquellentyp möchten Sie die Verbindung herstellen auf Microsoft SQL Server, und klicken Sie dann auf Weiter.

  8. Geben Sie im Feld Servername den Namen des Servers mit der SQL Server-Datenbank ein.

  9. Führen Sie unter Anmeldeinformationen eine der folgenden Aktionen aus:

    • Wenn von der Datenbank basierend auf den in einem Microsoft Windows-Netzwerk verwendeten Anmeldeinformationen bestimmt wird, wer über Zugriff verfügt, klicken Sie auf Windows-Authentifizierung verwenden.

    • Wenn von der Datenbank basierend auf einem angegebenen vom Datenbankadministrator zugeteilten Benutzernamen und Kennwort bestimmt wird, wer über Zugriff verfügt, klicken Sie auf Benutzername und Kennwort verwenden, und geben Sie dann den Benutzernamen und das Kennwort in den Feldern Benutzername und Kennwort ein.

  10. Klicken Sie auf Weiter.

  11. Klicken Sie in der Liste Wählen Sie die Datenbank, die die benötigten Daten enthält auf den Namen der zu verwendenden Datenbank, klicken Sie auf Mit einer ausgewählten Tabelle verbinden, klicken Sie auf den Namen der primären Tabelle, und klicken Sie dann auf Weiter.

  12. Geben Sie auf der nächsten Seite des Assistenten im Feld Dateiname den Namen für die Datei ein, in der die Datenverbindungsinformationen gespeichert werden, und klicken Sie dann zum Speichern dieser Einstellungen auf Fertig stellen.

    Wenn andere Tabellen in der Abfragedatenverbindung verwendet werden sollen, können Sie die anderen Tabellen auf dieser Seite des Assistenten hinzufügen.

    Fügen Sie weiterer Tabellen hinzu

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  13. Klicken Sie auf Weiter.

  14. Wenn Sie die Abfrageergebnisse zusammen mit der Formularvorlage auf dem Computer speichern möchten, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern. Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse auf dem Computer des Benutzers gespeichert, sodass die Benutzer Zugriff auf diese Daten haben, auch wenn keine Verbindung zwischen dem Computer und dem Netzwerk hergestellt ist.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  15. Klicken Sie auf Weiter.

  16. Geben Sie auf der nächsten Seite des Assistenten einen aussagekräftigen Namen für diese sekundäre Datenverbindung ein. Wenn beim Öffnen des Formulars automatisch vom Formular Daten abgerufen werden sollen, aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen.

Seitenanfang

Schritt 2: Konfigurieren des Steuerelements

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Steuerelement für das aufzufüllende Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Listenfeldeinträge auf Werte in einer externen Datenquelle nachschlagen.

  5. Klicken Sie in der Liste Datenquelle auf die zu verwendende Datenquelle.

  6. Klicken Sie neben dem Feld Einträge auf XPath festlegen Schaltfläche (Symbol) .

  7. Geben Sie im Dialogfeld Feld oder Gruppe auswählen durch Ausführen einer der folgenden Aktionen an, welche Daten dem Benutzer angezeigt werden und welche Daten an die externe Datenquelle übertragen werden.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird, den gleichen Daten ist, die vom Benutzer übermittelt werden

    • Klicken Sie auf ein Feld, und klicken Sie dann auf OK.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird aus den Daten unterscheidet, die vom Benutzer übermittelt werden

    Hinweis : In diesem Szenario befinden sich die dem Benutzer angezeigten Daten in einem der Felder in der Gruppe, und die vom Benutzer zu übertragenden Daten befinden sich in einem anderen Feld in derselben Gruppe.

    1. Klicken Sie auf eine Gruppe, und klicken Sie dann auf OK.

    2. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Wert.

    3. Kicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld mit den vom Benutzer an die externe Quelle zu übertragenden Daten, und klicken Sie dann auf OK.

    4. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) neben dem Feld Anzeigename.

    5. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld mit den im Steuerelement angezeigten Daten, und klicken Sie dann auf OK.

  8. Wenn das Feld im Feld Anzeigename über Werte mit ähnlichen Anzeigenamen verfügt, und es sollen nur eindeutige Namen angezeigt werden, aktivieren Sie das Kontrollkästchen Nur Einträge mit eindeutigen Anzeigenamen anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×