Verwenden von Werten aus einer Access-Datenbank zum Füllen eines Listenfelds, eines Dropdown-Listenfelds oder eines Kombinationsfelds

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In einem InfoPath-Formular können Sie Füllen eines Listenfelds, Dropdown-Listenfeld oder Kombinationsfeld mit Daten aus eine Verbindung zum Abfragen von Daten in einer Datenbank Microsoft Office Access 2007 (ACCDB) oder einer Access-Datenbank, die in einer früheren Version (MDB-Format) gespeichert wurde.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Schritt 1: Hinzufügen einer Verbindungs zum Abfragen von Daten

Schritt 2: Konfigurieren des Steuerelements

Optional: Einrichten eines Filters zum Einschränken der Elemente im Steuerelement

Übersicht

Ein Listenfeld, Dropdown-Listenfeld oder Kombinationsfeld zeigt Elemente, die Benutzer beim Ausfüllen eines InfoPath-Formulars auswählen können. Wenn Sie eine Formularvorlage entwerfen, können Sie diese Typen von Steuerelementen zum Anzeigen von Daten aus einer sekundäre Datenquelle in einer Access-Datenbank konfigurieren.

Bei einer sekundäre Datenverbindung handelt es sich um eine Datenverbindung von einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen. Sie können sekundäre Datenverbindungen so konfigurieren, dass sie Daten abrufen, die für Benutzer zum Ausfüllen von auf Ihrer Formularvorlage basierenden Formularen oder zum Senden von Formulardaten an eine externe Datenquelle erforderlich sind, z. B. an einen Webdienst.

Wenn Sie eine sekundäre Datenquelle die Daten Abfragen zur Formularvorlage hinzufügen, erstellt InfoPath eine sekundäre Datenquelle, die enthält Datenfelder und Gruppen, die Art und Weise entsprechen, dass die Daten in der Datenbank gespeichert ist. Die Verbindung zum Abfragen von Daten Ruft Daten aus dem Webdienst ab und anschließend die Daten in sekundäre Datenquelle des Formulars gespeichert.

Sie können die sekundäre Datenverbindung so konfigurieren, dass die Ergebnisse der Abfrage auf dem Computer der Benutzer gespeichert werden, damit diese Benutzer auf die Daten zugreifen können, auch wenn ihr Computer nicht mit einem Netzwerk verbunden ist. In Abhängigkeit von der Art der Daten möchten Sie die Abfrageergebnisse möglicherweise nur anzeigen, wenn die Benutzer mit einem Netzwerk verbunden sind.

Sicherheitshinweis : Wenn Sie eine sekundäre Datenverbindung verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, sollten Sie diese Funktion eventuell deaktivieren, um die Daten vor unberechtigter Verwendung zu schützen, falls der Computer verloren geht oder gestohlen wird. Wenn Sie diese Funktion deaktivieren, sind die Daten nur verfügbar, falls der Benutzer mit dem Netzwerk verbunden ist.

Wenn Sie die Anzahl der Elemente in einem Listenfeld-Steuerelement beschränken möchten, können Sie eine Filter verwenden. Verwenden Sie einen Filter, wenn Sie müssen eine Teilmenge der Daten angezeigt werden, die von einer Abfrage zurückgegeben wird, die basierend auf Kriterien, die von einem Benutzer ausgewählt ist. Diese Kriterien Hiermit werden können, die in ein anderes Steuerelement (z. B. ein Listenfeld, Kombinationsfeld, Dropdown-Listenfeld oder Textfeld) markiert ist, das mit einem Feld in der Datenquelle gebunden ist.

Da die Datenstruktur in der sekundären Datenquelle wie übereinstimmen muss Daten in der Datenbank gespeichert ist, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern. Finden Sie Links zu weiteren Informationen über datenverbindungen und Datenquellen in diesem Artikel im Abschnitt Siehe auch.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können einer Access-Datenbank nur dann eine Abfragedatenverbindung hinzufügen, wenn Sie eine Formularvorlage entwerfen, die keine Browserkompatible Formularvorlage ist.

Seitenanfang

Vorbemerkung

Bevor Sie Werte einer Access-Datenbank zum Füllen eines Steuerelements auf der Formularvorlage verwenden können, sind folgende Informationen vom Datenbankadministrator erforderlich:

  • Der Name und der Speicherort der Datenbank.

    Hinweis : Wenn andere Benutzer im Netzwerk Formularen, die auf dieser Formularvorlage basieren erstellt werden, stellen Sie sicher, dass Ihre Datenbank für diesen Benutzer zugegriffen werden kann.

  • Der Name der Tabelle oder Abfrage, die die Werte für das Steuerelement bereitstellt. Sie werden diese Tabelle oder Abfrage als Mastertabelle verwenden, wenn Sie die Datenverbindung zum Abfragen konfigurieren.

  • Die Namen der anderen Tabellen oder Abfragen, aus denen die primäre Tabelle oder Abfrage Daten erfordern möglicherweise. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle oder Abfrage und einer anderen Tabelle oder Abfrage manuell herstellen müssen, benötigen Sie die zugehörigen Feldnamen der beiden Tabellen oder Abfragen.

Seitenanfang

Schritt 1: Hinzufügen einer Abfragedatenverbindung

Wenn Sie nicht mit eine bestehenden Verbindung zum Abfragen von Daten verfügen, die Sie in der Formularvorlage verwenden können, verwenden Sie das folgende Verfahren, eine sekundäre Datenquelle, die Daten Abfragen zur Formularvorlage hinzufügen. Weist die Formularvorlage bereits eine sekundäre Datenquelle, die Sie verwenden können, können Sie diesen Abschnitt überspringen und wechseln Sie zu Schritt2: Konfigurieren des Steuerelements.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Wechseln Sie im Dialogfeld Datenquelle auswählen zum Speicherort Ihrer Datenbank.

    Hinweis : Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu der universal naming Convention (UNC)) Pfad des Speicherorts. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein Netzlaufwerk verwenden (die einen Buchstaben auf einem Netzlaufwerk, z. B. h oder z zuweisen, wird), werden für die Datenbank auf die bestimmte zugeordneten Netzlaufwerk Formulare, die Benutzer erstellen, die auf dieser Formularvorlage basieren suchen. Wenn der Benutzer nicht auf genau die gleiche Weise zugeordneten Netzlaufwerk verfügt, wird das Formular die Datenbank nicht finden.

  7. Klicken Sie auf den Namen der Datenbank und dann auf Öffnen.

  8. Klicken Sie im Dialogfeld Tabelle auswählen auf die zu verwendende Mastertabelle oder -abfrage, und klicken Sie dann auf OK.

  9. Aktivieren Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen.

    Standardmäßig werden alle Felder in der Tabelle oder Abfrage in der primären Datenquelle der Formularvorlage hinzugefügt.

  10. Deaktivieren Sie die Kontrollkästchen für die Felder, die nicht in die primäre Datenquelle einbezogen werden sollen.

  11. Fügen Sie zusätzliche Tabellen oder Abfragen hinzu, die Sie in der Abfragedatenverbindung einbeziehen möchten.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  12. Klicken Sie auf Weiter.

  13. Damit die Ergebnisse der Abfragedatenverbindung verfügbar sind, wenn das Formular nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern.

    Sicherheitshinweis : Das Aktivieren des Kontrollkästchens speichert die Daten auf dem Computer des Benutzers, wenn das Formular diese Datenverbindung verwendet. Wenn das Formular vertrauliche Daten aus dieser Verbindung abgerufen werden, sollten Sie so deaktivieren Sie dieses Feature zum Schutz die Daten, falls der Computer verloren gegangen sind oder gestohlen wird oder erfolgt andernfalls durch nicht autorisierte Benutzer.

  14. Klicken Sie auf Weiter.

  15. Geben Sie auf der nächsten Seite des Assistenten einen anschaulichen Namen für diese sekundäre Datenverbindung ein, und überprüfen Sie dann, dass die Daten im Abschnitt Zusammenfassung richtig sind.

  16. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, um das Formular so zu konfigurieren, dass die Daten beim Öffnen automatisch abgerufen werden.

Seitenanfang

Schritt 2: Konfigurieren des Steuerelements

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Listenfeld, das Dropdown-Listenfeld oder auf das Kombinationsfeld der Formularvorlage, das Sie konfigurieren möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Listenfeldeinträge auf Werte in einer externen Datenquelle nachschlagen.

  5. Klicken Sie in der Liste Datenquelle auf die zu verwendende Datenquelle.

  6. Klicken Sie auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Einträge.

  7. Geben Sie im Dialogfeld Feld oder Gruppe auswählen das Feld oder die Gruppe ein, dessen/deren Felder die Daten enthalten, die dem Benutzer angezeigt werden und die Daten, die an die externe Datenquelle gesendet werden, indem eine der folgenden Aktionen durchgeführt wird.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird, den gleichen Daten ist, die vom Benutzer übermittelt werden

    • Klicken Sie auf ein Feld, und klicken Sie dann auf OK.

    Geben Sie an, dass die Daten, die dem Benutzer angezeigt wird aus den Daten unterscheidet, die vom Benutzer übermittelt werden

    Hinweis : In diesem Szenario stammen die dem Benutzer angezeigten Daten aus einem der Felder in der Gruppe und die Daten, die der Benutzer sendet, sind in einem anderen Feld derselben Gruppe enthalten.

    1. Klicken Sie auf eine Gruppe und dann auf OK.

    2. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Wert.

    3. Kicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld mit den vom Benutzer an die externe Quelle zu übertragenden Daten, und klicken Sie dann auf OK.

    4. Klicken Sie im Dialogfeld Steuerelementeigenschaften auf XPath festlegen Schaltfläche (Symbol) , neben dem Feld Anzeigename.

    5. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf ein Feld mit den im Steuerelement angezeigten Daten, und klicken Sie dann auf OK.

  8. Wenn das Feld im Feld Anzeigename über Werte mit ähnlichen Anzeigenamen verfügt, und es sollen nur eindeutige Namen angezeigt werden, aktivieren Sie das Kontrollkästchen Nur Einträge mit eindeutigen Anzeigenamen anzeigen.

Seitenanfang

Seitenanfang

Optional: Einrichten eines Filters zum Einschränken der Elemente im Steuerelement

  1. Doppelklicken Sie auf das Listenfeld, das Dropdown-Listenfeld oder auf das Kombinationsfeld der Formularvorlage, das Sie konfigurieren möchten.

  2. Klicken Sie auf die Registerkarte Daten.

  3. Klicken Sie neben dem Feld Einträge auf XPath festlegen Schaltfläche (Symbol) .

  4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das Feld oder die Gruppe, das oder die das Feld enthält, das die Werte für das Steuerelement zur Verfügung stellt. Anschließend klicken Sie auf Daten filtern.

  5. Klicken Sie im Dialogfeld Daten filtern auf Hinzufügen.

    Hinweis : Wenn Sie einen vorhandenen Filter eine Bedingung hinzufügen möchten, klicken Sie auf den Filter, den Sie anwenden möchten, und klicken Sie dann auf Ändern.

  6. Klicken Sie im ersten Feld des Dialogfelds Filterbedingungen festlegen auf den Namen des Felds, dessen Daten Sie filtern möchten.

  7. Klicken Sie im zweiten Feld auf den Filtertyp, den Sie verwenden möchten.

  8. Klicken Sie im dritten Feld auf den Typ der Bedingung, der auf den Filter angewendet werden soll, und geben Sie dann die Bedingung ein.

  9. Klicken Sie zum Konfigurieren mehrerer Bedingungen für den Filter auf Und, und führen Sie dann eine der folgenden Aktionen aus:

    • Klicken Sie auf und, und fügen Sie dann Ihre neue Bedingung hinzu, wenn Sie sowohl die vorhandene als auch die neue Bedingung für Ihren Filter verwenden möchten.

    • Klicken Sie auf oder, und fügen Sie dann die zusätzliche Bedingung hinzu, wenn Sie entweder die vorhandene oder die neue Bedingung für Ihren Filter verwenden möchten.

  10. Klicken Sie auf OK, um die Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

    Die Formularvorlage wird in einem neuen Fenster geöffnet.

  12. Wählen Sie im Fenster Vorschau verschiedene Werte in das Filter-Steuerelement zum Testen der Filters ordnungsgemäß arbeitet.

    Der Filter ist nicht ordnungsgemäß funktionsfähig

    Wenn die Werte in dem Steuerelement, das einen Filter enthält, nicht richtig sind, weil entweder zu viele oder nicht genug Werte vorhanden sind, gehen Sie folgendermaßen vor:

    • Wenn in Ihrem Filter mehrere Bedingungen verwendet werden, entfernen Sie alle Bedingungen bis auf eine, um zu überprüfen, ob von dieser einzelnen Bedingung ordnungsgemäße Werte zurückgegeben werden. Wenn die richtigen Werte von der ersten Bedingung zurückgegeben werden, fügen Sie eine weitere Bedingung hinzu, und führen den Test erneut aus.

    • Filter unterscheiden zwischen Groß- und Kleinbuchstaben. Wenn Sie Daten anzeigen möchten, die mit einem Groß- oder Kleinbuchstaben beginnen, erstellen Sie einen Filter mit einer Bedingung für Großbuchstaben, wählen Sie oder im Dialogfeld Filterbedingung angeben aus, und erstellen Sie dann eine Bedingung für Kleinbuchstaben.

    • Wenn die gefilterten Werte genau dem Gegenteil von dem entsprechen, was Sie erwarten, beispielsweise die Produkte aller statt eines Lieferanten gefiltert werden, ändern Sie den Filtertyp in der Bedingung. Wenn Sie in Ihrer Bedingung z. B. den Filtertyp identisch verwenden, und Sie erhalten zu viele Produkte, so probieren Sie es mit dem Filtertyp ist ungleich.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×