Verwenden von SUMMENPRODUKT zum Addieren des Produkts korrespondierender Werte in einer oder mehreren Matrizen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Die Funktion SUMMENPRODUKT verwendet Zellbereiche (so genannte Matrizen) als Argumente (Argumente sind die Teile der Formel, die dafür sorgen, dass die Formel funktioniert). Mit der Funktion werden die Elemente der Matrizen multipliziert und die Ergebnisse dann addiert.

Diese Beispiel enthält ein Lebensmittelliste. In der ersten Matrix werden die Kosten für jeden Artikel aufgeführt, in der zweiten Matrix wird angegeben, wie viele Artikel eingekauft werden sollen.

Preise und Mengen, die zu multiplizieren und dann zu addieren sind

  1. Geben Sie zum Erstellen der Formel =SUMMENPRODUKT(B3:B6;C3:C6) ein, und drücken Sie die EINGABETASTE.

Jede Zelle in Spalte B wird nun mit der jeweils entsprechenden Zelle in der gleichen Zeile in Spalte C multipliziert, und die Ergebnisse werden addiert. Der Gesamtbetrag für Lebensmittel beläuft sich demnach auf 21,60 Euro.

  1. Zum Schreiben einer längeren Formel gibt, die Ihnen das gleiche Ergebnis, Typ = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 und drücken die EINGABETASTE.

Nachdem Sie die EINGABETASTE gedrückt haben, erhalten Sie dasselbe Ergebnis: 21,60 Euro. Zelle B3 wird mit C3 multipliziert, und das Ergebnis wird zum Ergebnis von Zelle B4 multipliziert mit Zelle C4 usw. addiert. Sie können sich sicher vorstellen, wie viel einfacher die Verwendung der Funktion SUMMENPRODUKT ist, wenn Sie tausende (oder auch nur hunderte) von Zeilen verarbeiten müssen.

Hinweise : 

  • Die Spalten oder Zeilen (Matrizen) müssen dieselbe Länge aufweisen.

  • Befindet sich in einer Zelle Text anstelle einer Zahl, wird als Wert 0 angenommen.

Beispiel

Wenn Sie mit der Funktion SUMMENPRODUKT und Matrizen experimentieren möchten, finden Sie hier eine Excel Online-Arbeitsmappe mit anderen als den in diesem Artikel verwendeten Daten.

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Ein

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Ergebnis

'=SUMMENPRODUKT(A2:B4;D2:E4)

=SUMMENPRODUKT(A2:B4;D2:E4)

Multipliziert alle Elemente in den beiden Matrizen (A2:B4 und D2:E4) und summiert anschließend die Produkte: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Für tieferen Einblicke können Sie diese Arbeitsmappe auch in Excel öffnen. Klicken Sie einfach auf das Excel-Symbol in der unteren rechten Ecke der Arbeitsmappe  Excel-Symbol in Excel Web App , speichern Sie die Datei an einem geeigneten Ort auf Ihrem Computer, und öffnen Sie die Datei.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×