Verwenden von Microsoft Query zum Abrufen externer Daten

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Mit Microsoft Query können Sie Daten aus externen Quellen abrufen. Wenn Sie mithilfe von Microsoft Query Daten aus Datenbanken und Dateien Ihres Unternehmens abrufen, brauchen die Daten, die Sie in Excel analysieren möchten, nicht neu erfasst zu werden. Sie können auch dafür sorgen, dass Ihre Excel-Berichte und Zusammenfassungen automatisch bei jeder Aktualisierung der Quelldatenbanken mit aktualisiert werden.

Was möchten Sie tun?

Informationen zu Microsoft Query

Herstellen einer Verbindung zu einer Datenquelle

Definieren einer Abfrage mithilfe des Query-Assistenten

Arbeiten mit den Daten in Excel

Informationen zu Microsoft Query

Mit Microsoft Query können Sie Verbindungen zu externen Datenquellen herstellen, Daten aus diesen externen Quellen auswählen, die Daten in Ihr Arbeitsblatt importieren und die Daten nach Bedarf aktualisieren, damit die Daten im Arbeitsblatt mit den Daten in den externen Quellen synchronisiert werden.

Datenbanktypen, auf die der Zugriff möglich ist     Sie können Daten aus mehreren Datenbanktypen abrufen, beispielsweise aus Microsoft Office Access, Microsoft SQL Server und Microsoft SQL Server OLAP Services. Sie können auch Daten aus Excel-Arbeitsmappen und Textdateien abrufen.

Microsoft Office enthält Treiber, die Sie zum Abrufen von Daten aus den folgenden Datenquellen verwenden können:

  • Microsoft SQL Server Analysis Services (OLAP-Anbieter)

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Textdatei-Datenbanken

Sie können auch ODBC-Treiber oder Datenquellentreiber von anderen Herstellern verwenden, um Informationen aus Datenquellen abzurufen, die hier nicht aufgeführt werden, beispielsweise aus anderen OLAP-Datenbanktypen. Informationen zur Installation eines hier nicht aufgeführten ODBC-Treibers oder Datenquellentreibers erhalten Sie in der Dokumentation zur Datenbank oder vom Hersteller der Datenbank.

Auswählen von Daten in einer Datenbank     Zum Abrufen von Daten aus einer Datenbank erstellen Sie eine Abfrage. Eine Abfrage ist vergleichbar mit einer Frage, die Sie über Daten stellen, die in einer externen Datenbank gespeichert sind. Beispiel: Ihre Daten sind in einer Access-Datenbank gespeichert, und Sie möchten die Verkaufszahlen für ein bestimmtes Produkt in einzelnen Regionen erfahren. Sie können die benötigten Daten abrufen, indem Sie nur die Daten für das Produkt und die Regionen auswählen, die Sie analysieren möchten.

Mit Microsoft Query können Sie die gewünschten Datenspalten auswählen und nur diese Daten in Excel importieren.

Aktualisieren des Arbeitsblatts in einer Operation     Sobald externe Daten in einer Excel-Arbeitsmappe verfügbar sind, können Sie die Daten Aktualisieren, wenn sich die Datenbank ändert, damit auch Ihre Analyse aktualisiert wird. Sie müssen die Zusammenfassungsberichte und -diagramme nicht neu erstellen. Beispielsweise können Sie eine Zusammenfassung des Umsatzes pro Monat erstellen und diese jeden Monat aktualisieren, sobald die neuen Umsatzzahlen bekannt sind.

So werden in Microsoft Query Datenquellen verwendet     Wenn Sie eine Datenquelle für eine bestimmte Datenbank eingerichtet haben, können Sie diese so oft verwenden, wie Sie möchten, um eine Abfrage zu erstellen, über die Sie Daten aus der betreffenden Datenbank auswählen und abrufen. Sie müssen die Verbindungsdaten also nicht erneut eingeben. In Microsoft Query wird über die Datenquelle eine Verbindung zur externen Datenbank hergestellt und die verfügbaren Daten angezeigt. Wenn Sie die Abfrage erstellt und die Daten an Excel zurückgegeben haben, werden die Abfragedaten und die Datenquellenangaben von Microsoft Query in der Excel-Arbeitsmappe bereitgestellt, sodass Sie erneut eine Verbindung zur Datenbank herstellen können, wenn Sie die Daten aktualisieren möchten.

Abbildung: So werden in Query Datenquellen verwendet

Verwenden von Microsoft Query zum Importieren von Daten     Führen Sie die folgenden einfachen Schritte aus, die in den nachfolgenden Abschnitten genauer beschrieben sind, um externe Daten mit Microsoft Query in Excel zu importieren.

  1. Herstellen einer Verbindung zu einer Datenquelle

  2. Definieren einer Abfrage mithilfe des Query-Assistenten

  3. Arbeiten mit den Daten in Excel

Seitenanfang

Herstellen einer Verbindung zu einer Datenquelle

Was ist eine Datenquelle?     Eine Datenquelle ist ein gespeicherter Satz von Daten, mit dem zwischen Excel bzw. Microsoft Query und einer externen Datenbank eine Verbindung hergestellt werden kann. Wenn Sie Microsoft Query zum Einrichten einer Datenquelle verwenden, geben Sie der Datenquelle einen Namen, und geben Sie dann den Namen und den Speicherort der Datenbank oder des Servers, den Datenbanktyp sowie Ihre Anmelde- und Kennwortinformationen an. Diese Informationen umfassen zudem den Namen eines OBDC-Treibers oder eines Datenquellentreibers. Hierbei handelt es sich um ein Programm, das Verbindungen zu einem bestimmten Datenbanktyp herstellt.

So richten Sie mit Microsoft Query eine Datenquelle ein:

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus anderen Quellen, und klicken Sie dann auf Von Microsoft Query.

  2. Führen Sie eine der folgenden Aktionen aus: 

    • Klicken Sie zum Angeben einer Datenquelle für eine Datenbank, eine Textdatei oder eine Excel-Arbeitsmappe auf die Registerkarte Datenbanken.

    • Klicken Sie zum Angeben einer OLAP-Cube-Datenquelle auf die Registerkarte OLAP-Cubes. Diese Registerkarte ist nur dann verfügbar, wenn Sie Microsoft Query über Excel ausgeführt haben.

  3. Doppelklicken Sie auf <Neue Datenquelle>.

    – Oder –

    Klicken Sie auf <Neue Datenquelle>, und klicken Sie dann auf OK.

    Das Dialogfeld Neue Datenquelle erstellen wird angezeigt.

  4. Geben Sie in Schritt 1 einen Namen ein, um die Datenquelle zu identifizieren.

  5. Klicken Sie in Schritt 2 auf einen Treiber für den Typ der Datenbank, die Sie als Datenquelle verwenden möchten.

    Wenn die externe Datenbank, auf die Sie zugreifen möchten, nicht von den ODBC-Treibern unterstützt wird, die zusammen mit Microsoft Query installiert werden, müssen Sie sich einen Microsoft Office-kompatiblen ODBC-Treiber von einem Drittanbieter (beispielsweise vom Hersteller der Datenbank) besorgen und diesen installieren. Setzen Sie sich mit dem Datenbankhersteller in Verbindung, um Installationsanleitungen zu erhalten.

    Hinweis : Für OLAP-Datenbanken sind ODBC-Treiber nicht erforderlich. Bei der Installation von Microsoft Query werden Treiber für Datenbanken installiert, die mit Microsoft SQL Server Analysis Services erstellt wurden. Wenn Sie eine Verbindung zu anderen OLAP-Datenbanken herstellen möchten, müssen Sie einen Datenquellentreiber und Clientsoftware installieren.

  6. Klicken Sie auf Verbinden, und geben Sie dann die erforderlichen Informationen zum Verbinden mit der Datenquelle ein. Bei Datenbanken, Excel-Arbeitsmappen und Textdateien müssen Sie je nach Typ der ausgewählten Datenquelle unterschiedliche Informationen angeben. Sie werden unter Umständen zur Eingabe eines Anmeldenamens, eines Kennworts, der Version der verwendeten Datenbank, des Speicherorts der Datenbank oder anderer Informationen aufgefordert, die für den ausgewählten Datenbanktyp spezifisch sind.

    Verwenden Sie sichere Kennwörter, bei denen Groß- und Kleinbuchstaben, Zahlen und Symbole kombiniert sind. Unsichere Kennwörter weisen nicht diese Mischung auf. Sicheres Kennwort: Y6dh!et5. Unsicheres Kennwort: Haus27. Kennwörter sollten mindestens acht Zeichen umfassen. Ein Pass-Ausdruck mit mindestens 14 Zeichen ist besser geeignet. Weitere Informationen finden Sie unter Schützen persönlicher Informationen mit sicheren Kennwörtern.

    Es ist ganz wichtig, dass Sie sich Ihr Kennwort merken. Wenn Sie das Kennwort vergessen, kann es von Microsoft nicht wieder bereitgestellt werden. Bewahren Sie die Kennwörter, die Sie sich notiert haben, an einem sicheren Ort getrennt von den anderen Informationen auf, die mit dem Kennwort geschützt werden sollen.

  7. Nachdem Sie die erforderlichen Informationen eingegeben haben, klicken Sie auf OK oder Fertig stellen, um zum Dialogfeld Neue Datenquelle erstellen zurückzukehren.

  8. Wenn Ihre Datenbank Tabellen aufweist und Sie möchten, dass eine der Tabellen automatisch im Query-Assistenten angezeigt wird, klicken Sie auf das Feld für Schritt 4 und dann auf die gewünschte Tabelle.

  9. Wenn Sie Anmeldenamen und Kennwort bei der Verwendung der Datenquelle nicht eingeben möchten, aktivieren Sie das Kontrollkästchen User-ID und Kennwort in der Datenquellendefinition speichern. Das gespeicherte Kennwort wird nicht verschlüsselt. Ist das Kontrollkästchen nicht verfügbar, erkundigen Sie sich beim Datenbankadministrator, ob diese Option bereitgestellt werden kann.

    Sicherheitshinweis : Vermeiden Sie das Speichern von Anmeldeinformationen beim Herstellen einer Verbindung zu Datenquellen. Diese Informationen werden möglicherweise als Klartext gespeichert, sodass ein Angreifer auf diese Informationen zugreifen und die Sicherheit der Datenquelle gefährden könnte.

Nachdem Sie diese Schritte ausgeführt haben, wird der Name der Datenquelle im Dialogfeld Datenquelle auswählen angezeigt.

Seitenanfang

Definieren einer Abfrage mithilfe des Query-Assistenten

Verwenden Sie für die meisten Abfragen den Query-Assistenten     Der Query-Assistent erleichtert Ihnen das Auswählen und Erfassen von Daten aus verschiedenen Tabellen und Feldern in Ihrer Datenbank. Mithilfe des Query-Assistenten können Sie die Tabellen und Felder auswählen, die berücksichtigt werden sollen. Eine innere Verknüpfung (eine Abfrageoperation, die festlegt, dass Zeilen aus zwei Tabellen auf der Grundlage identischer Feldwerte kombiniert werden) wird automatisch erstellt, wenn der Assistent ein Primärschlüsselfeld in einer Tabelle und ein Feld mit demselben Namen in einer zweiten Tabelle erkennt.

Sie haben im Query-Assistenten zudem die Möglichkeit, die Ergebnismenge zu sortieren und einfache Filtervorgänge auszuführen. Im letzten Schritt des Assistenten können Sie auswählen, ob die Daten an Excel zurückgegeben werden sollen, oder die Abfrage in Microsoft Query weiter optimieren. Nach dem Erstellen der Abfrage können Sie diese entweder in Excel oder in Microsoft Query ausführen.

Führen Sie die folgenden Schritte aus, um den Query-Assistenten zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus anderen Quellen, und klicken Sie dann auf Von Microsoft Query.

  2. Vergewissern Sie sich, dass im Dialogfeld Datenquelle auswählen das Kontrollkästchen Query-Assistenten zur Erstellung/Bearbeitung von Abfragen verwenden aktiviert ist.

  3. Doppelklicken Sie auf die gewünschte Datenquelle.

    – Oder –

    Klicken Sie auf die gewünschte Datenquelle, und klicken Sie dann auf OK.

Arbeiten Sie direkt in Microsoft Query, wenn Sie andere Abfragetypen erstellen möchten     Wenn Sie eine komplexere Abfrage erstellen möchten, als im Query-Assistenten möglich ist, können Sie direkt in Microsoft Query arbeiten. Mithilfe von Microsoft Query können Sie Abfragen anzeigen und ändern, die Sie im Query-Assistenten angelegt haben, oder Sie können ohne den Assistenten neue Abfragen erstellen. Arbeiten Sie direkt in Microsoft Query, wenn Sie Abfragen erstellen möchten, die Folgendes leisten:

  • Auswählen spezifischer Daten in einem Feld     In einer großen Datenbank möchten Sie möglicherweise einige der Daten eines Felds auswählen und nicht benötigte Daten unberücksichtigt lassen. Wenn Sie zum Beispiel Daten zu zwei Produkten eines Felds benötigen, das Informationen zu vielen Produkten enthält, wählen Sie mithilfe von Kriterien die Daten nur für die beiden gewünschten Produkte aus.

  • Abrufen von Daten auf der Grundlage verschiedener Kriterien bei jedem Ausführen der Abfrage     Wenn Sie den gleichen Excel-Bericht oder die gleiche Zusammenfassung für mehrere Bereiche der gleichen externen Daten erstellen müssen, beispielsweise einen separaten Verkaufsbericht für jede Region, können Sie eine Parameterabfrage erstellen. Wenn Sie eine Parameterabfrage ausführen, werden Sie aufgefordert, den Wert anzugeben, der als Kriterium verwendet wird, wenn mit der Abfrage Datensätze ausgewählt werden. In einer Parameterabfrage können Sie beispielsweise aufgefordert werden, eine bestimmte Region einzugeben, und Sie können diese Abfrage wieder verwenden, um jeden Ihrer regionalen Verkaufsberichte zu erstellen.

  • Verknüpfen von Daten auf eine andere Weise     Die inneren Verknüpfungen, die vom Query-Assistenten erstellt werden, stellen den am häufigsten verwendeten Verknüpfungstyp bei Abfragen dar. Manchmal empfiehlt sich jedoch die Verwendung eines anderen Verknüpfungstyps. Wenn Sie beispielsweise über eine Tabelle mit Produktvertriebsinformationen und eine Tabelle mit Kundeninformationen verfügen, verhindert eine innere Verknüpfung (der Verknüpfungstyp, der vom Query-Assistenten erstellt wird) das Abrufen der Kundendatensätze für Kunden, die keine Produkte erworben haben. Mithilfe von Microsoft Query können Sie diese Tabellen jedoch so verknüpfen, dass alle Kundendatensätze sowie die Vertriebsdaten jener Kunden abgerufen werden, die Produkte erworben haben.

Führen Sie die folgenden Schritte aus, um Microsoft Query zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus anderen Quellen, und klicken Sie dann auf Von Microsoft Query.

  2. Vergewissern Sie sich, dass im Dialogfeld Datenquelle auswählen das Kontrollkästchen Query-Assistenten zur Erstellung/Bearbeitung von Abfragen verwenden deaktiviert ist.

  3. Doppelklicken Sie auf die gewünschte Datenquelle.

    – Oder –

    Klicken Sie auf die gewünschte Datenquelle, und klicken Sie dann auf OK.

Erneutes Verwenden und Freigeben von Abfragen     Im Query-Assistenten und in Microsoft Query können Sie Ihre Abfragen als DQY-Dateien speichern, die bearbeitet, wieder verwendet und freigegeben werden können. In Excel können DQY-Dateien direkt geöffnet werden, sodass Sie oder andere Benutzer mit der gleichen Abfrage zusätzliche externe Datenbereiche erstellen können.

So öffnen Sie eine gespeicherte Abfrage in Excel:

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus anderen Quellen, und klicken Sie dann auf Von Microsoft Query. Daraufhin wird das Dialogfeld Datenquelle auswählen angezeigt.

  2. Klicken Sie im Dialogfeld Datenquelle auswählen auf die Registerkarte Abfragen.

  3. Doppelklicken Sie auf die gespeicherte Abfrage, die Sie öffnen möchten. Die Abfrage wird in Microsoft Query angezeigt.

Wenn Sie eine gespeicherte Abfrage öffnen möchten und Microsoft Query bereits geöffnet ist, klicken Sie in Microsoft Query auf das Menü Datei und dann auf Öffnen.

Wenn Sie auf eine DQY-Datei doppelklicken, wird Excel geöffnet, die Abfrage ausgeführt und das Ergebnis in ein neues Arbeitsblatt eingefügt.

Wenn Sie in Excel eine Zusammenfassung oder einen Bericht freigeben möchten, die bzw. der auf externen Daten beruht, können Sie anderen Benutzern eine Arbeitsmappe zur Verfügung stellen, die einen externen Datenbereich enthält, oder Sie können eine Vorlage erstellen. Über eine Vorlage können Sie die Zusammenfassung oder den Bericht speichern, ohne dass Sie die externen Daten speichern müssen. Damit bleibt die Datei kleiner. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

Seitenanfang

Arbeiten mit den Daten in Excel

Nach dem Erstellen einer Abfrage im Query-Assistenten oder in Microsoft Query können Sie die Daten an ein Excel-Arbeitsblatt zurückgeben. Die Daten werden dann entweder in einen Externer Datenbereich oder in einen PivotTable-Bericht umgewandelt, den Sie formatieren und aktualisieren können.

Formatieren abgerufener Daten     In Excel können Sie verschiedene Tools (z. B. Diagramme oder automatische Teilergebnisse) verwenden, um die von Microsoft Query abgerufenen Daten darzustellen oder zusammenzufassen. Sie können Daten formatieren, wobei die Formatierung auch dann erhalten bleibt, wenn die externen Daten aktualisiert werden. Sie können anstelle der Feldnamen eigene Spaltenbezeichnungen verwenden und automatisch Zeilennummern einfügen.

Neue Daten, die Sie am Ende eines Bereichs eingeben, können von Excel automatisch wie die vorhergehenden Zeilen formatiert werden. Darüber hinaus können Formeln, die in den vorhergehenden Zeilen wiederholt wurden, automatisch kopiert und auf zusätzliche Zeilen ausgeweitet werden.

Hinweis : Für die Erweiterung auf neue Zeilen im Bereich müssen Formate und Formeln in mindestens drei der fünf letzten vorhergehenden Zeilen enthalten sein.

Sie können diese Option jederzeit aktivieren (oder wieder deaktivieren):

  1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche , klicken Sie auf Excel-Optionen und anschließend auf die Kategorie Erweitert.

  2. Aktivieren Sie im Bereich Bearbeiten das Kontrollkästchen Datenbereich und Formeln erweitern, um diese Option zu aktivieren. Zum Deaktivieren der automatischen Datenbereichsformatierung deaktivieren Sie das Kontrollkästchen.

Aktualisieren externer Daten     Wenn Sie externe Daten aktualisieren, führen Sie die Abfrage aus, um neue oder geänderte Daten abzurufen, die Ihren Angaben entsprechen. Sie können eine Abfrage sowohl in Microsoft Query als auch in Excel aktualisieren. Excel bietet mehrere Optionen zum Aktualisieren von Abfragen, so z. B. das Aktualisieren von Daten bei jedem Öffnen der Arbeitsmappe oder das automatische Aktualisieren in bestimmten Zeitabständen. Sie können beim Aktualisierungsvorgang weiter in Excel arbeiten und dabei den Status überprüfen. Weitere Informationen finden Sie unter Aktualisieren verbundener (importierter) Daten.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×