Verwenden von Microsoft Query zum Abrufen externer Daten

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können Microsoft Query verwenden, um Daten aus externen Quellen abzurufen. Wenn Sie Microsoft Query zum Abrufen von Daten aus ihren Unternehmensdatenbanken und-Dateien verwenden, müssen Sie die Daten, die Sie in Excel analysieren möchten, nicht erneut eingeben. Sie können Ihre Excel-Berichte und-Zusammenfassungen auch automatisch aus der ursprünglichen Quelldatenbank aktualisieren, sobald die Datenbank mit neuen Informationen aktualisiert wird.

Mit Microsoft Query können Sie eine Verbindung mit externen Datenquellen herstellen, Daten aus diesen externen Quellen auswählen, diese Daten in Ihr Arbeitsblatt importieren und die Daten nach Bedarf aktualisieren, damit Ihre Arbeitsblattdaten mit den Daten in den externen Quellen synchronisiert bleiben.

Typen von Datenbanken, auf die Sie zugreifen können     Sie können Daten aus verschiedenen Datenbanktypen abrufen, einschließlich Microsoft Office Access, Microsoft SQL Server und Microsoft SQL Server OLAP Services. Sie können auch Daten aus Excel-Arbeitsmappen und aus Textdateien abrufen.

Microsoft Office bietet Treiber, mit denen Sie Daten aus den folgenden Datenquellen abrufen können:

  • Microsoft SQL Server Analysis Services (OLAP-Anbieter )

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Text Datei Datenbanken

Sie können auch ODBC-Treiber oder Datenquellentreiber anderer Hersteller verwenden, um Informationen aus Datenquellen abzurufen, die hier nicht aufgeführt sind, einschließlich anderer Typen von OLAP-Datenbanken. Informationen zum Installieren eines ODBC-Treibers oder Datenquellentreibers, der hier nicht aufgeführt ist, finden Sie in der Dokumentation der Datenbank, oder wenden Sie sich an den Datenbankanbieter.

Auswählen von Daten aus einer Datenbank     Sie rufen Daten aus einer Datenbank ab, indem Sie eine Abfrage erstellen, bei der es sich um eine Frage handelt, die Sie zu den in einer externen Datenbank gespeicherten Daten Fragen. Wenn beispielsweise Ihre Daten in einer Access-Datenbank gespeichert sind, möchten Sie möglicherweise die Umsatzzahlen für ein bestimmtes Produkt nach Region kennen. Sie können einen Teil der Daten abrufen, indem Sie nur die Daten für das Produkt und die Region auswählen, die Sie analysieren möchten.

Mit Microsoft Query können Sie die gewünschten Datenspalten auswählen und nur diese Daten in Excel importieren.

Aktualisieren des Arbeitsblatts in einem Vorgang     Nachdem Sie externe Daten in einer Excel-Arbeitsmappe gespeichert haben, können Sie bei jeder Änderung der Datenbank die Daten Aktualisieren, um Ihre Analyse zu aktualisieren, ohne Ihre Zusammenfassungsberichte und Diagramme neu erstellen zu müssen. So können Sie beispielsweise eine monatliche Umsatz Zusammenfassung erstellen und jeden Monat aktualisieren, wenn die neuen Verkaufszahlen eingehen.

Wie Microsoft Query Datenquellen verwendet     Nachdem Sie eine Datenquelle für eine bestimmte Datenbank eingerichtet haben, können Sie Sie immer dann verwenden, wenn Sie eine Abfrage zum auswählen und Abrufen von Daten aus dieser Datenbank erstellen möchten, ohne alle Verbindungsinformationen erneut eingeben zu müssen. Microsoft Query verwendet die Datenquelle, um eine Verbindung mit der externen Datenbank herzustellen und Ihnen anzuzeigen, welche Daten verfügbar sind. Nachdem Sie Ihre Abfrage erstellt und die Daten an Excel zurückgegeben haben, stellt Microsoft Query die Excel-Arbeitsmappe mit den Abfrage-und Datenquelleninformationen bereit, damit Sie die Verbindung mit der Datenbank wiederherstellen können, wenn Sie die Daten aktualisieren möchten.

Abbildung: So werden in Query Datenquellen verwendet

Verwenden von Microsoft Query zum Importieren von Daten     Wenn Sie externe Daten in Excel mit Microsoft Query importieren möchten, führen Sie diese grundlegenden Schritte aus, die in den folgenden Abschnitten ausführlich beschrieben werden.

Was ist eine Datenquelle?     Bei einer Datenquelle handelt es sich um einen gespeicherten Satz von Informationen, mit dem Excel und Microsoft Query eine Verbindung mit einer externen Datenbank herstellen können. Wenn Sie Microsoft Query zum Einrichten einer Datenquelle verwenden, geben Sie der Datenquelle einen Namen, und geben Sie dann den Namen und den Speicherort der Datenbank oder des Servers, den Typ der Datenbank sowie ihre Anmelde-und Kennwortinformationen an. Die Informationen umfassen auch den Namen eines OBDC-Treibers oder eines Datenquellentreibers, bei dem es sich um ein Programm handelt, das Verbindungen zu einem bestimmten Typ von Datenbank macht.

So richten Sie eine Datenquelle mithilfe von Microsoft Query ein:

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe externe Daten abrufen auf aus anderen Quellen, und klicken Sie dann auf von Microsoft Query.

  2. Führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie eine Datenquelle für eine Datenbank, eine Textdatei oder eine Excel-Arbeitsmappe angeben möchten, klicken Sie auf die Registerkarte Datenbanken .

    • Wenn Sie eine OLAP-Cube-Datenquelle angeben möchten, klicken Sie auf die Registerkarte OLAP -Cubes. Diese Registerkarte ist nur verfügbar, wenn Sie Microsoft Query aus Excel ausgeführt haben.

  3. Doppelklicken Sie auf <New Data Source>.

    – oder –

    Klicken Sie auf <New Data Source>, und klicken Sie dann auf OK.

    Das Dialogfeld neue Datenquelle erstellen wird angezeigt.

  4. Geben Sie in Schritt 1 einen Namen ein, um die Datenquelle zu identifizieren.

  5. Klicken Sie in Schritt 2 auf einen Treiber für den Typ der Datenbank, den Sie als Datenquelle verwenden.

    Hinweise: 

    • Wenn die externe Datenbank, auf die Sie zugreifen möchten, nicht von den ODBC-Treibern unterstützt wird, die mit Microsoft Query installiert werden, müssen Sie einen Microsoft Office-kompatiblen ODBC-Treiber von einem Drittanbieter beziehen und installieren, beispielsweise den Hersteller des Datenbank. Wenden Sie sich zur Installationsanleitung an den Datenbankanbieter.

    • Für OLAP-Datenbanken sind keine ODBC-Treiber erforderlich. Wenn Sie Microsoft Query installieren, werden Treiber für Datenbanken installiert, die mit Microsoft SQL Server Analysis Services erstellt wurden. Wenn Sie eine Verbindung mit anderen OLAP-Datenbanken herstellen möchten, müssen Sie einen Datenquellentreiber und eine Client Software installieren.

  6. Klicken Sie auf verbinden, und geben Sie dann die Informationen ein, die erforderlich sind, um eine Verbindung mit der Datenquelle herzustellen. Für Datenbanken, Excel-Arbeitsmappen und Textdateien hängt die von Ihnen bereitgestellten Informationen vom Typ der Datenquelle ab, die Sie ausgewählt haben. Sie werden möglicherweise aufgefordert, einen Anmeldenamen, ein Kennwort, die Version der Datenbank, die Sie verwenden, den Datenbankspeicherort oder andere Informationen anzugeben, die für den Typ der Datenbank spezifisch sind.

    Wichtig: 

    • Verwenden Sie sichere Kennwörter, bei denen Groß- und Kleinbuchstaben, Zahlen und Symbole kombiniert sind. Unsichere Kennwörter weisen nicht diese Mischung auf. Sicheres Kennwort: Y6dh!et5. Unsicheres Kennwort: Haus27. Kennwörter sollten mindestens acht Zeichen umfassen. Ein Pass-Ausdruck mit mindestens 14 Zeichen ist besser geeignet.

    • Es ist wichtig, dass Sie sich das jeweilige Kennwort merken. Wenn Sie das Kennwort vergessen, kann es nicht von Microsoft abgerufen werden. Bewahren Sie die notierten Kennwörter an einem sicheren Ort auf, damit sie nicht mit den zu schützenden Informationen in Verbindung gebracht werden können.

  7. Nachdem Sie die erforderlichen Informationen eingegeben haben, klicken Sie auf OK oder Fertig stellen , um zum Dialogfeld neue Datenquelle erstellen zurückzukehren.

  8. Wenn Ihre Datenbank Tabellen enthält und Sie möchten, dass eine bestimmte Tabelle automatisch im Abfrage-Assistenten angezeigt wird, klicken Sie auf das Feld für Schritt 4, und klicken Sie dann auf die gewünschte Tabelle.

  9. Wenn Sie Ihren Anmeldenamen und Ihr Kennwort bei der Verwendung der Datenquelle nicht eingeben möchten, aktivieren Sie das Kontrollkästchen meine Benutzer-ID und das Kennwort in der Datenquellendefinition speichern . Das gespeicherte Kennwort ist nicht verschlüsselt. Wenn das Kontrollkästchen nicht verfügbar ist, erkundigen Sie sich beim Datenbankadministrator, ob diese Option zur Verfügung gestellt werden kann.

    Sicherheitshinweis: Vermeiden Sie das Speichern von Anmeldeinformationen beim Herstellen einer Verbindung mit Datenquellen. Diese Informationen werden möglicherweise als nur-Text-Datei gespeichert, und ein böswilliger Benutzer kann auf die Informationen zugreifen, um die Sicherheit der Datenquelle zu gefährden.

Nachdem Sie diese Schritte ausgeführt haben, wird der Name der Datenquelle im Dialogfeld Datenquelleauswählen angezeigt.

Verwenden des Abfrage-Assistenten für die meisten Abfragen     Mit dem Abfrage-Assistenten können Sie Daten aus unterschiedlichen Tabellen und Feldern in der Datenbank einfach auswählen und zusammenführen. Mithilfe des Abfrage-Assistenten können Sie die Tabellen und Felder auswählen, die Sie einbeziehen möchten. Eine innere Verknüpfung (ein Abfragevorgang, der angibt, dass Zeilen aus zwei Tabellen auf der Grundlage identischer Feldwerte kombiniert werden) wird automatisch erstellt, wenn der Assistent ein Primärschlüsselfeld in einer Tabelle und ein Feld mit demselben Namen in einer zweiten Tabelle erkennt.

Sie können den Assistenten auch verwenden, um die Ergebnismenge zu sortieren und eine einfache Filterung durchzuführen. Im letzten Schritt des Assistenten können Sie auswählen, ob die Daten an Excel zurückgegeben werden sollen, oder die Abfrage in Microsoft Query weiter verfeinern. Nachdem Sie die Abfrage erstellt haben, können Sie Sie entweder in Excel oder in Microsoft Query ausführen.

Führen Sie die folgenden Schritte aus, um den Abfrage-Assistenten zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe externe Daten abrufen auf aus anderen Quellen, und klicken Sie dann auf von Microsoft Query.

  2. Stellen Sie im Dialogfeld Datenquelleauswählen sicher, dass das Kontrollkästchen Abfrage-Assistent zum Erstellen/Bearbeiten von Abfragen verwenden aktiviert ist.

  3. Doppelklicken Sie auf die Datenquelle, die Sie verwenden möchten.

    – oder –

    Klicken Sie auf die Datenquelle, die Sie verwenden möchten, und klicken Sie dann auf OK.

Arbeiten direkt in Microsoft Query für andere Arten von Abfragen     Wenn Sie eine komplexere Abfrage erstellen möchten, als der Abfrage-Assistent zulässt, können Sie direkt in Microsoft Query arbeiten. Sie können Microsoft Query verwenden, um Abfragen anzuzeigen und zu ändern, die Sie im Abfrage-Assistenten erstellen, oder Sie können neue Abfragen erstellen, ohne den Assistenten zu verwenden. Arbeiten Sie direkt in Microsoft Query, wenn Sie Abfragen erstellen möchten, die die folgenden Aktionen ausführen:

  • Auswählen bestimmter Daten aus einem Feld     In einer umfangreichen Datenbank möchten Sie möglicherweise einige Daten in einem Feld auswählen und nicht benötigte Daten auslassen. Wenn Sie beispielsweise Daten für zwei Produkte in einem Feld benötigen, das Informationen für viele Produkte enthält, können Sie Kriterien verwenden, um nur Daten für die beiden gewünschten Produkte auszuwählen.

  • Jedes Mal, wenn Sie die Abfrage ausführen, Daten basierend auf unterschiedlichen Kriterien abrufen     Wenn Sie denselben Excel-Bericht oder eine Zusammenfassung für mehrere Bereiche in denselben externen Daten erstellen müssen, beispielsweise einen separaten Umsatzbericht für die einzelnen Regionen, können Sie einen Parameterabfrage erstellen. Wenn Sie eine Parameterabfrage ausführen, werden Sie aufgefordert, einen Wert als Kriterium zu verwenden, wenn die Abfragedatensätze auswählt. Beispielsweise werden Sie von einer Parameterabfrage aufgefordert, einen bestimmten Bereich einzugeben, und Sie können diese Abfrage wieder verwenden, um jeden Ihrer regionalen Vertriebsberichte zu erstellen.

  • Verknüpfen von Daten auf unterschiedliche Weise     Die inneren Joins, die vom Abfrage-Assistenten erstellt werden, sind der häufigste Verknüpfungstyp, der beim Erstellen von Abfragen verwendet wird. Manchmal möchten Sie jedoch einen anderen Verknüpfungstyp verwenden. Wenn Sie beispielsweise über eine Tabelle mit Produktvertriebs Informationen und eine Tabelle mit Kundeninformationen verfügen, verhindert eine innere Verknüpfung (der vom Abfrage-Assistenten erstellte Typ) das Abrufen von Kundendatensätzen für Kunden, die keinen Einkauf getätigt haben. Mit Microsoft Query können Sie an diesen Tabellenteil nehmen, damit alle Kundendatensätze abgerufen werden, zusammen mit den Verkaufsdaten für die Kunden, die Käufe getätigt haben.

Führen Sie die folgenden Schritte aus, um Microsoft Query zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe externe Daten abrufen auf aus anderen Quellen, und klicken Sie dann auf von Microsoft Query.

  2. Stellen Sie im Dialogfeld Datenquelleauswählen sicher, dass das Kontrollkästchen Abfrage-Assistent zum Erstellen/Bearbeiten von Abfragen verwenden deaktiviert ist.

  3. Doppelklicken Sie auf die Datenquelle, die Sie verwenden möchten.

    – oder –

    Klicken Sie auf die Datenquelle, die Sie verwenden möchten, und klicken Sie dann auf OK.

Wieder verwenden und Freigeben von Abfragen     Sowohl im Abfrage-Assistenten als auch in Microsoft Query können Sie Ihre Abfragen als DQY-Datei speichern, die Sie ändern, wieder verwenden und freigeben können. Excel kann DQY-Dateien direkt öffnen, sodass Sie oder andere Benutzer zusätzliche externe Datenbereiche aus derselben Abfrage erstellen können.

So öffnen Sie eine gespeicherte Abfrage in Excel:

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe externe Daten abrufen auf aus anderen Quellen, und klicken Sie dann auf von Microsoft Query. Das Dialogfeld Datenquelleauswählen wird angezeigt.

  2. Klicken Sie im Dialogfeld Datenquelleauswählen auf die Registerkarte Abfragen .

  3. Doppelklicken Sie auf die gespeicherte Abfrage, die Sie öffnen möchten. Die Abfrage wird in Microsoft Query angezeigt.

Wenn Sie eine gespeicherte Abfrage öffnen möchten und Microsoft Query bereits geöffnet ist, klicken Sie auf das Menü Microsoft Query- Datei , und klicken Sie dann auf Öffnen.

Wenn Sie auf eine DQY-Datei doppelklicken, wird Excel geöffnet, die Abfrage wird ausgeführt, und die Ergebnisse werden dann in ein neues Arbeitsblatt eingefügt.

Wenn Sie eine Excel-Zusammenfassung oder einen Bericht freigeben möchten, die auf externen Daten basiert, können Sie anderen Benutzern eine Arbeitsmappe zuweisen, die einen externen Datenbereich enthält, oder Sie können eine Vorlage erstellen. Eine Vorlage ermöglicht es Ihnen, die Zusammenfassung oder den Bericht zu speichern, ohne die externen Daten zu speichern, damit die Datei kleiner ist. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

Nachdem Sie eine Abfrage im Abfrage-Assistenten oder in Microsoft Query erstellt haben, können Sie die Daten an ein Excel-Arbeitsblatt zurückgeben. Die Daten werden dann zu einer Externer Datenbereich oder PivotTable-Bericht, die Sie formatieren und aktualisieren können.

Formatieren von abgerufenen Daten     In Excel können Sie mithilfe von Tools wie Diagrammen oder automatischen Teilergebnissen die von Microsoft Query abgerufenen Daten präsentieren und zusammenfassen. Sie können die Daten formatieren, und die Formatierung bleibt erhalten, wenn Sie die externen Daten aktualisieren. Sie können anstelle der Feldnamen eigene Spaltenbeschriftungen verwenden und Zeilennummern automatisch hinzufügen.

Excel kann neue Daten, die Sie am Ende eines Bereichs eingeben, automatisch formatieren, damit Sie den vorhergehenden Zeilen entsprechen. Excel kann auch Formeln, die in den vorherigen Zeilen wiederholt wurden, automatisch kopieren und auf weitere Zeilen erweitern.

Hinweis: Um auf neue Zeilen im Bereich erweitert zu werden, müssen die Formate und Formeln in mindestens drei der fünf vorhergehenden Zeilen angezeigt werden.

Sie können diese Option (oder wieder aus) jederzeit aktivieren:

  1. Klicken Sie auf Datei > Optionen > Erweitert.

    In Excel 2007: Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , klicken Sie auf Excel-Optionen, und klicken Sie dann auf die Kategorie erweitert .

  2. Wählen Sie im Abschnitt Bearbeitungsoptionen die Kontrollkästchen Datenbereichs Formate und-Formeln erweitern aus. Deaktivieren Sie dieses Kontrollkästchen, um die automatische Formatierung des Datenbereichs erneut zu deaktivieren.

<c0>Aktualisieren von externen Daten</c0>.     Wenn Sie externe Daten aktualisieren, führen Sie die Abfrage aus, um alle neuen oder geänderten Daten abzurufen, die ihren Spezifikationen entsprechen. Sie können eine Abfrage sowohl in Microsoft Query als auch in Excel aktualisieren. In Excel stehen mehrere Optionen zum Aktualisieren von Abfragen zur Verfügung, einschließlich der Aktualisierung der Daten, wenn Sie die Arbeitsmappe öffnen und in Zeitintervallen automatisch aktualisieren. Sie können die Arbeit in Excel fortsetzen, während Daten aktualisiert werden, und Sie können auch den Status überprüfen, während die Daten aktualisiert werden. Weitere Informationen finden Sie unter Aktualisieren verbundener (importierter) Daten.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×