Verwenden von Matrixkonstanten in Matrixformeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn Sie eine Matrixformel eingeben, verwenden Sie üblicherweise einen Zellbereich im Arbeitsblatt. Dies ist aber nicht zwingend erforderlich. Sie können auch Matrixkonstanten verwenden, also Werte, die Sie in der Bearbeitungsleiste in geschweiften Klammern ({}) eingeben. Anschließend können Sie die jeweilige Konstante benennen, sodass sie einfacher wiederverwendet werden kann.

Sie können Konstanten in Matrixformeln oder direkt verwenden.

  1. Geben Sie in die Matrixformel eine geschweifte Klammer links, die gewünschten Werte und eine geschweifte Klammer rechts ein. Es folgt ein Beispiel: =SUMME(A1:E1*{1;2;3;4;5})

    Die Konstante befindet sich innerhalb der geschweiften Klammern ({)}, und diese geschweiften Klammern geben Sie tatsächlich manuell ein.

  2. Geben Sie den Rest der Formel ein, und drücken Sie STRG+UMSCHALT+EINGABETASTE.

    Die Formel sieht grundsätzlich wie {=SUMME(A1:E1*{1;2;3;4;5})} aus, und das Ergebnis sieht in etwa wie folgt aus:


    Eine Matrixkonstante, die in einer SUMMEN-Formel geschachtelt ist

    In der Formel wird A1 mit 1, B1 mit 2 usw. multipliziert. Dadurch ist es nicht erforderlich, dass Sie 1, 2, 3, 4, 5 in Zellen des Arbeitsblatts eingeben.

Verwenden einer Konstanten zum Eingeben von Werten in eine Spalte

Wenn Sie Werte in eine einzelne Spalte (beispielsweise in 3 Zellen in der Spalte C) eingeben möchten, gehen Sie wie folgt vor:

  1. Markieren Sie die Zellen, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Trennen Sie die Werte in der Konstanten durch Semikolons, nicht durch Punkte, und setzen Sie die Konstante in doppelte Anführungszeichen, wenn Sie Text eingeben. Beispiel: ={"Quartal 1";"Quartal 2";"Quartal 3"}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Die Konstante sieht wie folgt aus:

    Ein vertikale Matrixkonstane, in der Text verwendet wird

    Im Fachjargon ist dies eine eindimensionale vertikale Konstante.

Verwenden einer Konstanten zum Eingeben von Werten in eine Zeile

Wenn Sie schnell Werte in einen einzelne Zeile (beispielsweise die Zellen F1, G1 und H1) eingeben möchten, können Sie wie folgt vorgehen:

  1. Markieren Sie die Zellen, die verwendet werden sollen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Trennen Sie die Werte für diesen Fall aber mit Punkten, nicht mit Semikolons. Beispiel: ={1.2.3.4.5}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Die Konstante sieht wie folgt aus:

    Eine eindimensionale horizontale Matrixkonstante

    Im Fachjargon ist dies eine eindimensionale horizontale Konstante.

Verwenden einer Konstanten zum Eingeben von Werten in mehrere Spalten und Zeilen

  1. Markieren Sie die gewünschten Zellen.

    Achten Sie darauf, dass die Anzahl von markierten Spalten und Zeilen mit der Anzahl von Werten in der Konstanten übereinstimmt. Sollen mit der Konstanten beispielsweise Daten in vier Spalten und drei Zeilen geschrieben werden, markieren Sie genau so viele Spalten und Zeilen.

  2. Geben Sie ein Gleichheitszeichen und die Konstante ein. Trennen Sie die Werte in jeder Zeile durch Punkte, und geben Sie am Ende jeder Zeile ein Semikolon ein. Beispiel:

    ={1.2.3.4;5.6.7.8;9.10.11.12}

  3. Drücken Sie STRG+UMSCHALT+EINGABETASTE. Das Ergebnis sieht wie folgt aus:

    Eine zweidimensionale Matrixkonstante

    Im Fachjargon ist dies eine zweidimensionale Konstante, weil mit ihr Spalten und Zeilen ausgefüllt werden. Damit Sie sich nicht wundern: Es ist nicht möglich, eine dreidimensionale Konstante zu erstellen, denn eine Konstante kann nicht in einer anderen Konstanten geschachtelt werden.

Verwenden einer Konstanten in einer Formel

Nachdem Sie sich nun mit Matrixkonstanten vertraut gemacht haben, können Sie das folgende Arbeitsbeispiel verwenden.

  • Geben Sie in einer leeren Zelle die folgende Formel ein (oder verwenden Sie Kopieren und Einfügen), und drücken Sie dann STRG+UMSCHALT+EINGABETASTE:

    =SUMME(A1:E1*{1.2.3.4.5})

    In der Zelle A3 wird der Wert 85 angezeigt.

    Wie ist dieses Ergebnis entstanden? Der Wert in A1 wurde mit 1 multipliziert, der Wert in der Zelle B2 mit 2 usw. Anschließend wurden die Teilergebnisse mit der Funktion SUMME addiert. Das gleiche Ergebnis erzielen Sie mit folgender Formel: =SUMME(A1*1;B1*2;C1*3;D1*4;E1*5).

Sie können beide Wertemengen auch als Matrixkonstanten eingeben:

=SUMME({3.4.5.6.7}*{1.2.3.4.5})

Zum Ausprobieren kopieren Sie die Formel, markieren Sie eine leere Zelle, fügen Sie die Formel in die Bearbeitungsleiste ein, und drücken Sie dann STRG+UMSCHALT+EINGABETASTE. Sie erhalten dasselbe Ergebnis.

Hinweise : Suchen Sie nach folgenden Problemen, wenn die Konstanten nicht zum erwarteten Ergebnis führen:

  • Vergewissern Sie sich, dass die Werte mit dem richtigen Zeichen getrennt sind. Wenn ein Punkt oder Semikolon fehlt oder an der falschen Stelle steht, ist die Matrixkonstante wahrscheinlich fehlerhaft oder wird möglicherweise eine Warnmeldung angezeigt.

  • Möglicherweise haben Sie einen Zellbereich markiert, der nicht der Anzahl von Elementen in Ihrer Konstanten entspricht. Wenn Sie beispielsweise in einer Spalte sechs Zellen für die eine fünfzellige Konstante markiert haben, wird der in der leeren Zelle der Fehlerwert #NV angezeigt. Wenn Sie zu wenige Zellen markiert haben, ignoriert Excel jeden Wert, für den keine entsprechende Zelle vorhanden ist.

  • Weitere Informationen zu Matrixformeln finden Sie hier:

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×