Verwenden von Berichten zum Ermitteln der Leistung und Verwendung einer Website

Wenn Sie für die Verwaltung einer Website verantwortlich sind, werden Ihnen möglicherweise einige häufige Fragen zur Website gestellt wie die folgenden:

  • Wie viele Personen besuchen meine Website?

  • Wie hat sich der Datenverkehr auf der Website im Laufe der Zeit geändert?

  • Welche Personen sind die häufigsten Benutzer meiner Website?

  • Woher stammt der Datenverkehr auf meiner Website?

  • Auf welche Seiten und Ressourcen meiner Website wird am häufigsten zugegriffen?

  • Wie kann ich herausfinden, wo sich Dokumente und andere Ressourcen in unserem Workflowprozess befinden?

Zudem haben Sie als Manager einer Website möglicherweise auch Fragen, die Sie gern regelmäßig beantwortet haben möchten. Dazu könnten beispielsweise folgende Fragen gehören:

  • Befinden sich auf meiner Website Ressourcen, die ich entfernen kann, da sie nicht verwendet werden oder alt sind?

  • Wie kann ich Probleme auf meiner Website ermitteln (wie nicht verknüpfte Dateien, langsame Seiten und fehlerhafte Hyperlinks), bevor sie von Benutzern festgestellt und gemeldet werden?

Diese Fragen können zunächst eine große Herausforderung darstellen, aber mit Microsoft Office SharePoint Designer 2007 und einer in Windows SharePoint Services 3.0 oder in Microsoft Office SharePoint Server 2007 erstellten Website können Sie diese Fragen auf einfache Weise beantworten, indem Sie die Berichte in Office SharePoint Designer 2007 verwenden. In diesem Artikel wird erläutert, wie Sie Berichte zum Ermitteln der Leistung und Verwendung einer Website verwenden.

Wichtig : Daten für durch Office SharePoint Designer 2007 generierte Berichte werden auf dem Server gespeichert, auf dem die Website gehostet wird. Serveradministratoren können den Zugriff auf diese Berichte gewähren oder verweigern. Wenn die von Ihnen angeforderten Berichte keine Daten enthalten, wenden Sie sich für Hilfe an Ihren Serveradministrator. Beachten Sie, dass Sie mindestens über Webdesignerberechtigungen auf dem Server verfügen müssen, um die Website öffnen und die Berichte ausführen zu können.

Was möchten Sie tun?

Anzeigen des Websiteübersichtsberichts

Anzeigen von Berichten zu Dateien

Anzeigen von Berichten zu freigegebenem Inhalt

Anzeigen von Berichten zu Problemen

Anzeigen des Berichts "Verwendungszusammenfassung"

Anzeigen ausführlicher Verwendungsberichte

Darstellen der Ergebnisse von Verwendungsberichten in einem Diagramm

Sortieren eines Berichts

Filtern eines Berichts

Kopieren eines Berichts

Speichern eines Berichts

Anzeigen des Websiteübersichtsberichts

Der Websiteübersichtsbericht bietet eine allgemeine Übersicht über Ihre Website sowie Verknüpfungen zu ausführlicheren Berichten. Sie können beispielsweise einen Websiteübersichtsbericht wie den in der folgenden Abbildung generieren.

Websiteübersichtsbericht

So generieren Sie einen Websiteübersichtsbericht für Ihre Website:

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Zeigen Sie im Menü Website auf Berichte, und klicken Sie anschließend auf Websiteübersicht.

    Der Bericht wird generiert.

Hinweis : Sie können auf die Hyperlinks in der Spalte Name klicken, um zu ausführlicheren Berichten zu navigieren. Klicken Sie beispielsweise auf Fehlerhafte Hyperlinks, um direkt zum Bericht Fehlerhafte Hyperlinks zu navigieren.

Seitenanfang

Anzeigen von Berichten zu Dateien

Sie können Berichte generieren, in denen alle Dateien, kürzlich hinzugefügte oder geänderte Dateien oder ältere Dateien angezeigt werden. Wenn Sie beispielsweise neuen Inhalt auf der Startseite Ihrer Website oder in einem Newsletter, in dem für Ihre Website geworben wird, hervorheben möchten, können Sie den Bericht für kürzlich hinzugefügte Dateien verwenden, um den neuen Inhalt auf schnelle Weise zu identifizieren. Außerdem können Sie den Bericht Ältere Dateien verwenden, um alten Inhalt zu identifizieren, der auf mögliche Aktualisierungen oder ein Entfernen geprüft werden kann.

Wenn Sie Berichte zu Dateien ausführen möchten, geben Sie zunächst die Definitionen für kürzlich hinzugefügte/geänderte Dateien und ältere Dateien an sowie die Anzahl von Monaten, die in Berichten nach Monat dargestellt werden soll:

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Klicken Sie im Menü Extras auf Anwendungsoptionen.

  3. Klicken Sie auf die Registerkarte Berichtsansicht.

    Dialogfeld 'Anwendungsoptionen' mit angezeigter Registerkarte 'Berichtsansicht'

  4. Geben Sie im Feld "Kürzlich hinzugefügte/geänderte Dateien" sind weniger als die Anzahl von Tagen ein, mit der eine kürzlich hinzugefügte/geänderte Seite identifiziert wird.

  5. Geben Sie im Feld "Ältere Dateien" sind mehr als die Anzahl von Tagen ein, mit der eine ältere Seite identifiziert wird.

  6. Geben Sie im Feld Anzahl dargestellter Monate die Anzahl von Monaten ein, die in Berichten nach Monat angezeigt werden soll.

  7. Klicken Sie auf OK.

    Nun können Sie die Berichte ausführen.

  8. Zeigen Sie im Menü Website auf Berichte, zeigen Sie auf Dateien, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten:

    • Alle Dateien     Zeigt eine Liste aller Dateien in der Website an.

    • Kürzlich hinzugefügte Dateien     Zeigt eine Liste der Dateien an, die der Website innerhalb der in Schritt 4 angegebenen Anzahl von Tagen hinzugefügt wurden.

    • Kürzlich geänderte Dateien     Zeigt eine Liste der Dateien an, die in der Website innerhalb der in Schritt 4 angegebenen Anzahl von Tagen geändert wurden.

    • Ältere Dateien     Zeigt eine Liste der Dateien an, die gemäß der von Ihnen in Schritt 5 angegebenen Anzahl von Tagen als "älter" betrachtet werden.

    • Checkoutstatus     Zeigt eine Liste der Dateien in Ihrer Website mit dem aktuellen Checkoutstatus für jede Datei an. (Dieser Bericht enthält außerdem Spalten für die Daten Ausgecheckt von, Version und Gesperrt am.)

      In der Berichtsansicht können Sie für Berichte zu Dateien auf Optionen in der Liste klicken, um die Einstellungen für ältere oder kürzlich hinzugefügte/geänderte Dateien auf schnelle Weise zu ändern.

      Berichtsansicht mit angezeigtem Menü zum Filtern nach dem Dateialter

Seitenanfang

Anzeigen von Berichten zu freigegebenem Inhalt

Freigegebener Inhalt kann Masterseiten, angepasste und andere in der Websitedefinition enthaltene Seiten sowie Stylesheetverknüpfungen umfassen. Mit Office SharePoint Designer 2007 können Sie freigegebenen Inhalt auf einfache Weise suchen. Wenn Sie beispielsweise ein Logo auf allen Seiten in Ihrer Website ändern möchten und Sie Masterseiten zum Steuern der Formatierungen der Seiten verwenden, können Sie den Bericht Masterseiten verwenden, um alle Masterseiten zu suchen, auf denen das Logo geändert werden soll. Sie können auch den Bericht Stylesheetverknüpfungen verwenden, um alle Stylesheets zu suchen, die aktualisiert werden müssen, damit sie die Änderung der Schriftart oder Formatierung widerspiegeln, die Sie auf die gesamte Website anwenden möchten.

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Zeigen Sie im Menü Website auf Berichte, zeigen Sie auf Freigegebener Inhalt, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten:

    • Dynamische Webvorlagen     Zeigt eine Liste aller Seiten in der Website mit der Spalte Dynamische Webvorlagen an, mit der angegeben wird, ob die einzelnen Seiten einer dynamischen Webvorlage zugeordnet sind (und wenn ja, welcher).

    • Masterseiten     Zeigt eine Liste aller Seiten in der Website mit der Spalte Masterseiten an, mit der angegeben wird, ob die einzelnen Seiten einer Masterseite angefügt wurden (und wenn ja, welcher).

    • Angepasste Seiten     Zeigt eine Liste aller Seiten in der Website mit der Spalte Angepasst an, mit der angegeben wird, ob die jeweiligen auf der Websitedefinition basierenden Seiten angepasst wurden.

    • Stylesheetverknüpfungen     Zeigt eine Liste aller Seiten in der Website mit der Spalte Stylesheetverknüpfungen an, mit der angegeben wird, ob eine Seite einem Stylesheet angefügt wurde.

      Hinweis : Bei den angezeigten Stylesheetverknüpfungen handelt es sich um statische Stylesheetverknüpfungen (<link>-Tags). Dynamische Stylesheetverknüpfungen, die durch Microsoft ASP.NET-Steuerelemente (wie <SharePoint:CssLink>) generiert werden, sind in diesem Bericht nicht enthalten.

Seitenanfang

Anzeigen von Berichten zu Problemen

Office SharePoint Designer 2007-Berichte zu Problemen können Ihnen helfen, mögliche Probleme vorab zu ermitteln und diese zu beheben, bevor Benutzer davon betroffen sind. Mit diesen Berichten können Sie beispielsweise langsame Seiten identifizieren, fehlerhafte Hyperlinks finden und nach eventuell zu löschenden Dateien suchen, die nicht mit anderen Dateien verknüpft sind. Wenn Sie die Berichte zu Problemen ausführen möchten, legen Sie zunächst die Einstellungen zum Definieren langsamer Seiten fest.

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Klicken Sie im Menü Extras auf Anwendungsoptionen.

  3. Klicken Sie auf die Registerkarte Berichtsansicht.

    Dialogfeld 'Anwendungsoptionen' mit angezeigter Registerkarte 'Berichtsansicht'

  4. Geben Sie im Feld "Langsame Seiten" brauchen zum Downloaden mindestens die Anzahl von Sekunden an, mit denen definiert wird, wie lange der Download einer langsamen Seite dauert.

  5. Geben Sie im Feld Angenommene Modemgeschwindigkeit die Anzahl der Kilobits pro Sekunde (Kbps) für die durchschnittliche Verbindungsgeschwindigkeit der Benutzer an.

  6. Klicken Sie auf OK.

    Nun können Sie die Berichte ausführen.

  7. Klicken Sie auf Website, zeigen Sie auf Berichte und dann auf Probleme, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten:

    • Unverknüpfte Dateien     Zeigt eine Liste aller Dateien in der Website an, zu denen keine Verknüpfungen bestehen. Mit dieser Liste können Sie nicht verwendete Dateien suchen, die aus der Website entfernt werden sollten. Beachten Sie, dass in diesem Bericht Verknüpfungen, die durch ASP.NET-Steuerelemente (wie das Inhaltsverzeichnis-Webpart in von Microsoft Office SharePoint Server 2007 erstellten Websites) nicht berücksichtigt werden.

    • Langsame Seiten     Zeigt eine Liste der Seiten in der Website an, die entsprechend der in Schritt 3 vorgenommenen Definition und der in Schritt 4 angegebenen durchschnittlichen Verbindungsgeschwindigkeit als Seiten identifiziert werden, deren Ladevorgang lange dauert. Beachten Sie, dass dieser Bericht die Zeit widerspiegelt, die zum Laden des Seitenmarkups benötigt wird. Von ASP.NET-Steuerelementen generierter dynamischer Inhalt wird nicht berücksichtigt.

    • Hyperlinks     Zeigt eine Liste aller Hyperlinks in der Website an. Nachdem Sie diesen Bericht ausgeführt haben, werden Sie in einem Dialogfeld gefragt, ob Sie die Hyperlinks in der Website überprüfen möchten. Klicken Sie auf Ja, wenn die einzelnen Hyperlinks von Office SharePoint Designer 2007 für Sie überprüft werden sollen. Als Ergebnis dieses Prozesses wird eine Liste mit Hyperlinks erstellt, von denen jeder als OK oder Fehlerhaft identifiziert wird. Zum Bearbeiten eines fehlerhaften Hyperlinks klicken Sie im Bericht auf den Hyperlink und anschließend auf der Symbolleiste, die in der Berichtsansicht oben rechts im Dokument angezeigt wird, auf Hyperlink bearbeiten.

      Hinweis :  Dialogfeld 'Hyperlink bearbeiten'

    • Komponentenfehler     Zeigt eine Liste aller Komponenten – beispielsweise interaktive Schaltflächen oder der Zugriffszähler (alle früher und allgemein als Webbots oder Bots bezeichnet) – an, von denen derzeit Fehler generiert werden. Sie können eine Liste der Webkomponenten anzeigen, indem Sie im Menü Einfügen auf Webkomponente klicken.

Seitenanfang

Anzeigen des Berichts "Verwendungszusammenfassung"

Mit Berichten zur Websiteverwendung können Sie einige der dringendsten Fragen beantworten, die Websitebesitzer zu ihren Websites haben, beispielsweise von wie vielen Personen die Website verwendet wird, welche Ressourcen am beliebtesten sind, wer die Website am häufigsten verwendet und von wo aus die Besucher auf die Website wechseln. Der Bericht Verwendungszusammenfassung enthält eine Übersicht über alle Besuche, Seitenzugriffe, heruntergeladenen Bytes und vieles mehr.

Bericht 'Verwendungszusammenfassung'

Befolgen Sie diese Schritte, um den Bericht Verwendungszusammenfassung auszuführen:

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Zeigen Sie im Menü Website auf Berichte und dann auf Verwendung, und klicken Sie anschließend auf Verwendungszusammenfassung.

    Der Bericht wird generiert. Sie können auf ein beliebiges durch einen Hyperlink verbundenes Objekt in der Spalte Name klicken, um einen ausführlicheren Bericht anzuzeigen.

Seitenanfang

Anzeigen ausführlicher Verwendungsberichte

Sie können ausführliche Verwendungsberichte ausführen, um zu beantworten, auf welche Weise Benutzer auf die Website zugreifen. Während in dem im vorherigen Abschnitt generierten Bericht Verwendungszusammenfassung die Gesamtanzahl der Seitenzugriffe angezeigt wird, wird im Bericht Monatliche Seitenzugriffe genau aufgeführt, wie viele Zugriffe für die einzelnen Seiten in der Website gezählt wurden. Nachfolgend sind die Schritte zum Ausführen ausführlicher Verwendungsberichte erläutert:

  1. Öffnen Sie die Website, für die Sie den Bericht in Office SharePoint Designer 2007 ausführen möchten.

  2. Zeigen Sie im Menü Website auf Berichte und dann auf Verwendung, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten:

    • Monatliche Zusammenfassung     Bietet eine Übersicht über die Anzahl der Besuche und Zugriffe sowie über die Gesamtzugriffe und die Downloadgröße auf Ihrer Website pro Monat.

    • Wöchentliche Zusammenfassung     Bietet eine Übersicht über die Anzahl der Besuche und Zugriffe sowie über die Gesamtzugriffe und die Downloadgröße auf Ihrer Website pro Woche.

    • Tägliche Zusammenfassung     Bietet eine Übersicht über die Anzahl der Besuche und Zugriffe sowie über die Gesamtzugriffe und die Downloadgröße auf Ihrer Website pro Tag.

    • Monatliche Seitenzugriffe     Bietet eine Übersicht über die Anzahl der Gesamtzugriffe und der einzelnen Zugriffe für jede Seite in Ihrer Website pro Monat.

    • Wöchentliche Seitenzugriffe     Bietet eine Übersicht über die Anzahl der Gesamtzugriffe und der einzelnen Zugriffe für jede Seite in Ihrer Website pro Woche.

    • Tägliche Seitenzugriffe     Bietet eine Übersicht über die Anzahl der Gesamtzugriffe und der einzelnen Zugriffe für jede Seite in Ihrer Website pro Tag.

    • Besucher     Bietet eine Übersicht über die Anzahl der Besucher und deren jeweiligen prozentualen Anteil an der gesamten Besucheranzahl für einen ausgewählten Monat.

    • Betriebssysteme     Bietet eine Übersicht über die Anzahl der Betriebssysteme der Besucher und den jeweiligen prozentualen Anteil an der Gesamtanzahl der Betriebssysteme für einen ausgewählten Monat.

    • Browser     Bietet eine Übersicht über die Anzahl der Browser der Besucher und den jeweiligen prozentualen Anteil an der Gesamtsumme der Browser für einen ausgewählten Monat.

    • Verweisende Domänen     Bietet eine Übersicht über die Anzahl der Besuche, die von einer bestimmten Domäne stammen, und den jeweiligen prozentualen Anteil an der Gesamtanzahl der Domänen für einen ausgewählten Monat.

    • Verweisende URLs     Bietet eine Übersicht über die Anzahl der Besuche, die von einer bestimmten URL stammen, und den jeweiligen prozentualen Anteil an der Gesamtanzahl der URLs für einen ausgewählten Monat.

    • Suchbegriffe     Enthält die Anzahl der in das Suchfeld der Website eingegebenen Suchbegriffe und den jeweiligen prozentualen Anteil an der Gesamtanzahl der Suchbegriffe für einen ausgewählten Monat.

Seitenanfang

Darstellen der Ergebnisse von Verwendungsberichten in einem Diagramm

Sie können auf einfache Weise ein Diagramm erstellen, in dem Verwendungsdaten grafisch dargestellt werden, und somit schnell Trends erkennen und Verwendungsmuster identifizieren.

  1. Zeigen Sie im Menü Website auf Berichte und dann auf Verwendung, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten.

  2. Klicken Sie auf der Symbolleiste oben rechts im Dokumentfenster auf die Liste Diagramm, und klicken Sie auf den Diagrammtyp, den Sie erstellen möchten, beispielsweise Säulendiagramm.

    Symbolleiste in der Berichtsansicht mit angezeigter Liste 'Diagramme'

    Der Bericht wird in einem neuen Fenster geöffnet.

    Verwendungsdatendiagramm

    Hinweis : Standardmäßig werden Diagrammdaten gemeinsam mit Verwendungsberichten generiert. Wenn Sie die Diagrammdaten beim Versuch, den Bericht auszuführen, nicht finden, klicken Sie im Menü Extras auf Anwendungsoptionen, klicken Sie auf die Registerkarte Berichtsansicht, und stellen Sie anschließend sicher, dass das Kontrollkästchen Diagramm beim Speichern des Verwendungsberichts einschließen aktiviert ist.

Seitenanfang

Sortieren eines Berichts

Sie können einen Bericht in der Berichtsansicht sortieren, indem Sie auf die Spaltenüberschriften klicken.

Seitenanfang

Filtern eines Berichts

Sie können die Ergebnisse eines Berichts einschränken, um nur die gewünschten Informationen anzuzeigen. Sie können entweder nur eine Spalte oder aber mehrere Spalten filtern, um einen progressiven Filter zu erstellen.

  1. Zeigen Sie im Menü Website auf Berichte, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten.

  2. Klicken Sie auf den Pfeil neben der Überschrift der Spalte, nach der Sie filtern möchten, und klicken Sie anschließend auf die Daten, die Sie filtern möchten.

    Wenn Sie beispielsweise nach dem Dateityp filtern, können Sie auf den Pfeil neben der Spaltenüberschrift Typ und anschließend auf bmp klicken, um nur Bitmapdateien im Bericht anzuzeigen.

    Spalte 'Typ' mit angezeigtem Filtermenü

  3. Wenn Sie nach mehr als einer Spalte filtern möchten, wiederholen Sie Schritt 2 für jede Spalte.

  4. Wenn Sie einen benutzerdefinierten Filter auf eine Spalte anwenden möchten, klicken Sie auf den Pfeil neben der Spaltenüberschrift, und klicken Sie dann auf (Benutzerdefiniert). Geben Sie Ihre Suchkriterien ein, und klicken Sie anschließend auf OK.

    Sie können beispielsweise einen benutzerdefinierten AutoFilter verwenden, um alle BMP- und GIF-Bilddateien in Ihrer Website zu identifizieren.

    Dialogfeld 'AutoFilter'

  5. Wenn Sie einen Filter aus einer Spalte entfernen möchten, klicken Sie auf den Pfeil neben der Überschrift dieser Spalte, und klicken Sie anschließend auf (Alle).

Hinweis : Derzeit angewendete Filtereinstellungen werden beim Schließen der Website gespeichert. Wenn Sie keine Dateien in einem neu ausgeführten Bericht finden können, werden diese Dateien möglicherweise durch Filter ausgeblendet, die Sie in einer früheren Sitzung angewendet haben.

Zum Entfernen aller Filter aus einem Bericht klicken Sie mit der rechten Maustaste auf eine beliebige Spaltenüberschrift und im angezeigten Kontextmenü auf Filter entfernen.

Seitenanfang

Kopieren eines Berichts

Nachdem Sie einen Bericht ausgeführt haben, möchten Sie die Ergebnisse möglicherweise kopieren und in eine E-Mail-Nachricht oder in ein anderes Dokument (z. B. ein Microsoft Office Excel-Arbeitsblatt) einfügen. Sie können alle Berichte mit Ausnahme des Berichts Websiteübersicht kopieren.

  1. Klicken Sie in dem ausgeführten Bericht mit der rechten Maustaste auf eine beliebige Spaltenüberschrift, und klicken Sie anschließend im Kontextmenü auf Bericht kopieren.

    Menü der Spalte 'Name' mit ausgewähltem Befehl 'Bericht kopieren'

  2. Fügen Sie die Daten in das Dokument oder die Nachricht ein.

Seitenanfang

Speichern eines Berichts

Sie können Berichte speichern, wenn Sie Microsoft Office Excel 2007 verwenden möchten, um die Ergebnisse anzuzeigen und zu analysieren oder um aus ihnen benutzerdefinierte Diagramme zu erstellen.

  1. Zeigen Sie im Menü Website auf Berichte, und klicken Sie anschließend auf den Bericht, den Sie ausführen möchten.

  2. Klicken Sie im Menü Datei auf Speichern. Oder drücken Sie STRG+S.

  3. Geben Sie im Feld Dateiname einen Namen für den Bericht ein, und klicken Sie anschließend auf Speichern. Der Bericht wird als HTM-Datei in Ihrer Website gespeichert.

    In Excel geöffneter Bericht

  4. Doppelklicken Sie auf den Bericht, um ihn zu öffnen.

    Der Bericht wird in Office Excel 2007 geöffnet.

Seitenanfang

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×