Verwenden des Arguments "Matrix" in einer VERWEIS-Funktion

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Beim Erstellen einer Formel mit der Funktion SVERWEIS oder WVERWEIS geben Sie ein Argument "Matrix" ein, bei dem es sich um einen Zellbereich, z. B. D2:F39, handelt. Die Funktion durchsucht diesen Bereich nach den gesuchten Daten.

Das Argument "Matrix" ist immer das zweite Argument einer SVERWEIS- oder WVERWEIS-Funktion (das erste Argument enthält den Wert, nach dem Sie suchen). Diese Funktionen können ohne das Argument "Matrix" nicht ausgeführt werden.

Bei Ihrem ersten Argument kann es sich um einen bestimmten Wert, z. B. "41" oder "Schmidt", oder um einen Zellbezug, z. B. F2, handeln. Das erste Argument würde also wie folgt aussehen:

=SVERWEIS(F2;...

Auf den zu suchenden Wert folgt immer das Argument "Matrix" wie hier:

=SVERWEIS(F2;B4:D39;...

Für den jeweiligen Zellbereich, der im Argument "Matrix" angegeben wird, können relative oder absolute Zellbezüge verwendet werden. Wenn Sie die Formel in andere Zellen kopieren möchten, müssen Sie absolute Zellbezüge (achten Sie auf die $-Zeichen) wie folgt verwenden:

=SVERWEIS(F2;$B$2:BD$39;...

Wenn sich die Zellen im Argument "Matrix" auf einem anderen Arbeitsblatt in Ihrer Arbeitsmappe befinden, muss das Argument den Blattnamen, gefolgt von einem Ausrufezeichen, enthalten. Die entsprechende Syntax sähe wie folgt aus:

=SVERWEIS(F2;Tabelle2!$C$14:E$42;...

Die Spalte mit den gesuchten Werten wird als drittes Argument eingegeben. Diese Spalte wird als Nachschlagespalte bezeichnet. Wenn sich die Werte, die Sie anzeigen möchten, in Spalte D befinden (der dritten Spalte der Matrix), ist das letzte Argument eine 3.

=SVERWEIS(F2;B4:D39;3)

Zwar ist die Verwendung eines vierten Arguments optional, doch empfiehlt es sich, entweder "Falsch" oder "Wahr" zu verwenden. Verwenden Sie "Falsch", wenn Sie nach einer genauen Übereinstimmung suchen.

=SVERWEIS(F2;B4:D39;3;Falsch)

Wenn Sie "Wahr" eingeben oder das vierte Argument nicht angeben, gibt die Funktion eine ungefähre Übereinstimmung des Werts zurück, den Sie im ersten Argument angegeben haben. Wenn also das erste Argument "Schmidt" und das vierte Argument "Wahr" lautet, gibt die SVERWEIS-Funktion "Schmidt", "Schmidtlein" usw. zurück. Wenn Sie dagegen "Falsch" verwenden, gibt sie nur die Zeichenfolge "Schmidt", also die genaue Übereinstimmung zurück, und dieses Ergebnis wird zumeist gewünscht.

Die Verwendung von "Wahr" ist noch komplizierter, wenn die Nachschlagespalte (die Spalte, die Sie im dritten Argument angegeben haben) nicht in aufsteigender Reihenfolge (A bis Z oder kleinste bis größte Zahl) sortiert ist. In diesem Fall gibt die Funktion möglicherweise ein falsches Ergebnis zurück.

Weitere Informationen zu den Funktionen SVERWEIS und WVERWEIS finden Sie unter Nachschlage- und Verweisfunktionen (Referenz).

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×