Verwalten externer Datenbereiche und ihrer Eigenschaften

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können die Eigenschaften eines externen Datenbereichs ändern, um Daten zu kontrollieren, die über eine Verbindung zu einer externen Datenquelle in ein Arbeitsblatt importiert wurden.

Was möchten Sie tun?

Erfahren Sie mehr über externe Datenbereiche und Eigenschaften

Suchen externer Datenbereiche

Ändern des Namens von externen Datenbereichen

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche

Kopieren eines externen Datenbereichs und seiner zugrunde liegenden Abfrage

Festlegen, wie neue Daten zu externen Datenbereichen hinzugefügt werden

Festlegen von Datenformatierung und -layout

Kopieren von Formeln, wenn externe Datenbereiche erweitert werden

Fixieren von Daten in externen Datenbereichen

Anpassen von Feldnamen in externen Datenbereichen

Löschen von externen Datenbereichen

Weitere Informationen über externe Datenbereiche und -eigenschaften

Ein externer Datenbereich (der auch als Abfragetabelle bezeichnet wird) ist ein definierter Name oder ein Tabellenname, der den Speicherort der Daten definiert, die in ein Arbeitsblatt integriert werden. Wenn Sie eine Verbindung mit externen Daten herstellen, erstellt Excel automatisch einen externen Datenbereich. Die einzige Ausnahme bei dieser Vorgehensweise bezieht sich auf einen mit einer Datenquelle verbundenen PivotTable-Bericht, der keinen externen Datenbereich verwendet. In Excel können Sie einen externen Datenbereich formatieren und gestalten oder in Berechnungen auf die gleiche Weise wie andere Daten verwenden.

Eigenschaften von externen Datenbereichen

Ein externer Datenbereich verfügt über zusätzliche Eigenschaften (die nicht mit den Verbindungseigenschaften verwechselt werden dürfen), die Sie zum Steuern der Daten verwenden können, z. B. für die Beibehaltung der Zellenformatierung und der Spaltenbreite. Sie können diese Eigenschaften externer Datenbereiche ändern, indem Sie in der Gruppe Verbindungen auf der Registerkarte Daten auf Eigenschaften klicken. Nehmen Sie dann die gewünschten Änderungen wie folgt vor:

  • Verwenden Sie für externe Datenbereiche, die über Microsoft Query und den Datenverbindungs-Assistenten erstellt werden, das Dialogfeld Externe Dateneigenschaften.

  • Verwenden Sie für externe Datenbereiche, die aus einer importierten Textdatei oder einer HTML-Daten abrufenden Webabfrage erstellt werden, das Dialogfeld Eigenschaften des externen Datenbereichs.

  • Verwenden Sie für externe Datenbereiche, die über eine XML-Daten abrufende Webabfrage erstellt werden, das Dialogfeld Eigenschaften der XML-Zuordnung.

Verwenden von Vorlagen mit externen Datenbereichen

Wenn Sie eine Zusammenfassung oder einen Bericht freigeben möchten, die bzw. der auf externen Daten basiert, können Sie für andere Benutzer eine Arbeitsmappe bereitstellen, die einen externen Datenbereich enthält, oder Sie können eine Berichtsvorlage erstellen. Eine Berichtvorlage ermöglicht das Speichern der Zusammenfassung oder des Berichts, ohne dass die externen Daten gespeichert werden. Die Datei ist daher kleiner. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

Seitenanfang

Suchen externer Datenbereiche

  1. Wählen Sie das Arbeitsblatt aus, in dem Sie nach einem Externer Datenbereich suchen möchten.

  2. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben Namenfeld, und klicken Sie dann auf den Namen des gewünschten externen Datenbereichs.

Seitenanfang

Ändern des Namens von externen Datenbereichen

  1. Klicken Sie auf der Registerkarte Formeln in der Gruppe Definierte Namen auf Namens-Manager.

    Abbildung des Excel-Menübands

  2. Klicken Sie im Dialogfeld Namens-Manager auf den Namen des externen Datenbereichs, und klicken Sie dann auf Bearbeiten. Sie können auch auf den Namen doppelklicken.

  3. Geben Sie im Dialogfeld Name bearbeiten den neuen Namen für den Verweis in das Feld Name ein.

Hinweis : Mithilfe der Schaltfläche Schließen wird nur das Dialogfeld Namens-Manager geschlossen. Sie müssen nicht auf Schließen klicken, um bereits vorgenommene Änderungen zu bestätigen.

Seitenanfang

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche

Sie können die zugrunde liegende Abfrage für einen externen Datenbereich ändern, der mithilfe von Microsoft Query, über eine importierte Textdatei, über eine Webabfrage oder im Datenverbindungs-Assistenten erstellt wurde.

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche, die mithilfe von Microsoft Query erstellt wurden

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  3. Klicken Sie im Dialogfeld Externe Dateneigenschaften auf Verbindungseigenschaften Eigenschaften .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

Weitere Informationen zum Erstellen und Bearbeiten von Abfragen in Microsoft Query finden Sie in der Microsoft Query-Hilfe.

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche, die mithilfe einer importierten Textdatei erstellt wurden

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verbindungen.

    Abbildung der Excel-Multifunktionsleiste

  3. Klicken Sie im Dialogfeld Arbeitsmappenverbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

  5. Klicken Sie im Dialogfeld Textdatei importieren auf Importieren.

  6. Nehmen Sie die Änderungen an der importierten Textdatei im Textimport-Assistenten vor, und klicken Sie dann auf Fertig stellen.

    Weitere Informationen zum Importieren von Textdateien finden Sie unter Importieren oder Exportieren von Textdateien.

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche, die mithilfe einer Webabfrage erstellt wurden

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  3. Klicken Sie im Dialogfeld Arbeitsmappenverbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition, und klicken Sie dann auf Abfrage bearbeiten.

  5. Nehmen Sie im Dialogfeld Webabfrage bearbeiten die Änderungen vor, und klicken Sie dann auf Fertig stellen.

Weitere Informationen zum Erstellen und Bearbeiten von Webabfragen finden Sie unter Abrufen externer Daten von einer Webseite.

Ändern der zugrunde liegenden Abfrage für externe Datenbereiche, die mithilfe des Datenverbindungs-Assistenten erstellt wurden

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für den Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  3. Klicken Sie im Dialogfeld Externe Dateneigenschaften auf Verbindungseigenschaften Eigenschaften .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition.

  5. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie im Feld Befehlstyp auf Tabelle, und ändern Sie dann im Feld Befehlstext den Wert in den Namen einer entsprechenden Tabelle, Ansicht oder Abfrage.

    • Klicken Sie im Feld Befehlstyp auf SQL oder Standard, und bearbeiten Sie dann im Feld Befehlstext die SQL-Anweisung.

      Hinweis : In Abhängigkeit von der Definition der Verbindung ist das Feld Befehlstyp möglicherweise nicht verfügbar (es wird abgeblendet angezeigt).

Seitenanfang

Kopieren eines externen Datenbereichs und seiner zugrunde liegenden Abfrage

  1. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben Namenfeld, und wählen Sie dann den Namen des zu kopierenden externen Datenbereichs aus.

    Für eine Excel-Tabelle wählen Sie den Namen des Bereichs aus und drücken dann STRG+A, um die Tabellenüberschriften auszuwählen.

    Wenn Sie Spaltenüberschriften oder Formeln einbeziehen möchten, die nicht Teil des externen Datenbereichs sind, wählen Sie die Zellen aus, die die zu kopierenden Spaltenüberschriften oder Formeln enthalten. Klicken Sie auf den Pfeil neben dem Namenfeld auf der Bearbeitungsleiste, und klicken Sie dann auf den Namen des externen Datenbereichs, den Sie kopieren möchten.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Kopieren.

    Abbildung des Excel-Menübands

  3. Wechseln Sie zu der Arbeitsmappe, in die Sie den externen Datenbereich einfügen möchten.

  4. Bestimmen Sie den Bereich zum Einfügen, indem Sie in die Zelle in der linken oberen Ecke des Bereichs klicken.

    Damit sichergestellt wird, dass die Externe Daten nicht die vorhandenen Daten ersetzen, vergewissern Sie sich, dass sich auf dem Arbeitsblatt unter oder rechts von der Zelle keine Daten befinden, die Sie anklicken.

  5. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Einfügen.

Hinweis : Wenn Sie nur einen Teil eines externen Datenbereichs kopieren, die zugrunde liegenden Abfrage wird nicht kopiert, und die kopierten Daten können nicht aktualisiert werden.

Seitenanfang

Festlegen, wie neue Daten zu externen Datenbereichen hinzugefügt werden

Sie können steuern, wie eine kleinere oder größere Datengruppe behandelt wird, die beim Aktualisieren von Daten an Excel zurückgegeben wird.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  2. Klicken Sie im Dialogfeld Eigenschaften des externen Datenbereiches unter Wenn sich die Anzahl der Zeilen nach der Aktualisierung ändert auf eine der folgenden Optionen:

    • Zellen für neue Daten einfügen, nicht verwendete Zellen löschen

      Hinweise : 

      • Wenn in der Datenquelle eine oder mehrere Zeilen hinzugefügt werden, werden die Zellen direkt unter dem externen Datenbereich nach unten verschoben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

      • Wenn in der Datenquelle eine oder mehrere Zeilen gelöscht werden, werden die Zellen direkt unter dem externen Datenbereich nach oben verschoben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

    • Ganze Zeilen für neue Daten einfügen, nicht verwendete Zellen löschen

      Hinweise : 

      • Wenn in der Datenquelle eine oder mehrere Zeilen hinzugefügt werden, werden die Zellen direkt unter und rechts neben dem externen Datenbereich nach unten verschoben.

      • Wenn in der Datenquelle eine oder mehrere Zeilen gelöscht werden, werden die Zellen direkt unter und rechts neben dem externen Datenbereich nicht verschoben.

    • Bestehende Zellinhalte überschreiben, nicht verwendete Zellen löschen

      Hinweise : 

      • Wenn in der Datenquelle eine oder mehrere Zeilen hinzugefügt werden, werden die Zellen direkt unter dem externen Datenbereich überschrieben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

      • Wenn in der Datenquelle eine oder mehrere Zeilen gelöscht werden, werden die Zellen direkt unter und rechts neben dem externen Datenbereich nicht verschoben.

Seitenanfang

Festlegen von Datenformatierung und -layout

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  2. Führen Sie unter Datenformatierung und Layout einen oder mehrere der folgenden Schritte aus:

    • Aktivieren Sie das Kontrollkästchen Feldnamen einschließen, um Feldnamen als erste Zeile einzuschließen.

      Hinweis : Dieses Kontrollkästchen ist nur für einen externen Datenbereich verfügbar, der von einem Microsoft Office 2003-Programm konvertiert oder programmgesteuert erstellt wird.

    • Aktivieren Sie das Kontrollkästchen Zeilennummern einschließen, um eine Spalte für Zeilennummern hinzuzufügen.

      Hinweis : Dieses Kontrollkästchen ist für eine importierte Textdatei, eine XML-Datei oder eine Webabfrage nicht verfügbar.

    • Damit die angewendete Zellformatierung erhalten bleibt, aktivieren Sie das Kontrollkästchen Zellformatierung beibehalten.

      Hinweis : Bei einer Webabfrage ist diese Option automatisch deaktiviert, wenn Sie die Option Volle HTML-Formatierung im Dialogfeld Optionen deaktivieren. Sie können auf das Dialogfeld Optionen über das Dialogfeld Abfrage bearbeiten zugreifen.

    • Damit die von Ihnen festgelegte Spaltenbreite erhalten bleibt, aktivieren Sie das Kontrollkästchen Spaltenbreite anpassen.

    • Damit die Spaltensortierung, Filterung und das angewendete Layout erhalten bleiben, aktivieren Sie das Kontrollkästchen Sortieren/filtern/Layout für Spalte beibehalten.

      Hinweis : Dieses Kontrollkästchen ist für eine Webabfrage nicht verfügbar.

    • Damit die angewendete Spaltenfilterung erhalten bleibt, aktivieren Sie das Kontrollkästchen Filter für Spalte beibehalten.

      Hinweis : Dieses Kontrollkästchen ist nur für Webabfragen verfügbar, die auf XML-Daten basieren.

Seitenanfang

Kopieren von Formeln, wenn externe Datenbereiche erweitert werden

Hinweis : Das folgende Verfahren wird nur auf externe Datenbereiche angewendet, der von einem Microsoft Office 2003-Programm konvertiert oder programmgesteuert erstellt wird. In Office Excel 2007 werden alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt werden, als Excel-Tabellen erstellt. Diese Tabellen werden automatisch erweitert, wenn neue Zeilen hinzugefügt werden und berechnete Spalten füllen.

  1. Geben Sie eine Formel in eine Zelle ein, die an die erste Zeile mit Daten im externen Datenbereich angrenzt.

    Hinweis : Die erste Zeile mit Daten ist möglicherweise die erste oder zweite Zeile im externen Datenbereich. Dies ist abhängig davon, ob die erste Zeile Überschriften enthält.

  2. Markieren Sie die Zelle, und doppelklicken Sie auf das Ausfüllkästchen, um die Formel in alle Zeilen im externen Datenbereich zu kopieren.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  5. Aktivieren Sie im Dialogfeld Eigenschaften des externen Datenbereiches das Kontrollkästchen Formeln in angrenzenden Zellen ausfüllen.

    Hinweis : Wenn der externe Datenbereich beim Aktualisieren erweitert wird, kopiert Excel nur die Formeln, die direkt an den externen Datenbereich angrenzen oder sich in diesem befinden.

Seitenanfang

Fixieren von Daten in externen Datenbereichen

Durch das Fixieren eines externen Datenbereichs bleiben die Daten, aber nicht die zugrunde liegende Abfrage erhalten, daher kann ein fixierter externer Datenbereich nicht aktualisiert werden.

Fixieren von Daten in Excel-Tabellen

  1. Klicken Sie auf das Arbeitsblatt, das die Excel-Tabelle enthält, aus der Sie die Datenverbindung entfernen möchten.

  2. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben Namenfeld, und klicken Sie dann auf den Namen des externen Datenbereichs, aus dem Sie die Datenverbindung entfernen möchten. Der Datenbereich wird dann markiert.

  3. Klicken Sie auf der Registerkarte Extras in der Gruppe Externe Tabellendaten auf Verknüpfung aufheben. Der Datenbereich bleibt mit demselben Namen erhalten, aber die Verbindung wird gelöscht.

Fixieren von Daten in einem Bereich

Hinweis : Das folgende Verfahren wird nur auf externe Datenbereiche angewendet, der von einem Microsoft Office 2003-Programm konvertiert oder programmgesteuert erstellt wird. In Office Excel 2007 werden alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt werden, als Excel-Tabellen erstellt. Diese Tabellen werden automatisch erweitert, wenn neue Zeilen hinzugefügt werden und berechnete Spalten füllen.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  2. Deaktivieren Sie unter Abfragedefinition das Kontrollkästchen Abfragedefinition speichern.

Hinweis : Wenn Sie die Arbeitsmappe speichern, wird die zugrunde liegende Abfrage aus der Arbeitsmappe gelöscht. Die gespeicherten Datenbankabfragedateien (DQY- oder ODC-Dateien) werden jedoch nicht gelöscht. Wenn Sie die Abfrage beim Erstellen im Abfrage-Assistenten oder in Microsoft Query gespeichert haben, wird die Abfragedatei auf Ihrem Computer gespeichert, und Sie können die Abfrage erneut verwenden, um externe Daten abzurufen. Weitere Informationen hierzu finden Sie in der Hilfe zu Microsoft Query.

Seitenanfang

Anpassen von Feldnamen in externen Datenbereichen

Hinweis : Das folgende Verfahren gilt nur für externe Datenbereiche, die mithilfe des Datenverbindungs-Assistenten oder mit Microsoft Query erstellt wurden (und nicht in eine importierte Textdatei oder Webabfrage) sowie für externe Datenbereiche, die von einem Microsoft Office 2003-Programm konvertiert oder programmgesteuert erstellt wurden. In Office Excel 2007 werden alle externe Datenbereiche, die mithilfe der Benutzeroberfläche erstellt werden, als Excel-Tabellen erstellt.

  1. Fügen Sie über dem externen Datenbereich eine leere Zeile ein.

    So fügen Sie eine leere Zeile ein

    1. Führen Sie eine der folgenden Aktionen aus:

      • Einfügen von neuen leeren Zellen    Markieren Sie einen Bereich von Zellen, wo neue leere Zellen eingefügt werden sollen. Markieren Sie so viele Zellen, wie Sie auch einfügen möchten.

      • Einfügen einer einzelnen Zeile    Klicken Sie auf eine Zelle in der Zeile, unter der Sie die neue Zeile direkt einfügen möchten. Wenn Sie z. B. eine neue Zeile über Zeile 5 einfügen möchten, klicken Sie auf eine Zelle in Zeile 5.

      • Einfügen von mehreren Zeilen    Wählen Sie Zeilen direkt unter der Zeile aus, wo Sie neue Zeilen einfügen möchten. Markieren Sie so viele Zeilen, wie Sie auch einfügen möchten.

      • Einfügen einer einzelnen Spalte    Klicken Sie auf eine Zelle in der Spalte, die sich direkt rechts neben der Stelle befindet, wo Sie die neue Spalte einfügen möchten. Wenn Sie z. B. eine neue Spalte links von Spalte B einfügen möchten, klicken Sie auf eine Zelle in Spalte B.

      • Einfügen mehrerer Spalten    Markieren Sie Spalten direkt neben der Stelle, wo Sie neue Spalten einfügen möchten. Markieren Sie so viele Spalten, wie Sie auch einfügen möchten.

    2. Klicken Sie auf der Registerkarte Start in der Gruppe Zellen auf den Pfeil neben Einfügen, und klicken Sie dann auf eine der folgenden Optionen: Zellen einfügen, Tabellenzeilen einfügen oder Tabellenspalten einfügen.

      Wenn Sie leere Zellen einfügen, klicken Sie auf Zellen nach rechts verschieben oder Zellen nach unten verschieben, um zu definieren, wohin die vorhandenen Zellen verschoben werden sollen.

      Wenn eine Formatierung vorhanden ist, können Sie den Befehl Format übertragen Schaltflächensymbol in der Gruppe Zwischenablage auf der Registerkarte Start verwenden, um auszuwählen, wie die Formatierung der eingefügten Zellen, Zeilen oder Spalten festgelegt wird.

  2. Geben Sie die gewünschten Beschriftungen in die Zellen in der leeren Zeile ein.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung der Excel-Multifunktionsleiste

  5. Deaktivieren Sie im Dialogfeld Eigenschaften des externen Datenbereiches unter Datenformatierung und Layout das Kontrollkästchen Feldnamen einschließen, und klicken Sie dann auf OK.

  6. Klicken Sie auf eine Zelle im externen Datenbereich, und klicken Sie dann auf Daten aktualisieren Schaltflächensymbol , um die vorhandenen Feldnamen zu entfernen und den externen Datenbereich zu aktualisieren.

Hinweis : Wenn Sie Daten aus einer Datenbank abrufen, bleiben alle Änderungen an Spaltennamen in Microsoft Query im externen Datenbereich erhalten. Weitere Informationen zum Ändern von Spaltennamen in der Abfrage finden Sie in der Microsoft Query-Hilfe.

Seitenanfang

Löschen von externen Datenbereichen

  1. Klicken Sie auf das Arbeitsblatt, das den zu löschenden externen Datenbereich enthält.

  2. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben Namenfeld, und klicken Sie dann auf den Namen des zu löschenden externen Datenbereichs.

    Wenn es sich bei dem externen Datenbereich um eine Excel-Tabelle handelt, drücken Sie STRG+A, um die gesamte Tabelle zu markieren.

  3. Drücken Sie ENTF, um den externen Datenbereich zu löschen.

  4. Wenn Sie die zugrunde liegende Abfrage löschen möchten, klicken Sie auf Ja, wenn die Aufforderung von Excel angezeigt wird.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×