Verschieben einer veröffentlichten Formularvorlage in einer neuen SharePoint-Dokumentbibliothek

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Abrufen einer Arbeitskopie Ihrer Formularvorlage

Schritt 1: Veröffentlichen der Formularvorlage in die neue Dokumentbibliothek

Schritt 2: Kopieren Sie und erneutes Verknüpfen Sie der vorhandenen Formulare

Übersicht

Nachdem Sie eine Formularvorlage in einer Dokumentbibliothek veröffentlicht haben, die von Ihren Benutzern ausgefüllt werden soll, müssen Sie diese Formularvorlage u. U. in eine andere Dokumentbibliothek verschieben. Möglicherweise müssen Sie Ihre Formularvorlage z. B. auf einen Server mit mehr Leistung verschieben, sodass die Formulare von mehreren Benutzern gleichzeitig ausgefüllt werden können. Einige Benutzer haben vielleicht bereits Formulare ausgefüllt, die auf Ihrer in der ursprünglichen Dokumentbibliothek gespeicherten Formularvorlage basieren. Wenn Sie Ihre Formularvorlage in eine neue Dokumentbibliothek verschieben, möchten Sie diese vorhandenen Formulare ebenfalls verschieben. Außerdem möchten Sie sicherstellen, dass diese vorhandenen Formulare in der neuen Dokumentbibliothek funktionieren, bevor Sie die alte Dokumentbibliothek archivieren oder löschen.

Tipp : Bevor Sie veröffentlichte Formularvorlagen in eine neue Dokumentbibliothek verschieben, sollten Sie einen Plan erstellen, der Ihre Benutzer darüber informiert, dass ihre Formulare in eine neue Dokumentbibliothek verschoben wurden. Ihre Benutzer sollen die neue Dokumentbibliothek zum Speichern neuer oder zum Ändern vorhandener Formulare verwenden. Der Plan sollte auch einen Prozess zum Archivieren oder Löschen der ursprünglichen Dokumentbibliothek umfassen.

Um eine Formularvorlage und deren vorhandene Formulare in eine neue Dokumentbibliothek zu verschieben, müssen Sie zuerst die Arbeitskopie Ihrer Formularvorlage in die neue Dokumentbibliothek verschieben. Die Arbeitskopie ist die Version, die auf Ihrem Computer oder in einem Programm zur Versionskontrolle (z. B. Microsoft Visual SourceSafe) gespeichert ist.

Tipp : Wenn Sie über keine Arbeitskopie der Formularvorlage verfügen, können Sie eine Kopie der Formularvorlage aus der ursprünglichen Dokumentbibliothek auf Ihren Computer speichern, um sie als Arbeitskopie zu verwenden.

Nachdem Sie die Arbeitskopie in einer neuen Dokumentbibliothek veröffentlicht haben, müssen Sie beliebige Formulare aus der alten Dokumentbibliothek in die neue kopieren und die Formulare in der neuen Dokumentbibliothek mit der neu veröffentlichten Formularvorlage verknüpfen.

Sollten Sie infolge des Verschiebens der Formularvorlage Änderungen vornehmen müssen, dann nehmen Sie die Änderungen vor dem Veröffentlichen der Formularvorlage vor. Der Speicherort der externen Datenquellen, die von den Formularen verwendet werden, die auf dieser Formularvorlage basieren, werden möglicherweise infolge des Verschiebens der Formularvorlage ebenfalls geändert. In diesem Fall müssen Sie die Datenverbindung in der Formularvorlage in den neuen Speicherort der externen Datenquelle ändern, bevor Sie die Formularvorlage veröffentlichen. Verknüpfungen zu weiteren Informationen zum Ändern der Datenverbindungen finden Sie im Abschnitt Siehe auch.

Hinweis : Veröffentlichen einer Formularvorlage ist nicht identisch mit eine Formularvorlage speichern. Wenn Sie eine Formularvorlage veröffentlichen, addiert den Veröffentlichen-Assistenten Ort der Veröffentlichung und verarbeitungsanweisung zur Formularvorlage, damit Benutzer Formulare öffnen können, die auf dieser Formularvorlage basieren. Wenn Sie eine Formularvorlage speichern, werden Sie eine Kopie der Formularvorlage speichern, wie Sie vorgehen, wenn Sie eine Datei auf Ihrem Computer speichern. Wenn Sie Ihre Formularvorlage für Ihre Benutzer zum Ausfüllen zur Verfügung stellen möchten, sollten Sie immer den Veröffentlichen-Assistenten verwenden.

Seitenanfang

Vorbemerkung

Bevor Sie die Formularvorlage und eventuell vorhandene auf der Formularvorlage basierende Formulare in eine neue Dokumentbibliothek verschieben, benötigen Sie Folgendes:

  • Die Arbeitskopie der Formularvorlage    Das ist eine Kopie der Formularvorlage, die Sie ändern und dann in der neuen Dokumentbibliothek veröffentlichen. Die Arbeitskopie kann auf Ihrem Computer oder in einem Programm zur Versionskontrolle (z. B. Visual SourceSafe) gespeichert werden.

  • Die Speicherorte der neuen externen Datenquellen    Wenn die auf der Formularvorlage basierenden Formulare geänderte externe Datenquellen verwenden, benötigen Sie die neuen Speicherorte der externen Datenquellen. Überprüfen Sie mit Ihrem Administrator, dass Sie und Ihre Benutzer über die entsprechenden Berechtigungen zum Verwenden der externen Datenquellen verfügen. Wenn die Formularvorlage Einstellungen in einer Datenverbindungsdatei verwendet, um eine Verbindung mit einer externen Datenquelle herzustellen, bestätigen Sie, dass die Datenverbindungsdatei mit dem neuen Speicherort der externen Datenquelle aktualisiert wurde.

  • Die passenden Rechte auf dem Server mit Windows SharePoint Services 3.0    Sie benötigen die passenden Rechte auf dem Server, um eine Formularvorlage zu veröffentlichen und um eventuell vorhandene Formulare aus der alten Dokumentbibliothek in die neue zu kopieren. Prüfen Sie gemeinsam mit Ihrem Serveradministrator nach, ob Sie diese Rechte haben.

Seitenanfang

Beziehen einer Arbeitskopie Ihrer Formularvorlage

Wenn Sie eine Formularvorlage ändern möchten, die in einer Dokumentbibliothek oder an einer gemeinsam genutzten Netzwerkadresse veröffentlicht wurde, und Sie keine Arbeitskopie Ihrer Formularvorlage besitzen, können Sie eine Arbeitskopie der Formularvorlage vom Veröffentlichungsort auf Ihren Computer speichern.

Tipp : Erwägen Sie den Einsatz eines Programms zur Versionskontrolle (z. B. Microsoft Visual SourceSafe), um die Arbeitskopien Ihrer Formularvorlagen zu verwalten.

Speichern einer Kopie Ihrer Formularvorlage aus einer Dokumentbibliothek auf Ihren Computer

  1. Öffnen Sie in einem Webbrowser die Dokumentbibliothek, in der die Formularvorlage veröffentlicht wurde.

  2. Klicken Sie im Menü Einstellungen auf Einstellungen und anschließend auf Formularbibliothek-Einstellungen.

  3. Klicken Sie unter Allgemeine Einstellungen auf Erweiterte Einstellungen.

  4. Klicken Sie im Bereich Dokumentvorlage auf Vorlage bearbeiten.

    Die Formularvorlage wird in Microsoft Office InfoPath geöffnet.

  5. Klicken Sie im Dialogfeld Microsoft Office InfoPath auf Ja.

  6. Klicken Sie im Menü Datei auf Speichern unter.

  7. Klicken Sie im Dialogfeld Microsoft Office InfoPath auf OK.

  8. Wechseln Sie im Dialogfeld Speichern unter zu dem Verzeichnis, in dem die Kopie der Formularvorlage gespeichert werden soll, und klicken Sie dann auf Speichern.

Speichern einer Kopie der Formularvorlage aus dem gemeinsam genutzten Netzwerkordner auf Ihren Computer

  1. Klicken Sie im Menü Datei auf Formularvorlage entwerfen.

  2. Klicken Sie unter Formularvorlage öffnen auf Auf meinem Computer.

  3. Navigieren Sie zu dem freigegebenen Netzwerkordner der veröffentlichten Formularvorlage, klicken Sie anschließend auf die Formularvorlage und dann auf Öffnen.

  4. Klicken Sie im Menü Datei auf Speichern unter.

  5. Klicken Sie im Dialogfeld Microsoft Office InfoPath auf OK.

  6. Wählen Sie im Dialogfeld Speichern unter einen anderen Speicherort als den ursprünglichen Veröffentlichungsort aus, an dem eine Arbeitskopie der Formularvorlage gespeichert werden soll, und klicken Sie dann auf Speichern.

Seitenanfang

Schritt 1: Veröffentlichen der Formularvorlage in der neuen Dokumentbibliothek

  1. Öffnen Sie die Arbeitskopie der Formularvorlage im Entwurfsmodus.

  2. Klicken Sie im Menü Datei auf Veröffentlichen.

  3. Klicken Sie im Veröffentlichen-Assistenten auf Auf einem SharePoint-Server mit oder ohne InfoPath Forms Services, und klicken Sie dann auf Weiter.

  4. Geben Sie im Feld Geben Sie den Speicherort der SharePoint- oder InfoPath Forms Services-Website ein den Speicherort der SharePoint-Website ein, die die neue Dokumentbibliothek enthält, die Sie in Ihre neue Formularvorlage verschieben möchten, und klicken Sie auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Dokumentbibliothek, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf Neue Dokumentbibliothek erstellen, und klicken Sie dann auf Weiter.

  7. Geben Sie auf der nächsten Seite des Assistenten einen Namen und eine Beschreibung für die neue Dokumentbibliothek ein, und klicken Sie dann auf Weiter.

  8. Wählen Sie die Felder in der Formularvorlage aus, die in der Standardansicht der Dokumentbibliothek als Spalten angezeigt werden sollen.

    So wird's gemacht

    1. Klicken Sie auf Hinzufügen.

    2. Wählen Sie das Feld aus, das der Dokumentbibliothek als Spalte hinzugefügt werden soll, und führen Sie anschließend eine der folgenden Aktionen aus:

      • Geben Sie im Feld Spaltenname einen Namen für die Spalte ein.

      • Wählen Sie in der Liste Websitespaltengruppe die Websitespalte aus, wählen Sie anschließend in der Liste Spaltenname einen Namen aus, und klicken Sie dann auf OK.

        Hinweis : Wenn Sie ausgewählt haben, dass in einem wiederholten Feld Daten in der Dokumentbibliothek angezeigt werden sollen, können Sie angeben, wie das Feld in der Dokumentbibliothek angezeigt werden soll. Klicken Sie dazu auf einen Wert in der Liste Funktion. Sie können angeben, ob der erste Wert im Feld, der letzte Wert oder die Anzahl der Vorkommen des Felds angezeigt werden soll oder ob alle Werte zusammengeführt werden.

    3. Klicken Sie auf OK.

    Verknüpfungen zu weiteren Informationen zum Anzeigen von Daten in Spalten in einer Dokumentbibliothek finden Sie im Abschnitt Siehe auch.

  9. Klicken Sie auf Weiter.

  10. Bestätigen Sie auf der nächsten Seite des Assistenten, dass die angezeigten Informationen korrekt sind, und klicken Sie dann auf Veröffentlichen.

  11. Aktivieren Sie das Kontrollkästchen Diese Dokumentbibliothek öffnen, und klicken Sie dann auf Schließen, um die Dokumentbibliothek zu öffnen und den Prozess zum Ausfüllen eines Formulars zu testen, das auf dieser Formularvorlage basiert.

    Die Dokumentbibliothek wird in einem Browser geöffnet. Wenn Sie auf der Listensymbolleiste auf Neu klicken, wird in Microsoft Office InfoPath ein auf dieser Formularvorlage basierendes Formular geöffnet.

Nach Veröffentlichen der Formularvorlage in einer neuen Dokumentbibliothek, können Sie die vorhandenen Formulare, die auf der alten Version der Formularvorlage basieren, aus der alten Dokumentbibliothek in die neue kopieren. Nach Kopieren der vorhandenen Formulare können Sie die vorhandenen Formulare mit der neuen Version der Formularvorlage erneut verknüpfen. Wenn Sie die vorhandenen Formulare nicht miteinander verknüpfen, können Benutzer diese vorhandenen Formulare möglicherweise nicht öffnen.

Seitenanfang

Schritt 2: Kopieren und erneutes Verknüpfen der vorhandenen Formulare

Dieses Verfahren wird davon ausgegangen, dass beide Dokumentbibliotheken auf einem Server sind, die Windows SharePoint Services 3.0 ausgeführt wird.

  1. Öffnen Sie die alte Dokumentbibliothek in einem Webbrowser.

  2. Klicken Sie im Menü Ansicht auf Explorer-Ansicht.

  3. Halten Sie STRG gedrückt, wählen Sie jedes zu verschiebende Formular aus, und klicken Sie dann mit der rechten Maustaste auf eines der Formulare.

  4. Klicken Sie im Dialogfeld Internet Explorer auf Ja, und klicken Sie dann im Kontextmenü auf Kopieren.

  5. Öffnen Sie die neue Dokumentbibliothek.

  6. Klicken Sie unter Ansicht wählen auf Explorer-Ansicht.

  7. Klicken Sie mit der rechten Maustaste in den leeren Bereich im Ordnerfenster.

  8. Klicken Sie im Dialogfeld Internet Explorer auf Ja, und klicken Sie dann im Kontextmenü auf Einfügen.

  9. Klicken Sie im Menü Ansicht auf Dokumente erneut verknüpfen.

  10. Aktivieren Sie in der Spalte Erneut verknüpfen das Kontrollkästchen für jedes Formular, das Sie mit der neuen Formularvorlage verknüpfen möchten.

  11. Klicken Sie auf der Listensymbolleiste auf Ausgewählte Dokumente erneut verknüpfen.

Nachdem Sie die vorhandenen Formulare mit der neuen Formularvorlage erneut verknüpft haben, können Ihre Benutzer die vorhandenen Formulare, die Sie in die neue Dokumentbibliothek kopiert haben, ändern, oder sie füllen neue Formulare aus, die auf der neu veröffentlichten Formularvorlage basieren.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×