Vermeiden defekter Formeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn Formeln nicht beabsichtigte Ergebnisse oder Fehler zeitigen, kann das sehr frustrierend sein, vor allem dann, wenn Sie nicht wissen, was Sie im nächsten Schritt unternehmen sollten.

Eine ganze Reihe von Punkten kann falsch sein. Beispielsweise kann es nicht gepaarte Klammern, Schreibfehler oder Verweise auf Daten in Bereichen geben, die gar nicht vorhanden sind. Die folgenden bewährten Methoden können Ihnen helfen, häufige Fehler beim Erstellen oder Korrigieren von Formeln zu vermeiden bzw. zu beheben.

Bewährte Methode:

Zum Vermeiden dieses häufigen Fehlers:

Beginnen Sie jede Funktion mit einem Gleichheitszeichen (=)

Wenn Ihre Eingabe nicht mit einem Gleichheitszeichen beginnt, stellt sie keine Formel dar und wird nicht berechnet – ein häufiger Fehler, der aber schnell gemacht ist.

Wenn Sie beispielsweise SUMME(A1:A10), Excel Online eingeben, sehen Sie die Textzeichenfolge SUMME(A1:A10) anstelle des Ergebnisses einer Formel. Wenn Sie 11/2 eingeben, wird ein Datum angezeigt, wie z. B. 02. Nov oder 02. 11. 2014, statt des Ergebnisses der Division von 11 durch 2.

Sie können diese unerwünschten Ergebnisse vermeiden, indem Sie immer mit einem Gleichheitszeichen beginnen. Geben Sie z. B. ein: =SUMME(A1:A10) und =11/2.

Achten Sie beim Einfügen von Klammern darauf, dass diese geschlossen werden

Achten Sie darauf, dass alle Klammern Teil eines zusammen gehörenden Paares sind. In einer Formel, die eine Funktion verwendet, muss jeder öffnenden Klammer eine schließende Klammer entsprechen, damit die Funktion ordnungsgemäß funktioniert.

Zum Beispiel funktioniert die Formel =WENN(B5<0);"Ungültig";B5*1,05) nicht, da es in ihr zwei schließende Klammern aber nur eine öffnende Klammer gibt.

Die richtige Formel würde so aussehen: =WENN(B5<0;"Ungültig";B5*1,05).

Geben Sie alle erforderlichen Argumente ein

Die meisten Funktionen weisen erforderliche Argumente auf – Werte, die Sie eingeben müssen, damit die Funktion funktioniert. Nur wenige Formeln (wie etwa PI oder TODAY) nehmen keine Argumente an. Überprüfen Sie die Formelsyntax, die angezeigt wird, wenn Sie beginnen, ein Gleichheitszeichen gefolgt von einer Funktion einzugeben, um sicherzugehen, dass Sie alle erforderlichen Argumente eingeben – nicht mehr und nicht weniger.

Beispielsweise akzeptiert die Funktion GROSS nur eine Textzeichenfolge oder einen Zellbezug als Argument: =GROSS("hallo") oder =GROSS(C2)

Ferner erfordern einige Funktionen, wie etwa SUMME, nur numerische Argumente, während andere Funktionen, wie etwa ERSETZEN zumindest als eins ihrer Argumente einen Textwert erfordern. Wenn Sie den falschen Datentyp verwenden, geben einige Funktionen möglicherweise unerwartete Ergebnisse zurück oder zeigen einen Fehler #WERT! an.

Verwenden Sie nicht formatierte Zahlen in Formeln

Geben Sie keine mit Dollarzeichen ($) oder Dezimaltrennzeichen (,) formatierten Zahlen in Formeln ein, da Dollarzeichen absolute Bezüge bedeuten und Kommas als Argumenttrennzeichen interpretiert werden können. In der Berechnung von Formeln werden keine formatierten Zeichen verwendet. Geben Sie statt $1.000 nur 1000 in die Formel ein.

Wenn Sie formatierte Zahlen in Argumenten verwenden, ergibt die Berechnung unerwartete Ergebnisse, vielleicht aber auch den Fehler #ZAHL!. Wenn Sie z. B. die Formel =ABS(-2,134) eingeben, um den absoluten Wert von -2134 zu ermitteln, zeigt Excel Online (bei Gebietsschemaeinstellungen für englischsprachige Länder) den Fehler #ZAHL! an, da die Funktion "ABS" nur ein Argument annimmt.

Sie können das Ergebnis der Formel durch Anwenden eines Zahlenformats nach Belieben mit Dezimaltrennzeichen und Währungssymbolen formatieren, nachdem Sie die Formel unter Verwendung unformatierter Zahlen eingegeben haben.

Verwenden Sie den richtigen Datentyp für die Zelle

Ihre Formel gibt möglicherweise nicht die erwarteten Ergebnisse zurück, wenn der Datentyp der Zelle nicht in Berechnungen verwendet werden kann.

Wenn Sie z.B. eine einfache Formel "=2+3" in eine Zelle eingeben, die als Text formatiert ist, kann Excel Online die eingegebenen Daten nicht berechnen. Dann sehen Sie in der Zelle lediglich =2+3.

Dies können Sie beheben, indem Sie den Datentyp der Zelle wie nachfolgend dargestellt von Text in Allgemein ändern:

  1. Wählen Sie die Zelle aus.

  2. Klicken Sie auf Start > Pfeil Zahlenformat, und wählen Sie Allgemein aus.

  3. Drücken Sie F2, um die Zelle in den Bearbeitungsmodus zu versetzen, und drücken Sie dann die EINGABETASTE, um die Formel zu übernehmen.

Ein Datumswert, den Sie in eine Zelle eingeben, die den Datentyp "Zahl" aufweist, wird möglicherweise als numerischer Datumswert statt als Datum angezeigt. Um diese Zahl als Datum anzuzeigen, wählen Sie im Katalog Zahlenformat ein Datumsformat aus.

Verwenden Sie das Symbol "*" zum Multiplizieren von Zahlen

Vielleicht möchten Sie "x" als Multiplikationsoperator in einer Formel verwenden – stattdessen müssen Sie aber das Sternsymbol (*) verwenden.

Wenn Sie ein "x" in Ihrer Formel verwenden, kann Excel Online das Ergebnis nicht berechnen und zeigt stattdessen in der Zelle die Formel an; ein gepunkteter roter Rand um die Zelle weist Sie auf einen Formelfehler hin.

Schließen Sie Text in Formeln in Anführungszeichen ein

Wenn Sie eine Formel erstellen, die Text enthält, schließen Sie den Text in Anführungszeichen ein.

Beispielsweise kombiniert die Formel ="Heute ist " & TEXT(HEUTE(),"dddd, dd. mmmm") den Text "Heute ist " mit den Ergebnissen der Funktionen TEXT und HEUTE und gibt in der Zelle Heute ist Montag, 30. Mai zurück.

In der Formel weist "Heute ist " ein Leerzeichen vor dem schließenden Anführungszeichen auf, um das Leerzeichen bereitzustellen, das zwischen den Wörtern Heute ist und Montag, 30. Mai angezeigt werden soll. Ohne die Anführungszeichen um den Text würde die Formel möglicherweise den Fehler #NAME? anzeigen.

Schachteln Sie nicht mehr als 64 Funktionen in einer Formel

Sie können bis zu 64 Ebenen von Funktionen innerhalb einer Formel kombinieren (oder verschachteln).

Beispielsweise weist die Formel =WENN(WURZEL(PI())<2,"Kleiner als zwei!","Größer als zwei!") drei (3) Ebenen von Funktionen auf: Die Funktion "PI" ist in die Funktion "WURZEL" verschachtelt, die ihrerseits in die Funktion "WENN" verschachtelt ist.

Vermeiden Sie die Division von Zahlenwerten durch Null

Das Teilen einer Zelle durch eine andere Zelle, die den Wert "Null" (0) oder keinen Wert aufweist, führt zu einem Fehler #DIV/0!.

Um diesen Fehler zu vermeiden, verschachteln Sie den Divisionsvorgang in einer Funktion WENNFEHLER. Geben Sie beispielsweise die folgenden zwei Formeln in Zellen in einem Arbeitsblatt ein:

=WENNFEHLER(3/0;0)

=WENNFEHLER(3/7;0)

Die erste Formel gibt "0" zurück, da die Funktion WENNFEHLER erkennt, dass die Division durch Null zu einem Fehler führt. Die zweite Formel gibt den Wert von 3/7 zurück – hier tritt kein Fehler auf, weil Sie nicht durch Null dividieren.

Um sich das Erstellen von Formeln zu erleichtern, kann es sinnvoll sein, sich mit den Tipps und Tricks für Formeln vertraut zu machen.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×