Verbinden Sie mit einer XML-Datei (Power Query)

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Verwenden Sie des Excel abrufen und Transformieren Sie (Power Query)-Nutzung in Verbindung mit einer XML-Datei.

  1. Klicken Sie auf der Registerkarte Daten, klicken Sie dann Daten abrufen > Aus Datei > Aus XML. Wenn Sie die Daten abrufen-Schaltfläche angezeigt werden, klicken Sie auf Neue Abfrage > Aus Datei > Aus XML.

  2. Suchen Sie im Dialogfeld Durchsuchen (XML-Tabellen) die URL einer Datei, oder geben Sie diese ein, um eine Datei zu importieren oder zu verknüpfen.

  3. Klicken Sie auf Öffnen.

    Wenn die Verbindung erfolgreich hergestellt wurde, können Sie im Bereich Navigator die Elementsammlungen in der XML-Datei in Tabellenform durchsuchen und als Vorschau anzeigen.

  1. Klicken Sie in der Menüband-Registerkarte Power Query auf Aus Datei > Aus XML.

    Dialogfeld zum Power Query aus einer Datei
  2. Suchen Sie im Dialogfeld Durchsuchen (XML-Tabellen) die URL einer Datei, oder geben Sie diese ein, um eine Datei zu importieren oder zu verknüpfen.

  3. Klicken Sie auf Öffnen.

    Wenn die Verbindung erfolgreich hergestellt wurde, können Sie im Bereich Navigator die Elementsammlungen in der XML-Datei in Tabellenform durchsuchen und als Vorschau anzeigen.

Wichtig : Stellen Sie sicher, dass Sie heruntergeladen und installiert die Power Query-Add-in.

Hinweis : Power Query ist nicht in Excel 2007 unterstützt, aber Sie können die Methode externe Daten abrufen zum Importieren von XML-Daten verwenden.

  1. Klicken Sie auf der Registerkarte Daten, klicken Sie dann Externe Daten abrufen > Aus anderen Quellen > Aus XML.

  2. Klicken Sie im Dialogfeld Datenquelle auswählen suchen Sie oder geben Sie eine Datei-URL zu importieren oder wählen Sie die Option Neue Quelle zur Verknüpfung mit einer Datei aus.

Formelbeispiel

Sie können auch den Abfrage-Editor zum Schreiben von Formeln für Power Query verwenden. Beispielsweise:

= Xml.Tables(File.Contents("C:\Downloads\XML Example.xml"))

Hinweis : Der Abfrage-Editor wird nur angezeigt, wenn Sie mithilfe von Power Query eine Abfrage laden, bearbeiten oder eine neue Abfrage erstellen. Das folgende Video zeigt das Abfrage-Editor-Fenster, das geöffnet wird, nachdem eine Abfrage aus einer Excel-Arbeitsmappe bearbeitet wurde. Wenn Sie den Abfrage-Editor anzeigen möchten, ohne eine vorhandene Arbeitsmappenabfrage zu laden oder zu bearbeiten, wählen Sie auf der Registerkarte Power Query des Menübands im Abschnitt Externe Daten abrufen die Option Aus anderen Quellen > Leere Abfrage aus. Im nachstehenden Video wird eine einzige Möglichkeit zum Anzeigen des Abfrage-Editors gezeigt.

So zeigen Sie den Abfrage-Editor in Excel an

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Power Query wird als "Abrufen und Transformieren in Excel 2016" bezeichnet

Importieren von Daten aus externen Quellen

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×