Veröffentlichen einer Arbeitsmappe in einer SharePoint-Bibliothek

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In Microsoft Excel 2013 können Sie eine Arbeitsmappe in einer Microsoft SharePoint-Bibliothek veröffentlichen, damit sie von andere Personen in einem Webbrowser angezeigt oder bearbeitet werden kann, ohne dass Excel auf den jeweiligen Computern installiert sein muss. Das Veröffentlichen ist im Wesentlichen mit dem Speichern vergleichbar, Sie können mit einigen integrierten Optionen jedoch steuern, was für den Betrachter angezeigt wird, wenn er die Arbeitsmappe in einem Browser öffnet.

Die Einführung eines organisationsweit einheitlichen Verfahrens für das Speichern oder Veröffentlichen einer Arbeitsmappe auf einer zentralen SharePoint-Website kann zur Sicherstellung beitragen, dass geringfügige Versionsunterschiede der gleichen Arbeitsmappe nicht überall in der Organisation bekannt gegeben werden, wenn deren Veröffentlichung per E-Mail angekündigt wird.

Es gibt einige Veröffentlichungsoptionen, mit denen Sie festlegen können, dass nur bestimmte Teile der Arbeitsmappe wie Diagramme hervorgehoben werden, oder Sie können andere Teile von der Anzeige im Browser ausschließen. So können Sie beispielsweise ein Diagramm, jedoch nicht die zugrunde liegenden Daten anzeigen. Oder Sie können bestimmte Arbeitsblätter nur für die Personen anzeigen, für die sie relevant sind, und andere Arbeitsblätter ausblenden.

In diesem Artikel wird gezeigt, wie eine Arbeitsmappe vom Excel 2013-Desktopprogramm aus veröffentlicht wird. Er befasst sich nicht mit dem Herstellen der Verbindung von einer Arbeitsmappe oder von Arbeitsmappendaten zu einem Excel Web Access-Webpart auf einer SharePoint-Webseite. Weitere Informationen zu Excel Web Access-Webparts finden Sie im Artikel Verbinden eines Excel Web Access-Webparts mit einer Excel-Arbeitsmappe.

Wenn Sie eine Arbeitsmappe auf einer SharePoint-Website veröffentlichen, wird die gesamte Arbeitsmappe in SharePoint gespeichert. Ein Benutzer mit den entsprechenden SharePoint-Berechtigungen kann die gesamte Arbeitsmappe entweder im Browser oder im Excel-Desktopprogramm anzeigen und bearbeiten.

Wenn Office Online auf SharePoint bereitgestellt wurde, verläuft die Anzeige und die Arbeit mit den Daten im Browser sehr ähnlich wie die Arbeit mit den Daten im Excel-Desktopprogramm. Im Gegensatz zum Excel-Desktopprogramm ist sogar die gleichzeitige Bearbeitung einer Arbeitsmappe durch mehrere Benutzer im Browser möglich. Wird bei der Anzeige einer Arbeitsmappe im Browser die Schaltfläche In Excel Online bearbeiten angezeigt, wissen Sie, dass Office Online verfügbar sind.

'In Excel Online bearbeiten' im Menü 'Arbeitsmappe bearbeiten'

Weitere Informationen finden Sie im Artikel Unterschiede zwischen der Verwendung einer Arbeitsmappe in Excel und in Excel Services.

Vorbereiten der Arbeitsmappe

Vor der Veröffentlichung der Arbeitsmappe haben Sie die Möglichkeit, die Arbeitsblätter oder Elemente auszuwählen, die im Browser angezeigt werden sollen. Denken Sie daran, dass der gesamte Inhalt der Arbeitsmappe weiterhin auf dem SharePoint-Server gespeichert ist, obwohl Sie in diesem Modus einschränken können, welche Inhalte angezeigt werden.

Wenn Sie gesamte Arbeitsblätter als Elemente zusätzlich zu anderen Elementen wie Diagrammen und PivotTables einschließen möchten, definieren Sie das gesamte Arbeitsblatt als einen benannten Bereich. Markieren Sie das gesamte Arbeitsblatt, und definieren Sie dann einen benannten Bereich. Dieser benannte Bereich steht dann im Dialogfeld Veröffentlichungsoptionen als auswählbares Element zur Verfügung, wenn Sie bereit für die Veröffentlichung sind.

Wenn Sie möchten, dass die Benutzer einen Wert in eine Zelle eingeben können, der von einer Formel in einer anderen Zelle benötigt wird, können Sie diese Zelle vor dem Veröffentlichen der Arbeitsmappe mit einem definierten Namen versehen. Sie können diesen definierten Namen dann als Parameter auf der Registerkarte Parameter im Dialogfeld Browseransichtsoptionen hinzufügen.

Nachstehend wird beispielsweise die Zelle D2 mit dem definierten Namen "Rate" angezeigt. Im Browser gibt der Benutzer den Wert 5,625 in das Feld im Bereich Parameter ein und klickt dann auf Übernehmen. Dieser Wert wird nun in der Zelle D2 angezeigt, und die Formel in A2 greift auf den Wert in D2 zu. Das Ergebnis der Formel wird neu berechnet und in A2 angezeigt: 1.151,31 €.

Weitere Informationen zum Definieren von Bereichen finden Sie in der Excel-Hilfe.

Bei der Eingabe eines Parameters wird die Zelle D2 verwendet

Hinweis : Wenn Sie Datenschnitte für eine Excel-Tabelle erstellen und einen Namen für den Zellbereich definieren, der die Tabelle und die Datenschnitte enthält, können Sie die Datenschnitte nicht zum Filtern der Tabelle im Browser verwenden, wenn Sie nur den definierten Bereich veröffentlichen. Wenn Sie die Tabelle oder das gesamte Arbeitsblatt bzw. die gesamte Arbeitsmappe veröffentlichen, funktionieren die Datenschnitte im Browser jedoch wie erwartet.

Veröffentlichen der Arbeitsmappe

  1. Klicken Sie auf Datei > Speichern unter > SharePoint.

  2. Wenn Sie Ihre SharePoint-Ordner unter finden Sie unteraktuellen Ordner oder zuletzt verwendete Ordner, klicken Sie auf den gewünschten Ordner. Andernfalls klicken Sie auf Durchsuchen, und geben Sie die Webadresse für die SharePoint-Website. Navigieren Sie dann zu dem Ordner, in dem Sie die Arbeitsmappe zu veröffentlichen möchten. Das Dialogfeld Speichern unter angezeigt wird.

  3. Wenn Sie einzelne Arbeitsblätter oder Elemente auswählen möchten, die aus der Arbeitsmappe veröffentlicht werden sollen, klicken Sie auf Browseransichtsoptionen. Damit werden die Registerkarten Anzeigen und Parameter angezeigt. Wenn Sie jedoch die gesamte Arbeitsmappe veröffentlichen möchten, klicken Sie auf Speichern. Führen Sie andernfalls einen der folgenden Schritte durch:

  • Wenn die gesamte Arbeitsmappe im Browser angezeigt werden soll, wählen Sie auf der Registerkarte Anzeigen im Listenfeld Gesamte Arbeitsmappe aus.

  • Wenn im Browser nur bestimmte Arbeitsblätter angezeigt werden sollen, wählen Sie auf der Registerkarte Anzeigen im Listenfeld Blätter aus, und deaktivieren Sie die Kontrollkästchen der Arbeitsblätter, die im Browser nicht ausgeblendet werden sollen.

    Standardmäßig sind alle Blätter ausgewählt. Wenn Sie alle Blätter schnell wieder sichtbar machen möchten, nachdem Sie einige Kontrollkästchen deaktiviert haben, aktivieren Sie das Kontrollkästchen Alle Blätter.

  • Wenn nur bestimmte Elemente im Browser angezeigt werden sollen (wie benannte Bereiche, Diagramme, Tabellen oder PivotTables), wählen Sie auf der Registerkarte Anzeigen im Listenfeld Elemente in der Arbeitsmappe aus, und aktivieren Sie die Kontrollkästchen für die Elemente, die angezeigt werden sollen.

  • Auf der Registerkarte Parameter können Sie alle definierten Namen hinzufügen, die Sie zum Festlegen von Zellen verwenden möchten, die bearbeitet werden können, wenn Benutzer die Arbeitsmappe im Browser anzeigen. Klicken Sie dann auf OK, um das Dialogfeld zu schließen.

  1. Speichern Sie die Arbeitsmappe.

Hinweise : 

  • Wenn Sie Elemente auswählen, die denselben Namen haben (wie ein Diagramm und die zugrunde liegende Datentabelle), steht nur eines dieser Elemente im Browser zur Verfügung. Zum Anzeigen aller Elemente müssen Sie sicherstellen, dass jedes Element in der Arbeitsmappe einen eindeutigen Namen aufweist.

  • Wenn Sie Elemente auswählen, die denselben Namen haben (wie ein Diagramm und die zugrunde liegende Datentabelle), steht nur eines dieser Elemente im Browser zur Verfügung. Zum Anzeigen aller Elemente müssen Sie sicherstellen, dass jedes Element in der Arbeitsmappe einen eindeutigen Namen aufweist.

  • Tabellen können auf der Registerkarte Entwurf in der Gruppe Eigenschaften, PivotTable-Berichte auf der Registerkarte Optionen in der Gruppe PivotTable und Diagramme oder PivotChart-Berichte auf der Registerkarte Layout in der Gruppe Eigenschaften umbenannt werden. Andere Elemente mit doppelt vorkommenden Namen, wie benannte Bereiche, werden in der Gruppe Definierte Namen auf der Registerkarte Formeln umbenannt.

  • Tabellen können auf der Registerkarte Entwurf in der Gruppe Eigenschaften, PivotTable-Berichte auf der Registerkarte Optionen in der Gruppe PivotTable und Diagramme oder PivotChart-Berichte auf der Registerkarte Layout in der Gruppe Eigenschaften umbenannt werden. Andere Elemente mit doppelt vorkommenden Namen, wie benannte Bereiche, werden in der Gruppe Definierte Namen auf der Registerkarte Formeln umbenannt.

Weitere Informationen zu Excel Services und zur Arbeit mit Daten im Browser

Business Intelligence-Funktionen in Excel Services

Arbeiten mit externen Daten in Excel Services

Aktualisieren von Daten in einer Arbeitsmappe in einem Browserfenster

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×