VERGLEICH (Funktion)

Mit der Funktion VERGLEICH wird in einem Bereich von Zellen nach einem angegebenen Element gesucht und anschließend die relative Position dieses Elements im Bereich zurückgegeben. Ein Beispiel: Wenn der Bereich A1:A3 die Werte "5", "25" und "38" enthält, gibt die Formel =VERGLEICH(25;A1:A3;0) den Wert "2" zurück, weil "25" der zweite Wert im Bereich ist.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Tipp : Verwenden Sie VERGLEICH immer dann statt einer der VERWEIS-Funktionen, wenn Sie die Position eines Elements in einem Bereich und nicht das Element selbst benötigen. Sie können die Funktion VERGLEICH beispielsweise verwenden, um einen Wert für das Argument Zeile in der INDEX-Funktion bereitzustellen.

Syntax

VERGLEICH(Suchkriterium;Suchmatrix;[Vergleichstyp])

Die Syntax der Funktion VERGLEICH weist die folgenden Argumente auf:

  • Suchkriterium    Erforderlich. Der Wert, mit dem Sie Elemente in der Suchmatrix abgleichen möchten. Wenn Sie beispielsweise in einem Telefonbuch die Telefonnummer eines Bekannten suchen, verwenden Sie dessen Namen als Suchkriterium, obwohl die Telefonnummer der Wert ist, den Sie eigentlich wünschen.

    Bei dem Argument Suchkriterium kann es sich um einen Wert (Zahl, Text oder logischen Wert) oder einen Zellbezug auf eine Zahl, einen Text oder einen logischen Wert handeln.

  • Suchmatrix    Erforderlich. Der Zellbereich, der durchsucht wird.

  • Vergleichstyp    Optional. Die Zahl -1, 0 oder 1. Das Argument Vergleichstyp gibt an, auf welche Weise Excel die Werte in der Suchmatrix mit dem Wert für Suchkriterium abgleicht.

    In der folgenden Tabelle wird erörtert, wie mit der Funktion Werte basierend auf der Einstellung des Arguments Vergleichstyp gefunden werden.

Vergleichstyp

Verhalten

1 oder nicht angegeben

VERGLEICH sucht nach dem größten Wert, der kleiner oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in aufsteigender Reihenfolge angeordnet sein, z. B. ...-2, -1, 0, 1, 2, ..., A-Z, FALSCH, WAHR.

0

VERGLEICH sucht nach dem ersten Wert, der mit dem Wert für Suchkriterium genau übereinstimmt. Die Werte im Argument Suchmatrix dürfen in beliebiger Reihenfolge angeordnet sein.

-1

VERGLEICH sucht nach dem kleinsten Wert, der größer oder gleich dem Wert für Suchkriterium ist. Die Werte im Argument Suchmatrix müssen in absteigender Reihenfolge angeordnet sein, z. B. WAHR, FALSCH, Z-A,...2, 1, 0, -1, -2,... usw.

  • VERGLEICH gibt als Ergebnis die Position zurück, die der jeweils gefundene Wert innerhalb der Suchmatrix einnimmt, und nicht den Wert selbst. Zum Beispiel gibt VERGLEICH("b";{"a"."b"."c"};0) den Wert 2 zurück. Dies ist die relative Position, die "b" innerhalb der Matrix {"a"."b"."c"} einnimmt.

  • VERGLEICH unterscheidet beim Abgleichen von Zeichenfolgen (Text) nicht zwischen Groß- und Kleinbuchstaben.

  • Findet VERGLEICH keinen übereinstimmenden Wert, gibt die Funktion den Fehlerwert #NV zurück.

  • Ist Vergleichstyp gleich 0 und ist als Suchkriterium eine Zeichenfolge angegeben, können Sie im Argument Suchkriterium die Platzhalterzeichen Fragezeichen (?) und Sternchen (*) verwenden. Ein Fragezeichen ersetzt ein Zeichen; ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor das zu suchende Zeichen setzen.

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Produkt

Anzahl

Bananen

25

Orangen

38

Äpfel

40

Birnen

41

Formel

Beschreibung

Ergebnis

=VERGLEICH(39;B2:B5;1)

Da es keine genaue Übereinstimmung gibt, wird die Position des nächstkleineren Werts (38) im Bereich B2:B5 zurückgegeben.

2

=VERGLEICH(41;B2:B5;0)

Die Position des Werts 41 im Bereich B2:B5.

4

=VERGLEICH(40;B2:B5;-1)

Gibt einen Fehlerwert zurück, da die Werte im Bereich B2:B5 nicht in absteigender Reihenfolge angeordnet sind.

#NV

Siehe auch

Funktion SVERWEIS

Funktion INDEX

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×