Steuern einer Website mit Visio

Wenn Sie sich mit dem tagtäglichen Verwalten einer Website befassen, wissen Sie, dass Sie mit der Gesamtstruktur der Website eingehend vertraut sein, Entwicklungsänderungen verfolgen und beschädigte Hyperlinks suchen und reparieren müssen. Alle diese und andere Aufgaben können mit den Websiteübersicht-Tools in Microsoft Office Visio Professional ausgeführt werden.

Was möchten Sie tun?

Erstellen einer Inhaltsübersicht der Website

Automatisches Überprüfen der Website auf Fehler

Verfolgen der an der Website vorgenommenen Änderungen

Erstellen einer Inhaltsübersicht der Website

Das Verwalten einer Site beginnt mit einer Analyse ihres aktuellen Zustands. Beim Erstellen einer Websiteübersicht erstellen Sie eine aktuelle grafische Darstellung der Struktur und des Inhalts der Site.

Eine Websiteübersicht, mit der die aktuelle hierarchische Struktur der Verknüpfungen auf der Website angezeigt wird

Jedes Shape in der Siteübersicht stellt eine Verknüpfung auf der Website dar, und jedes Shape enthält Informationen zum Verknüpfungstyp und zur Adresse. Wenn Sie mit der rechten Maustaste auf ein Shape klicken, können Sie direkt vom Shape zu seiner Adresse im Web navigieren.

  1. Zeigen Sie in Visio im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf Websiteübersicht.

  2. Geben Sie im Dialogfeld Websiteübersicht erstellen die Adresse einer Website für eine der folgenden Optionen ein:

    • Wenn sich die Website, für die Sie eine Übersicht erstellen möchten, auf einem HTTP-Server befindet, geben Sie die Adresse der Website in das Feld Adresse ein.

    • Wenn sich die Website auf einem Netzwerkserver oder auf einer lokalen Festplatte befindet, klicken Sie auf Durchsuchen, navigieren Sie zu der Datei, die den Stamm der Websiteübersicht bilden soll, und klicken Sie dann auf Öffnen.

  3. Klicken Sie im Dialogfeld Websiteübersicht erstellen auf Einstellungen, um die Einstellungen für die maximale Anzahl der Ebenen und der Verknüpfungen zu überprüfen, die erkannt werden sollen.

  4. Führen Sie zum Ändern der Einstellungen eine der folgenden Aktionen aus:

    • Ändern Sie auf der Registerkarte Layout den Layoutstil der Websiteübersicht, z.B. die Anzahl der Ebenen, die erkannt werden sollen, oder ob die Zeichnung als Kompakte Struktur oder Flussdiagramm angezeigt werden soll.

    • Wählen Sie auf der Registerkarte Erweiterungen die Dateitypen (z. B. DOC, JPG oder EXE) aus, die in der Übersicht berücksichtigt werden sollen.

    • Wählen Sie auf der Registerkarte Protokolle die Protokolle aus (beispielsweise mailto, ftp oder NNTP), die in der Übersicht berücksichtigt werden sollen.

    • Wählen Sie auf der Registerkarte Attribute die HTML-Attribute aus (beispielsweise HREF, SRC oder CODE), die nach Verknüpfungen durchsucht werden sollen.

    • Wählen Sie auf der Registerkarte Weitere Optionen bestimmte Optionen aus, um Ihre Suchkriterien weiter einzuschränken.

    • Klicken Sie auf OK.

  5. Klicken Sie im Dialogfeld Websiteübersicht erstellen auf OK.

  6. Klicken Sie zum Speichern der Websiteübersicht im Menü Datei auf Speichern.

Seitenanfang

Automatisches Überprüfen der Website auf Fehler

Die wichtigste Aufgabe bei der Verwaltung von Websites ist es, sicherzustellen, dass die Verknüpfungen auf der Website funktionieren und keine Fehler aufweisen.

Beim Erstellen einer Websiteübersicht wird in Visio jede Verknüpfung, die den angegebenen Parametern entspricht, verfolgt, und ggf. gefundene Fehler werden protokolliert. Verknüpfungen mit Fehlern werden in der Websiteübersicht im Fenster Filter und im Fenster Liste als Shapes angezeigt, die mit einem roten X durchgestrichen sind. Wenn diese Fenster nicht angezeigt werden, zeigen Sie im Menü Websiteübersicht auf Fenster, und klicken Sie anschließend entweder auf Listenfenster oder auf Filterfenster. Sie können problemlos eine Liste der beschädigten Verknüpfungen mit den jeweiligen Fehlern erstellen, sodass Sie Ihre Arbeit verfolgen und die erforderlichen Reparaturen vornehmen können.

Eine Websiteübersicht, mit der die Struktur einer Website angezeigt wird. Jedes Shape mit einem roten X stellt eine unterbrochene Verknüpfung dar.

Erstellen eines Berichts über die fehlerhaften Verknüpfungen auf der Website

  1. Öffnen Sie die Websiteübersicht, für die ein Fehlerbericht erstellt werden soll.

  2. Zeigen Sie im Menü Websiteübersicht auf Berichte, klicken Sie auf Websiteübersicht – Verknüpfungen mit Fehlern, und klicken Sie dann auf Ausführen.

  3. Wählen Sie aus, mit welchem Dateityp (beispielsweise Excel oder XML) die Informationen gespeichert werden sollen, und klicken Sie dann auf OK.

    In Visio wird ein Bericht mit allen Verknüpfungen erstellt, für die Hyperlinkfehler vorliegen.

  4. Wenn der Bericht in einem anderen Programm als Visio (z. B. Microsoft Office Excel) geöffnet wird, benennen und speichern Sie den Bericht.

Reparieren fehlerhafter Verknüpfungen

Einigen fehlerhaften Verknüpfungen liegen Timeoutfehler zugrunde. Klicken Sie zum Beheben dieser Fehler mit der rechten Maustaste auf die Verknüpfung, und klicken Sie dann auf Aktualisieren oder auf Übergeordneten Hyperlink aktualisieren.

Andere fehlerhafte Verknüpfungen werden durch Fehler wie Site nicht gefunden, Zugriff verweigert, Kennwort erforderlich oder durch falsche Dateinamen, falsche Dateiadressen und fehlende Dateien verursacht, wodurch die Fehlermeldungen 404 oder Datei nicht gefunden ausgelöst werden können. Alle diese Fehler müssen auf der Website behoben werden.

Die Website und die Websiteübersicht sind nicht dynamisch miteinander verknüpft, sodass sich Änderungen an der Website nicht automatisch auf die Websiteübersicht und umgekehrt auswirken. Wenn Sie eine beschädigte Verknüpfung auf der Website repariert haben, können Sie die Websiteübersicht aktualisieren, indem Sie mit der rechten Maustaste auf das Shape für die beschädigte Verknüpfung klicken und anschließend auf Hyperlink aktualisieren klicken. Das rote X wird nicht mehr angezeigt.

Seitenanfang

Verfolgen der an der Website vorgenommenen Änderungen

Wenn mehrere Entwickler an der Site arbeiten, kann das Verfolgen ihrer Arbeit schnell sehr aufwendig werden. Mit dem Websiteübersicht-Vergleichsbericht können Sie zwei Versionen der Site miteinander vergleichen, um die über einen bestimmten Zeitraum vorgenommenen Änderungen zu quantifizieren. Im Bericht werden die zwei Versionen miteinander verglichen, und eine Liste der Unterschiede wird erstellt. Dabei werden nicht nur die Verknüpfungen aufgelistet, die nur in einer der Übersichten enthalten sind, sondern auch die folgenden Änderungen an Verknüpfungen in beiden Übersichten:

  • Fehlerstatus

  • Dateititel

  • Dateigröße

  • Dateiänderungsdatum

Angenommen, Sie möchten die im Laufe einer Woche an der Site ausgeführten Arbeiten quantifizieren. Erstellen Sie einfach eine Übersicht der Website zu Beginn der Woche und eine weitere am Ende der Woche. Vergleichen Sie anschließend die beiden Übersichten, um einen Bericht über die Änderungen zu erstellen. Sie können den Bericht auch einem aufgestellten Arbeitsplan für die Woche gegenüberstellen, um festzustellen, ob der Terminplan für das Websiteprojekt eingehalten wurde.

Vergleichen von Websiteübersichten

  1. Öffnen Sie die aktuellste Übersicht der Website.

  2. Klicken Sie im Menü Websiteübersicht auf Mit vorangehendem Dokument vergleichen.

  3. Navigieren Sie zum Speicherort der Websiteübersicht, mit der verglichen werden soll, wählen Sie die Datei aus, und klicken Sie dann auf Öffnen.

    Die beiden Übersichten werden in Visio verglichen, und es wird ein HTML-Bericht mit einer Liste der Unterschiede erstellt.

  4. Benennen und speichern Sie den Bericht.

Seitenanfang

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×