So wird ein #BEZUG!-Fehler korrigiert

Der Fehler #BEZUG! wird angezeigt, wenn eine Formel auf eine Zelle verweist, die nicht gültig ist. Häufigste Ursache hierfür ist, dass Zellen, auf die aus einer Formel verwiesen wird, gelöscht oder durch andere Daten ersetzt wurden.

Beispiel: #BEZUG!-Fehler nach Löschen einer Spalte

Im folgenden Beispiel wird die Formel =SUMME(B2;C2;D2) in Spalte E verwendet.

Eine Formel, in der explizite Zellenbezüge verwendet werden, etwa =SUMME(B2;C2;D2), kann einen #BEZUG!-Fehler verursachen, wenn eine Spalte gelöscht wurde.

Würden Sie Spalte B, C oder D löschen, würde ein #BEZUG!-Fehler verursacht. In diesem Fall wird die Spalte C (2007 Sales) gelöscht, weshalb die Formel nun =SUMME(B2;#BEZUG!;C2) lautet. Wenn Sie explizite Zellbezüge wie diesen verwenden (wobei Sie auf jede Zelle einzeln verweisen und die Zellen durch Semikolons getrennt sind) und eine Zeile oder Spalte löschen, auf die verwiesen wird, kann Excel den Zellbezug nicht auflösen, sodass der Fehler #BEZUG! zurückgegeben wird. Dies ist der Hauptgrund, warum es nicht zu empfehlen ist, explizite Zellbezüge in Funktionen zu verwenden.

Beispiel für einen #BEZUG!-Fehler, der durch Löschen einer Spalte verursacht wird.

Lösung

  • Wenn Sie Zeilen oder Spalten versehentlich gelöscht haben, können Sie sofort auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche "Rückgängig" klicken (oder STRG+Z drücken), um die Zeilen oder Spalten wiederherzustellen.

  • Passen Sie die Formel so an, dass in ihr ein Bereichsbezug anstelle einzelner Zellen verwendet wird, etwa =SUMME(B2:D2). Jetzt können Sie eine beliebige Spalte im Bereich der Summe löschen, und Excel passt die Formel automatisch an. Sie können auch =SUMME(B2:B5) für eine Zeilensumme verwenden.

Beispiel: SVERWEIS mit falschen Bereichsbezügen

Im folgenden Beispiel, =SVERWEIS(A8;A2:D5;5;FALSCH), wird ein #BEZUG!-Fehler zurückgegeben, weil nach einem Wert gesucht wird, der aus Spalte 5 zurückgegeben werden soll, aber der Bezugsbereich gleich A:D ist, sodass er nur 4 Spalten enthält.

Beispiel einer SVERWEIS-Formel mit einem falschen-Bereich.  Formel ist =SVERWEIS(A8;A2:D5;5;FALSCH).  Es gibt keine fünfte Spalte im SVERWEIS-Bereich, sodass 5 einen #BEZUG!-Fehler verursacht.

Lösung

Passen Sie den Bereich an, sodass er größer ist, oder verringern Sie den Spaltenverweiswert entsprechend dem Bezugsbereich. =SVERWEIS(A8;A2:E5;5;FALSCH) ist ein gültiger Bezugsbereich ebenso wie =SVERWEIS(A8;A2:D55;4;FALSCH).

Beispiel: INDEX mit falschem Zeilen- oder Spaltenbezug

In diesem Beispiel gibt die Formel =INDEX(B2:E5;5;5) einen #BEZUG!-Fehler zurück, weil der INDEX-Bereich 4 Zeilen mal 4 Spalten groß ist, in der Formel aber gefordert wird, auch die Werte zurückzugeben, die in der fünften Zeile und fünften Spalte stehen.

Beispiel einer INDEX-Formel mit einem ungültigen Bereichsbezug.  Formel ist =INDEX(B2:E5;5;5), aber der Bereich hat nur 4 Zeilen mal 4 Spalten.

Lösung

Passen Sie die Zeilen- oder Spaltenbezüge so an, dass sie im INDEX-Verweisbereich liegen. =INDEX(B2:E5;4;4) würde ein gültiges Ergebnis zurückgegeben.

Beispiel: Bezugnehmen auf eine geschlossene Arbeitsmappe mit INDIREKT

Im folgenden Beispiel wird in einer INDIREKT-Funktion auf eine Arbeitsmappe Bezug genommen, die geschlossen ist. Dadurch wird ein #BEZUG!-Fehler verursacht.

Beispiel für einen #BEZUG!-Fehler, der durch eine INDIREKT-Funktion verursacht wird, die sich auf eine geschlossene Arbeitsmappe bezieht.

Lösung

Öffnen Sie die Arbeitsmappe, auf die Bezug genommen wird.

OLE/DDE-Probleme

Wenn Sie eine OLE-Verknüpfung (Object Linking and Embedding) verwenden, die einen #BEZUG!-Fehler zurückgibt, starten Sie das Programm, das über die Verknüpfung aufgerufen wird.

Hinweis: OLE ist eine Technologie, die Sie verwenden können, um Informationen zwischen Programmen gemeinsam zu nutzen.

Wenn Sie ein DDE-Thema (Dynamic Data Exchange, dynamischer Datenaustausch) verwendet haben, das einen #BEZUG!-Fehler zurückgibt, müssen Sie sich vergewissern, dass Sie auf das richtige Thema verweisen.

Hinweis: DDE ist ein eingeführtes Protokoll für den Austausch von Daten zwischen Programmen, die auf Microsoft Windows basieren.

Makroprobleme

Wenn ein Makro eine Funktion auf dem Arbeitsblatt aufruft, die sich auf eine Zelle oberhalb der Funktion bezieht, und sich die Zelle mit der Funktion in Zeile 1 befindet, gibt die Funktion einen #BEZUG!-Fehler zurück, weil sich über der Zeile 1 keine Zellen befinden. Überprüfen Sie die Funktion, um festzustellen, ob sich ein Argument auf eine Zelle oder einen Zellbereich bezieht, die oder der nicht gültig ist. Dies erfordert möglicherweise ein Bearbeiten des Makros im Visual Basic-Editor (VBE), damit diese Situation berücksichtigt wird.

Haben Sie eine Frage zu einer bestimmten Funktion?

Eine Frage im Excel-Communityforum stellen

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×