So korrigieren Sie einen #NV-Fehler

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Der Fehler #NV weist im Allgemeinen darauf hin, dass eine Formel nicht das finden kann, nach dem gesucht werden soll.

Beste Lösung

Die häufigste Ursache für einen #NV-Fehler in Verbindung mit SVERWEIS-, WVERWEIS-, VERWEIS- oder VERGLEICH-Funktionen ist, dass die Formel einen Wert, auf den verwiesen wird, nicht finden kann. Ein Beispiel hierfür ist ein Nachschlagewert, der in den Quelldaten nicht vorhanden ist.

Es ist kein Nachschlagewert vorhanden.  Die Formel in Zelle E2 lautet =SVERWEIS(D2;$D$6:$E$8;2;FALSCH).  Der Wert "Banane" kann nicht gefunden werden, also gibt die Formel einen #NV-Fehler zurück.
Das Element wurde in den Quelldaten nicht gefunden

Im vorliegenden Fall gibt es das Element "Banane" nicht in der Nachschlagetabelle, also gibt SVERWEIS einen #NV-Fehler zurück.

Lösung: Stellen Sie entweder sicher, dass sich der Nachschlagewert in den Quelldaten befindet, oder verwenden Sie einen Fehlerhandler wie WENNFEHLER in der Formel. Beispiel: =WENNFEHLER(FORMEL();0); diese Formel besagt Folgendes:

  • =WENN(Ihre Formel einen Fehler zurückgibt, zeige 0 an, ansonsten zeige das Ergebnis der Formel an)

Sie können auch "" verwenden, damit nichts angezeigt wird, oder eigenen Text verwenden: =WENNFEHLER(FORMEL();"Fehlermeldung")

Wenn Sie nicht sicher sind, was an dieser Stelle zu tun ist oder welche Art von Hilfe Sie benötigen, können Sie im Excel-Communityforum nach ähnlichen Fragen suchen oder selbst eine Frage posten.

Link zum Excel-Communityforum

Hinweis : Klicken Sie hier, wenn Sie Hilfe zum #NV-Fehler bei einer bestimmten Funktion (z. B SVERWEIS oder INDEX/VERGLEICH) benötigen.

Wenn Sie fortfahren möchten, sehen Sie sich die folgenden Checkliste an. Darin finden Sie Schritte zur Problembehandlung, mit deren Hilfe Sie herausfinden können, was in Ihren Formeln möglicherweise schiefgelaufen ist.

Der Nachschlagewert und die Quelldaten weisen unterschiedliche Datentypen auf. Beispiel: SVERWEIS verweist auf eine Zahl, aber die Quelldaten sind als Text gespeichert.

Falsche Werttypen  Das Beispiel zeigt eine SVERWEIS-Formel, die einen #NV-Fehler zurückgibt, da das Nachschlageelement als Zahl, die Nachschlagetabelle jedoch als Text formatiert ist.
#NV-Fehler, die von unterschiedlichen Datentypen verursacht werden

Lösung: Stellen Sie sicher, dass dieselben Datentypen verwendet werden. Sie können die Zellformate überprüfen, indem Sie eine Zelle oder einen Zellbereich markieren, dann mit der rechten Maustaste klicken und Zellen formatieren > Zahl auswählen (oder STRG+1 drücken). Nun können Sie das Zellformat bei Bedarf ändern.

Dialogfeld "Zellen formatieren", Registerkarte "Zahl", Option "Text" ausgewählt

Tipp : Wenn Sie eine Formatänderung für die gesamte Spalte erzwingen müssen, weisen Sie erst das gewünschte Format zu, und verwenden Sie dann Daten > Text in Spalten > Fertig stellen.

Sie können mit der Funktion GLÄTTEN alle führenden oder nachgestellten Leerzeichen entfernen. Im folgenden Beispiel ist GLÄTTEN in einer SVERWEIS-Funktion geschachtelt, um führende Leerzeichen aus den Namen in A2:A7 zu entfernen und den Namen der Abteilung zurückzugeben.

Verwenden von SVERWEIS mit GLÄTTEN in einer Matrixformel, um führende/nachgestellte Leerzeichen zu entfernen  Die Formel in Zelle E3 lautet {=SVERWEIS(D2;GLÄTTEN(A2:B7);2;FALSCH)} und muss mit STRG+UMSCHALT+EINGABETASTE eingegeben werden.

{=SVERWEIS(D2;GLÄTTEN(A2:B7);2;FALSCH)}

Hinweis : Dies ist eine Matrixformel, die mit STRG+UMSCHALT+EINGABETASTE eingegeben werden muss. Excel schließt die Formel automatisch in geschweifte Klammern {} ein. Wenn Sie versuchen, diese manuell einzugeben, zeigt Excel die Formel als Text an.

Standardmäßig müssen Tabellen für Funktionen, die Daten in Tabellen nachschlagen, in aufsteigender Reihenfolge sortiert sein. Die Arbeitsblattfunktionen SVERWEIS und WVERWEIS enthalten jedoch das Argument Bereich_Verweis, mit dem die Funktion angewiesen wird, auch dann eine genaue Übereinstimmung zu suchen, wenn die Tabelle nicht sortiert ist. Um eine genaue Übereinstimmung zu finden, legen Sie das Argument Bereich_Verweis auf FALSCH fest. Wenn Sie WAHR verwenden und die Funktion somit anweisen, nach einer ungefähren Übereinstimmung zu suchen, kann dies nicht nur zu einem #NV-Fehler führen, sondern es können auch fehlerhafte Ergebnisse wie im folgenden Beispiel zurückgegeben werden.

Das Beispiel für die Verwendung von SVERWEIS mit dem Bereich_Verweis-Argument WAHR kann zu falschen Ergebnissen führen.
SVERWEIS schlägt fehl, da das Argument "Ungefähre Übereinstimmung" in einer nicht sortierten Tabelle verwendet wird

In diesem Beispiel gibt nicht nur "Banane" einen #NV-Fehler zurück, sondern "Birne" gibt auch einen falschen Preis zurück. Dies wird von dem Argument WAHR verursacht, mit dem SVERWEIS angewiesen wird, nach einer ungefähren Übereinstimmung anstatt einer genauen Übereinstimmung zu suchen. Es gibt keine ungefähre Übereinstimmung für "Banane", und "Birne" steht alphabetisch vor "Pfirsich". In diesem Fall würde SVERWEIS mit dem Argument FALSCH den richtigen Preis für "Birne" zurückgeben, "Banane" würde aber weiterhin einen #NV-Fehler zurückgeben, da es "Banane" in der Nachschlageliste nicht gibt.

Wenn Sie die Funktion VERGLEICH verwenden, versuchen Sie, den Wert des Arguments Vergleichstyp zu ändern, um die Sortierreihenfolge der Tabelle anzugeben. Zum Finden einer exakten Übereinstimmung legen Sie das Argument Vergleichstyp auf 0 (Null) fest.

Zum Beheben dieses Problems stellen Sie sicher, dass der Bereich, auf den die Matrixformel verweist, die gleiche Anzahl Zeilen und Spalten wie der Zellbereich aufweist, in den die Matrixformel eingegeben wurde, oder geben Sie die Matrixformel in mehr bzw. weniger Zellen ein, um eine Übereinstimmung mit dem Bereichsverweis in der Formel zu erzielen.

In diesem Beispiel wurde in Zelle E2 auf nicht übereinstimmende Bereich verwiesen:

Beispiel für eine Matrixformel mit nicht übereinstimmenden Bereichsverweisen, die einen #NV-Fehler verursachen  Die Formel in Zelle E2 lautet {=SUMME(WENN(A2:A11=D2;B2:B5))} und muss mit STRG+UMSCHALT+EINGABETASTE eingegeben werden.

{=SUMME(WENN(A2:A11=D2;B2:B5))}

Damit die Formel korrekt berechnet wird, muss sie so geändert werden, dass in beiden Bereichen die Zeilen 2-11 berücksichtigt werden.

{=SUMME(WENN(A2:A11=D2;B2:B11))}

Hinweis : Dies ist eine Matrixformel, die mit STRG+UMSCHALT+EINGABETASTE eingegeben werden muss. Excel schließt die Formel automatisch in geschweifte Klammern {} ein. Wenn Sie versuchen, diese manuell einzugeben, zeigt Excel die Formel als Text an.

Beispiel für #NV in Zellen, wodurch verhindert wird, dass eine SUMME-Formel ordnungsgemäße Berechnungen durchführt

In diesem Fall weisen Mai-Dezember #NV-Werte auf, sodass die Summe nicht berechnet werden kann und stattdessen ein #NV-Fehler zurückgegeben wird.

Um dieses Problem zu beheben, überprüfen Sie die Formelsyntax der verwendeten Funktion, und geben Sie alle erforderlichen Argumente in die Formel ein, die den Fehler zurückgibt. Hierbei müssen Sie möglicherweise den Visual Basic-Editor (VBE) zum Überprüfen der Formel verwenden. Sie können über die Registerkarte "Entwicklertools" oder durch Drücken von ALT+F11 auf VBE zugreifen.

Zum Beheben dieses Problems überprüfen Sie, ob die Arbeitsmappe, die die benutzerdefinierte Funktion enthält, geöffnet ist und die Funktion ordnungsgemäß arbeitet.

Zum Beheben des Problems überprüfen Sie, ob die Argumente in der Funktion richtig sind und an der richtigen Stelle verwendet werden.

Um das Problem zu beheben, drücken Sie STRG+ALT+F9, um das Blatt neu zu berechnen.

Sie können den Funktions-Assistenten verwenden, wenn Ihnen die richtigen Argumente nicht geläufig sind. Markieren Sie die Zelle mit der betreffenden Formel, wechseln Sie dann im Menüband zur Registerkarte Formel, und klicken Sie auf Funktion einfügen.

Schaltfläche "Funktion einfügen"

Excel ruft nun automatisch den Assistenten auf:

Beispiel für das Dialogfeld "Formel-Assistent"

Während Sie auf die einzelnen Argumente klicken, erhalten Sie von Excel die entsprechenden Informationen.

#NV kann sich als äußerst nützlich erweisen! Es ist gängige Praxis, #NV in Verbindung mit Daten für Diagramme wie in den folgenden Beispielen gezeigt zu verwenden, da #NV-Werte nicht in Diagrammen angezeigt werden. Hier einige Beispiele für Diagramme mit Nullwerten anstelle von #NV.

Beispiel für ein Liniendiagramm, in dem 0-Werte dargestellt werden

Im vorstehenden Beispiel sehen Sie, dass die Nullwerte dargestellt und als gerade Linie am Fuß des Diagramms angezeigt werden, die dann nach oben schießt, um die Gesamtsumme anzuzeigen. Im folgenden Beispiel wurden die Nullwerte durch #NV ersetzt.

Beispiel für ein Liniendiagramm, in dem #NV-Fehler nicht dargestellt werden

Weitere Informationen zum #NV-Fehler in einer bestimmten Funktion finden Sie unter den folgenden Themen:

Seitenanfang

Haben Sie eine Frage zu einer bestimmten Funktion?

Bereitstellen einer Frage in das Excel-Community-forum

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Konvertieren von als Text gespeicherten Zahlen in "Zahl"

SVERWEIS (Funktion)

WVERWEIS (Funktion)

VERWEIS (Funktion)

VERGLEICH (Funktion)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Beheben häufig auftretender Fehler in Formeln mit der Fehlerüberprüfung

Tastenkombinationen in Excel 2016 für Windows

Tastenkombinationen in Excel 2016 für Mac

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×