So korrigieren Sie einen #DIV/0!-Fehler

Microsoft Excel zeigt den Fehler #DIV/0! an, wenn eine Zahl durch Null (0) geteilt werden soll. Dies geschieht, wenn Sie eine einfache Formel, wie =5/0, eingeben oder wenn eine Formel auf eine Zelle mit dem Wert 0 oder eine leere Zelle verweist, wie in dieser Abbildung dargestellt.

Beispiele für Formeln, die zu #DIV/0!-Fehlern führen

Führen Sie eine der folgenden Aktionen aus, um den Fehler zu beheben:

  • Stellen Sie sicher, dass in der Funktion bzw. in der Formel als Divisor weder Null noch eine leere Zelle verwendet wird.

  • Ändern Sie den Zellbezug in der Formel auf eine andere Zelle, in der sich keine Null (0) oder ein leerer Wert befindet.

  • Geben Sie #NV in die Zelle ein, auf die als Divisor verwiesen wird, wodurch sich das Ergebnis der Formel ebenfalls in #NV ändert, was anzeigt, dass der Wert für den Divisor nicht verfügbar ist.

In vielen Fällen kann der Fehler #DIV/0! nicht vermieden werden, da Ihre Formeln auf eine Eingabe von Ihnen oder einer anderen Person warten. In diesem Fall möchten Sie, dass keine Fehlermeldung angezeigt wird, daher gibt es einige Fehlerbehandlungsmethoden, mit denen Sie den Fehler unterdrücken können, während auf die Eingabe gewartet wird.

Auswerten des Nenners für 0 oder "kein Wert"

Die einfachste Methode zum Unterdrücken des #DIV/0!-Fehlers besteht darin, eine WENN-Funktion zum Auswerten des Vorhandenseins eines Nenners zu verwenden. Wenn es eine 0 oder keinen Wert gibt, zeige eine 0 oder keinen Wert als Formelergebnis anstelle des #DIV/0!-Fehlers an, andernfalls berechne die Formel.

Wenn die Formel, die den Fehler zurückgibt, beispielsweise =A2/A3 lautet, geben Sie =WENN(A3;A2/A3;0) ein, damit 0, oder =WENN(A3;A2/A3;””), damit eine leere Zeichenfolge zurückgegeben wird. Es kann auch eine benutzerdefinierte Meldung wie die folgende angezeigt werden: =WENN(A3;A2/A3;"Eingabe erforderlich"). Mit der Funktion QUOTIENT aus dem ersten Beispiel würden Sie =WENN(A3;QUOTIENT(A2;A3);0) verwenden. Damit wird Excel Folgendes mitgeteilt: WENN(A3 vorhanden ist, gib das Ergebnis der Formel zurück, andernfalls ignorieren).

Beispiele für das Auflösen von #DIV/0!-Fehlern

Verwenden von WENNFEHLER, um den Fehler #DIV/0! zu unterdrücken

Sie können diesen Fehler auch unterdrücken, indem Sie Ihren Divisionsvorgang in der Funktion WENNFEHLER schachteln. Wenn Sie wieder A2/A3 verwenden, können Sie =WENNFEHLER(A2/A3;0) eingeben. Damit wird Excel mitgeteilt, dass 0 zurückgegeben werden soll, wenn die Formel einen Fehler aufweist, andernfalls das Ergebnis der Formel.

In Excel-Versionen vor Excel 2007 können Sie die Methode WENN(ISTFEHLER()) verwenden: =WENN(ISTFEHLER(A2/A3);0;A2/A3). Lesen Sie hierzu IST-Funktionen).

Beachten Sie: Sowohl die Methode WENNFEHLER als auch die Methode WENN(ISTFEHLER()) sind Rahmenfehlerhandler, die alle Fehler und nicht nur #DIV/0! unterdrücken. Sie müssen sicherstellen, dass Ihre Formel ordnungsgemäß funktioniert, bevor Sie Fehlerbehandlungen zuweisen, andernfalls merken Sie ggf. nicht, dass die Formel nicht wie erwartet funktioniert.

Tipp : Wenn die Fehlerüberprüfung in Excel aktiviert ist, können Sie neben der Zelle, die den Fehlerwert anzeigt, auf Schaltflächensymbol klicken. Klicken Sie auf Berechnungsschritte anzeigen, falls dieser Befehl verfügbar ist, und wählen Sie die Lösung aus, die für Ihre Daten funktioniert.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

WENN-Funktion

WENNFEHLER-Funktion

IST-Funktionen

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×