Senden von Formulardaten an eine Microsoft Access-Datenbank

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Inhalt dieses Artikels

Übersicht

Schritt 1: Aktivieren der Verbindung zum Absenden von Daten

Schritt 2: Konfigurieren der Absendeoptionen

Übersicht

Wenn Sie eine Microsoft Office InfoPath-Formularvorlage entwerfen, die auf einer Microsoft Office Access- (MDB) oder Microsoft Office Access 2007-Datenbank (ACCDB) basiert, dann erstellt der Datenverbindungs-Assistent eine Sendedatenverbindung zur Datenbank, wenn die folgenden Bedingungen zutreffen.

  • Die Formularvorlage wurde so entworfen, dass sie von Benutzern mithilfe von InfoPath ausgefüllt werden muss. Wenn das Formular mithilfe eines Webbrowsers ausgefüllt wird, können die Daten vom Formular nicht direkt an eine Datenbank gesendet werden. Um eine Browserkompatible Formularvorlage zum Senden von Daten an eine Datenbank zu konfigurieren, verwenden Sie eine Datenverbindung, die Daten an einen Webdienst sendet, der mit der Datenbank zusammenarbeitet.

  • Die in der primären Datenverbindung verwendete Masterdatenbanktabelle enthält einen Primärschlüssel, eine eindeutige Einschränkung oder einen eindeutigen Index.

  • Alle anderen Datenbanktabellen, die mit dieser primären Datenverbindung verwendet werden, besitzen eine einfache hierarchische Beziehung zur Masterdatenbanktabelle.

  • Die Datenbank enthält keine Felder, die große binäre Datentypen wie Fotos, Abbildungen, OLE-Objekte, Dateianhänge, den Office Access-Memo-Datentyp oder den SQL Text-Datentyp speichern kann.

Wenn die Datenbank diesen Anforderungen entspricht, erstellt InfoPath die Sendedatenverbindung und fügt die Schaltfläche Absenden zur Symbolleiste Standard und den Befehl Absenden zum Menü Datei des Formulars hinzu.

Hinweis : Sekundäre Datenverbindungen können keine Daten an eine Datenbank senden. Wenn Sie eine Sendedatenverbindung zu einer Datenbank als sekundäre Datenverbindung verwenden möchten, ermitteln Sie einen Webdienst, der mit der Datenbank zusammenarbeitet, und fügen Sie dann eine Sendedatenverbindung zu diesem Webdienst hinzu.

Nachdem Sie die Sendedatenverbindung aktiviert haben, können Sie die Sendeoptionen für die Formularvorlage mithilfe der folgenden Verfahren anpassen.

  • Ändern Sie den Text, der auf der Schaltfläche Absenden der Symbolleiste Standard angezeigt wird sowie den Befehl Absenden im Menü Datei.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden der Symbolleiste Standard und für den Befehl Absenden im Menü Datei.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem das Formular abgesendet wurde.

Seitenanfang

Schritt 1: Aktivieren der Verbindung zum Absenden von Daten

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf die primäre Datenverbindung, und klicken Sie dann auf Ändern.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Weiter.

  4. Aktivieren Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Absenden für diese Verbindung aktivieren, und klicken Sie dann auf Fertig stellen.

Seitenanfang

Schritt 2: Konfigurieren der Sendeoptionen

Nachdem Sie die Sendedatenverbindung aktiviert haben, fügt InfoPath die Schaltfläche Absenden zur Symbolleiste Standard und den Befehl Absenden zum Menü Datei hinzu. InfoPath konfiguriert auch die Formulare, die auf dieser Formularvorlage basieren, um Benutzern eine Meldung anzuzeigen, nachdem diese ihre vervollständigten Formulare gesendet haben. Diese Meldung gibt an, ob das Formular erfolgreich gesendet wurde. Standardmäßig lässt InfoPath das Formular auch geöffnet, nachdem es von einem Benutzer gesendet wurde. Gehen Sie wie folgt vor, um den auf der Schaltfläche Absenden angezeigten Text sowie das Verhalten zu ändern, das auftritt, nachdem Benutzer ihre Formulare gesendet haben:

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, die Sie als Tastenkombination verwenden möchten. Geben Sie beispielsweise, um ALT + B als die Tastenkombination für die Senden-Schaltfläche und der Befehl zuweisen, Su & bsenden.

  2. Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×