Schrittweises Auswerten einer geschachtelten Formel

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Verstehen, wie eine geschachtelte Formel das endgültige Ergebnis berechnet ist manchmal schwierig, da es verschiedene zwischen-XT für Berechnungen und logische Prüfungen gibt. Verwenden Sie das Dialogfeld Formel auswerten, sehen Sie jedoch die verschiedenen Teile einer verschachtelten Formel in der Reihenfolge, die die Formel berechnet wird ausgewertet. Angenommen, die Formel =Wenn(Mittelwert(F2:F5) > 50,SUM(G2:G5),0) ist leichter zu verstehen, wenn Sie die folgenden Zwischenergebnisse sehen können:

Im Dialogfeld angezeigte Schritte

Beschreibung

=WENN(MITTELWERT(F2:F5)>50;SUMME(G2:G5);0)

Zunächst wird die geschachtelte Formel angezeigt. Die Funktionen MITTELWERT und SUMME sind in der WENN-Funktion geschachtelt.

=WENN (40> 50;SUMME(G2:G5);0)

Der Zellbereich F2: F5 enthält die Werte 55, 35, 45 und 25 und somit ist das Ergebnis der Funktion MITTELWERT(F2:F5) 40.

=WENN(Falsch;SUMME(G2:G5);0)

40 ist nicht größer als 50, damit der Ausdruck im ersten Argument der Wenn-Funktion (das Prüfungsargument) falsch ist.

0

Die Wenn-Funktion gibt den Wert des dritten Arguments (das Argument Sonst_Wert). Die Summe-Funktion nicht ausgewertet, da es das zweite Argument für die Wenn-Funktion (das Argument Dann_Wert), und es zurückgegeben nur, wenn der Ausdruck true ist.

  1. Markieren Sie die Zelle, die Sie auswerten möchten. Es kann immer nur jeweils eine Zelle ausgewertet werden.

  2. Klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Formel auswerten.

    Die Gruppe 'Formelüberwachung' auf der Registerkarte 'Formeln'

  3. Klicken Sie auf Auswerten, um den Wert des unterstrichenen Bezugs auszuwerten. Das Ergebnis der Auswertung wird kursiv dargestellt.

    Wenn der unterstrichene Teil der Formel auf eine andere Formel verweist, klicken Sie auf Einzelschritt, um die andere Formel im Feld Auswertung anzuzeigen. Klicken Sie auf Rückschritt, um zur vorherigen Zelle und Formel zurückzukehren.

    Hinweis: Die Schaltfläche Einzelschritt ist nicht für einen Bezug verfügbar, wenn der Bezug zum zweiten Mal in der Formel auftritt oder wenn sich die Formel auf eine Zelle in einer anderen Arbeitsmappe bezieht.

  4. Fahren Sie fort, bis jeder Teil der Formel ausgewertet wurde.

  5. Wenn Sie die Auswertung erneut anzeigen möchten, klicken Sie auf Neu starten.

    Wenn Sie die Auswertung beenden möchten, klicken Sie auf Schließen.

    Hinweise: 

    • Einige Teile von Formeln, die das IF, und wählen die Funktionen werden nicht ausgewertet, und im Feld Auswertung wird #nv angezeigt.

    • Wenn ein Bezug leer ist, wird im Feld Auswertung ein Nullwert (0) angezeigt.

    • Formeln mit Zirkelbezüge möglicherweise nicht wie erwartet ausgewertet werden. Wenn Zirkelbezüge gescannt werden sollen, können Sie iterative Berechnung aktivieren.

    • Die folgenden Funktionen werden neu berechnet jeder Änderung des Arbeitsblatts, und kann dazu führen, dass das Tool Formel auswerten von in der Zelle angezeigt, andere Ergebnisse erzielt: Zufallszahl, OFFSET, Zelle, wird von indirekt, jetzt, heute, ZUFALLSBEREICH, Informationen und SUMMEWENN (in einigen Szenarien).

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×