Schrittweises Auswerten einer geschachtelten Formel

Manchmal lässt es sich nur schwer nachvollziehen, wie eine verschachtelte Formel das Endergebnis berechnet, da mehrere Zwischenberechnungen und Wahrheitsprüfungen durchgeführt werden. Mithilfe des Dialogfelds Formel auswerten können Sie jedoch die verschiedenen Teile einer verschachtelten Formel in der Reihenfolge auswerten, in der die Formel berechnet wird. Beispielsweise ist die Formel = wenn (Mittelwert (F2: F5) >50, Summe (G2: G5), 0) leichter verständlich, wenn die folgenden Zwischenergebnisse angezeigt werden:

Im Dialogfeld angezeigte Schritte

Beschreibung

=WENN(MITTELWERT(F2:F5)>50;SUMME(G2:G5);0)

Zunächst wird die geschachtelte Formel angezeigt. Die Funktionen MITTELWERT und SUMME sind in der WENN-Funktion geschachtelt.

=WENN (40> 50;SUMME(G2:G5);0)

Der Zellbereich F2:F5 enthält die Werte 55, 35, 45 und 25. Daher lautet das Ergebnis der Funktion MITTELWERT(F2:F5) 40.

=WENN(Falsch;SUMME(G2:G5);0)

40 ist nicht größer als 50, daher ist der Ausdruck im ersten Argument der wenn-Funktion (dem Argument Prüfung) falsch.

0

Die WENN-Funktion gibt den Wert des dritten Arguments zurück (das Argument Sonst_Wert). Die Summe-Funktion wird nicht ausgewertet, da Sie das zweite Argument für die wenn-Funktion (value_if_true-Argument) ist und nur zurückgegeben wird, wenn der Ausdruck wahr ist.

  1. Markieren Sie die Zelle, die Sie auswerten möchten. Es kann immer nur jeweils eine Zelle ausgewertet werden.

  2. Klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Formel auswerten.

    Die Gruppe 'Formelüberwachung' auf der Registerkarte 'Formeln'

  3. Klicken Sie auf Auswerten, um den Wert des unterstrichenen Bezugs auszuwerten. Das Ergebnis der Auswertung wird kursiv dargestellt.

    Wenn der unterstrichene Teil der Formel auf eine andere Formel verweist, klicken Sie auf Einzelschritt, um die andere Formel im Feld Auswertung anzuzeigen. Klicken Sie auf Rückschritt, um zur vorherigen Zelle und Formel zurückzukehren.

    Hinweis: Die Schaltfläche Einzelschritt ist nicht für einen Bezug verfügbar, wenn der Bezug zum zweiten Mal in der Formel auftritt oder wenn sich die Formel auf eine Zelle in einer anderen Arbeitsmappe bezieht.

  4. Fahren Sie fort, bis jeder Teil der Formel ausgewertet wurde.

  5. Wenn Sie die Auswertung erneut anzeigen möchten, klicken Sie auf Neu starten.

    Wenn Sie die Auswertung beenden möchten, klicken Sie auf Schließen.

    Hinweise: 

    • Einige Teile von Formeln, die die Funktionen if und Choose verwenden, werden nicht ausgewertet, und #N/a wird im Feld Auswertung angezeigt.

    • Wenn ein Bezug leer ist, wird im Feld Auswertung ein Nullwert (0) angezeigt.

    • Formeln mit Zirkelbezüge werden möglicherweise nicht erwartungsgemäß ausgewertet. Wenn Zirkelbezüge erwünscht sind, können Sie die iterative Berechnung aktivieren.

    • Die folgenden Funktionen werden jedes Mal neu berechnet, wenn das Arbeitsblatt geändert wird, und können dazu führen, dass das Tool zum Auswerten von Formeln die Ergebnisse anders als in der Zelle zeigt: Rand, Offset, Zelle, indirekt, jetzt, heute, RANDBETWEEN, Info und SUMMEWENN (in einigen Szenarien).

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Siehe auch

Vermeiden defekter Formeln

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×