Schritt 4: Freigeben eines Makros für andere Personen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In Bezug auf das Freigeben von Makros ist es wichtig, zu verstehen, dass ein Makro in der Office-Datei gespeichert ist, sodass Sie die Datei für andere Benutzer freigeben müssen. Wenn Sie ein Makro in Word erstellt haben, müssen Sie die Datei als Word-Vorlage mit Makros (DOTM-Datei) oder als Word-Dokument mit Makros (DOCM-Datei) freigeben. Wenn Sie das Makro in Excel erstellt haben, müssen Sie die Datei als Excel-Arbeitsmappe mit Makros (XLSM-Datei) oder als Excel-Vorlage mit Makros (XLTM-Datei) freigeben.

Wenn Sie ein Word-Makro erstellt haben, müssen Sie ein paar zusätzliche Schritte ausführen, um Ihr Makro freizugeben:

Erstellen der leeren Word-Vorlage

  1. Öffnen Sie ein neues Word-Dokument.

  2. Klicken Sie im Menü Datei auf Speichern unter.

  3. Weisen Sie Ihrer Datei den Namen "global_macros.dotm" zu.

  4. Wählen Sie in der Dropdownliste Format das Format Word-Vorlage mit Makros (*.dotm) aus.

  5. Wählen Sie aus, wo die Datei im Netzwerk gespeichert werden soll.

  6. Klicken Sie auf Speichern, und schließen Sie dann die Vorlage.

Exportieren des Word-Makros aus dem Dokument

Führen Sie für das in Schritt 1 aufgezeichnete Makro die folgenden Schritte aus, um das Makro zu exportieren:

  1. Öffnen Sie das Dokument oder die Vorlage, das/die das zu exportierende Makro enthält.

  2. Zeigen Sie im Menü Extras auf Makro, und klicken Sie dann auf Makros.

  3. Wählen Sie das zu exportierende Makro aus, und klicken Sie dann auf Bearbeiten. Zu exportierendes Makro auswählen

  4. Klicken Sie im Visual Basic-Editor auf Datei > Datei exportieren.

  5. Speichern Sie das Makro im selben Ordner wie die Vorlage mit Makros "global_macros.dotm".

Importieren des Word-Makros in die neue leere Vorlage

  1. Öffnen Sie die Datei "global_macros.dotm", und klicken Sie dann auf Extras > Makro > Visual Basic-Editor.

  2. Klicken Sie zum Importieren des Makros auf Datei > Datei importieren, navigieren Sie zu dem Ordner, in den Sie Ihr Makro exportiert haben, wählen Sie die Datei aus, und klicken Sie dann auf Öffnen.

  3. Speichern Sie das Modul, beenden Sie den Visual Basic-Editor, und beenden Sie dann Word.

Sie können jetzt Ihr Makro für andere Benutzer freigeben und die Benutzer anweisen, die folgenden Schritte auszuführen, um das Makro auf ihren Computern zu installieren.

Installieren der Vorlage: Einrichten von Word für die Verwendung des Makros

  1. Legen Sie die Datei "global_macro.dotm" im folgenden Verzeichnis ab:

    • Word für Mac 2011: Macintosh-Laufwerk: Users: Benutzername: Library: Application Support: Microsoft: Office: User Templates: Meine Vorlagen

    • Word 2003 unter Windows (oder höher): "C:\Dokumente und Einstellungen\Benutzername\Anwendungsdaten\Microsoft\Word\STARTUP"

      Hinweis :  Bei "Benutzername" handelt es sich um den Anmeldenamen des Benutzers.

  2. Klicken Sie in Word auf Word > Einstellungen.

Word-Einstellungen

  1. Klicken Sie im Abschnitt Persönliche Einstellungen auf Dateispeicherorte

  2. Wählen Sie in der Liste Dateispeicherorte den Eintrag Start aus, und klicken Sie dann auf Ändern.

Dateispeicherort

  1. Stellen Sie sicher, dass Word als Startordner den Ordner verwendet, in dem Sie die Datei "global_macro.dotm" abgelegt haben.

  2. Klicken Sie auf Auswählen, um das Dialogfeld Ordner auswählen zu schließen, und klicken Sie dann auf OK, um das Dialogfeld "Dateispeicherorte" zu schließen.

Im letzten Schritt legen Sie fest, dass Word beim Starten die Datei "global_macros.dotm" verwendet.

  1. Klicken Sie in Word auf Extras > Vorlagen und Add-Ins.

  2. Aktivieren Sie in der Liste die Datei "global_macros.dotm", und klicken Sie auf OK.

    Tipp :  Wenn Ihre Vorlage nicht in der Liste angezeigt wird, befindet sich die Datei "global_macros.dotm" nicht im Word-Startordner. Kehren Sie zu Schritt 1 in diesem Abschnitt zurück, und stellen Sie sicher, dass es sich bei dem Startordner um denselben Ordner handelt, in den Sie die Datei global_macros.dotm kopiert haben.

Globale Vorlage in Word 2007 einrichten

 Schritt 1: Starten der Makroaufzeichnung

Schritt 2: Lesen und Verstehen des Codes

Schritt 3: Grundlagen der Programmierung

Schritt 4: Freigeben eines Makros für andere Personen

Schritt 5: Praktische Beispiele

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×