SUMMEWENNS (Funktion)

Mit der Funktion SUMMEWENNS, einer der mathematischen und trigonometrischen Funktionen, werden alle Argumente addiert, die mehrere Kriterien erfüllen. Beispielsweise würden Sie SUMMEWENNS verwenden, um die Anzahl der Einzelhändler im Land zu addieren, (1) die in einem bestimmten Postleitzahlbereich wohnen, und (2) deren Gewinne einen bestimmten Wert überschreiten.

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Dieses Video ist Teil des Schulungskurses Erweiterte WENN-Funktionen.

Syntax

SUMMEWENNS(Summe_Bereich; Kriterien_Bereich1; Kriterien1; [Kriterien_Bereich2; Kriterien2]; ...)

  • =SUMMEWENNS(A2:A9;B2:B9;"=A*";C2:C9;"Tom")

  • =SUMMEWENNS(A2:A9;B2:B9;"<>Bananen";C2:C9;"Tom")

Argumentname

Beschreibung

Summe_Bereich    (erforderlich)

Der zu addierende Zellbereich.

Kriterienbereich1    (erforderlich)

Der Bereich, der auf Kriterien1 getestet wird.

Mit Kriterien_Bereich1 und Kriterien1 richten Sie ein Suchpaar ein, wobei ein Bereich nach bestimmten Kriterien durchsucht wird. Sobald Elemente in dem Bereich gefunden werden, werden die entsprechenden Werte in Summe_Bereich addiert.

Kriterien1    (erforderlich)

Die Kriterien, die definieren, welche Zellen in Kriterien_Bereich1 addiert werden. Kriterien können beispielsweise in folgender Form eingegeben werden: 32, ">32", B4, "Äpfel" oder "32".

Kriterienbereich2;Kriterien2;...    (optional)

Zusätzliche Bereiche und zugehörige Kriterien. Sie können bis zu 127 Bereich/Kriterien-Paare eingeben.

Beispiele

Wenn Sie diese Beispiele in Excel verwenden möchten, ziehen Sie, um die Daten in der Tabelle auszuwählen. Klicken Sie mit der rechten Maustaste auf die Auswahl, und wählen Sie Kopieren aus. Klicken Sie in einem neuen Arbeitsblatt mit der rechten Maustaste auf Zelle A1, und wählen Sie unter Einfügeoptionen die Option Formatierung der Zielzellen übernehmen aus.

Verkaufte Menge

Produkt

Verkäufer

5

Äpfel

Tom

4

Äpfel

Sarah

15

Artischocken

Tom

3

Artischocken

Sarah

22

Bananen

Tom

12

Bananen

Sarah

10

Möhren

Tom

33

Möhren

Sarah

Formel

Beschreibung

=SUMMEWENNS(A2:A9;B2:B9;"=A*";C2:C9;"Tom")

Addiert die Anzahl der Produkte, die mit A beginnen und von Tom verkauft wurden. Das Platzhalterzeichen * wird in Kriterien1, "=A*", verwendet, um nach übereinstimmenden Produktnamen in Kriterienbereich1, "B2:B9", zu suchen, und es wird nach dem Namen "Tom" in Kriterienbereich2, "C2:C9", gesucht. Anschließend werden die Zahlen in Summe_Bereich, A2:A9, die beide Bedingungen erfüllen, addiert. Das Ergebnis lautet "20".

=SUMMEWENNS(A2:A9;B2:B9;"<>Bananen";C2:C9;"Tom")

Addiert die Anzahl der Produkte, außer Bananen, die von Tom verkauft wurden. Durch Verwenden von <> in Kriterien1, "<> Bananen", werden Bananen ausgeschlossen. Außerdem wird nach dem Namen "Tom" in Kriterienbereich2, C2: C9, gesucht. Anschließend werden die Zahlen in Summe_Bereich, A2:A9, die beide Bedingungen erfüllen, addiert. Das Ergebnis lautet "30".

Häufig auftretende Probleme

Problem

Beschreibung

0 (null) wird anstelle des erwarteten Ergebnisses angezeigt.

Stellen Sie sicher, dass Kriterien1;2 in Anführungszeichen angegeben sind, wenn Sie nach Textwerten, z. B. dem Namen einer Person, suchen.

Das Ergebnis ist falsch, wenn Summe_Bereich die Werte WAHR oder FALSCH aufweist.

Die Werte WAHR und FALSCH für Summe_Bereich werden unterschiedlich ausgewertet, was bei der Addition möglicherweise zu unerwarteten Ergebnissen führt.

Zellen in Summe_Bereich, die WAHR enthalten, werden als "1" ausgewertet. Zellen, die FALSCH enthalten, werden als "0" (null) ausgewertet.

Bewährte Methoden

Aktion

Beschreibung

Verwenden Sie Platzhalterzeichen.

Die Verwendung von Platzhalterzeichen wie Fragezeichen (?) und Sternchen (*) in Kriterien1;2 kann Ihnen die Suche nach ähnlichen, aber nicht exakten Übereinstimmungen erleichtern.

Ein Fragezeichen ersetzt ein einzelnes Zeichen. Ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen suchen möchten, müssen Sie eine Tilde (~) vor dem zu suchenden Zeichen eingeben.

Beispiel: =SUMMEWENNS(A2:A9;B2:B9;"= A*";C2: C9;"An?") addiert alle Instanzen mit Namen, die mit "Zu" beginnen und mit einem dritten Buchstaben enden, der variieren kann.

Informationen zum Unterschied zwischen SUMMEWENN und SUMMEWENNS.

Die Reihenfolge der Argumente in SUMMEWENNS und SUMMEWENN unterscheidet sich. Insbesondere ist das Argument Summe_Bereich in SUMMEWENNS das erste Argument, in SUMMEWENN jedoch das dritte Argument. Dies ist eine häufige Ursache für Probleme mit diesen Funktionen.

Wenn Sie diese ähnlichen Funktionen kopieren und bearbeiten, stellen Sie sicher, dass Sie die Argumente in der richtigen Reihenfolge angeben.

Verwenden Sie die gleiche Anzahl von Zeilen und Spalten für Bereichsargumente.

Das Argument Kriterien_Bereich muss die gleiche Anzahl von Zeilen und Spalten wie das Argument Summe_Bereich aufweisen.

Seitenanfang

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Sehen Sie sich ein Video zur Verwendung erweiterter WENN-Funktionen wie SUMMEWENNS an

Mit der Funktion SUMMEWENN werden nur die Werte addiert, die einem einzelnen Kriterium entsprechen

Mit der Funktion QUADRATESUMME werden mehrere Werte addiert, nachdem jeweils eine mathematische Operation zum Bilden der Quadratzahl ausgeführt wurde

Mit der Funktion ZÄHLENWENN werden nur die Werte gezählt, die einem einzelnen Kriterium entsprechen

Mit der Funktion ZÄHLENWENNS werden nur die Werte gezählt, die mehreren Kriterien entsprechen

Funktion WENNS (Office 365, Excel 2016 und höher)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Mathematische und trigonometrische Funktionen

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×