SUMMENPRODUKT (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion SUMMENPRODUKT in Microsoft Excel beschrieben.

Beschreibung

Multipliziert die einander entsprechenden Komponenten der angegebenen Arrays miteinander und gibt die Summe dieser Produkte zurück.

Syntax

SUMMENPRODUKT(Array1;[Array2];[Array3];...)

Die Syntax der Funktion SUMMENPRODUKT weist die folgenden Argumente auf:

  • Array1     Erforderlich. Das erste Arrayargument, dessen Komponenten Sie multiplizieren und anschließend addieren möchten

  • Array2; Array3;...     Optional. 2 bis 255 Arrayargumente, deren Komponenten Sie multiplizieren und anschließend addieren möchten

Hinweise

  • Die als Argumente angegebenen Arrays müssen bezüglich der Zeilen- und Spaltenanzahl identisch sein. Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück.

  • Arrayelemente, die keine numerischen Ausdrücke sind, behandelt SUMMENPRODUKT so, als wären sie mit 0 belegt.

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Array 1

Array 2

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Beschreibung

Ergebnis

=SUMMENPRODUKT(A2:B4; D2:E4)

Multipliziert alle Elemente in den beiden Matrizen und summiert anschließend die Produkte: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×