ODER (Funktion)

Verwenden Sie die Funktion ODER (eine der logischen Funktionen), um zu bestimmen, ob eine Bedingung in einer Prüfung WAHR ist.

Beispiel

Beispiele für die Verwendung der ODER-Funktion.

Die Funktion ODER gibt den Wert WAHR zurück, wenn eines der Argumente als WAHR bewertet wird. Wenn alle Argumente als FALSCH bewertet werden, gibt die Funktion den Wert FALSCH zurück.

Die Funktion ODER wird häufig verwendet, um den Nutzen anderer Funktionen zu erhöhen, mit denen Wahrheitsprüfungen ausgeführt werden. Mit der Funktion WENN wird beispielsweise eine Wahrheitsprüfung ausgeführt und dann ein Wert zurückgegeben, wenn die Prüfung mit WAHR bewertet wird, und es wird ein anderer Wert zurückgegeben, wenn die Prüfung mit FALSCH bewertet wird. Wenn Sie die Funktion ODER als Argument "Wahrheitsprüfung" in der Funktion WENNFunktion verwenden, können Sie viele verschiedene Bedingungen und nicht nur eine prüfen.

Syntax

ODER(Wahrheitswert1;[Wahrheitswert2]; ...)

Die Syntax der Funktion ODER weist die folgenden Argumente auf:

Argument

Beschreibung

Wahrheitswert1

Erforderlich. Die erste zu prüfende Bedingung, die entweder als WAHR oder als FALSCH bewertet werden kann.

Wahrheitswert2; ...

Optional. Zusätzlich zu prüfende Bedingungen, die entweder als WAHR oder als FALSCH bewertet werden können. Es können maximal 255 Bedingungen angegeben werden.

Hinweise

  • Die Argumente müssen als Wahrheitswerte, WAHR oder FALSCH, oder in Matrizen oder Bezügen ausgewertet werden, die Wahrheitswerte enthalten.

  • Enthält ein als Matrix oder Bezug angegebenes Argument Text oder leere Zellen, werden diese Werte ignoriert.

  • Enthält der angegebene Bereich keine Wahrheitswerte, gibt ODER den Fehlerwert #WERT! zurück.

  • Sie können mit einer ODER-Matrixformel prüfen, ob ein bestimmter Wert innerhalb einer Matrix vorhanden ist. Drücken Sie zum Eingeben einer Matrixformel STRG+UMSCHALT+EINGABETASTE.

Beispiele

Nachfolgend finden Sie einige allgemeine Beispiele für die Verwendung von ODER allein und in Verbindung mit WENN.

Beispiele für die Verwendung der ODER-Funktion mit der WENN-Funktion.


Formel

Beschreibung

=ODER(A2>1;A2<100)

Zeigt WAHR an, wenn A2 größer als 1 ODER kleiner als 100 ist. Andernfalls wird FALSCH angezeigt.

=WENN(ODER(A2>1;A2<100);A3;"Der Wert liegt außerhalb des gültigen Bereichs")

Zeigt den Wert in Zelle A3 an, wenn dieser größer als 1 ODER kleiner als 100 ist. Andernfalls wird die Meldung "Der Wert liegt außerhalb des gültigen Bereichs" angezeigt.

=WENN(ODER(A2<0;A2>50);A2;"Der Wert liegt außerhalb des gültigen Bereichs")

Zeigt den Wert in Zelle A2 an, wenn dieser kleiner als 0 ODER größer als 50 ist. Andernfalls wird eine Meldung angezeigt.

Verkaufsprovisionsberechnung

Dies ist ein relativ gängiges Szenario, in dem wir mit den Funktionen WENN und ODER berechnen müssen, ob die Verkäufer eine Provision erhalten.

Beispiel für die Verwendung der WENN- und ODER-Funktion zum Berechnen von Umsatzprovisionen.
  • =WENN(ODER(B14>=$B$4;C14>=$B$5);B14*$B$6;0)WENN Gesamtumsatz größer als oder gleich (>=) Umsatzziel ODER Accounts größer als oder gleich (>=) Accountziel, wird der Gesamtumsatz mit dem Prozentsatz der Provision multipliziert. Andernfalls wird 0 zurückgegebenen.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice

Siehe auch

Sehen Sie sich ein Video zur Verwendung der Funktion WENN an

Verwenden von verschachtelten Funktionen in einer Formel

WENN (Funktion)

UND (Funktion)

NICHT (Funktion)

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Ermitteln von Fehlern in Excel 2016

Tastenkombinationen in Excel 2016 für Windows

Tastenkombinationen in Excel 2016 für Mac

Logische Funktionen (Referenz)

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×