Nachschlagen von Werten mit SVERWEIS, INDEX oder VERGLEICH

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Zum Auffinden eines Werts in einer umfangreichen Liste können Sie eine Nachschlagefunktion verwenden. Häufig wird die Funktion SVERWEIS verwendet, doch auch die Funktion WVERWEIS und die gemeinsame Verwendung der Funktionen INDEX und VERGLEICH können nützlich sein.

Hier ein Überblick über SVERWEIS und die verwendeten Argumente:

= SVERWEIS(<Suchwert>,<Nachschlagebereich>,<Spalte>,<Ungefähre Übereinstimmung>)

Beispiel: =SVERWEIS(21500;C2:E7;3;FALSCH)

  • Das erste Argument (ein für die Funktion erforderliches Element) ist der Wert, nach dem Sie suchen möchten. Dabei kann es sich um einen Zellbezug wie B2 oder einen Wert wie "Schmidt" oder "21500" handeln.

  • Das zweite Argument ist der Zellbereich, von dem Sie annehmen, dass er den gesuchten Wert enthält.

    Wichtig : Bei SVERWEIS muss die Spalte mit dem gesuchten Wert oder Zellbezug die Spalte ganz links im Bereich sein.

  • Das dritte Argument ist die Spalte im Nachschlagebereich von Zellen, die den anzuzeigenden Wert enthält.

Obwohl das vierte Argument optional ist, geben Sie die meisten Personen falsch (oder 0). Warum? Da dies die Funktion Suchen Sie eine genaue Übereinstimmung auf die Suche erzwingt. Sie können Geben Sie kein Argument oder wahr, aber wenn eine genaue Übereinstimmung gefunden wird, gibt die Funktion die- nächstgelegenenungefähre Übereinstimmung– und in der Regel, die meisten Personen eine ungefähre Übereinstimmung möchten nicht.

Um anzuzeigen, wie eine ungefähre Übereinstimmung Internetsites werden kann, sagen, für den Preis für ein Webpart mit ID 2345768 gefunden haben, aber Sie wechseln zweier Zahlen zurück, und es in der Formel wie folgt falsch: =VLOOKUP(2345678,A1:E7,5). die Formel gibt den Kurs für das falsche Teil, da SVERWEIS der nächsten Zahl kleiner als oder gleich gefunden die angegebene Nummer (2345678). Sie können einen Kunden falsch aufgrund dieses Fehlers Abrechnung einhandeln.

Wenn Sie "FALSE" oder "0" als Argument für die ungefähre Übereinstimmung angeben und keine exakte Übereinstimmung vorhanden ist, gibt die Formel "#NV" anstelle des falschen Werts in der Zelle zurück, und das ist natürlich viel besser. In diesem Fall bedeutet "#NV" nicht, dass Sie die Formel falsch eingegeben haben (mit Ausnahme der falsch eingegebenen Zahl), sondern es heißt, dass 2345678 nicht gefunden wurde (gewünscht war 2345768).

Dieses Beispiel zeigt, wie die Funktion ausgeführt wird. Wenn Sie einen Wert in die Zelle B2 (das erste Argument) eingeben, durchsucht SVERWEIS die Zellen C2:E7 (das zweite Argument) und gibt entsprechend der nächstgelegenen ungefähren Übereinstimmung den Wert aus der dritten Spalte des Bereichs zurück (Spalte E, das dritte Argument).

Eine typische Nutzung der Funktion SVERWEIS

In diesem Beispiel wurde das vierte Argument leer gelassen, sodass die Funktion eine ungefähre Übereinstimmung zurückgibt.

Verwenden der Funktion WVERWEIS

Wenn Sie mit SVERWEIS vertraut sind, ist auch die Funktion WVERWEIS nicht schwer zu verwenden. Sie geben die gleichen Argumente ein, doch sucht WVERWEIS nach Werten in Zeilen und nicht in Spalten.

Gemeinsame Verwendung von INDEX und VERGLEICH

Wenn Sie nicht auf eine Suche in der Spalte ganz links beschränkt sein möchten, können Sie eine Kombination der Funktionen INDEX und VERGLEICH verwenden. Eine Formel, bei der diese Funktionen zusammen verwendet werden, ist ein wenig komplexer als eine Formel mit einer SVERWEIS-Funktion, doch kann sie auch leistungsfähiger sein. Es gibt Benutzer, die eine INDEX/VERGLEICH-Kombination der Funktion SVERWEIS bei Weitem vorziehen.

Dieses Beispiel zeigt eine kleine Liste, bei der sich der gesuchte Wert (Chicago) nicht in der Spalte ganz links befindet. SVERWEIS kann also nicht verwendet werden. Stattdessen wird die Funktion VERGLEICH verwendet, um im Bereich B1:B11 nach "Chicago" zu suchen. Der Wert wird in Zeile 4 gefunden. Dann verwendet INDEX diesen Wert als Nachschlageargument und findet die Bevölkerungszahl für Chicago in der viertenSpalte (Spalte D). Die verwendete Formel wird in Zelle A14 gezeigt.

Verwenden von INDEX und VERGLEICH zum Nachschlagen eines Werts

Weitere Informationen zu Nachschlagefunktionen (Verweisfunktionen)

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×