Nachschlagen von Werten mit SVERWEIS, INDEX oder VERGLEICH

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Angenommen Sie, Sie verfügen über eine Liste von Büronummern-Speicherort, und Sie wissen, welche Mitarbeiter in jeder Niederlassung werden müssen. Die Kalkulationstabelle ist große, sodass Sie vielleicht denken, dass es Aufgabe schwierig ist. Es ist eigentlich ganz einfach mit einer Verweis-Funktion.

Die Funktionen SVERWEIS und WVERWEIS zusammen mit INDEX und Vergleich,sind einige der am häufigsten geeigneten Funktionen in Excel.

Hinweis: Das Nachschlage-Assistent-Feature ist nicht mehr in Excel verfügbar.

Hier ist ein Beispiel für SVERWEIS verwendet.

=SVERWEIS(B2;C2:E7;3;WAHR)

In diesem Beispiel ist B2 das erste Argument– ein Element der Daten, die die Funktion für die Arbeit erledigen. Dieser erste Argument ist für SVERWEIS der Wert, den Sie suchen möchten. Dieses Argument kann ein Zellbezug oder einen festen Wert wie "Schmitt" oder 21.000 sein. Das zweite Argument ist der Zellbereich, C2-:E7, in dem Sie für den Wert suchen, die Sie suchen möchten. Das dritte Argument ist die Spalte in diesem Bereich von Zellen, die den Wert enthält, den Sie anfordern.

Das vierte Argument ist optional. Geben Sie TRUE oder FALSE. Wenn Sie WAHR eingeben, oder lassen Sie das Argument leer, gibt die Funktion eine ungefähre Übereinstimmung des Werts im ersten Argument angegebenen. Wenn Sie "FALSE" eingeben, wird die Funktion den Wert entsprechen bereitstellen, indem Sie das erste Argument. Kurzum, das vierte Argument leer lassen – oder WAHR eingeben – mehr Flexibilität.

Dieses Beispiel zeigt, wie die Funktion funktioniert. Wenn Sie einen Wert in Zelle B2 (das erste Argument) eingeben, sucht SVERWEIS die Zellen im Bereich C2:E7 (2nd Argument) und gibt die nächste ungefähre Übereinstimmung aus der dritten Spalte im Bereich, Spalte E (Argument 3rd).

Eine typische Nutzung der Funktion SVERWEIS

Das vierte Argument leer, damit die Funktion eine ungefähre Übereinstimmung zurückgibt. Wenn sie nicht der Fall, müssten Sie geben Sie einen der Werte in den Spalten C oder D überhaupt ein Ergebnis zu erhalten.

Wenn Sie mit der SVERWEIS vertraut sind, ist die Funktion WVERWEIS genauso einfach zu verwenden. Geben Sie die gleichen Argumente, aber es in Zeilen anstelle von Spalten durchsucht. "

Probieren Sie es aus.

Wenn Sie die Suchfunktionen experimentieren, bevor Sie sie für Ihre eigenen Daten nutzen möchten, hier einige Beispieldaten. Einige Excel-Benutzer, wie mithilfe von SVERWEIS und WVERWEIS; andere Benutzer bevorzugen mithilfe von INDEX und Vergleich. Versuchen Sie jede Methode, und sehen Sie, welche für Sie am besten gefallen hat.

SVERWEIS-Beispiel, bei der Arbeit

Kopieren Sie die folgenden Daten in eine leere Kalkulationstabelle...

Tipp:    Bevor Sie die Daten in Excel einfügen, legen Sie die Breite der Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Dichte

Viskosität

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beschreibung

Ergebnis

=SVERWEIS(1;A2:C10;2)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

2,17

=SVERWEIS(1;A2:C10;3;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte C zurückgegeben.

100

=SVERWEIS(0,7;A2:C10;3;FALSCH)

Bei Verwendung einer genauen Entsprechung wird in Spalte A nach dem Wert 0,7 gesucht. Da es keine genaue Entsprechung in Spalte A gibt, wird ein Fehler zurückgegeben.

#NV

=SVERWEIS(0,1;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird in Spalte A nach dem Wert 0,1 gesucht. Da 0,1 kleiner als der kleinste Wert in Spalte A ist, wird ein Fehler zurückgegeben.

#NV

=SVERWEIS(2;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 2 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 2 ist, gesucht (1,29). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

1,71

WVERWEIS-Beispiel

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Tipp:    Bevor Sie die Daten in Excel einfügen, legen Sie die Breite der Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Achsen

Getriebe

Schrauben

4

4

9

5

7

10

6

8

11

Formel

Beschreibung

Ergebnis

=WVERWEIS("Achsen";A1:C4;2;WAHR)

Sucht "Achsen" in Zeile 1 und gibt den Wert aus Zeile 2 zurück, der in derselben Spalte (Spalte A) steht.

4

=WVERWEIS("Getriebe";A1:C4;3;FALSCH)

Sucht "Getriebe" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte (Spalte B) steht.

7

=WVERWEIS("B";A1:C4;3;WAHR)

Sucht "B" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte steht. Da für "B" keine genaue Entsprechung gefunden wird, wird der höchste Wert in Zeile 1 verwendet, der kleiner ist als "B": "Achsen" in Spalte A.

5

=WVERWEIS("Schrauben";A1:C4;4)

Sucht "Schrauben" in Zeile 1 und gibt den Wert aus Zeile 4 zurück, der in derselben Spalte (Spalte C) steht.

11

=WVERWEIS(3;{1.2.3;"a"."b"."c";"d"."e"."f"};2;WAHR)

Sucht die Zahl 3 in der dreizeiligen Matrixkonstanten und gibt den Wert aus Zeile 2 in derselben Spalte (in diesem Fall der dritten Spalte) zurück. Die Matrixkonstante umfasst drei Zeilen, die jeweils durch ein Semikolon (;) getrennt sind. Da "c" in Zeile 2 und in derselben Spalte wie 3 gefunden wird, wird "c" zurückgegeben.

c

INDEX und Vergleich Beispiele

In diesem Beispiel letzten setzt die Funktionen INDEX und Vergleich zusammen, um die frühesten Rechnungsnummer und das entsprechende Datum für jede von fünf Orten zurückzukehren. Da das Datum als Zahl zurückgegeben wird, verwenden wir die Funktion TEXT formatieren als Datum ein. Die INDEX-Funktion verwendet das Ergebnis der Funktion Vergleich tatsächlich als Argument. Die Kombination der Funktionen INDEX und Vergleich verwendet, zweimal in jeder Formel – zuerst, um die Rechnungsnummer zurückzugeben und dann auf das Datum zurück.

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Tipp:    Bevor Sie die Daten in Excel einfügen, legen Sie die Breite der Spalten A bis D auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Rechnung

Ort

Rechnungsdatum

Früheste Rechnung nach Ort mit Datum

3115

Aachen

7.4.12

="Aachen = "&INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);3);"t.m.jj")

3137

Aachen

9.4.12

="Augsburg = "&INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);3);"t.m.jj")

3154

Aachen

11.4.12

="Darmstadt = "&INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);3);"t.m.jj")

3191

Aachen

21.4.12

="Nürnberg = "&INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);3);"t.m.jj")

3293

Aachen

25.4.12

="Essen = "&INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);3);"t.m.jj")

3331

Aachen

27.4.12

3350

Aachen

28.4.12

3390

Aachen

1.5.12

3441

Aachen

2.5.12

3517

Aachen

8.5.12

3124

Augsburg

9.4.12

3155

Augsburg

11.4.12

3177

Augsburg

19.4.12

3357

Augsburg

28.4.12

3492

Augsburg

6.5.12

3316

Darmstadt

25.4.12

3346

Darmstadt

28.4.12

3372

Darmstadt

1.5.12

3414

Darmstadt

1.5.12

3451

Darmstadt

2.5.12

3467

Darmstadt

2.5.12

3474

Darmstadt

4.5.12

3490

Darmstadt

5.5.12

3503

Darmstadt

8.5.12

3151

Nürnberg

9.4.12

3438

Nürnberg

2.5.12

3471

Nürnberg

4.5.12

3160

Essen

18.4.12

3328

Essen

26.4.12

3368

Essen

29.4.12

3420

Essen

1.5.12

3501

Essen

6.5.12

Weitere Informationen zu Suchfunktionen

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×