Nachschlagen von Werten mit SVERWEIS, INDEX oder VERGLEICH

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie haben eine Liste mit Büronummern und müssen wissen, welche Mitarbeiter in jedem Büro sitzen. Das Arbeitsblatt ist aber sehr umfangreich, sodass Sie sich fragen, wie am besten vorzugehen ist? Verwenden Sie eine Nachschlagefunktion (Verweisfunktion). Die hierfür nützlichsten Funktionen sind SVERWEIS und WVERWEIS sowie die Funktionen INDEX und VERGLEICH.

Hinweis :  Möglicherweise suchen Sie nach dem Nachschlage-Assistenten. Dieses Feature gehört nicht mehr zu Excel.

Es folgt eine kurze Wiederholung, wie SVERWEIS verwendet werden kann.

=SVERWEIS(B2;C2:E7;3;WAHR)

Das erste Argument (ein Wert, der zum Ausführen der Funktion erforderlich ist) gibt den Wert an, nach dem Sie suchen. Dies kann ein Zellbezug oder eine Konstante wie "Schmidt" oder "21.000" sein. Das zweite Argument enthält den Zellbereich, in dem Sie den Wert vermuten, nach dem Sie suchen. Im vorliegenden Beispiel ist das C2 bis C7. Das dritte Argument gibt die Spalte im Zellbereich an, die den Wert enthält, den Sie sehen möchten.

Das vierte Argument ist optional. Sie können WAHR oder FALSCH eingeben. Wenn Sie WAHR eingeben oder das Argument nicht angeben, gibt die Funktion eine ungefähre Übereinstimung des Werts zurück, den Sie im ersten Argument angegeben haben. Wenn Sie FALSCH eingeben, entspricht die Funktion dem Wert, der im ersten Argument angegeben ist. Anders formuliert heißt das, ist das vierte Argument nicht oder als WAHR angegeben, erhalten Sie mehr Flexibilität.

In diesem Beispiel wird veranschaulicht, wie die Funktion ausgeführt wird. Wenn Sie einen Wert in die Zelle B2 (das erste Argument) eingeben, durchsucht SVERWEIS die Zellen C2 bis E7 (das zweite Argument) und gibt entsprechend der nächstgelegenen ungefähren Übereinstimmung den Wert aus der dritten Spalte des Bereichs zurück (Spalte E, das dritte Argument).

Eine typische Nutzung der Funktion SVERWEIS

Das vierte Argument ist leer, sodass die Funktion eine ungefähre Übereinstimmung zurückgibt. Wäre für dieses Argument der Wert FALSCH angegeben, müssten Sie einen der Werte aus der Spalte C oder D angeben, um überhaupt ein Ergebnis zu erhalten.

Sobald Sie sich mit SVERWEIS vertraut gemacht haben, dürfte es Ihnen keine Probleme bereiten, die Funktion WVERWEIS zu verwenden. Sie geben die gleichen Argumente ein, diese Funktion sucht aber in Zeilen statt in Spalten nach Werten.

Probieren Sie es aus

Wenn Sie die Nachschlagefunktionen ausprobieren möchten, bevor Sie sie für Ihre eigenen Daten verwenden, stehen hier einige Beispieldaten bereit. Manche Benutzer verwenden gerne SVERWEIS und WVERWEIS, während andere die gemeinsame Verwendung von INDEX und VERGLEICH bevorzugen. Probieren Sie alle Funktionen aus, sodass Sie feststellen können, mit welchen Sie am besten zurechtkommen.

SVERWEIS in Aktion

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Hinweis    Legen Sie vor dem Einfügen der Daten in Excel die Breite der Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (Registerkarte Start, Gruppe Ausrichtung).

Dichte

Viskosität

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beschreibung

Ergebnis

'=SVERWEIS(1;A2:C10;2)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

=SVERWEIS(1;A2:C10;2)

'=SVERWEIS(1;A2:C10;3;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte C zurückgegeben.

=SVERWEIS(1;A2:C10;3;WAHR)

'=SVERWEIS(0,7;A2:C10;3;FALSCH)

Bei Verwendung einer genauen Entsprechung wird in Spalte A nach dem Wert 0,7 gesucht. Da es keine genaue Entsprechung in Spalte A gibt, wird ein Fehler zurückgegeben.

=SVERWEIS(0,7;A2:C10;3;FALSCH)

'=SVERWEIS(0,1;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird in Spalte A nach dem Wert 0,1 gesucht. Da 0,1 kleiner als der kleinste Wert in Spalte A ist, wird ein Fehler zurückgegeben.

=SVERWEIS(0,1;A2:C10;2;WAHR)

'=SVERWEIS(2;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 2 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 2 ist, gesucht (1,29). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

=SVERWEIS(2;A2:C10;2;WAHR)

WVERWEIS in Aktion

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Hinweis    Legen Sie vor dem Einfügen der Daten in Excel die Breite der Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (Registerkarte Start, Gruppe Ausrichtung).

Achsen

Getriebe

Schrauben

4

4

9

5

7

10

6

8

11

Formel

Beschreibung

Ergebnis

'=WVERWEIS("Achsen";A1:C4;2;WAHR)

Sucht "Achsen" in Zeile 1 und gibt den Wert aus Zeile 2 zurück, der in derselben Spalte (Spalte A) steht.

=WVERWEIS("Achsen";A1:C4;2;WAHR)

'=WVERWEIS("Getriebe";A1:C4;3;FALSCH)

Sucht "Getriebe" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte (Spalte B) steht.

=WVERWEIS("Getriebe";A1:C4;3;FALSCH)

'=WVERWEIS("B";A1:C4;3;WAHR)

Sucht "B" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte steht. Da für "B" keine genaue Entsprechung gefunden wird, wird der höchste Wert in Zeile 1 verwendet, der kleiner ist als "B": "Achsen" in Spalte A.

=WVERWEIS("B";A1:C4;3;WAHR)

'=WVERWEIS("Schrauben";A1:C4;4)

Sucht "Schrauben" in Zeile 1 und gibt den Wert aus Zeile 4 zurück, der in derselben Spalte (Spalte C) steht.

=WVERWEIS("Schrauben";A1:C4;4)

'=WVERWEIS(3;{1.2.3;"a"."b"."c";"d"."e"."f"};2;WAHR)

Sucht die Zahl 3 in der dreizeiligen Matrixkonstanten und gibt den Wert aus Zeile 2 in derselben Spalte (in diesem Fall der dritten Spalte) zurück. Die Matrixkonstante umfasst drei Zeilen, die jeweils durch ein Semikolon (;) getrennt sind. Da "c" in Zeile 2 und in derselben Spalte wie 3 gefunden wird, wird "c" zurückgegeben.

=WVERWEIS(3;{1.2.3;"a"."b"."c";"d"."e"."f"};2;WAHR)

INDEX und VERGLEICH in Aktion

In diesem Beispiel werden die Funktionen INDEX und VERGLEICH zusammen verwendet, um die früheste Rechnungsnummer und das entsprechende Datum für jeden von fünf Orten zurückzugeben. Da das Datum als Zahl zurückgegeben wird, wird die Funktion TEXT verwendet, um sie als Datum zu formatieren. Die Funktion INDEX verwendet das Ergebnis der Funktion VERGLEICH als Argument. Die Kombination der Funktionen INDEX und VERGLEICH wird zweimal in jeder Formel verwendet – zuerst, um die Rechnungsnummer zurückzugeben, und dann zum Zurückgeben des Datums.

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Hinweis    Legen Sie vor dem Einfügen der Daten in Excel die Breite der Spalten A bis D auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (Registerkarte Start, Gruppe Ausrichtung).

Rechnung

Ort

Rechnungsdatum

Früheste Rechnung nach Ort mit Datum

3115

Aachen

7.4.12

="Aachen = "&INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);3);"t.m.jj")

3137

Aachen

9.4.12

="Augsburg = "&INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);3);"t.m.jj")

3154

Aachen

11.4.12

="Darmstadt = "&INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);3);"t.m.jj")

3191

Aachen

21.4.12

="Nürnberg = "&INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);3);"t.m.jj")

3293

Aachen

25.4.12

="Essen = "&INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);3);"t.m.jj")

3331

Aachen

27.4.12

3350

Aachen

28.4.12

3390

Aachen

1.5.12

3441

Aachen

2.5.12

3517

Aachen

8.5.12

3124

Augsburg

9.4.12

3155

Augsburg

11.4.12

3177

Augsburg

19.4.12

3357

Augsburg

28.4.12

3492

Augsburg

6.5.12

3316

Darmstadt

25.4.12

3346

Darmstadt

28.4.12

3372

Darmstadt

1.5.12

3414

Darmstadt

1.5.12

3451

Darmstadt

2.5.12

3467

Darmstadt

2.5.12

3474

Darmstadt

4.5.12

3490

Darmstadt

5.5.12

3503

Darmstadt

8.5.12

3151

Nürnberg

9.4.12

3438

Nürnberg

2.5.12

3471

Nürnberg

4.5.12

3160

Essen

18.4.12

3328

Essen

26.4.12

3368

Essen

29.4.12

3420

Essen

1.5.12

3501

Essen

6.5.12

Weitere Informationen zu Nachschlagefunktionen (Verweisfunktionen)

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×