Nachschlagen von Werten mit SVERWEIS, INDEX oder VERGLEICH

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Angenommen, Sie verfügen über eine Liste mit Bürostandort Nummern, und Sie müssen wissen, welche Mitarbeiter sich in jedem Büro befinden. Die Kalkulationstabelle ist riesig, daher denken Sie vielleicht, dass es eine schwierige Aufgabe ist. Es ist eigentlich ganz einfach mit einer Nachschlagefunktion.

Die Funktionen SVERWEIS und WVERWEIS sind zusammen mit Index und Übereinstimmungeinige der nützlichsten Funktionen in Excel.

Hinweis: Das Feature für den Nachschlage-Assistenten steht in Excel nicht mehr zur Verfügung.

Im folgenden finden Sie ein Beispiel für die Verwendung von SVERWEIS.

=SVERWEIS(B2;C2:E7;3;WAHR)

In diesem Beispiel ist B2 das erste Argument– ein Datenelement, das die Funktion bearbeiten muss. Für SVERWEIS ist dieses erste Argument der Wert, den Sie suchen möchten. Dieses Argument kann ein Zellbezug oder ein fester Wert wie "Schmidt" oder 21.000 sein. Das zweite Argument ist der Zellbereich, C2-: E7, in dem nach dem Wert gesucht werden soll, den Sie suchen möchten. Das dritte Argument ist die Spalte in diesem Zellbereich, die den gesuchten Wert enthält.

Das vierte Argument ist optional. Geben Sie entweder wahr oder falsch ein. Wenn Sie wahr eingeben oder das Argument leer lassen, gibt die Funktion eine ungefähre Übereinstimmung des Werts zurück, den Sie im ersten Argument angeben. Wenn Sie FALSE eingeben, entspricht die Funktion dem Wert, der mit dem ersten Argument angegeben wird. Mit anderen Worten: Wenn Sie das vierte Argument leer lassen oder wahr eingeben, erhalten Sie mehr Flexibilität.

Dieses Beispiel zeigt, wie die Funktion funktioniert. Wenn Sie einen Wert in Zelle B2 (das erste Argument) eingeben, durchsucht SVERWEIS die Zellen im Bereich C2: E7 (zweites Argument) und gibt die nächste ungefähre Übereinstimmung aus der dritten Spalte im Bereich, Spalte E (drittes Argument) zurück.

Eine typische Nutzung der Funktion SVERWEIS

Das vierte Argument ist leer, sodass die Funktion eine ungefähre Übereinstimmung zurückgibt. Wenn dies nicht der Fall ist, müssen Sie einen der Werte in den Spalten C oder D eingeben, um überhaupt ein Ergebnis zu erhalten.

Wenn Sie mit SVERWEIS vertraut sind, können Sie die WVERWEIS-Funktion ebenso einfach verwenden. Sie geben die gleichen Argumente ein, aber es wird in Zeilen anstelle von Spalten gesucht.

Verwenden von INDEX und Vergleich statt SVERWEIS

Es gibt bestimmte Einschränkungen bei der Verwendung von SVERWEIS – die Funktion SVERWEIS kann nur einen Wert von links nach rechts nachschlagen. Dies bedeutet, dass sich die Spalte, die den gesuchten Wert enthält, immer links von der Spalte befinden sollte, die den Rückgabewert enthält. Wenn Ihr Arbeitsblatt jetzt nicht auf diese Weise erstellt wird, verwenden Sie SVERWEIS nicht. Verwenden Sie stattdessen die Kombination aus den Funktionen INDEX und Vergleich.

Dieses Beispiel zeigt eine kleine Liste, bei der sich der gesuchte Wert (Chicago) nicht in der Spalte ganz links befindet. SVERWEIS kann also nicht verwendet werden. Stattdessen wird die Funktion VERGLEICH verwendet, um im Bereich B1:B11 nach "Chicago" zu suchen. Der Wert wird in Zeile 4 gefunden. Dann verwendet INDEX diesen Wert als Nachschlageargument und findet die Bevölkerungszahl für Chicago in der viertenSpalte (Spalte D). Die verwendete Formel wird in Zelle A14 gezeigt.

Weitere Beispiele für die Verwendung von INDEX und Vergleich anstelle von SVERWEIS finden Sie im Artikel https://www.MrExcel.com/Excel-Tips/Excel-VLOOKUP-Index-Match/ von Bill Jelen, Microsoft MVP.

Probieren Sie es aus.

Wenn Sie mit Nachschlagefunktionen experimentieren möchten, bevor Sie Sie mit ihren eigenen Daten ausprobieren, finden Sie hier einige Beispieldaten.

SVERWEIS-Beispiel bei der Arbeit

Kopieren Sie die folgenden Daten in ein leeres Arbeitsblatt.

Tipp: Legen Sie vor dem Einfügen der Daten in Excel die Spaltenbreiten für die Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Dichte

Viskosität

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beschreibung

Ergebnis

=SVERWEIS(1;A2:C10;2)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

2,17

=SVERWEIS(1;A2:C10;3;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 1 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 1 ist, gesucht (0,946). Anschließend wird der Wert in derselben Zeile in Spalte C zurückgegeben.

100

=SVERWEIS(0,7;A2:C10;3;FALSCH)

Bei Verwendung einer genauen Entsprechung wird in Spalte A nach dem Wert 0,7 gesucht. Da es keine genaue Entsprechung in Spalte A gibt, wird ein Fehler zurückgegeben.

#NV

=SVERWEIS(0,1;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird in Spalte A nach dem Wert 0,1 gesucht. Da 0,1 kleiner als der kleinste Wert in Spalte A ist, wird ein Fehler zurückgegeben.

#NV

=SVERWEIS(2;A2:C10;2;WAHR)

Bei Verwendung einer ungefähren Entsprechung wird bei einer Suche nach dem Wert 2 in Spalte A nach dem größten Wert in Spalte A, der kleiner oder gleich 2 ist, gesucht (1,29). Anschließend wird der Wert in derselben Zeile in Spalte B zurückgegeben.

1,71

WVERWEIS-Beispiel

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Tipp: Legen Sie vor dem Einfügen der Daten in Excel die Spaltenbreiten für die Spalten A bis C auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Achsen

Getriebe

Schrauben

4

4

9

5

7

10

6

8

11

Formel

Beschreibung

Ergebnis

=WVERWEIS("Achsen";A1:C4;2;WAHR)

Sucht "Achsen" in Zeile 1 und gibt den Wert aus Zeile 2 zurück, der in derselben Spalte (Spalte A) steht.

4

=WVERWEIS("Getriebe";A1:C4;3;FALSCH)

Sucht "Getriebe" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte (Spalte B) steht.

7

=WVERWEIS("B";A1:C4;3;WAHR)

Sucht "B" in Zeile 1 und gibt den Wert aus Zeile 3 zurück, der in derselben Spalte steht. Da für "B" keine genaue Entsprechung gefunden wird, wird der höchste Wert in Zeile 1 verwendet, der kleiner ist als "B": "Achsen" in Spalte A.

5

=WVERWEIS("Schrauben";A1:C4;4)

Sucht "Schrauben" in Zeile 1 und gibt den Wert aus Zeile 4 zurück, der in derselben Spalte (Spalte C) steht.

11

=WVERWEIS(3;{1.2.3;"a"."b"."c";"d"."e"."f"};2;WAHR)

Sucht die Zahl 3 in der dreizeiligen Matrixkonstanten und gibt den Wert aus Zeile 2 in derselben Spalte (in diesem Fall der dritten Spalte) zurück. Die Matrixkonstante umfasst drei Zeilen, die jeweils durch ein Semikolon (;) getrennt sind. Da "c" in Zeile 2 und in derselben Spalte wie 3 gefunden wird, wird "c" zurückgegeben.

c

Beispiele für INDEX und Vergleich

In diesem letzten Beispiel werden die Funktionen INDEX und Vergleich zusammen verwendet, um die früheste Rechnungsnummer und das zugehörige Datum für jede der fünf Städte zurückzugeben. Da das Datum als Zahl zurückgegeben wird, verwenden wir die TEXT-Funktion, um es als Datum zu formatieren. Die INDEX-Funktion verwendet tatsächlich das Ergebnis der ÜBEREINSTIMMUNGs Funktion als Argument. Die Kombination der Funktionen INDEX und Vergleich wird in jeder Formel zweimal verwendet, um zuerst die Rechnungsnummer zurückzugeben und das Datum zurückzugeben.

Kopieren Sie alle Zellen in dieser Tabelle, und fügen Sie sie in Zelle A1 eines leeren Arbeitsblatts in Excel ein.

Tipp: Legen Sie vor dem Einfügen der Daten in Excel die Spaltenbreiten für die Spalten A bis D auf 250 Pixel fest, und klicken Sie auf Zeilenumbruch (RegisterkarteStart, Gruppe Ausrichtung ).

Rechnung

Ort

Rechnungsdatum

Früheste Rechnung nach Ort mit Datum

3115

Aachen

7.4.12

="Aachen = "&INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Aachen";$B$2:$B$33;0);3);"t.m.jj")

3137

Aachen

9.4.12

="Augsburg = "&INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Augsburg";$B$2:$B$33;0);3);"t.m.jj")

3154

Aachen

11.4.12

="Darmstadt = "&INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Darmstadt";$B$2:$B$33;0);3);"t.m.jj")

3191

Aachen

21.4.12

="Nürnberg = "&INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Nürnberg";$B$2:$B$33;0);3);"t.m.jj")

3293

Aachen

25.4.12

="Essen = "&INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);1)& ", Rechnungsdatum: " & TEXT(INDEX($A$2:$C$33;VERGLEICH("Essen";$B$2:$B$33;0);3);"t.m.jj")

3331

Aachen

27.4.12

3350

Aachen

28.4.12

3390

Aachen

1.5.12

3441

Aachen

2.5.12

3517

Aachen

8.5.12

3124

Augsburg

9.4.12

3155

Austin

11.4.12

3177

Austin

19.4.12

3357

Austin

28.4.12

3492

Augsburg

6.5.12

3316

Darmstadt

25.4.12

3346

Dallas

28.4.12

3372

Dallas

1.5.12

3414

Dallas

1.5.12

3451

Dallas

2.5.12

3467

Dallas

2.5.12

3474

Dallas

4.5.12

3490

Dallas

5.5.12

3503

Darmstadt

8.5.12

3151

Nürnberg

9.4.12

3438

New Orleans

2.5.12

3471

Nürnberg

4.5.12

3160

Essen

18.4.12

3328

Essen

26.4.12

3368

Essen

29.4.12

3420

Essen

1.5.12

3501

Essen

6.5.12

Siehe auch

Kurzübersichtskarte: SVERWEIS –

-und Verweisfunktionen (Referenz)

Verwenden des Matrix-Arguments in einer SVERWEIS-Funktion

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×