Modelle von Windows XP-Oberflächenelementen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Mit der Vorlage Windows XP-Benutzeroberfläche können Sie Modelle von Benutzeroberflächen mit Shapes erstellen, die gemäß den Microsoft Windows XP-Richtlinien entworfen wurden. Die Shapes enthalten die Elemente, die häufig in Oberflächen verwendet werden, z.B. ein leeres Formular als Basis eines Anwendungsfensters, Seiten für Assistenten, Symbolleisten- und Menü-Shapes sowie Steuerelement-Shapes.

Sie können diese Formen verwenden, alle Elemente aus einem Modell einer komplexen Anwendungsfensters oder ein Dialogfeld mit Registerkarten an ein einfaches Meldungsfeld oder eine einzelne Schaltfläche vornehmen.

Was möchten Sie tun?

Erstellen eines einzelnen Dialogfelds

Erstellen eines Dialogfelds mit Registerkarten

Erstellen eines Anwendungsfensters

Erstellen von Menüs und Symbolleisten

Erstellen eines einzelnen Dialogfelds

  1. Ziehen Sie aus Fenster und Dialogfelder ein Leeres Formular-Shape auf das Zeichenblatt.

  2. Markieren Sie das Shape, und geben Sie einen Titel für das Dialogfeld ein.

  3. Ziehen Sie ein Fenster-Schaltflächen-Shape auf die rechte Seite der Titelleiste, und wählen Sie den Schaltflächentyp aus. Normalerweise sind die Schaltflächen Hilfe und Schließen von links nach rechts angeordnet.

  4. Fügen Sie Befehlsschaltflächen zur unteren rechten Ecke des Leeres Formular-Shapes hinzu, z. B. OK, Abbrechen und Übernehmen.

    how

    1. Ziehen Sie Befehlsschaltfläche-Shapes aus Standardsteuerelemente an den unteren rechten Rand des Leeres Formular-Shapes.

    2. Markieren Sie die jeweilige Schaltfläche, und geben Sie den Namen des Steuerelements ein.

  5. Ziehen Sie die gewünschten Steuerelemente auf das Leeres Formular-Shape. Klicken Sie mit der rechten Maustaste auf die Shapes, um die gewünschten Optionen auszuwählen.

    Wenn Sie für ein bestimmtes Steuerelement-Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste auf das Shape, und klicken Sie auf Hilfe.

    Wenn Sie Text mit dem Text-Tool auf dem Leeres Formular-Shape erstellen, formatieren Sie den Text mit der Schriftart Tahoma und der Größe 8 Pt.

  6. Gruppieren Sie Befehle in logischen Gruppen.

  7. Ziehen Sie Gruppenfeld-Shapes und Gruppenlinie-Shapes auf das Leeres Formular-Shape, um die Gruppen visuell zu trennen.

    Richten Sie die Steuerelemente mit Führungslinien aus.

    Das Dialogfeld Drucken (Menü Datei) ist ein gutes Beispiel für ein Dialogfeld mit vielen der häufig verwendeten Elemente.

Seitenanfang

Erstellen eines Dialogfelds mit Registerkarten

  1. Ziehen Sie aus Fenster und Dialogfelder ein Leeres Formular-Shape auf das Zeichenblatt.

  2. Markieren Sie das Shape, und geben Sie einen Titel für das Dialogfeld ein.

  3. Ziehen Sie ein Fenster-Schaltflächenshape auf die rechte Seite der Titelleiste, und wählen Sie den Schaltflächentyp aus. Normalerweise sind die Schaltflächen Hilfe und Schließen vorhanden und von links nach rechts angeordnet.

  4. Fügen Sie der unteren rechten Ecke des Leeres Formular-Shapes Befehlsschaltflächen hinzu, z. B. OK, Abbrechen und Übernehmen.

    how

    1. Ziehen Sie Befehlsschaltfläche-Shapes aus Standardsteuerelemente an den unteren rechten Rand des Leeres Formular-Shapes.

    2. Markieren Sie die jeweilige Schaltfläche, und geben Sie den Namen des Steuerelements ein.

  5. Ziehen Sie ein Register (Hauptteil)-Shape auf das Leeres Formular-Shape, und ändern Sie die Größe so, dass es in das Formular passt und außerdem Platz für Registerkarten lässt.

  6. Ziehen Sie ein Register (Registerkarten)-Shape auf das Zeichenblatt, und kleben Sie es an den oberen Rand des Register (Hauptteil)-Shapes.

  7. Markieren Sie das Register (Registerkarten)-Shape, und geben Sie einen Namen für die Registerkarte ein.

  8. Wiederholen Sie Schritte 6 und 7 für jede Registerkarte, und kleben Sie die Registerkarten dabei aneinander und an das Register (Hauptteil)-Shape.

  9. Klicken Sie mit der rechten Maustaste auf die Registerkarte, die als vordere Registerkarte angezeigt werden soll, klicken Sie auf Vordergrundregisterkarte, und legen Sie für die anderen Hintergrundregisterkarte fest.

  10. Ziehen Sie die gewünschten Steuerelemente auf das Leeres Formular-Shape. Klicken Sie mit der rechten Maustaste auf die Shapes, um die gewünschten Optionen auszuwählen.

    Wenn Sie für ein bestimmtes Steuerelement-Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste auf das Shape, und klicken Sie auf Hilfe.

    Wenn Sie Text mit dem Text-Tool auf dem Leeres Formular-Shape erstellen, formatieren Sie den Text mit der Schriftart Tahoma und der Größe 8 Pt.

  11. Gruppieren Sie Befehle in logischen Gruppen.

  12. Ziehen Sie Gruppenfeld-Shapes und Gruppenlinie-Shapes auf das Leeres Formular-Shape, um die Gruppen visuell zu trennen.

    Richten Sie die Steuerelemente mit Führungslinien aus.

    Das Dialogfeld Seite einrichten (Menü Datei) ist ein gutes Beispiel für ein Dialogfeld mit vielen der häufig verwendeten Elemente.

Seitenanfang

Erstellen eines Anwendungsfensters

  1. Ziehen Sie aus Fenster und Dialogfelder ein Leeres Formular-Shape auf das Zeichenblatt.

  2. Markieren Sie das Shape, und geben Sie einen Titel für das Anwendungsfenster ein.

  3. Wenn Sie ein Symbol links neben dem Text in der Titelleiste einfügen möchten, klicken Sie mit der rechten Maustaste auf das Leeres Formular-Shape, und aktivieren Sie das Kontrollkästchen Platz für Symbol.

  4. Ziehen Sie ein Fenster-Schaltflächenshape auf die rechte Seite der Titelleiste, und wählen Sie den Schaltflächentyp aus. Normalerweise sind drei Schaltflächen vorhanden: eine Schaltfläche Minimieren, eine Schaltfläche Maximieren oder Wiederherstellen und eine Schaltfläche Schließen, die von links nach rechts angeordnet sind.

  5. Ziehen Sie aus Symbolleisten und Menüs ein Menüleiste-Shape auf das Leeres Formular-Shape, kleben Sie es unten an die Titelleiste, und fügen Sie dann Menüeinträge hinzu.

    how

    1. Ziehen Sie ein Oberster Menüeintrag-Shape auf das Zeichenblatt, und kleben Sie es an den linken Rand des Menüleiste-Shapes.

      Sie können links neben dem ersten Menüeintrag ein Symbol platzieren.

    2. Markieren Sie das Shape, und geben Sie einen Namen ein. Wenn der Menüeintrag über eine Tastenkombination verfügt, unterstreichen Sie den entsprechenden Buchstaben.

    3. Wiederholen Sie bei Bedarf Schritte 1 und 2.

      Wenn Sie für ein Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Hilfe.

      Wenn Sie die Verbindungspunkte Verbindungspunkt (blaues X) ausblenden möchten, klicken Sie im Menü Ansicht auf Verbindungspunkte.

      Die Einträge in einer Spalte sollten alle so breit sein wie der breiteste Eintrag.

    Wenn Sie die Ziehpunkte am linken Rand der Menüleiste anzeigen möchten, klicken Sie mit der rechten Maustaste auf das Shape, und deaktivieren Sie die das Kontrollkästchen Menüleiste sperren.

  6. Ziehen Sie aus Symbolleisten und Menüs ein Symbolleiste-Shape auf das Leeres Formular-Shape, kleben Sie es unten an die Menüleiste, und fügen Sie dann Symbolleisten-Schaltflächen hinzu.

    how

    1. Ziehen Sie eines der Symbolleisten-Schaltflächen-Shapes auf das Zeichenblatt, und kleben Sie es an den linken Rand des Symbolleiste-Shapes.

    2. Wählen Sie im Dialogfeld Shape-Daten den gewünschten Schaltflächentyp aus. Wenn Sie die Schaltfläche später ändern möchten, klicken Sie mit der rechten Maustaste auf das Shape, und klicken Sie auf Schaltflächentyp einrichten, um das Dialogfeld Shape-Daten erneut zu öffnen.

    3. Ziehen Sie bei Bedarf weitere Symbolleisten-Schaltflächen- und Schaltflächentrennzeichen-Shapes auf das Zeichenblatt, und kleben Sie diese aneinander.

      Wenn Sie für ein Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Hilfe.

      Wenn Sie die Verbindungspunkte Verbindungspunkt (blaues X) ausblenden möchten, klicken Sie im Menü Ansicht auf Verbindungspunkte.

    Wenn Sie die Ziehpunkte am linken Rand der Symbolleiste anzeigen möchten, klicken Sie mit der rechten Maustaste auf das Shape, und deaktivieren Sie die das Kontrollkästchen Symbolleiste sperren.

  7. Ziehen Sie bei Bedarf horizontale und vertikale Bildlaufleisten aus Standardsteuerelemente an den rechten und den unteren Rand des Leeres Formular-Shapes.

  8. Klicken Sie mit der rechten Maustaste auf die Bildlaufleisten, und wählen Sie Bildgröße einstellen aus, um die Größe des Bildlaufs für das Fenster anzugeben.

    Verkleinern Sie die Bildgröße, um anzugeben, dass nur ein kleiner Teil des Dokuments angezeigt wird. Vergrößern Sie die Bildgröße, um anzugeben, dass der größte Teil des Dokuments angezeigt wird.

  9. Ziehen Sie ein Statusleiste-Shape an den unteren Rand des Anwendungsfensters, und formatieren Sie dieses entsprechend.

    how

    1. Ziehen Sie ein Statusleistentrenn-Shape auf das Zeichenblatt, und kleben Sie es an den Steuerpunkt Steuerpunkt des Statusleiste-Shapes.

      Steuerpunkte bieten eine Stelle, an der ein Statusleistentrenn-Shape an ein Statusleiste-Shape oder an ein anderes Statusleistentrenn-Shape geklebt werden kann.

      Wenn das Statusleistentrenn-Shape nicht angezeigt wird, nachdem Sie es an ein Statusleiste-Shape geklebt haben, markieren Sie das Statusleiste-Shape, zeigen Sie im Menü Shape auf Reihenfolge, und klicken Sie anschließend auf Eine Ebene nach hinten.

    2. Ziehen Sie ein Fensterziehpunkt-Shape an den rechten Rand der Statusleiste, um anzuzeigen, dass die Größe des Fensters gegenwärtig geändert werden kann.

Seitenanfang

Erstellen von Menüs und Symbolleisten

Zum Erstellen einfacher Menüs, Dropdownmenüs und Symbolleisten können Sie die Windows XP-Shapes verwenden.

Erstellen eines Menüs

  1. Ziehen Sie ein Menüleiste-Shape aus Symbolleisten und Menüs auf das Zeichenblatt. Wenn Sie die Ziehpunkte am linken Rand der Menüleiste anzeigen möchten, klicken Sie mit der rechten Maustaste auf das Shape, und deaktivieren Sie die das Kontrollkästchen Menüleiste sperren.

  2. Ziehen Sie ein Oberster Menüeintrag-Shape auf das Zeichenblatt, und kleben Sie es an den linken Rand des Menüleiste-Shapes.

    Tipp : Es empfiehlt sich möglicherweise, links neben dem ersten Menüeintrag ein Symbol zu platzieren.

  3. Markieren Sie das Shape, und geben Sie einen Namen ein. Wenn der Menüeintrag über eine Tastenkombination verfügt, unterstreichen Sie den entsprechenden Buchstaben.

  4. Wiederholen Sie bei Bedarf Schritte 2 und 3.

    Wenn Sie für ein Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Hilfe.

    Wenn Sie die Verbindungspunkte Verbindungspunkt (blaues X) ausblenden möchten, klicken Sie im Menü Ansicht auf Verbindungspunkte.

    Die Einträge in einer Spalte sollten alle so breit sein wie der breiteste Eintrag.

Erstellen eines Dropdownmenüs

  1. Ziehen Sie ein Oberster Menüeintrag-Shape auf das Zeichenblatt.

  2. Markieren Sie das Shape, und geben Sie einen Namen ein. Wenn der Menüeintrag über eine Tastenkombination verfügt, unterstreichen Sie den entsprechenden Buchstaben.

  3. Ziehen Sie ein Eintrag Dropdownmenü-Shape auf das Zeichenblatt, kleben Sie es unten an das Oberster Menüeintrag-Shape, und geben Sie einen Namen ein.

  4. Wiederholen Sie Schritt 3 für alle Einträge des Dropdownmenüs in der Spalte.

  5. Legen Sie die Breite aller Eintrag Dropdownmenü-Shapes auf die Breite des breitesten Eintrags fest.

  6. Klicken Sie mit der rechten Maustaste auf jedes Eintrag Dropdownmenü-Shape, klicken Sie auf Menüeintrageigenschaften, und wählen Sie dann die entsprechenden Optionen aus.

    Wenn Sie für ein Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Hilfe.

    Wenn Sie die Verbindungspunkte Verbindungspunkt (blaues X) ausblenden möchten, klicken Sie im Menü Ansicht auf Verbindungspunkte.

Erstellen einer Symbolleiste

  1. Ziehen Sie ein Symbolleiste-Shape aus Symbolleisten und Menüs auf das Zeichenblatt. Wenn Sie die Ziehpunkte am linken Rand der Symbolleiste anzeigen möchten, klicken Sie mit der rechten Maustaste auf das Shape, und deaktivieren Sie die das Kontrollkästchen Symbolleiste sperren.

  2. Ziehen Sie ein Symbolleisten-Schaltfläche-Shape auf das Zeichenblatt, und kleben Sie es an den linken Rand des Symbolleiste-Shapes.

  3. Wählen Sie im Dialogfeld Shape-Daten den gewünschten Schaltflächentyp aus. Wenn Sie die Schaltfläche später ändern möchten, klicken Sie mit der rechten Maustaste auf das Shape, und klicken Sie auf Schaltflächentyp einrichten, um das Dialogfeld Shape-Daten erneut zu öffnen.

  4. Ziehen Sie bei Bedarf weitere Symbolleisten-Schaltfläche- und Schaltflächentrennzeichen-Shapes auf das Zeichenblatt, und kleben Sie diese aneinander.

    Wenn Sie für ein Shape Hilfe benötigen, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Hilfe.

    Wenn Sie die Verbindungspunkte Verbindungspunkt (blaues X) ausblenden möchten, klicken Sie im Menü Ansicht auf Verbindungspunkte.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×