Mit PivotTable-Berichten arbeiten

zurück | weiter

Sie haben einen einfachen PivotTable-Bericht erstellt. Sie können die Felder verschieben und Ihre Daten unter so vielen Perspektiven betrachten wie sich logische Kombinationen durch die Quelldaten ergeben. Aber es könnte sein, dass Sie den PivotTable-Bericht noch etwas weiter anpassen möchten. Die folgenden Abschnitte enthalten einen Überblick über die Möglichkeiten sowie Tipps zum Anpassen der Feld- und Tabelleneinstellungen.

Feldeinstellungen

Sie können das Layout Ihrer Tabelle umorganisieren, Feldnamen anpassen, Teilergebnisse verwalten, Formeln auswählen, mit denen Sie die Werte-Felder bilden oder zusammenfassen, und Ergebnisse der Felder sortieren oder filtern. Alle diese Aktionen lassen sich über das Dialogfeld Feldeinstellungen für den entsprechenden Feldtyp ausführen, aber eigentlich benötigen Sie meistens gar kein Dialogfeld. Über die kontextbezogenen Registerkarten der PivotTable-Tools und die Optionen des Kontextmenüs, das Sie durch Klicken mit der rechten Maustaste auf ein Feld in der Tabelle öffnen, können Sie eine große Zahl der Feldeinstellungen anpassen, einige mit nur einem Klick. Es folgen Beschreibungen, wie Sie einige der nützlichsten Feldanpassungen durchführen können:

  • Auf der Registerkarte PivotTable-Tools/Entwurf in der GruppeLayout (siehe Abbildung 16.12) können Sie über Berichtslayout das Layout in ein Kurzformat, in ein Gliederungsformat und in ein Tabellenformat ändern oder leere Zeilen nach jeder Gruppe einer Zeilenbeschriftung für ein leichter lesbares Layout einfügen.

    .

    Abbildung 16.12: Die Gruppe Layout auf der Registerkarte PivotTable-Tools/Entwurf

    Die Optionen für das Layout des Berichts betreffen alle Ebenen der Zeilenbeschriftungen; daraus folgert, dass Sie nur eine Layouteinstellung pro Tabelle einrichten können. Das Hinzufügen von Leerzeilen wird unterhalb einer jeden Zeilenfeldgruppierung durchgeführt.

  • Die Plus- und Minusschaltflächen für die Erweiterung bzw. Zusammenfassung sind bei jedem Zeilen- oder Spaltenfeld standardmäßig eingeblendet, die ein Feld auf einer niedrigeren Ebene unter sich haben. Zum Ausblenden dieser Schaltflächen klicken Sie auf der Registerkarte PivotTable-Tools/Optionen in der Gruppe Einblenden/Ausblenden aufSchaltflächen +/-.

  • Um die Teilergebnisse für alle Zeilen- oder Spaltenfelder, die ein Feld auf einer niedrigeren Ebene unter sich haben, auszublenden, klicken Sie mit der rechten Maustaste auf irgendein Element des Feldes und klicken dann auf Teilergebnis <Feldname>. Um alle Teilergebnisse in der Tabelle auf einmal auszublenden, benutzen Sie die Schaltfläche Teilergebnisse in der GruppeLayout auf der Registerkarte PivotTable-Tools/Entwurf. Lesen Sie mehr über das Ein- und Ausblenden der Teilergebnisse im Kasten »Ich werde die Teilergebnisse in einem PivotTable-Zeilen- bzw. -Spaltenfeld nicht los« weiter hinten in diesem Abschnitt.

  • Um den Namen eines Feldes in der Tabelle zu ändern, klicken Sie auf irgendein Element dieses Feldes in der Tabelle und editieren dann auf der RegisterkarteitPivotTable-Tools/Optionen in der GruppeAktives Feld den Namen und drücken anschließend die (Eingabe)-Taste. Dieser Vorgang wirkt sich nicht auf den Namen des Feldes in den Quelldaten aus.

Hinweis Beginn

Benutzen Sie die Optionen zum Erweitern und Reduzieren in der Gruppe Aktives Feld, umalle sichtbaren Elemente des aktiven Feldes ein- bzw. auszublenden. Um einen bestimmten Eintrag ein- oder auszublenden, benutzen Sie die Plus- bzw. Minusschaltfläche. Sie können auch jeden Eintrag oder das gesamte Feld über das Kontextmenü ein- oder ausblenden. Sie erhalten das Kontextmenü durch Klicken mit der rechten Maustaste auf irgendeinen Eintrag des Feldes.

Hinweis Ende

  • Wie bereits erwähnt, summiert Excel die Werte, wenn es das dem Werte-Bereich hinzugefügte Feld als numerisch erkennt, ansonsten werden die Werte gezählt. Diese Funktion können Sie mit zusätzlicher Flexibilität im Bedarfsfall ändern. Wie bei den meisten Funktionen bekannt, klicken Sie mit der rechten Maustaste auf ein Element des Werte-Feldes, zeigen im Kontextmenü auf Daten zusammenfassen nach und klicken dann auf eine der sechs angebotenen Funktionen oder auf Weitere Optionen, um zum DialogfeldWertfeldeinstellungen zu gelangen.

  • Um das Zahlenformat für alle Elemente des Werte-Feldes zu ändern, klicken Sie mit der rechten Maustaste auf irgendein Element und wählen Zahlenformat.

Hinweis Beginn

Sowohl für die Beschriftungs- als auch für die Werte-Felder enthält das zugehörige Kontextmenü die Option Zellen formatieren . Anders als bei den Zahlenformaten für Werte-Felder wirken sich die Zellformatierungen nur auf die markierten Zellen aus, gerade so, als wenn Sie Zellen im normalen Arbeitsblatt markieren. Die Formatierungen, die Sie über das Dialogfeld Zellen formatieren zuweisen, sind direkte Formatierungen und werden bei der Zuweisung einer PivotTable-Formatvorlage nicht entfernt. Abhängig von den Einstellungen für Ihren PivotTable-Bericht werden die Zellformatierungen bei der Aktualisierung des PivotTable-Berichts nicht beibehalten. Um die Zellformatierung bei der Aktualisierung zu erhalten, aktivieren Sie im Dialogfeld PivotTable-Optionen auf der Registerkarte Layout & Format das Kontrollkästchen Zellformatierung bei Aktualisierung beibehalten.

Hinweis Ende

  • Falls Sie einen Teil der Daten aus der PivotTable herausziehen möchten, klicken Sie mit der rechten Maustaste auf ein Werte-Feld und wählen Details anzeigen.Excel erstellt daraufhin eine Tabelle in einem neuen Arbeitsblatt, die alle Details aus den Quelldaten des entsprechenden Teils der PivotTable enthält. Sie können z.B. mit der rechten Maustaste auf den Wert neben Geschäftsentwicklung klicken und dann Details anzeigen wählen (siehe Abbildung 16.13).

.

Abbildung 16.13: Kontextmenü zu einem Werte-Feld

Excel erstellt dann die in Abbildung 16.14 gezeigte Tabelle in einem neuen Arbeitsblatt.

.

Abbildung 16.14: Auszug aus der PivotTable in einem neuen Arbeitsblatt

Hinweis Beginn

Falls die OptionDetails anzeigen für Ihre Tabelle abgeblendet dargestellt ist, klicken Sie im Dialogfeld PivotTable-Optionen auf der Registerkarte Daten auf 'Details anzeigen' aktivieren.

Hinweis Ende

Kasten Beginn

Ich werde die Teilergebnisse in einem PivotTable-Zeilen- bzw. -Spaltenfeld nicht los

Wenn Sie die Anzeige der Teilergebnisse für ein Feld ausschalten und es scheint, als ob nichts passieren würde, dann unterliegen Sie einem verbreiteten Irrtum. Sie müssen das Teilergebnis bei dem Feld ausschalten, das ein Teilergebnis anzeigt, und nicht bei dem Feld, das einen Wert für die Berechnung des Teilergebnisses beisteuert.

Angenommen, Sie haben drei Zeilenfelder wie in der PivotTable in Abbildung 16.15.

.

Abbildung 16.15: Ausschnitt der PivotTable

Wenn Sie die Teilergebnisse, die in den Zeilen bei jedem Namen erscheinen, nicht mehr angezeigt bekommen möchten, dann müssen Sie die Anzeige der Teilergebnisse für den Namen ausschalten. Obwohl diese Teilergebnisse die Werte aus den Seminaren zusammenfassen, sind es dennoch nicht die Teilergebnisse der Seminare.

Bei Zeilen- und Spaltenfeldern ist die Anzeige der Teilergebnisse standardmäßig eingeschaltet. Aber es werden nur die Teilergebnisse angezeigt, die Felder einer darunterliegenden Ebene enthalten, deren Werte zu einem Teilergebnis zusammenfassbar sind.

Sie können die Anzeige der Teilergebnisse jederzeit, für jedes einzelne Feld, nach dem Klicken mit der rechten Maustaste auf das jeweilige Feld über die Optionen im Kontextmenü ausschalten. Klicken Sie einfach aufTeilergebnis <Feldname>. Sollte dabei nichts passieren, vergewissern Sie sich, dass Sie das richtige Feld ausgewählt haben. Um alle Teilergebnisse auf einmal im gesamten PivotTable-Bericht auszuschalten, klicken Sie auf der RegisterkartePivotTable-Tools/Entwurf auf Teilergebnisseund dann aufTeilergebnisse nicht anzeigen.

Kasten Ende

Das Feldeinstellungen-Dialogfeld verwenden

Für die Felder in den Bereichen Zeilenbeschriftungen, Spaltenbeschriftungen und Berichtsfilter benötigen Sie das Feldeinstellungen-Dialogfeld für zwei Situationen: zum Anpassen der Funktion bei der Anwendung der Teilergebnisse und zum Einfügen von Seitenumbrüchen zwischen Elementen beim Ausdruck.

Bei Feldern im Bereich Werteöffnen Sie das Dialogfeld Wertfeldeinstellungen, um über das Kontextmenü hinaus weitere Funktionen verfügbar zu haben. Dies ist der einzige Ort, um auf die Optionen Werte anzeigen als zugreifen zu können. Diese Optionen ermöglichen es Ihnen, ein Werte-Feld in verschiedensten Berechnungsarten darzustellen. Hierdurch erhalten Sie die Möglichkeit, die begrenzte Anzahl der benutzbaren Funktionen für die Summierung der Werte eines Feldes flexibel zu erweitern. Sie können z.B. festlegen, dass die Werte als prozentuale Differenz von einem bestimmten anderen Feld angezeigt werden sollen (siehe Abbildung 16.16).

.

Abbildung 16.16: Das Dialogfeld Wertfeldeinstellungen mit geöffneter Registerkarte Werte anzeigen als

Berechnete Felder erstellen

Zusätzlich zu den Feldern in Ihren Quelldaten können Sie ein Feld hinzufügen, das auf der Basis der Werte in einem oder mehreren Feldern Ihrer Quelldaten berechnet wird. Berechnete Felder können nur im Bereich Werte des PivotTable-Berichts eingesetzt werden.

  • Um ein berechnetes Feld zu erstellen, klicken Sie auf der Registerkarte PivotTable-Tools/Optionen in der Gruppe Tools auf Formeln und anschließend auf Berechnetes Feld. Im Dialogfeld Berechnetes Feld einfügen (siehe Abbildung 16.17) geben Sie dem Feld einen Namen und erstellen die Formel aus den in der Liste enthaltenen Feldern. Klicken Sie auf die SchaltflächeHinzufügen, um das neue Feld in die Liste der Felder in der PivotTable-Feldliste aufzunehmen. Das Feld wird dem Bereich Wertein Ihrer PivotTable hinzugefügt. Sie können es wie jedes andere Feld auch wieder aus der PivotTable entfernen.

    .

    Abbildung 16.17: Das Dialogfeld Berechnetes Feld einfügen

  • Um ein berechnetes Feld wieder aus der Liste der Felder zu löschen oder das Feld zu modifizieren, benutzen Sie das Dialogfeld Berechnetes Feld einfügen. Nachdem Sie dieses Dialogfeld geöffnet haben, markieren Sie das zu löschende Feld in der Dropdownliste Name und klicken dann auf Löschen. Nach dem Auswählen des Feldes in der Dropdownliste können Sie die Formel des berechneten Feldes auch bearbeiten.

Tabellenoptionen

Mittels der entsprechenden Option auf der Registerkarte PivotTable-Tools/Optionen können Sie den PivotTable-Bericht umbenennen sowie über die RegisterkartePivotTable-Tools/Entwurf die Gesamtergebnisse für Zeilen und Spalten hinzufügen und wieder entfernen. Sie können auch ein einzelnes Gesamtergebnis einer Zeile oder Spalte über das Kontextmenü zu einer Zelle, die ein Gesamtergebnis enthält, entfernen.

Wenn Sie sich das Dialogfeld PivotTable-Optionen genauer ansehen, zeigt sich, dass Sie damit eine höhere Flexibilität besitzen. Um auf dieses Dialogfeld zugreifen zu können, klicken Sie auf der Registerkarte PivotTable-Tools/Optionen in der Gruppe PivotTable auf Optionenoder Sie klicken mit der rechten Maustaste in den PivotTable-Bericht und klicken dann auf PivotTable-Optionen.

Ich empfehle Ihnen, sich das Dialogfeld etwas genauer anzuschauen, bevor Sie das erste Mal einen PivotTable-Bericht erstellen, um sich einmal die vielen Details, die hier zur Verfügung stehen, zu vergegenwärtigen. Zusätzlich zu den bereits erwähnten PivotTable-Einstellungen möchte ich Ihnen einige meiner Favoriten nennen:

  • Auf der Registerkarte Layout & Format können Sie Text angeben, der bei leeren Zellen oder bei Fehlerwerten eingesetzt werden soll. Außerdem können Sie die Weite des Einzugs der nachfolgenden Zeilenbeschriftungen bestimmen, wenn Sie das Berichtslayout auf Kurzformat eingestellt haben.

  • Auf der Registerkarte Summen & Filter können Sie mehrere Filter pro Feld zulassen.

  • Auf der Registerkarte Anzeige können Sie die Reihenfolge der Felder in der Feldliste im AufgabenbereichPivotTable-Feldliste festlegen.

zurück | weiter

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×