Lernprogramm: Erstellen von außergewöhnlichen Power View-Berichten – Teil 1

Kurzfassung:    Am Ende des vorherigen Lernprogramms, Einbinden von Internetdaten und Festlegen der Standardeinstellungen von Power View-Berichten, enthielt Ihre Excel-Arbeitsmappe ein vollständiges Datenmodell und war bereit zum Erstellen von Berichten. In diesem Lernprogramm erstellen Sie drei verschiedene Power View-Berichte, erhalten in diesem Zusammenhang einige Tipps und erfahren die Schritte, die Sie zum Erstellen vieler weiterer Berichte verwenden können.

Dieses Lernprogramm enthält die folgenden Abschnitte:

Erstellen interaktiver Kartendiagramme

Erstellen interaktiver Kreisdiagramme

Erstellen interaktiver Balken- und Säulendiagramme

Wissensstand und Prüfung

Am Ende dieses Lernprogramms gibt es eine Prüfung, mit der Sie Ihren Wissensstand testen können.

In dieser Lernprogrammreihe werden Daten verwendet, mit denen olympische Medaillen, Gastgeberländer und verschiedene olympische Sportwettkämpfe angegeben werden. Zu den Lernprogrammen dieser Reihe gehören die folgenden:

  1. Importieren von Daten in Excel 2013 und Erstellen eines Datenmodells

  2. Erweitern von Datenmodellbeziehungen mithilfe von Excel 2013, Power Pivot und DAX

  3. Erstellen von kartenbasierten Power View-Berichten

  4. Einbinden von Internetdaten und Festlegen der Standardeinstellungen von Power View-Berichten

  5. Erstellen von außergewöhnlichen Power View-Berichten – Teil 1

  6. Erstellen von außergewöhnlichen Power View-Berichten – Teil 2

Es empfiehlt sich, die Lernprogramme der Reihe nach durchzuarbeiten.

In diesen Lernprogrammen wird Excel 2013 mit aktiviertem Power Pivot verwendet. Weitere Informationen zu Excel 2013 finden Sie unter Excel 2013 – Schnellstarthandbuch. Eine Anleitung zum Aktivieren von Power Pivot finden Sie unter PowerPivot-Add-In.

Erstellen interaktiver Kartendiagramme

Das Erstellen von Berichten in Power View macht Spaß und ist einfach. Darüber hinaus sind die Berichte, die Sie erstellen, interaktiv, was es den Betrachtern des Berichts erlaubt, auf Datenelemente zu klicken, um so neue Erkenntnisse aus Ihren Daten zu gewinnen.

In diesem Abschnitt erstellen Sie ein neues Kartendiagramm und erweitern es. Dann erstellen Sie Balken- und Kreisdiagramme, die die Daten auf interessante Weise darstellen. Im Verlauf dieser Aktionen fügen Sie dem Datenmodell einige neue Berechnungen hinzu, damit die Berichte Ihren Vorstellungen entsprechend aussehen. Fangen wir also an.

Erstellen eines interaktiven Kartendiagramms

In einem vorherigen Lernprogramm haben Sie einen einfachen Kartenbericht erstellt, um die Gastgeberstädte für verschiedene Olympiaden darzustellen. Sie entscheiden, dass in diesem Datenmodell weitere interessante Informationen verfügbar sind und möchten diese auf verschiedene Weisen darstellen. Zu Beginn erstellen Sie einen neuen Power View-Kartenbericht, um die Anzahl der von jedem Land bzw. jeder Region gewonnenen Medaillen, den Medaillentyp und schließlich die Ergebnisse nach Jahreszeit ("Saison") darzustellen.

  1. Wählen Sie in Excel das Arbeitsblatt Power View1 aus. Ihr Blatt sieht aus wie in der folgenden Abbildung, basierend auf der in vorherigen Lernprogrammen abgeschlossenen Arbeit und abhängig davon, wo Sie auf den Zeichenbereich klicken.

    Power View-Bericht in Arbeitsmappe

    Erstellen Sie einen neuen Power View-Bericht, indem Sie im Menüband POWER VIEW > Einfügen > Power View auswählen. Ein leeres Power View-Berichtblatt wird erstellt. Benennen Sie den Bericht in Map um, indem Sie mit der rechten Maustaste auf die Registerkarte unten klicken und in dem angezeigten Menü Umbenennen auswählen.

  2. Erweitern Sie die Tabelle Medals in den Power View-Feldern, und wählen Sie "NOC_CountryRegion" aus. Wählen Sie zum Abrufen von Informationen zu Medaillen das Feld "Medals" aus. Die von Power View erstellte Tabelle sieht wie in der folgenden Abbildung aus.
    Eine neue Power View-Tabelle, basierend auf Medaillen

    Hmm – das entspricht nicht Ihren Vorstellungen. Dieser Bericht zeigt den Medaillentyp, der vom jeweiligen Land bzw. der Region gewonnen wurde an, doch Sie möchten die Anzahl der Medaillen darstellen. In einem vorherigen Lernprogramm haben Sie eine DAX-Formel verwendet, um den Prozentsatz der gewonnenen Medaillen zu bestimmen. Daher beschließen Sie, DAX zu verwenden, um die Medaillenanzahl zu berechnen.

  3. Wählen Sie in Power Pivot auf der Registerkarte Medals die Zelle unter der Spalte "Medal" aus. Wenn keine Zellen unterhalb der Spalten verfügbar sind, wird möglicherweise der Berechnungsbereich nicht angezeigt. Um den Berechnungsbereich anzuzeigen, wählen Sie Start > Ansicht > Berechnungsbereich aus. Geben Sie folgende DAX-Formel in die Zelle ein: 

    Medal Count:=COUNTA([Medal])

     Hinweis:Sie können DAX-Formeln in jeder beliebigen Zelle im Berechnungsbereich erstellen, sodass das jeweilige berechnete Feld in dieser Tabelle in Clienttools wie Power View oder PivotTables verfügbar ist. Das Auswählen der Zelle unterhalb des Felds "Medal" ist lediglich eine gute Methode, um zu verfolgen, welche Spalte davon berechnet wird.

  4. Zurück in Excel wird Ihr Datenmodell aktualisiert. Im Arbeitsblatt Map wird unter Power View-Felder jetzt das Feld "Medal Count" angezeigt. Da "Medal Count" ein berechnetes Feld ist, wird neben dem Feld ein kleines Taschenrechnersymbol angezeigt. Heben Sie bei ausgewählter Tabelle, die Sie im vorherigen Schritt erstellt haben, die Auswahl von "Medal" auf, und wählen Sie "Medal Count" aus. So ist es besser! Auf Ihrem Bildschirm wird jetzt die Anzahl der Medaillen angezeigt, die von jedem Land bzw. jeder Region gewonnen wurden, wie in der folgenden Abbildung gezeigt.

    Power View-Tabelle ändert sich in Anzahl der Medaillen

  5. Wählen Sie ENTWURF > Visualisierung wechseln > Karte aus, um die Tabelle als Karte anzuzeigen. Ändern Sie die Größe der Karte, um sie zu vergrößern. Wenn Sie auf eine der Blasen auf der Karte zeigen, werden zusätzliche Informationen angezeigt, wie in der folgenden Abbildung gezeigt. Probieren Sie es selbst.
    Auf Daten in Power View-Karten zeigen, um weitere Informationen anzuzeigen

Erstellen eines interaktiven Kreisdiagramms in einer Karte

Nachdem Sie nun die Kartenvisualisierung erstellt haben, ist es an der Zeit, das Ganze interessanter zu gestalten. In den folgenden Schritten ändern Sie die Blasen mit nur wenigen Klicks in interaktive Kreisdiagramme.

  1. Ziehen Sie in Power View aus Power View-Felder das Feld "Medal" auf das Feld "FARBE". Jetzt wird jede Blase auf der Karte zu einem Kreisdiagramm, bei dem die Größe jedes Kreissegments vom gewonnenen Medaillentyp abhängig ist. Wenn Sie die Karte auswählen, werden Navigationstools angezeigt, mit deren Hilfe Sie vergrößern oder verschieben können, wie in der folgenden Abbildung gezeigt.
    Anwenden von Farbe auf Power View-Kartenvisualisierungen

  2. Zeigen Sie auf eins der Kreisdiagramme. Die daraufhin angezeigten Informationen sind von dem Kreissegment abhängig, auf das Sie zeigen. In der folgenden Abbildung zeigen wir auf das rote Segment für Spanien (ESP), und die Visualisierung zeigt Informationen zu diesem Teil der Blase an. Beachten Sie auch, dass die Blase erweitert wird, um die Navigation in anderen Segmenten zu erleichtern.
    Weitere Informationen in Kartenvisualisierungen – einfach draufzeigen

Sie besitzen nun eine interaktive Karte, die es ermöglicht zu vergrößern und zu verkleinern sowie auf Datenelemente zu zeigen, und so weitere Informationen zu erhalten.

Beachten Sie, dass die Medaillen alphabetisch sortiert sind, was die Standardeinstellung ist. Sie möchten aber folgende Reihenfolge: Gold, Silber, Bronze. Um dies zu erreichen, müssen wir "Medal" nach einem anderen Wert sortieren.

Ändern der Sortierreihenfolge eines Felds

Zum Ändern der Standardsortierreihenfolge müssen Sie das Feld "Medal" einem anderen Feld zuordnen und dann nach dem zugeordneten Feld sortieren. Zu diesem Zeitpunkt ist kein Feld zugeordnet, doch Sie können eins erstellen. Hierzu sind nur wenige Schritte erforderlich, doch sobald Sie diese abgeschlossen haben, werden Sie sehen, wie bequem und einfach es ist, das Verhalten des Datenmodells Ihren Wünschen anzupassen.

  1. Fügen Sie in Excel ein neues Arbeitsblatt hinter Population ein. Benennen Sie das Blatt in MedalValue um. Geben Sie folgende Daten in das Arbeitsblatt "MedalValue" ein. Sie können sie auch kopieren und einfügen.

Medal

MedalValue

Gold

1

Silber

2

Bronze

3

  1. Formatieren Sie die Daten als Tabelle (in einer Zelle STRG+A drücken, dann STRG+T, um die Daten als Tabelle zu formatieren). Stellen Sie sicher, dass Sie im Fenster Tabelle erstellen die Option Tabelle hat Überschriften aktivieren. Geben Sie der Tabelle unter ENTWURF > Eigenschaften > Tabellenname den Namen MedalValue.

  2. Wählen Sie, immer noch in Excel, Power Pivot > Tabellen > Zu Datenmodell hinzufügen aus, um die Tabelle zum Datenmodell hinzuzufügen.

  3. Wählen Sie in Power Pivot "Diagrammsicht" aus. Verschieben Sie die Tabelle MedalValue neben die Tabelle Medals. Es ist kein Problem, wenn Sie andere Tabellen beiseite schieben, um etwas mehr Platz zu bekommen. Ziehen Sie in der Tabelle Medals das Feld "Medal" auf das Feld "Medal" in der Tabelle MedalValue, und erstellen Sie eine Beziehung. Wählen Sie die Linie zwischen diesen Tabellen aus, um die von Ihnen erstellte Beziehung hervorzuheben. Ihre Diagrammsicht sieht wie in der folgenden Abbildung aus.
    Erstellen einer Beziehung zwischen 'Medals' und 'MedalValue'

  4. Wählen Sie in Power Pivot in der Datenansicht die Tabelle Medals aus. Scrollen Sie nach rechts, und wählen Sie die Spalte mit dem Titel Spalte hinzufügen aus. Geben Sie in der Bearbeitungsleiste folgende DAX-Formel ein: 

    =RELATED(MedalValue[MedalValue])

     Die RELATED-Funktion gibt einen Wert aus einer anderen Tabelle im Datenmodell zurück. Sie können nur mit Spalten sortieren, die sich in derselben Tabelle befinden, weshalb sich die "MedalValue"-Werte in der Tabelle Medals befinden müssen. Die RELATED-Funktion erlaubt es uns, ein MedalValue-Feld in die Tabelle Medals abzurufen. Benennen Sie die Spalte in Medal Value um.

  5. Jetzt müssen wir angeben, wie Power View (und andere Clienttools) das Feld "Medal" sortieren sollen. Wählen Sie zuerst die Spalte "Medal" aus, und wählen Sie dann Start > Sortieren und Filtern > Nach Spalte sortieren aus. Wählen Sie in dem angezeigten Fenster "Medal Value" als die Spalte aus, nach der "Medal" sortiert werden soll, wie in der folgenden Abbildung gezeigt.

    Fenster 'Nach Spalte sortieren'

  6. Zurück in Excel wird die neue Sortierreihenfolge automatisch in der zuvor erstellten Kartenvisualisierung übernommen, wie in der folgenden Abbildung gezeigt.

    Die Kartenvisualisierung in der von Ihnen gewünschten Sortierung

Filtern von Visualisierungen mithilfe eines Datenschnitts

Nachdem Sie nun eine Kartenvisualisierung olympischer Ereignisse haben, können Sie die Ergebnisse nach Jahreszeit filtern. Dies lässt sich einfach mit Datenschnitten bewerkstelligen.

  1. Ziehen Sie in Power View "Season" aus der Tabelle Medals in Power View-Felder auf den Berichtzeichenbereich. Es wird eine Tabelle mit den "Season"-Feldern erstellt. Die Tabelle wird Ihre Karte wahrscheinlich überlappen, weshalb Sie die Größe der Karte ändern und die Tabelle "Season" neben die Karte verschieben.

  2. Wählen Sie bei ausgewählter Tabelle "Season" im Menüband den Befehl ENTWURF > Slicer > Slicer. Die Karte kann jetzt mithilfe des "Season"-Datenschnitts gefiltert werden. Probieren Sie es aus. Klicken Sie auf dem Datenschnitt auf "Summer", dann auf "Winter". Beachten Sie, wie die Karte entsprechend Ihrer Auswahl sofort aktualisiert wird.

  3. Um den Datenschnitt (Slicer) zu löschen und alle Ergebnisse anzuzeigen, klicken Sie auf das Symbol Filter löschen, das oberhalb der Datenschnitttabelle angezeigt wird. Das Symbol wird nur angezeigt, wenn Sie auf die Visualisierung zeigen. Das Symbol Filter löschen sieht wie ein kleiner Radiergummi aus, wie in der folgenden Abbildung gezeigt.
    Das Symbol 'Filter löschen' in Power View

Filtern anderer Visualisierungen mithilfe der Karte

Sie können nicht nur Datenschnitte zum Filtern der Karte verwenden. Sie können auch die Karte verwenden, um andere im Bericht enthaltene Tabellen interaktiv zu filtern.

  1. Ziehen Sie in Power View aus der Tabelle Events "Sport" auf den Berichtzeichenbereich. Es wird eine Tabelle namens "Sports" erstellt. Ziehen Sie "Medal Count" aus der Tabelle Medals ebenfalls auf die Tabelle "Sports". Ihr Bericht sieht wie in der folgenden Abbildung aus.

    Hinzufügen der Tabelle 'Sports' zu Ihrem Power View-Bericht

    Hinweis: Wenn in Ihren Daten leere Einträge vorhanden sind, die Sie entfernen möchten, verwenden Sie den Bereich Filter. Beispielsweise können sie leere Einträge aus Sports entfernen. Wenn der Bereich "Filter" reduziert ist, erweitern Sie Filter, wählen Sie die Tabelle Sports aus, und klicken Sie auf den Pfeil neben "Sports", wählen Sie (Alle), um alle Einträge auszuwählen, dann (Leer), um leere Einträge aus der Visualisierung auszuschließen.

  2. Wenn Sie auf die Kreisdiagramme in der Karte klicken, Wird die Visualisierung der Tabelle "Sports" auf Basis Ihrer Auswahl und aller Datenschnitte, die ausgewählt sind, gefiltert. Nicht ausgewählte Kreisdiagramme werden abgeblendet, ebenso Segmente desselben Kreisdiagramms, die nicht ausgewählt sind. Klicken Sie beispielsweise im Datenschnitt "Season" auf "Winter", vergrößern Sie die Ansicht, und klicken Sie auf den orangefarbenen Teil des Kreisdiagramms von Finnland – die Tabelle "Sports" wird automatisch und sofort angepasst. Finnland hat 95 Silbermedaillen gewonnen, davon 11 beim Biathlon, 18 beim Eishockey usw. In der folgenden Abbildung werden die Ergebnisse dargestellt.

    Datenschnitte, Tabellen und Karten sind in Power View interaktiv

Erstellen eines interaktiven Balkendiagramms

Aber Moment, es gibt noch mehr. Es könnte interessant sein, die Verteilung von Medaillen in der Kartenvisualisierung auf Grundlage der Tabellenvisualisierung "Sport" darzustellen. Allerdings möchten wir statt Zahlen ein Balkendiagramm anzeigen.

  1. Wählen Sie die Tabellenvisualisierung "Sport". Wählen Sie im Menüband den Befehl ENTWURF > Visualisierung wechseln > Balkendiagramm > Gruppierte Balken aus. Die Visualisierung von "Sport" wird zu einem Balkendiagramm.

  2. Wählen Sie auf dem Datenschnitt "Season" "Summer" aus. Beachten Sie, wie sich das Balkendiagramm "Sport" ändert, um die Sportarten darzustellen, die zu den Olympischen Sommerspielen gehören.

  3. Klicken Sie auf dem Balkendiagramm "Sport" auf den Balken neben "Fencing". Beachten Sie, dass die anderen Balken im Diagramm abgeblendet sind, aber sichtbar bleiben. Beachten Sie außerdem, dass sich in der Kartenvisualisierung die Kreisdiagramme so ändern, dass sie nur noch Medaillen zeigen, die für die im Balkendiagramm Sport getroffene Auswahl verliehen wurden. Länder oder Regionen, die beim Fechten keine Medaille gewonnen haben, sind abgeblendet. In der folgenden Abbildung sehen Sie, wie Ihr Power View-Bericht aussieht.

    Mehrere Visualisierungen in Power View sind interaktiv

  4. Klicken Sie auf einige der anderen Balken in "Sports", und sehen Sie, wie Power View die Karte und die Balkendiagramme sofort auf Grundlage Ihrer Auswahl aktualisiert.

Um diese Visualisierung als Video anzusehen, betrachten Sie das folgende Video:

Ihr Browser unterstützt kein Video. Installieren Sie Microsoft Silverlight, Adobe Flash Player oder Internet Explorer 9.

Erstellen interaktiver Kreisdiagramme

Sie haben gesehen, wie die Kartenvisualisierung Kreisdiagramme aufnehmen kann, doch Sie können interaktive Kreisdiagramme in Power View auch außerhalb von Karten erstellen. In diesem Abschnitt erfahren Sie, wie Sie interaktive Kreisdiagramme erstellen, ein Drilldown in die Daten jedes Kreisdiagramms durchführen und wie Sie Kreissegmente erstellen. Fangen wir also an.

Erstellen eines interaktiven Kreisdiagramms

  1. Wählen Sie in Excel die Registerkarte "Map" aus, und klicken Sie auf POWER VIEW > Einfügen > Power View. Eine neue Registerkarte wird erstellt. Benennen Sie die Registerkarte in Pie um.

  2. Wählen Sie in Power View-Felder in der Tabelle Medals das Feld "Year" aus. Power View summiert die Daten, weil es sich um Zahlen handelt. Um dies zu verhindern, klicken Sie auf den Pfeil neben "Year" im Bereich FELDER, und wählen Sie Anzahl (eindeutig) aus, wie in der folgenden Abbildung gezeigt.

    'Anzahl (eindeutig)' in Power View-Felder auswählen

  3. Wählen Sie als Nächstes in Events "Sport" aus. Im Berichtzeichenbereich wird eine Tabelle erstellt. Um die Visualisierung in ein Kreisdiagramm zu ändern, wählen Sie ENTWURF > Visualisierung wechseln > Anderes Diagramm > Kreis. Die folgende Abbildung stelle Ihr Kreisdiagramm dar.

    Wow – das ist ein ziemlich überfülltes Kreisdiagramm

  4. Dieses Kreisdiagramm ist zu unübersichtlich. Sie entschließen sich, die Ergebnisse nur nach Wintersportarten zu filtern. Klicken Sie zuerst auf das Pfeilsymbol im reduzierten Bereich Filter. Der Bereich Filter wird erweitert. Klicken Sie im Bereich Filter auf ANSICHT, damit alle von Ihnen gezogenen Filter auf alle Berichte in der Ansicht angewendet werden. Ziehen Sie "Season" aus der Tabelle Medals in den Bereich Filter. Wählen Sie im Filter "Season" "Winter" aus, wie in der folgenden Abbildung gezeigt.

    So ist es besser – Kreisdiagramme sollten nicht zu überfüllt sein

  5. Ebenso wie die Kartenvisualisierung ist das Kreisdiagramm interaktiv. Zeigen Sie auf ein Kreissegment im Diagramm, woraufhin Informationen angezeigt werden. Durch Klicken auf ein Kreissegment oder eine Farbe in der Legende wird die jeweilige Sportart hervorgehoben. In der folgenden Abbildung klicken Sie auf "Skating", und die dazugehörigen Legendeninformationen und das Segment des Kreisdiagramms werden hervorgehoben, während alle anderen Kreissegmente und Legendenelemente abgeblendet werden.

    Power View-Kreisdiagramme sind interaktiv – klicken Sie einfach auf ein Legendenelement

Um die Hervorhebung aufzuheben, klicken Sie erneut auf das ausgewählte Kreissegment, oder klicken Sie auf den leeren Bereich in der Visualisierung.

Das ist ein interessantes Kreisdiagramm, und es ließ sich ganz einfach erstellen. Doch Power View kann weitere interessante Kreisdiagramme erstellen, indem mehrere Ebenen von Hierarchien visualisiert werden können.

Erstellen eines Drilldown-Kreisdiagramms mithilfe von Hierarchien

Lassen Sie uns ein weiteres Kreisdiagramm erstellen und hierzu eine Hierarchie verwenden, die Sie in einem vorherigen Lernprogramm erstellt haben.

  1. Klicken Sie in Power View-Felder in der Tabelle Events auf "Sport" um dessen Auswahl aufzuheben, und klicken Sie dann auf "SDE". "SDE" ist die Hierarchie "Sport/Discipline/Event", die Sie in einem vorherigen Lernprogramm erstellt haben

  2. Das Kreisdiagramm wird ohne Änderungen angezeigt. Doppelklicken Sie auf das Segment "Skiing" des Kreisdiagramms, woraufhin Power View ein Drilldown in die nächste Ebene der Hierarchie durchführt. Jetzt basiert das Kreisdiagramm auf den Disziplinen der Skisportarten. Beachten Sie, dass in der Legende jetzt die Disziplinen unter der Sportart "Skifahren" aufgeführt werden, wie in der folgenden Abbildung gezeigt.

    Power View-Kreisdiagramme, die Hierarchien verwenden, ermöglichen ein Drilldown in die Daten

    Beachten Sie außerdem den Pfeil nach oben, der in der oberen rechten Ecke der Visualisierung links neben dem Filtersymbol angezeigt wird. Klicken Sie auf den Pfeil nach oben, um ein Drillup in der Hierarchie durchzuführen, wodurch in diesem Fall ein Kreisdiagramm der Sportarten angezeigt wird.

  3. Doppelklicken Sie auf das Kreissegment "Ski Jumping", woraufhin in dem Kreisdiagramm ein Drilldown eine weitere Ebene nach unten in der Hierarchie durchgeführt wird, nämlich zu "Events". Die Wettkämpfe für Skispringen werden angezeigt, und in der Legende ist zu sehen, dass im Diagramm "Events" angezeigt werden, die niedrigste Ebene in der Hierarchie.
    Doppelklicken auf Power View-Kreisdiagramme, um in hierarchische Daten einzutauchen

  4. Um auf höhere Ebenen der Hierarchie zurückzukehren, auch als Drillup bezeichnet, klicken Sie auf den Pfeil nach oben, wie in der folgenden Abbildung gezeigt. Wenn die höchste Ebene in der Hierarchie angezeigt wird, wird der Pfeil nach oben nicht mehr angezeigt.
    Das Drillupsymbol in Power View

Verwenden von Kreissegmenten zum Anzeigen von mehr Details

Sie können in Kreisdiagrammen mehr Details anzeigen.

  1. Ziehen Sie "Gender" aus der Tabelle Medals in Power View-Felder auf den Bereich SEGMENTE. Jedes Segment im Kreisdiagramm ist nun so aufgeteilt, dass gezeigt wird, wie die Daten nach "Gender" (Geschlecht) aufgeteilt sind. Zeigen Sie auf eins der Segmente im Kreisdiagramm, und die bereitgestellten Informationen werden auf Basis des Geschlechts ("Gender") angezeigt.

  2. Führen Sie ein Drilldown in "Skiing", dann in "Alpine Skiing" durch. Zeigen Sie auf das untere Kreissegment des "downhill"-Wettkampfs, und Sie sehen, dass Frauenteams bei 16 Gelegenheiten am "downhill"-Wettkampf teilgenommen haben, wie in der folgenden Abbildung gezeigt.

    Auf Segmente von Power View-Kreisdiagrammen zeigen, um weitere Informationen anzuzeigen

Kreuzfiltern von Balkendiagrammen mit anderen Visualisierungen

Sie können viele verschiedene Filter auf Kreisdiagramme anwenden. Sie können sogar andere Visualisierungen zum Filtern von Kreisdiagrammen verwenden, wobei Interaktion mit allen Diagrammen in der Ansicht möglich ist.

  1. Klicken Sie außerhalb des Kreisdiagramms auf den Zeichenbereich des Power View-Berichts. Wählen Sie unter Power View-Felder in der Tabelle Population "Population" aus, und wählen Sie dann in der Tabelle Population das Feld "Country Name " aus, um den Länder- oder Regionsnamen anzuzeigen.

  2. Lassen Sie uns die Ansicht auf nur noch eine Handvoll von Ländern oder Regionen filtern. Um den Bereich "Filter" anzuzeigen, können Sie entweder im Menüband von POWER VIEW die Option Filterbereich auswählen, oder Sie können auf das Filtersymbol klicken, das in der rechten oberen Ecke angezeigt wird, wenn Sie auf eine Visualisierung zeigen. Die Auswahl von Filterbereich im Menüband und das Filtersymbol sind beide in der folgenden Abbildung zu sehen.
    Das Filtersymbol wird angezeigt, wenn Sie auf eine Power View-Visualisierung zeigen

  3. Wählen Sie in Filter nur die folgenden Länder oder Regionen aus: Austria, Canada, Chile, Czech Republic, France und Germany.

  4. Lassen Sie uns das in ein gruppiertes Balkendiagramm umwandeln. Klicken Sie im Menüband auf ENTWURF > Visualisierung wechseln > Balkendiagramm > Gruppiertes Balkendiagramm.

  5. Klicken Sie in dem Balkendiagramm auf einen der Balken. Beachten Sie, wie die Daten im Kreisdiagramm auf Grundlage Ihrer Auswahl aktualisiert werden, wobei die entsprechenden Informationen hervorgehoben werden. Klicken Sie im Balkendiagramm auf "Canada". Ihr Bericht sieht wie in der folgenden Abbildung aus.

    Dynamische Daten in Power View-Kreisdiagrammvisualisierungen

    Klicken Sie versuchsweise auf andere Auswahlmöglichkeiten, und sehen Sie, wie sich das Kreisdiagramm sofort entsprechend Ihrer Auswahl ändert.

  6. Sie können auch, genau wie zuvor, ein Drilldown in die Daten durchführen. Doppelklicken Sie auf ein "Skiing"-Segment im Kreisdiagramm, doppelklicken Sie dann auf die Disziplin "Alpine Skiing", und das Kreisdiagramm reagiert, indem alle "Events" in der Disziplin "Alpine Skiing" angezeigt werden. Das Filtern von Ergebnissen durch Klicken auf das Balkendiagramm funktioniert auf dieselbe Weise auf dieser Ebene der Hierarchie. Klicken Sie auf "France", und das Kreisdiagramm filtert die "Event"-Ergebnisse für "France", wie in der folgenden Abbildung gezeigt.

    Verwenden mehrerer Power View-Visualisierungen für aussagekräftige, interaktive Berichte

Sie können viele verschiedene Typen von Visualisierungen verwenden, um Kreisdiagramme zu filtern, die in Power View auch noch alle interaktiv sind. Und wenn Sie Berichte auf einer Business Intelligence-Website auf SharePoint bereitstellen, bleiben Ihre Power View-Berichte für alle Benutzer interaktiv, die die Berechtigung zu deren Anzeige besitzen.

Erstellen interaktiver Balken- und Säulendiagramme

Sie haben gesehen, wie man mithilfe von Balkendiagrammen andere Visualisierungen wie Kreisdiagramme filtern kann. In diesem Abschnitt erfahren Sie, wie Sie ansprechende Balken- und Säulendiagramme erstellen, die interaktiv sind.

  1. Wählen Sie POWER VIEW > Einfügen > Power View aus, um einen neuen Power View-Bericht zu erstellen. Benennen Sie diesen Bericht in Bar and Column um.

  2. Wählen Sie in der Tabelle Medals "Medal Count" und dann noch "NOC_CountryRegion" ebenfalls in der Tabelle Medals aus. Wählen Sie im Menüband den Befehl ENTWURF > Visualisierung wechseln > Säulendiagramm > Gruppierte Säulen aus. Die Visualisierung enthält zu viele Einträge. Lassen Sie uns also die Ansicht so filtern, dass nur Länder oder Regionen angezeigt werden, die 200 oder mehr Medaillen gewonnen haben. Hierzu klicken Sie auf das Filtersymbol, und ändern Sie dann den Modus des Filters in "Erweitert", indem Sie neben dem Radiergummi auf das Symbol mit dem Pfeil nach rechts klicken, wie in der folgenden Abbildung gezeigt.

    Das Symbol für 'Erweiterter Filtermodus' in Power View

  3. Um das Diagramm interessanter zu gestalten, ziehen Sie "Medal" aus der Tabelle Medals auf die Visualisierung.

  4. Nehmen Sie als Nächstes einen Datenschnitt auf. Klicken Sie auf den Berichtzeichenbereich außerhalb des Diagramms, wählen Sie in der Tabelle Medals das Feld "Medal" aus, und wählen Sie dann im Menüband ENTWURF > Datenschnitt aus. Ihr Bericht sieht wie in der folgenden Abbildung aus.

    Säulendiagramme in Power View

  5. Das ist interessant. Aber Sie entschließen sich, dass es als gestapelte Säulen noch besser wäre. Wählen Sie ENTWURF > Visualisierung wechseln > Säulendiagramm > Gestapelte Säulen. Das sieht schon besser aus, und Ihr Bericht sieht nun wie in der folgenden Abbildung aus.

    Gestapeltes Säulendiagramme in Power View

  6. Lassen Sie uns nun einen weiteren Datenschnitt auf Grundlage von "Season" hinzufügen. Klicken Sie auf eine leere Stelle des Berichtzeichenbereichs, und wählen Sie dann in der Tabelle Medals "Season" aus. Wählen Sie dann im Menüband die Option Datenschnitt aus. Wenn Sie auf "Winter" klicken, bemerken Sie, dass keine Einträge vorhanden sind – sieht so aus, als ob keine Land oder keine Region mindestens 200 Medaillen im Winter gewonnen hat. Klicken Sie im Bereich "Filter" auf DIAGRAMM, ändern Sie den Filter "Medal Count" auf mindestens 30 Medaillen, und Sie sehen folgende Ergebnisse.

    Filtern gestapelter Säulendiagramme in Power View

  7. Dieses Diagramm ist ebenfalls interaktiv. Klicken Sie in der Legende von "Medal" auf "Silver". Die Ergebnisse für Silbermedaillen werden hervorgehoben, und der Rest der Ergebnisse in der Tabelle wird abgeblendet, wie in der folgenden Abbildung gezeigt.

    Power View-Säulendiagramme sind interaktiv

  8. Obgleich dies ein Säulendiagramm ist, lässt es sich einfach in ein Balkendiagramm ändern. Wählen Sie im Menüband den Befehl ENTWURF > Visualisierung wechseln > Balkendiagramm > Gestapelte Balken aus. Sie erhalten dasselbe Diagramm, allerdings auf die Seite gelegt als Balkendiagramm, wie in der folgenden Abbildung gezeigt. Das Balkendiagramm ist genauso interaktiv wie die anderen Diagramme.

    Power View-Visualisierungen lassen sich einfach ändern

Es gibt alle möglichen Methoden, um mit diesen Balken- und Säulendiagrammen zu interagieren. Erforschen Sie diese selbst.

Wissensstand und Prüfung

Wiederholung des Gelernten

In diesem Lernprogramm haben Sie erfahren, wie Sie interaktive Karten-, Kreis-, Balken und Säulendiagramme mit nur wenigen Mausklicks erstellen können. Sie haben ferner gelernt, wie Hierarchien Ihre Berichte noch stärker interaktiv gestalten und Betrachtern Ihrer Berichte ermöglichen können, sich mit dem Bericht in seiner ganzen Tiefe auseinanderzusetzen.

Darüber hinaus haben Sie erfahren, wie man mehrere Visualisierungen in einem Bericht zusammenfasst und wie diese Visualisierungen sich gegenseitig filtern, miteinander interagieren und aufeinander aufbauen können.

Im nächsten Lernprogramm dieser Reihe erstellen Sie weitere verblüffende Power View-Berichte – einschließlich Berichten mit Animationen, und zeigen, wie sich die olympischen Daten im zeitlichen Verlauf verändert haben. Dass ist ziemlich eindrucksvoll und recht einfach zu erstellen, und es macht noch mehr Spaß die Reaktion der anderen Leute zu sehen, die sich Ihre Berichte ansehen.

Hier ist ein Link zum nächsten Lernprogramm, sodass Sie versuchen können, diese Berichte selbst zu erstellen:

Lernprogramm 6: Erstellen von außergewöhnlichen Power View-Berichten – Teil 2

PRÜFUNG

Sie möchten feststellen, wie gut Sie sich an das Gelernte erinnern? Nachstehend haben Sie Gelegenheit dazu. In der folgenden kleinen Prüfung werden Features, Möglichkeiten oder Anforderungen hervorgehoben, die Sie in diesem Lernprogramm kennengelernt haben. Am Ende der Seite finden Sie die Antworten. Viel Glück!

Frage 1: Welche der folgenden Aussagen zur Sortierreihenfolge von Werten in einem Feld ist wahr?

A: Zum Ändern der Sortierreihenfolge eines Felds müssen Sie das Feld einem anderen Feld zuordnen und dann das ursprüngliche Feld löschen.

B: Sie können die Sortierreihenfolge eines Felds nicht ändern, egal wie.

C: Wenn Sie nach einem zugeordneten Feld sortieren möchten, muss das zugeordnete Feld im Datenmodell enthalten sein.

D: Keine der oben genannten Aussagen.

Frage 2: Welche Funktionalität stellt ein Datenschnitt bereit?

A: Datenschnitte duplizieren Daten aus einem Feld in ein anderes.

B: Datenschnitte schneiden Daten in zwei Hälften und behalten die eine Hälfte der Daten.

C: Datenschnitte filtern Visualisierungen auf Grundlage der Daten in den Datenschnittfeldern.

D: Keine der oben genannten Funktionen.

Frage 3: Wenn Sie eine Hierarchie in einer Berichtvisualisierung verwenden, welche der folgenden Möglichkeiten bieten sich dann?

A: Keine – Sie können keine Hierarchien in Visualisierungen verwenden.

B: Sie können Drilldowns durch die Ebenen der Hierarchie durchführen, wodurch sich die Visualisierung automatisch ändert, um die aktuelle Ebene der Hierarchie wiederzugeben.

C: Sie können Drilldowns durch die Ebenen einer Hierarchie durchführen, aber kein Drillup.

D: B und C.

Frage 4: Welche der folgenden Antworten ist im Bereich Filter richtig?

A: Durch das Ziehen eines Felds in den Bereich DIAGRAMM des Bereichs Filter werden alle Berichte auf dem Power View-Blatt gefiltert.

B: Durch das Ziehen eines Felds in den Bereich ANSICHT des Bereichs Filter werden alle Berichte auf dem Power View-Blatt gefiltert.

C: Sie müssen dasselbe Feld in beide Bereiche, DIAGRAMM und ANSICHT, des Bereichs Filter ziehen, um alle Visualisierungen auf dem Power View-Blatt zu filtern.

D: Sie können Felder nicht auf den Bereich Filter ziehen.

Prüfungsantworten

  1. Richtige Antwort: C

  2. Richtige Antwort: C

  3. Richtige Antwort: B

  4. Richtige Antwort: B

Hinweise : Daten und Bilder in dieser Lernprogrammreihe basieren auf folgenden Datenquellen:

  • Olympics Dataset von Guardian News & Media Ltd.

  • Flaggenbilder von CIA Factbook (cia.gov)

  • Bevölkerungsdaten von der Weltbank (worldbank.org)

  • Piktogramme der olympischen Sportarten von Thadius856 und Parutakupiu

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×