Korrigieren eines #WERT!-Fehlers in der ZÄHLENWENN/ZÄHLENWENNS-Funktion

In diesem Thema werden die häufigeren Ursachen für den #WERT!-Fehler in der Funktion ZÄHLENWENN und ZÄHLENWENNS aufgeführt.

Problem: Die Formel verweist auf Zellen in einer geschlossenen Arbeitsmappe

ZÄHLENWENN-/ZÄHLENWENNS-Funktionen, die auf eine Zelle oder einen Zellbereich in einer geschlossenen Arbeitsmappe verweisen, führen zu einem #WERT!-Fehler.

Hinweis: Dies ist ein bekanntes Problem bei mehreren anderen Excel-Funktionen wie SUMMEWENN, SUMMEWENNS, ANZAHLLEEREZELLEN, um nur einige zu nennen. Weitere Informationen finden Sie unter Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLLEEREZELLEN geben einen #WERT!-Fehler zurück.

Lösung: Öffnen Sie die verknüpfte Arbeitsmappe, die in der Formel angegeben ist, und drücken Sie F9, um die Formel zu aktualisieren.

Sie können dieses Problem auch umgehen, indem Sie die Funktionen SUMME und WENN gemeinsam in einer Matrixformel verwenden. Weitere Informationen finden Sie unter Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLLEEREZELLEN geben einen #WERT!-Fehler zurück.

Problem: Die Zeichenfolge ist länger als 255 Zeichen.

Lösung: Kürzen Sie die Zeichenfolge, falls möglich. Wenn Sie sie nicht kürzen können, verwenden Sie die Funktion VERKETTEN oder den &-Operator (kaufmännisches Und-Zeichen), um den Wert in mehrere Zeichenfolgen zu unterteilen. Beispiel:

  • =ZÄHLENWENN(B2:B12;"lange Zeichenfolge"&"weitere lange Zeichenfolge")

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren eines #WERT!-Fehlers

Funktion ZÄHLENWENN

Funktion ZÄHLENWENNS

WENN-Funktion – Geschachtelte Formeln und das Vermeiden von Fallgruben

Sehen Sie sich ein Video zu erweiterten WENN-Funktionen an

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×