Korrigieren eines #WERT!-Fehlers in der VERKETTEN-Funktion

Wichtig : In Excel 2016, Excel Mobile und Excel Online wurde VERKETTEN durch die Funktion TEXTKETTE ersetzt. Obwohl VERKETTEN aus Gründen der Abwärtskompatibilität weiterhin verfügbar ist, sollten Sie die Verwendung von TEXTKETTE in Betracht ziehen, da die Funktion robuster ist.

Eins der am gängigsten Szenarios, in denen der Fehler #WERT! bei VERKETTEN auftritt, ist, wenn Sie versuchen, eine Zeichenkette zu erzeugen, die einen Zellbezug enthält, der einen Fehler aufweist, z. B. #WERT!.

Im folgenden Beispiel möchten wir D2, E2 und F2 verketten, wobei E2 einen #WERT!-Fehler aufweist.

#WERT!-Fehler in VERKETTEN

Der Fehler in E2 bewirkt, dass die Funktion den Fehler #WERT! anzeigt. Damit sie erfolgreich funktioniert, müssen Sie den Fehler durch einen anderen Wert als den Fehler ersetzen. Sie können eine Formel erstellen, die den Zellbezug auf einen Fehler überprüft, und die, wenn ein Fehler vorliegt, die Textzeichenfolge anzeigt, in der anstelle des Fehlers eine 0 angezeigt wird (alternativ können Sie 0 auch durch Ihren eigenen Text ersetzen, aber Sie müssen den Text dann in Anführungszeichen setzen – "Ihr Text").

Eine Formel wie die folgende funktioniert:

=WENN(ISTFEHLER(E2);VERKETTEN(D2;" "; 0;" "; F2))

Als Problemumgehung verwendete Funktionen WENN und ISTFEHLER, um eine Zeichenfolge mit einem #WERT!-Fehler zu verketten

Wie funktioniert das? Die WENN-Funktion verwendet die Funktion WENNFEHLER, um zu ermitteln, ob in E2 ein Fehler vorhanden ist, und, falls einer vorliegt, kombiniert die Funktion VERKETTEN die Werte in D2, E2 und F2 (die Funktion ersetzt den Fehler durch 0), und zeigt die resultierende Textzeichenfolge an. Beachten Sie, dass die Formel auch Leerzeichen (" ") verwendet, um die Werte besser zu trennen.

Beheben des #WERT!-Fehlers mit VERKETTEN in Excel 2003 und älteren Versionen

Wenn Sie den #WERT!-Fehler in Office Excel 2003 oder älteren Versionen erhalten, müssen Sie die Option "Alternative Formelberechnung" in Excel deaktivieren. Befolgen Sie die in #WERT!-Fehler beim Verketten von Zellen dargelegten Schritte, um das Problem zu beheben.

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Siehe auch

Korrigieren eines #WERT!-Fehlers

Funktion VERKETTEN

Funktion TEXTKETTE

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×