Korrigieren eines #WERT!-Fehlers in der SUMMEWENN/SUMMEWENNS-Funktion

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In diesem Thema werden die häufigeren Ursachen für den #WERT!-Fehler in der Funktion SUMMEWENN und SUMMEWENNS aufgeführt sowie erläutert, wie er zu beheben ist.

Problem: Die Formel verweist auf Zellen in einer geschlossenen Arbeitsmappe.

SUMMEWENN-/SUMMEWENNS-Funktionen, die auf eine Zelle oder einen Zellbereich in einer geschlossenen Arbeitsmappe verweisen, führen zu einem #WERT!-Fehler.

Hinweis: Dies ist ein bekanntes Problem bei mehreren anderen Excel-Funktionen wie ZÄHLENWENN, ZÄHLENWENNS, ANZAHLLEEREZELLEN, um nur einige zu nennen. Weitere Informationen finden Sie in dem Artikel Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLLEEREZELLEN geben einen #WERT!-Fehler zurück.

Lösung: Öffnen Sie die in der Formel angegebene Arbeitsmappe, und drücken Sie F9, um die Formel zu aktualisieren.

Sie können dieses Problem auch umgehen, indem Sie die Funktionen SUMME und WENN gemeinsam in einer Matrixformel verwenden. Weitere Informationen finden Sie in dem Artikel Die Funktionen SUMMEWENN, ZÄHLENWENN und ANZAHLLEEREZELLEN geben einen #WERT!-Fehler zurück.

Problem: Die Kriterienzeichenfolge ist länger als 255 Zeichen.

Die Funktionen SUMMEWENN/SUMMEWENNS geben falsche Ergebnisse zurück, wenn Sie versuchen, mit ihnen Zeichenfolgen mit mehr als 255 Zeichen abzugleichen.

Lösung: Kürzen Sie die Zeichenfolge, falls möglich. Wenn Sie sie nicht kürzen können, verwenden Sie die Funktion VERKETTEN oder den &-Operator (kaufmännisches Und-Zeichen), um den Wert in mehrere Zeichenfolgen zu unterteilen. Beispiel:

=SUMMEWENN(B2:B12;"lange Zeichenfolge"&"weitere lange Zeichenfolge")

Problem: In SUMMEWENNS ist das Argument Kriterien_Bereich nicht mit dem Argument Summe_Bereich konsistent.

Der Bereichsargumente müssen in SUMMEWENNS immer identisch sein. Das bedeutet, dass die Argumente Kriterien_Bereich und Summe_Bereich auf dieselbe Anzahl von Zeilen und Spalten verweisen müssen.

Im folgenden Beispiel soll die Formel die Summe der täglichen Verkäufe von Äpfeln in Detmold zurückgeben. Das Argument Summe_Bereich (C2: C10) entspricht aber nicht derselben Anzahl von Zeilen und Spalten in den Argumenten Kriterien_Bereich (A2:A12 & B2:B12). Die Verwendung der Syntax =SUMMEWENNS(C2: C10;A2:A12;A14;B2:B12;B14) führt zu einem #WERT!-Fehler.

Die fehlerhafte Formel lautet =SUMMEWENNS(C2:C10;A2:A12;A14;B2:B12;B14), wobei C2:C10 C2:C12 sein muss
In der SUMMEWENNS-Funktion muss der Kriterien_Bereich mit dem Summe_Bereich konsistent sein.

Lösung: Ändern Sie gemäß diesem Beispiel den Summe_Bereich in C2:C12, und probieren Sie die Formel noch mal.

Hinweis :  SUMMEWENN kann Bereiche unterschiedlicher Größen verwenden.

Haben Sie eine Frage zu einer bestimmten Funktion?

Bereitstellen einer Frage in das Excel-Community-forum

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Korrigieren eines #WERT!-Fehlers

SUMMEWENN (Funktion)

SUMMEWENNS (Funktion)

Videos zu erweiterten WENN-Funktionen

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×