Korrigieren eines #WERT!-Fehlers in den Funktionen MITTELWERT und SUMME

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn MITTELWERT oder SUMME auf Zellen verweisen, die #WERT!-Fehler enthalten, führen die Formeln zu einem #WERT!-Fehler.

#WERT!-Fehler in MITTELWERT

Um die Fehlerwerte zu "übersehen", konstruieren wir eine Formel, die die Fehler im Bezugsbereich ignoriert und gleichzeitig den Mittelwert mit den restlichen "normalen" Werten berechnet.

Um dieses Szenario zu umgehen, verwenden wir eine Kombination aus MITTELWERT zusammen mit WENN und ISTFEHLER, um zu bestimmen, ob im angegebenen Bereich ein Fehler vorhanden ist. Dieses spezielle Szenario erfordert eine Matrixformel:

=MITTELWERT(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Hinweis : Dies ist eine Matrixformel, die mit STRG+UMSCHALT+EINGABETASTE eingegeben werden muss. Excel schließt die Formel automatisch in geschweifte Klammern {} ein. Wenn Sie versuchen, diese manuell einzugeben, zeigt Excel die Formel als Text an.

Matrixfunktion in MITTELWERT zum Beheben des #WERT!-Fehlers

Hinweis : Die oben gezeigte Funktion funktioniert nicht nur für #WERT!-Fehler, sondern auch für #N/V-, #NULL-, #DIV/0!- und andere Fehler.

Sie können auch SUMME auf dieselbe Art verwenden:

=SUMME(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Haben Sie eine Frage zu einer bestimmten Funktion?

Bereitstellen einer Frage in das Excel-Community-forum

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Korrigieren eines #WERT!-Fehlers

Funktion MITTELWERT

Funktion SUMME

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Verwenden der Fehlerüberprüfung zum Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×