Kombinieren von Dateien in einem Ordner mit Binärdateien kombinieren (Power Query)

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Verwenden Sie des Excel abrufen und Transformieren Sie Experience (Power Query), um mehrere Dateien, denen dasselbe Schema, aus einem einzelnen Ordner in einer Tabelle zu kombinieren. Ein Beispiel dafür ist das Kombinieren von Budget Arbeitsmappen für mehrere Abteilungen, wo die Spalten sind die gleichen, die Anzahl der Zeilen und Werte unterscheiden sich jedoch zwischen Arbeitsmappen.

Um mit dem Kombinieren mehrerer Dateien zu beginnen, müssen Sie zunächst sicherstellen, dass sich alle zu kombinierenden Dateien in einem einzigen Dateiordner befinden.

Hinweis : Unterstützt werden Excel-, Text-, CSV-, JSON-, XML- und Access-Dateien.

  1. Klicken Sie auf der Registerkarte Daten, klicken Sie dann Daten abrufen > Aus Datei > Aus Ordner. Wenn Sie die Daten abrufen-Schaltfläche angezeigt werden, klicken Sie dann auf Neue Abfrage > Aus Datei > Aus Ordner

    Kombinieren von Binärdateien aus Datei > aus Ordner Option

  2. Klicken Sie auf die Schaltfläche Durchsuchen, um nach Ihrem Ordner zu suchen.

    Es wird eine Liste der Dateien im Ordner angezeigt. In diesem Fall haben wir 4 Excel-Arbeitsmappen geladen. Nachdem Sie überprüft haben, dass die gewünschten Dateien aufgeführt sind, wählen Sie die Option kombinieren und Laden.

    Kombinieren von Binärdateien kombinieren und Option laden
  3. Jede Datei wird analysiert, und das richtige Dateiformat bestimmt, wie Text, Excel oder JSON. In diesem Fall wird eine Liste von Arbeitsblättern in der ersten Arbeitsmappe in Excel angezeigt. Wählen Sie das Arbeitsblatt, das Sie verwenden möchten, und klicken Sie dann, und klicken Sie auf OK. Die Binärdateien kombinieren transformieren Prozess wird dann automatisch Erstellen einer Abfrage zum Konsolidieren von Daten aus jeder Datei und Anzeigen der Ergebnisse in einem einzelnen Arbeitsblatt.

    Dialogfeld "Binärdateien kombinieren" mit verfügbaren Excel-Arbeitsblättern zur Auswahl des primären Konsolidierungsziels
  4. Wenn sich die ursprünglichen Datendateien ändern, können Sie die importierten Daten stets aktualisieren. Klicken Sie auf eine beliebige Stelle im Datenbereich, und wechseln Sie dann zu Abfragetools > Aktualisieren. Darüber hinaus können Sie durch Ändern der automatisch erstellten Beispielabfrage ganz einfach zusätzliche Transformations- oder Extraktionsschritte anwenden, ohne sich über das Ändern oder Erstellen zusätzlicher Funktionsabfrageschritte Gedanken machen zu müssen. Alle Änderungen an der Beispielabfrage werden automatisch in der verknüpften Funktionsabfrage generiert.

Um mit dem Kombinieren mehrerer Dateien zu beginnen, müssen Sie zunächst sicherstellen, dass sich alle zu kombinierenden Dateien in einem einzigen Dateiordner befinden.

Hinweis : Unterstützt werden Excel-, Text-, CSV-, JSON-, XML- und Access-Dateien.

  1. Klicken Sie auf der Registerkarte Power Query, dann Aus Datei > Aus Ordner.

    Power Query > aus Datei > aus Ordneroptionen
  2. Klicken Sie auf die Schaltfläche Durchsuchen, um nach Ihrem Ordner zu suchen.

    Es wird eine Liste der Dateien im Ordner angezeigt. Wählen Sie die Option Bearbeiten aus, um den Abfrage-Editor zu öffnen. In diesem Fall haben wir 4 Excel-Arbeitsmappen geladen.

    Dialogfeld "Binärdateien kombinieren" mit den zu kombinierenden Dateien
  3. Nachdem Sie überprüft haben, dass alle gewünschten Dateien aufgeführt sind, klicken Sie in der Spalte Inhalt auf die Schaltfläche Binärdateien kombinieren.

    Drücken Sie in der Spalte "Inhalt" der Abfrage oder im Power Query-Menüband im Abschnitt "Kombinieren" auf die Schaltfläche "Binärdateien kombinieren".
  4. Jede Datei wird analysiert, und das richtige Dateiformat (z. B. Text, Excel oder JSON) wird bestimmt. In diesem Fall wird eine Liste der Arbeitsblätter aus der ersten Excel-Arbeitsmappe angezeigt. Wählen Sie das Arbeitsblatt aus, das Sie verwenden möchten, und klicken Sie auf OK.

    Dialogfeld "Binärdateien kombinieren" mit verfügbaren Excel-Arbeitsblättern zur Auswahl des primären Konsolidierungsziels
  5. Durch den Transformationsprozess beim Kombinieren der Binärdateien wird automatisch eine Abfrage erstellt, um die Daten der einzelnen Dateien zu konsolidieren und eine Vorschau anzuzeigen. Wenn Sie mit dem Ergebnis zufrieden sind, klicken Sie auf Schließen und Laden.

    Vorschau im Dialogfeld "Binärdateien kombinieren" Drücken Sie "Schließen & laden", um die Ergebnisse zu übernehmen und sie in Excel zu importieren.

    Durch den Kombinationsprozess der Binärdateien werden die aufgelisteten Arbeitsblätter in einem einzigen Arbeitsblatt konsolidiert.

  6. Wenn sich die ursprünglichen Datendateien ändern, können Sie die importierten Daten stets aktualisieren. Klicken Sie auf eine beliebige Stelle im Datenbereich, und wechseln Sie dann zu Abfragetools > Aktualisieren. Darüber hinaus können Sie durch Ändern der automatisch erstellten Beispielabfrage ganz einfach zusätzliche Transformations- oder Extraktionsschritte anwenden, ohne sich über das Ändern oder Erstellen zusätzlicher Funktionsabfrageschritte Gedanken machen zu müssen. Alle Änderungen an der Beispielabfrage werden automatisch in der verknüpften Funktionsabfrage generiert.

Bekannte Probleme

Beim Laden der Prozedur "Binärdateien kombinieren" in Excel wird möglicherweise folgende Fehlermeldung angezeigt:

Fehlermeldung beim Kombinieren von Binärdateien. Dies ist ein bekanntes Problem, um das wir uns kümmern.

Wenn Sie die Fehlermeldung(en) schließen, indem Sie auf OK klicken, wird der Prozess Binärdateien kombinieren abgeschlossen, und Ihr Daten werden trotz des Fehlers ordnungsgemäß geladen. Wir arbeiten daran, den Fehler zu beheben.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Abrufen und Transformieren in Excel 2016

Importieren von Daten aus externen Datenquellen

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×