Importieren von XML-Daten

Wenn Sie zuvor eine XML-Zuordnung erstellt haben, können Sie sie zum Importieren von XML-Daten in zugeordnete Zellen verwenden. Es gibt aber auch mehrere Methoden und Befehle zum Importieren von XML-Daten ohne eine XML-Zuordnung.

Wenn Sie über eine XML-Zuordnung verfügen, führen Sie diese Schritte aus, um XML-Daten in die zugeordneten Zellen zu importieren:

  1. Wählen Sie in der XML-Zuordnung eine der zugeordneten Zellen aus.

  2. Klicken Sie auf Entwicklertools > Importieren.

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  3. Suchen und markieren Sie im Dialogfeld XML importieren die XML-Datendatei (XML), die Sie importieren möchten, und klicken Sie auf Importieren.

Weitere Methoden zum Importieren von XML-Daten

Weitere Informationen zu Problemen finden Sie unter Häufige Probleme beim Importieren von XML-Daten am Ende dieses Artikels.

Importieren einer XML-Datendatei als XML-Tabelle

  1. Klicken Sie auf Entwicklertools > Importieren.

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  2. Suchen und markieren Sie im Dialogfeld XML importieren die XML-Datendatei (XML), die Sie importieren möchten, und klicken Sie auf Importieren.

    Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

  3. Führen Sie im Dialogfeld Daten importieren eine der folgenden Aktionen aus:

    1. Wählen Sie XML-Tabelle in vorhandenem Arbeitsblatt aus, um den Inhalt der XML-Datendatei in eine XML-Tabelle auf dem Arbeitsblatt an der angegebenen Zellenposition zu importieren.

    2. Wählen Sie XML-Tabelle in neuem Arbeitsblatt aus, um den Inhalt der Datei in eine XML-Tabelle in einem neuen Arbeitsblatt, beginnend in Zelle A1, zu importieren. Im Aufgabenbereich XML-Quelle wird das Schema der XML-Datendatei angezeigt.

  4. Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

  5. Um das Verhalten von XML-Daten (z. B. Datenbindung, Format und Layout) zu steuern, klicken Sie auf Eigenschaften, um das Dialogfeld Eigenschaften der XML-Zuordnung anzuzeigen. Beispielsweise werden vorhandene Daten in einem zugeordneten Bereich beim Importieren von Daten standardmäßig überschrieben. Sie können dieses Verhalten aber ändern.

Importieren mehrerer XML-Datendateien

  1. Wählen Sie eine zugeordnete Zelle aus, um mehrere XML-Dateien in einen einzigen Satz von zugeordneten Zellen zu importieren.

    Wenn Sie mehrere XML-Dateien in mehrere Gruppen von zugeordneten Zellen importieren möchten, klicken Sie in eine beliebige nicht zugewiesene Zelle auf dem Arbeitsblatt.

  2. Klicken Sie auf Entwicklertools > Importieren.

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  3. Suchen und markieren Sie im Dialogfeld XML importieren die XML-Datendatei (XML), die Sie importieren möchten.

    • Wenn es sich um fortlaufende Dateien handelt, drücken Sie die UMSCHALTTASTE, und klicken Sie auf die erste und letzte Datei in der Liste. Alle Daten aus den XML-Dateien werden importiert und an die zugeordneten Zellen angefügt.

    • Wenn es sich nicht um fortlaufende Dateien handelt, halten Sie STRG gedrückt, und klicken Sie auf jede Datei in der Liste, die Sie importieren möchten.

  4. Klicken Sie auf Importieren.

    Wenn Sie nicht fortlaufende Dateien ausgewählt haben, wird das Dialogfeld <Dateiname>.xml wird importiert angezeigt. Wählen Sie für jede Datei die XML-Zuordnung aus, die der XML-Datendatei entspricht, die Sie importieren.

    Wenn Sie für alle ausgewählten Dateien, die noch nicht importiert wurden, dieselbe Zuordnung verwenden möchten, wählen Sie Diese XML-Zuordnung für alle ausgewählten Dateien des Schemas benutzen aus.

Importieren mehrerer XML-Datendateien als externe Daten

Um mehrere XML-Dateien zu importieren, die den gleichen Namespace, aber unterschiedliche XML-Schemas verwenden, können Sie den Befehl Vom XML-Datenimport verwenden. Excel erstellt eine eindeutige XML-Zuordnung für jede XML-Datendatei, die Sie importieren.

Hinweis : Wenn Sie mehrere XML-Dateien importieren, für die kein Namespace definiert ist, werden diese XML-Dateien so behandelt, als ob sie den gleichen Namespace verwenden.

  1. Klicken Sie auf Daten > Aus anderen Quellen, und klicken Sie dann auf Vom XML-Datenimport.

  2. Wechseln Sie zu dem Laufwerk, Ordner oder Internetspeicherort, das bzw. der die XML-Datendatei (XML) enthält, die Sie importieren möchten.

  3. Wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  4. Führen Sie im Dialogfeld Daten importieren eine der folgenden Aktionen aus:

    • XML-Tabelle in vorhandenem Arbeitsblatt    Die Inhalte der Datei werden in eine neue XML-Tabelle in einem neuen Arbeitsblatt importiert. Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

    • Vorhandenes Arbeitsblatt    Die XML-Daten werden in eine zweidimensionale Tabelle mit Zeilen und Spalten importiert, in der XML-Tags als Spaltenüberschriften und die Daten in Zeilen unterhalb der Spaltenüberschriften angezeigt werden. Das erste Element (der Stammknoten) wird wie ein Titel verwendet und an der angegebenen Zellenposition angezeigt. Die restlichen Tags werden über die zweite Zeile alphabetisch sortiert. In diesem Fall wird von Excel kein Schema abgeleitet und Sie können keine XML-Zuordnung verwenden.

    • Neues Arbeitsblatt    Excel fügt ein neues Arbeitsblatt zu Ihrer Arbeitsmappe hinzu und platziert die XML-Daten automatisch im neuen Arbeitsblatt oben links. Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

  5. Um das Verhalten von XML-Daten (z. B. Datenbindung, Format und Layout) zu steuern, klicken Sie auf Eigenschaften, um das Dialogfeld Eigenschaften der XML-Zuordnung anzuzeigen. Beispielsweise werden vorhandene Daten in einem zugeordneten Bereich beim Importieren von Daten standardmäßig überschrieben. Sie können dieses Verhalten aber ändern.

Öffnen einer XML-Datendatei zum Importieren der enthaltenen Daten

  1. Klicken Sie auf Datei > Öffnen.

    Wenn Sie Excel 2007 verwenden, klicken Sie auf Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche > Öffnen.

  2. Klicken Sie im Dialogfeld Öffnen auf das Laufwerk, den Ordner oder den Internetspeicherort, das bzw. der die zu öffnende Datei enthält.  

  3. Wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  4. Wenn das Dialogfeld XML importierenangezeigt wird, verweist die Datei, die Sie geöffnet haben, auf ein oder mehrere XSLT-Stylesheets (Extensible Stylesheet Language Transformation). Sie können somit auf eine der folgenden Optionen klicken:

    • Datei ohne Anwendung eines Stylesheets öffnen    Die XML-Daten werden in eine zweidimensionale Tabelle mit Zeilen und Spalten importiert, in der XML-Tags als Spaltenüberschriften und die Daten in Zeilen unterhalb der Spaltenüberschriften angezeigt werden. Das erste Element (der Stammknoten) wird wie ein Titel verwendet und an der angegebenen Zellenposition angezeigt. Die restlichen Tags werden über die zweite Zeile alphabetisch sortiert. In diesem Fall wird von Excel kein Schema abgeleitet und Sie können keine XML-Zuordnung verwenden.

    • Datei mit dem folgenden angewendeten Stylesheet öffnen (ein Stylesheet auswählen)    Wählen Sie das Stylesheet aus, die Sie anwenden möchten, und klicken Sie dann auf OK. Die XML-Daten sind entsprechend dem ausgewählten Stylesheet formatiert.

      Hinweis : Die XML-Daten werden in Excel schreibgeschützt geöffnet, damit Sie die ursprüngliche Quelldatei nicht versehentlich im XLSM-Dateiformat (Excel-Arbeitsmappe mit Makros) speichern. In diesem Fall wird von Excel kein Schema abgeleitet und Sie können keine XML-Zuordnung verwenden.

  5. Wenn das Dialogfeld XML öffnen angezeigt wird, weist die XML-Datei keine XSLT-Stylesheetverweise auf. Klicken Sie zum Öffnen der Datei auf eine der folgenden Optionen:

    • Klicken Sie auf Als XML-Tabelle, um eine XML-Tabelle in einer neuen Arbeitsmappe zu erstellen.

      Der Inhalt der Datei wird in die XML-Tabelle importiert. Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

    • Klicken Sie auf Als eine schreibgeschützte Arbeitsmappe.

      Die XML-Daten werden in eine zweidimensionale Tabelle mit Zeilen und Spalten importiert, in der XML-Tags als Spaltenüberschriften und die Daten in Zeilen unterhalb der Spaltenüberschriften angezeigt werden. Das erste Element (der Stammknoten) wird wie ein Titel verwendet und an der angegebenen Zellenposition angezeigt. Die restlichen Tags werden über die zweite Zeile alphabetisch sortiert. In diesem Fall wird von Excel kein Schema abgeleitet und Sie können keine XML-Zuordnung verwenden.

      Die XML-Daten werden in Excel schreibgeschützt geöffnet, damit Sie die ursprüngliche Quelldatei nicht versehentlich im XLSM-Dateiformat (Excel-Arbeitsmappe mit Makros) speichern. In diesem Fall wird von Excel kein Schema abgeleitet und Sie können keine XML-Zuordnung verwenden.

    • Klicken Sie auf Aufgabenbereich " XML-Quelle" verwenden.

      Im Aufgabenbereich XML-Quelle wird das Schema der XML-Datendatei angezeigt. Anschließend können Sie Elemente des Schemas auf das Arbeitsblatt ziehen, um diese dem Arbeitsblatt zuzuordnen.

      Wenn die XML-Datendatei nicht auf ein Schema verweist, leitet Excel das Schema aus der XML-Datendatei ab.

Häufige Probleme beim Importieren von XML-Daten

Excel zeigt das Dialogfeld Fehler beim XML-Import an, wenn die Daten nicht entsprechend der XML-Zuordnung überprüft werden können. Klicken Sie in diesem Dialogfeld auf Details, um weitere Informationen zu den einzelnen Fehlern zu erhalten. Die folgende Tabelle enthält einige häufige Importfehler:

Fehler

Was ist geschehen?

Fehler bei der Schemaüberprüfung

Wenn Sie auf Beim Importieren und Exportieren Daten gegen das Schema validieren im Dialogfeld Eigenschaften der XML-Zuordnung geklickt haben, wurden die Daten importiert, aber nicht gegen die angegebene XML-Zuordnung überprüft.

Einige Daten wurden als Text importiert

Die importierten Daten wurden teilweise oder vollständig vom deklarierten Datentyp in Text konvertiert. Wenn Sie diese Daten in einer Berechnung verwenden möchten, müssen Sie sie wieder von Text in Zahlen oder Datumsangaben konvertieren. Ein in Text konvertierter Datumswert funktioniert beispielsweise in der Funktion JAHR nicht wie beabsichtigt, wenn Sie ihn nicht wieder in den Datentyp "Datum" konvertieren. Excel konvertiert Daten in Text, wenn:

  • Die Daten in einem von Excel nicht unterstützten Format vorliegen.

  • Die Daten sind nicht mit der Excel-internen Darstellung des XSD-Datentyps kompatibel sind. Um dieses Problem zu beheben, überprüfen Sie jede Datentypdeklaration, um sicherzustellen, dass die XML-Daten entsprechend dem XML-Schema gültig sind.

XML-Parserfehler

Der XML-Parser kann die angegebene XML-Datei nicht öffnen. Stellen Sie sicher, dass die XML-Datei keine Syntaxfehler aufweist und dass sie ordnungsgemäß formatiert ist.

Es wurde keine XML-Zuordnung gefunden, die den Daten entspricht.

Dieses Problem kann auftreten, wenn Sie mehr als eine XML-Datendatei zum Importieren auswählen und Excel für eine der Dateien keine übereinstimmende XML-Zuordnung findet. Importieren Sie für die in der Titelleiste des Dialogfelds genannte Datei zuerst ein entsprechendes Schema, und versuchen Sie dann erneut, die Datei zu importieren.

Eine XML-Tabelle lässt sich nicht vergrößern, um die Daten aufzunehmen.

Sie versuchen, Zeilen durch Importieren oder Anfügen von Daten in die XML-Tabelle hinzuzufügen, aber die Tabelle lässt sich nicht erweitern. Eine XML-Tabelle kann nur vom unteren Rand nach unten erweitert werden. Möglicherweise befindet sich unmittelbar unterhalb der XML-Tabelle ein Objekt, z. B. ein Bild oder eine andere Tabelle, welches das Erweitern der XML-Tabelle verhindert. Oder durch das Erweitern der XML-Tabelle würde die in Excel geltende Zeilenbeschränkung von 1.048.576 Zeilen überschritten. Um dieses Problem zu beheben, ordnen Sie die Tabellen und Objekte auf dem Arbeitsblatt neu an, um das Erweitern der XML-Tabelle vom unteren Rand nach unten zu ermöglichen.

Die angegebene XML-Datei verweist nicht auf ein Schema

Die XML-Datei, die Sie öffnen möchten, verweist nicht auf ein XML-Schema. Um mit den XML-Daten in der Datei arbeiten zu können, benötigt Excel ein Schema basierend auf dem Inhalt der XML-Datei. Wenn das Schema falsch oder unzureichend ist, entfernen Sie es aus Ihrer Arbeitsmappe. Erstellen Sie dann eine XML-Schemadatei, und bearbeiten Sie die XML-Datendatei so, dass sie auf das Schema verweist. Weitere Informationen finden Sie unter Zuordnen von XML-Elementen zu Zellen in einer XML-Zuordnung.

Hinweis : Das abgeleitete Excel-Schema kann nicht als separate XML-Schemadatendatei (XSD) exportiert werden. Obwohl XML-Schema-Editoren und andere Methoden zum Erstellen einer XML-Schemadatei vorhanden sind, verfügen Sie möglicherweise dennoch nicht über einen bequemen Zugang zu ihnen oder wissen nicht, wie Sie damit umgehen müssen.

Führen Sie die folgenden Schritte aus, um das von Excel erstellte Schema aus Ihrer Arbeitsmappe zu entfernen:

  1. Klicken Sie auf Entwicklertools > Quelle.

    XML-Befehle auf der Registerkarte 'Entwicklertools'

    Wenn die Registerkarte Entwicklertools nicht angezeigt wird, lesen Sie Anzeigen der Registerkarte "Entwicklertools".

  2. Klicken Sie im Aufgabenbereich XML-Quelle auf XML-Zuordnungen.

  3. Klicken Sie im Dialogfeld XML-Zuordnungen auf die von Excel erstellte XML-Zuordnung und dann auf Löschen.

Das Importieren mehrerer XML-Dateien, die den gleichen Namespace, aber verschiedene Schemas verwenden, funktioniert nicht wie erwartet

Wenn Sie mit mehreren XML-Datendateien und XML-Schemas arbeiten, erstellen Sie in der Regel eine XML-Zuordnung für jedes Schema, ordnen die gewünschten Elemente zu, und importieren dann jede XML-Datendatei in die entsprechende XML-Zuordnung. Wenn Sie mehrere XML-Dateien mit demselben Namespace mithilfe des Befehls Importieren öffnen, können Sie nur ein XML-Schema verwenden. Wenn Sie mit diesem Befehl mehrere XML-Dateien öffnen, die den gleichen Namespace, aber verschiedene Schemas verwenden, können Sie unerwartete Ergebnisse erhalten. Beispielsweise können Daten überschrieben oder die Dateien nicht geöffnet werden.

Um mehrere XML-Dateien zu importieren, die den gleichen Namespace, aber unterschiedliche XML-Schemas verwenden, versuchen Sie, den Befehl Vom XML-Datenimport zu verwenden (klicken Sie auf Daten > Aus anderen Quellen). Bei diesem Befehl können mehrere XML-Dateien mit demselben Namespace verschiedene XML-Schemas verwenden. Excel erstellt eine eindeutige XML-Zuordnung für jede zu importierende XML-Datendatei.

Hinweis : Wenn Sie mehrere XML-Dateien importieren, für die kein Namespace definiert ist, werden diese XML-Dateien so behandelt, als ob sie den gleichen Namespace verwenden.

Anzeigen der Registerkarte "Entwicklertools"

Wenn die Registerkarte Entwicklertools nicht angezeigt wird, führen Sie die folgenden Schritte aus, um sie anzuzeigen:

  • In Excel 2013 und Excel 2010:

    1. Klicken Sie auf Datei > Optionen.

    2. Klicken Sie auf die Kategorie Menüband anpassen.

    3. Aktivieren Sie unter Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie auf OK.

  • In Excel 2007:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche > Excel-Optionen.

    2. Klicken Sie auf die Kategorie Beliebt.

    3. Aktivieren Sie unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie auf OK.

Siehe auch

Überblick über XML in Excel

Zuordnen von XML-Elementen zu Zellen in einer XML-Zuordnung

Exportieren von XML-Daten

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×