Importieren von Daten aus Excel, SQL Server, SharePoint und anderen externen Quellen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können schnell importieren und Anzeigen von Daten direkt auf den Shapes, Microsoft Office Visio Professional 2007 verwenden. Der erste Schritt besteht eine Verbindung zur Datenquelle herstellen und Importieren von Daten in der Zeichnung. Im zweite Schritt ist die importierten Daten mit Shapes verknüpfen.

Informationen zum Ihre Shapes Daten hinzufügen, ohne die Daten importiert werden finden Sie unter Hinzufügen von Daten mit Shapes.

Inhalt dieses Artikels

Schritt 1: Importieren der Daten

Schritt 2: Verknüpfen von Datenzeilen mit Shapes in der Zeichnung

Schritt 1: Importieren der Daten

Im ersten Schritt verwenden Sie den Assistenten für die Datenauswahl, um Daten in das Fenster Externe Daten zu importieren.

Die Daten, die in dem Fenster Externe Daten angezeigt wird ist eine Momentaufnahme der Datenquelle zum Zeitpunkt des Imports. Sie können die Daten in Ihrer Zeichnung die Änderungen in den Quelldaten entsprechend zu aktualisieren. Jedoch nicht die Datenquelle aktualisiert werden, indem Sie die Daten in Ihrer Zeichnung ändern. Aktualisieren importierter Datenfinden Sie unter.

  1. Klicken Sie im Menü Daten auf Daten mit Shapes verknüpfen.

  2. Legen Sie auf der ersten Seite des Assistenten für die Datenauswahl fest, welche Datenquellentypen Sie verwenden möchten:

    • Microsoft Office Excel-Arbeitsmappe

    • Microsoft Office Access-Datenbank

    • Microsoft Windows SharePoint Services-Liste

    • Microsoft SQL Server-Datenbank

    • Andere OLEDB- oder ODBC-Datenquelle

    • Zuvor erstellte Verbindung

  3. Schließen Sie die übrigen Seiten des Assistenten ab.

    Hinweis : Wenn Sie keine Excel-Arbeitsmappe, Access-Datenbank oder SharePoint-Liste auf der ersten Seite des Assistenten ausgewählt haben, werden Sie beim Bearbeiten des Assistenten für die Datenauswahl vorübergehend an den Datenverbindungs-Assistenten weitergeleitet.

    Für die meisten Seiten des Assistenten ist eine spezielle Hilfe verfügbar. Drücken Sie die Taste F1, oder klicken Sie auf die Schaltfläche Hilfe, um die Hilfe aufzurufen.

Nachdem Sie auf der letzten Seite des Datenverbindungs-Assistenten auf Fertig stellen klicken, wird das Fenster Externe Daten mit den importierten Daten in einem Raster angezeigt.

Seitenanfang

Schritt 2: Verknüpfen von Datenzeilen mit Shapes in der Zeichnung

Es gibt drei Möglichkeiten, Datenzeilen mit Shapes in der Zeichnung zu verknüpfen: Sie können Datenzeilen einzeln mit vorhandenen Shapes verknüpfen, Sie können die Zeilen automatisch mit Shapes verknüpfen, oder Sie können Shapes aus den Daten erstellen.

Einzelnes Verknüpfen von Zeilen mit vorhandenen Shapes

Dieser Ansatz empfiehlt sich für vorhandene Zeichnungen mit relativ wenigen Shapes.

  • Ziehen Sie eine Zeile aus dem Fenster Externe Daten auf ein Shapes in der Zeichnung.

    Ihre Daten werden in dem Shape angezeigt, und ein Verknüpfungssymbol wird links neben der Zeile im Fenster Externe Daten angezeigt.

    Eine Zeile auf ein Shape ziehen

    Hinweise : 

    • Sie können eine einzelne Zeile mit mehreren Shapes verknüpfen, doch nicht mehrere Zeilen mit einem einzelnen Shape.

    • Ändern oder die Darstellung des Shapes und Daten zu verbessern, finden Sie unter Optimieren von Daten mit Datengrafiken.

    • Klicken Sie zum Anzeigen des Fensters Externe Daten im Menü Ansicht auf Fenster für externe Daten.

Automatisches Verknüpfen von Zeilen mit vorhandenen Shapes

Dieser Ansatz empfiehlt sich für vorhandene Zeichnungen mit vielen Shapes. Sie können diesen Ansatz nur nutzen, wenn die Shapes bereits Daten enthalten, die Sie mit den Daten in der Datenquellen abgleichen können.

  1. Klicken Sie im Menü Daten auf Automatisch verknüpfen.

  2. Führen Sie die Schritte im Assistenten zum automatischen Verknüpfen aus.

    Die Daten werden in den Shapes angezeigt. Ändern oder die Darstellung des Shapes und Daten zu verbessern, finden Sie unter Optimieren von Daten mit Datengrafiken.

Für die meisten Seiten des Assistenten ist eine spezielle Hilfe verfügbar. Drücken Sie F1, oder klicken Sie auf das Hilfesymbol, um die Hilfe aufzurufen.

Erstellen von Shapes aus Daten

Dieser Ansatz empfiehlt sich, wenn die Zeichnung noch keine Shapes enthält und Sie keine bestimmten Shapes verwenden müssen.

  1. Klicken Sie auf ein Shape im Fenster Shapes.

  2. Ziehen Sie eine Zeile oder eine Gruppe von Zeilen aus dem Fenster Externe Daten auf einen leeren Bereich in der Zeichnung.

    Eine Instanz des Shapes, auf das Sie geklickt haben, wird für jede Zeile angezeigt, die Sie auf die Zeichnung ziehen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×