Importieren oder Exportieren von Textdateien (TXT oder CSV)

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Es gibt zwei Möglichkeiten, mithilfe von Microsoft Excel Daten aus einer Textdatei zu importieren: Sie können die Textdatei in Excel öffnen, oder Sie können die Textdatei als externen Datenbereich importieren. Mit dem Befehl Speichern unter können Sie Daten aus Excel in eine Textdatei exportieren.

Es gibt zwei häufig verwendete Textdateiformate:

  • Textdateien mit Trennzeichen (TXT), in denen die einzelnen Textfelder üblicherweise durch TAB-Zeichen (ASCII-Zeichencode 009) getrennt sind.

  • Kommagetrennte Werttextdateien (CSV), in denen die einzelnen Textfelder üblicherweise durch Kommas (,) getrennt sind.

Sie können das Trennzeichen ändern, das in durch Trennzeichen getrennten Dateien und in CSV-Textdateien verwendet wird. Dies kann erforderlich sein um sicherzustellen, das der Import- oder Exportvorgang in der gewünschten Weise abläuft.

Hinweise    

  • Sie können bis zu 1.048.576 Zeilen und 16.384 Spalten importieren oder exportieren.

Was möchten Sie tun?

Importieren einer Textdatei durch Öffnen der Datei in Excel

Importieren einer Textdatei durch Herstellen einer Verbindung mit der Datei

Exportieren von Daten in eine Textdatei durch Speichern der Daten

Ändern des in einer Textdatei verwendeten Trennzeichens

Ändern des Trennzeichens in allen CSV-Textdateien

Importieren einer Textdatei durch Öffnen der Datei in Excel

Mit dem Befehl Öffnen können Sie eine Textdatei öffnen, die nicht in einer Excel-Arbeitsmappe, sondern in einem anderen Programm erstellt wurde. Wenn Sie eine Textdatei in Excel öffnen, wird das Format der Datei nicht verändert . Dies geht aus der Excel-Titelleiste hervor, in der die Dateinamenerweiterung der Textdatei (z. B. TXT oder CSV) beibehalten wird.

  1. Klicken Sie auf die Registerkarte Datei und dann auf Öffnen.

    Wenn Sie Excel 2007 verwenden, klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche und dann auf Öffnen.

  2. Wählen Sie im Dialogfeld Öffnen die Option Textdateien aus.

  3. Suchen Sie die Textdatei, die Sie öffnen möchten, und doppelklicken Sie darauf.

    • Handelt es sich bei der Datei um eine Textdatei (TXT), wird von Excel der Textimport-Assistent gestartet. Wenn Sie diese Schritte abgeschlossen haben, klicken Sie auf Fertig stellen, um den Importvorgang abzuschließen.

    • Lesen Sie: Importieren von Daten mithilfe des Textimport-Assistenten, wenn Sie weitere Informationen zu Trennzeichen und erweiterten Optionen benötigen.

    • Handelt es sich bei der Datei um eine CSV-Datei, wird sie von Excel automatisch geöffnet, und die Daten werden in einer neuen Arbeitsmappe angezeigt.

      Hinweis    Wenn in Excel eine CSV-Datei geöffnet wird, werden die Standardeinstellungen für das Datenformat verwendet, um zu interpretieren, wie die einzelnen Datenspalten importiert werden müssen. Wenn Sie beim Konvertieren von Spalten in unterschiedliche Datenformate ein größeres Maß an Flexibilität wünschen, können Sie den Textimport-Assistenten verwenden. Beispielsweise kann das Datenformat einer Datenspalte in einer CSV-Datei MTJ sein, das Standarddatenformat in Excel ist jedoch TMJ, oder Sie möchten eine Spalte, die Zahlen mit führenden Nullen enthält, in Text konvertieren, sodass die führenden Nullen beibehalten werden. Zum zwangsweisen Ausführen des Textimport-Assistenten in Excel können Sie die Dateierweiterung von CSV in TXT ändern, bevor Sie die Datei öffnen, oder eine Textdatei importieren, indem eine Verbindung mit der Datei hergestellt wird.

Seitenanfang

Importieren einer Textdatei durch Herstellen einer Verbindung mit der Datei

Sie können Daten aus einer Textdatei als Externer Datenbereich in ein vorhandenes Arbeitsblatt importieren.

  1. Klicken Sie auf die Zelle, in die die Daten aus der Textdatei eingefügt werden sollen.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Aus Text.

    Abbildung des Excel-Menübands

  3. Suchen Sie die Textdatei, die Sie importieren möchten, und doppelklicken Sie auf diese.

    Befolgen Sie die Anweisungen des Textimport-Assistenten. Klicken Sie auf jeder beliebigen Seite des Text-Import-Assistenten auf Hilfe Schaltflächensymbol , um weitere Informationen zum Verwenden des Assistenten anzuzeigen. Wenn Sie diese Schritte im Assistenten abgeschlossen haben, klicken Sie auf Fertig stellen, um den Importvorgang abzuschließen.

  4. Führen Sie im Dialogfeld Daten importieren folgende Schritte aus:

    • Sie können auch auf Eigenschaften klicken, um die Aktualisierungs-, Formatierungs- und Layoutoptionen für die importierten Daten festzulegen.

    • Führen Sie unter Wo sollen die Daten eingefügt werden? eine der folgenden Aktionen aus:

      • Wenn Sie die Daten an der ausgewählten Position zurückgeben möchten, klicken Sie auf Vorhandenes Arbeitsblatt.

      • Wenn Sie die Daten an die obere linke Ecke eines neuen Arbeitsblatts zurückgeben möchten, klicken Sie auf Neues Arbeitsblatt.

  5. Klicken Sie auf OK.

    Der externe Datenbereich wird in Excel an der angegebenen Position eingefügt.

Wenn eine Datenspalte von Excel nicht in das gewünschte Format konvertiert wird, können Sie die Daten nach dem Import umwandeln. Weitere Informationen finden Sie unter Konvertieren von Zahlen, die als Text gespeichert wurden und Konvertieren von Datumsangaben, die als Text gespeichert wurden, in Datumswerte.

Seitenanfang

Exportieren von Daten in eine Textdatei durch Speichern der Daten

Mit dem Befehl Speichern unter können Sie ein Excel-Arbeitsblatt in eine Textdatei konvertieren.

  1. Klicken Sie auf die Registerkarte Datei, und klicken Sie dann auf Speichern unter.

    • Das Dialogfeld Speichern unter wird angezeigt.

  2. Wählen Sie im Feld Dateityp das Textdateiformat für das Arbeitsblatt aus.

    • Klicken Sie z. B. auf Text (Tabstopp-getrennt) oder CSV (Trennzeichen-getrennt).

    • Hinweis : Die verschiedenen Formate unterstützen unterschiedliche Featuregruppen. Informationen zu den Featuregruppen, die von den verschiedenen Textdateiformaten unterstützt werden, finden Sie unter Dateiformate, die von Excel unterstützt werden.

  3. Navigieren Sie zum dem Speicherort, an dem die neue Textdatei gespeichert werden soll, und klicken Sie dann auf Speichern.

  4. Sie werden in einem Dialogfeld darauf hingewiesen, dass nur das aktuelle Arbeitsblatt in der neuen Datei gespeichert wird. Wenn Sie sicher sind, dass das aktuelle Arbeitsblatt als Textdatei gespeichert werden soll, klicken Sie auf OK. Sie können weitere Arbeitsblätter als separate Textdateien speichern, indem Sie dieses Verfahren für jedes einzelne Arbeitsblatt wiederholen.

  5. In einem zweiten Dialogfeld werden Sie daran erinnert, dass Ihr Arbeitsblatt Features enthalten kann, die von Textdateiformaten nicht unterstützt werden. Wenn Sie nur die Daten aus dem Arbeitsblatt in der neuen Textdatei speichern möchten, klicken Sie auf Ja. Wenn Sie sich nicht sicher sind und wissen möchten, welche Excel-Features von Textdateiformaten nicht unterstützt werden, klicken Sie auf Hilfe, um weitere Informationen zu erhalten.

Weitere Informationen zum Speichern von Dateien in anderen Formaten finden Sie unter Speichern einer Arbeitsmappe in einem anderen Dateiformat.

Seitenanfang

Ändern des in einer Textdatei verwendeten Trennzeichens

Wenn Sie zum Importieren einer Datei den Textimport-Assistenten verwenden, können Sie in Schritt 2 des Assistenten das Trennzeichen, das für eine getrennte Textdatei verwendet wird, von einem TAB-Zeichen in ein anderes Zeichen ändern. In diesem Schritt können Sie darüber hinaus ändern, wie aufeinanderfolgende Trennzeichen (z. B. aufeinanderfolgende Anführungszeichen) behandelt werden.

Lesen Sie: Importieren von Daten mithilfe des Textimport-Assistenten, wenn Sie weitere Informationen zu Trennzeichen und erweiterten Optionen benötigen.

Seitenanfang

Ändern des Trennzeichens in allen CSV-Textdateien

  1. Klicken Sie in Microsoft Windows auf Start und dann auf Systemsteuerung.

  2. Öffnen Sie das Dialogfeld für das Ändern der Regions- und Spracheinstellungen.

  3. Geben Sie in das Feld Listentrennzeichen ein neues Trennzeichen ein.

  4. Klicken Sie zweimal auf OK

Hinweis    Nachdem Sie das Listentrennzeichen für Ihren Computer geändert haben, wird das neue Zeichen von allen Programmen verwendet. Mithilfe desselben Verfahrens können Sie das Zeichen auch wieder in das Standardzeichen zurück ändern.

Seitenanfang

Haben Sie eine Frage zu einer bestimmten Funktion?

Eine Frage im Excel-Communityforum stellen

Helfen Sie uns bei der Verbesserung von Excel

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Übersicht über Formeln in Excel

Vermeiden defekter Formeln

Finden und Korrigieren von Fehlern in Formeln

Tastenkombinationen und Funktionstasten in Excel

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×