Ich kann meine replizierte Datenbank nicht im Access 2007-Format speichern

Symptome

In Microsoft Office Access 2007 können replizierte Datenbanken, die in früheren Versionen von Access (MDB-Format) erstellt wurden, nicht im neuen ACCDB-Dateiformat gespeichert werden. Beim Verwenden des Befehls Datenbank speichern unter (klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche und dann auf den Pfeil neben Speichern unter) wird die Option abgeblendet (nicht verfügbar) angezeigt.

Grund

Das ACCDB-Dateiformat unterstützt die Replikation nicht.

Lösung

Verwenden der replizierten Datenbank im MDB-Dateiformat

Sie können die replizierte Datenbank weiterhin im MDB-Dateiformat verwenden. Die Replikationsfunktionalität wird für das MDB-Dateiformat weiter unterstützt.

Manuelles Neuerstellen der Datenbank im Office Access 2007-Dateiformat

Wenn Sie feststellen, dass das neue Dateiformat Vorteile bietet, die die Vorteile der Replikation überwiegen, können Sie eine neue Datenbank im Office Access 2007-Format erstellen und die replizierte Datenbank manuell erneut erstellen.

Hinweis : Diese Methode kann bei jeder replizierten Datenbank verwendet werden. Wenn Sie jedoch kein Vollreplikat verwenden, das mit allen anderen Replikaten in der Replikatgruppe synchronisiert wurde, werden die Daten und Projekte, die sich nicht bereits im Replikat befinden, nicht in die neue Datenbank aufgenommen.

Vergewissern Sie sich vor Beginn der Datenbankneuerstellung, dass alle ausgeblendeten Objekte und Systemobjekte im Replikat sichtbar sind. So stellen Sie sicher, dass Sie bei Neuerstellung auf die replikatspezifischen Felder im Replikat zugreifen können.

  1. Öffnen Sie das Replikat, das Sie konvertieren möchten. Das Replikat muss mit der gleichen Access-Version geöffnet werden, mit der das Replikat ursprünglich erstellt wurde, damit die ausgeblendeten Felder und die Systemfelder angezeigt werden.

  2. Klicken Sie im Menü Extras auf Optionen. Das Dialogfeld Optionen wird geöffnet.

  3. Wählen Sie auf der Registerkarte Ansicht im Abschnitt Anzeigen die Optionen Ausgeblendete Objekte und Systemobjekte. Klicken Sie auf OK, um die neuen Einstellungen zu übernehmen, und schließen Sie das Dialogfeld Optionen.

Manuelles Neuerstellen der Datenbank

  1. Erstellen Sie eine leere Datenbank, und öffnen Sie diese.

    Hinweis : Access erstellt eine neue, leere Tabelle mit dem Namen Tabelle1. Löschen Sie diese Tabelle, indem Sie sie sofort schließen, ohne Änderungen daran vorzunehmen. Klicken Sie mit der rechten Maustaste auf die Objektregisterkarte und klicken Sie im Kontextmenü auf Schließen.

  2. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren auf Access.

    Das Dialogfeld Externe Daten - Access-Datenbank wird angezeigt.

  3. Klicken Sie auf Durchsuchen, um die replizierte Datenbank zu suchen.

  4. Klicken Sie auf die replizierte Datenbank, die die Datenbankobjekte enthält, die Sie in der neuen Datenbank erneut erstellen möchten, und klicken Sie dann auf Öffnen.

  5. Klicken Sie im Dialogfeld Externe Daten - Access-Datenbank auf Importieren Sie Tabellen, Abfragen, Formulare, Berichte, Makros und Module in die aktuelle Datenbank, und klicken Sie dann auf OK.

  6. Klicken Sie auf die Datenbankobjekte, die in die neue Datenbank importiert werden sollen. Wenn Sie alle Objekte importieren möchten, klicken Sie auf der Registerkarte auf Alle auswählen.

    Wichtig    Wählen Sie jetzt noch keine Tabellen aus. Die Tabellen werden später neu erstellt.

  7. Nachdem Sie die Objekte ausgewählt haben, klicken Sie auf OK, um diese zu importieren.

    Auf der letzten Seite des Assistenten verfügen Sie über eine Option zum Speichern der Importschritte für die zukünftige Verwendung. Aktivieren Sie hierfür das Kontrollkästchen Importschritte speichern, geben Sie die entsprechenden Informationen ein und klicken Sie dann auf Import speichern.

  8. Öffnen Sie die replizierte Datenbank in Office Access 2007. Erstellen Sie für jede Tabelle in der replizierten Datenbank eine Tabellenerstellungsabfrage, die alle Daten aus der alten Tabelle liest und eine Tabelle in der neuen Datenbank mit denselben Daten erstellt.

    Hinweis : Wenn das Feld GUID (Globally Unique Identifier) ein Primärschlüssel ist (und Fremdschlüssel in anderen Tabellen darauf verweisen), müssen Sie dieses Feld in die neue Tabelle einfügen. Wird s_GUID dagegen nicht als Primärschlüssel verwendet, besteht kein Grund, das Feld in die neue Tabelle zu übernehmen. Die Felder s_Lineage und s_Generation dürfen nicht in die neue Tabelle kopiert werden.

    Die Felder s_GUID, s_Lineage und s_Generation sind standardmäßig ausgeblendet. Gehen Sie wie folgt vor, um diese Felder anzuzeigen:

    1. Stellen Sie in der replizierten Datenbank sicher, dass alle Tabellen geschlossen sind.

    2. Klicken Sie mit der rechten Maustaste auf den oberen Rand des Navigationsbereichs und dann auf Navigationsoptionen. Das Dialogfeld Navigationsoptionen wird geöffnet.

    3. Wählen Sie im Abschnitt Anzeigeoptionen die Option Systemobjekte anzeigen aus, und klicken Sie dann auf OK .

      So wird's gemacht

      1. Erstellen Sie eine Abfrage, und wählen Sie die Tabellen mit den Datensätzen aus, die in der neuen Tabelle enthalten sein sollen.

        So wird's gemacht

        1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Andere auf Abfrageentwurf.

        2. Klicken Sie im Dialogfeld Tabelle anzeigen auf die Registerkarte für die Tabellen, die Sie verwenden möchten.

        3. Doppelklicken Sie auf den Namen jedes einzelnen Objekts, das Sie der Abfrage hinzufügen möchten, und klicken Sie dann auf Schließen.

        4. Fügen Sie im Entwurfsbereich Felder zur Zeile Feld hinzu.

        5. Klicken Sie im Menü Ansicht auf Datenblattansicht, um das Ergebnis der Abfrage anzuzeigen.

      2. Klicken Sie in der Entwurfsansicht der Abfrage auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Neue Tabelle erstellen. Daraufhin wird das Dialogfeld Neue Tabelle erstellen angezeigt.

      3. Geben Sie im Feld Tabellenname den Namen der Tabelle ein, die Sie erstellen oder ersetzen möchten.

      4. Klicken Sie auf Andere Datenbank, und geben Sie dann entweder den Pfad der Datenbank ein, in der Sie die neue Tabelle speichern möchten, oder klicken Sie auf Durchsuchen, um nach der Datenbank zu suchen.

      5. Klicken Sie auf OK.

      6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Damit wird die neue Tabelle erstellt.

        Hinweis : Die neu erstellte Tabelle übernimmt weder die Feldeigenschaften noch die Einstellung des Primärschlüssel aus der Originaltabelle.

  9. Erstellen Sie für jede Tabelle in der neuen Datenbank den Index und Primärschlüssel, der auch in der Tabelle des Replikats verwendet wird.

    So wird's gemacht

    1. Öffnen Sie eine Tabelle in der Entwurfsansicht.

    2. Klicken Sie im oberen Teil des Fensters auf das Feld, für das Sie einen Index erstellen möchten.

    3. Klicken Sie im unteren Teil des Fensters in das Einstellungsfeld für die Indiziert-Eigenschaft und dann auf Ja (Duplikate möglich) oder Ja (Ohne Duplikate).

    4. Wählen Sie das Feld bzw. die Felder aus, aus denen sich der Primärschlüssel zusammensetzt.

    5. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Extras auf Primärschlüssel.

  10. Erstellen Sie für jede Tabelle in der neuen Datenbank die Beziehung, die für die Replikattabelle bestanden haben.

    So wird's gemacht

    Wenn Sie eine Beziehung zwischen Tabellen erstellen, müssen die verbundenen Felder nicht denselben Namen besitzen. Verbundene Felder müssen jedoch denselben Datentyp aufweisen, es sei denn, der Primärschlüssel ist ein Feld vom Typ AutoWert-Datentyp. Ein Feld vom Typ AutoWert kann nur mit einem Feld vom Typ Zahl verbunden werden, wenn die Feldgröße-Eigenschaft beider verbundenen Felder identisch ist. Sie können z. B. ein Feld vom Typ AutoWert und ein Feld vom Typ Zahl verbinden, wenn die Feldgröße-Eigenschaft beider Felder den Typ Long Integer aufweist. Auch wenn beide Felder den Typ Zahl aufweisen, müssen sie über dieselbe Einstellung für die Feldgröße-Eigenschaft verfügen.

    Definieren einer 1:n-Beziehung oder einer 1:1-Beziehung

    1. Schließen Sie alle geöffneten Tabellen. Sie können keine Beziehungen zwischen geöffneten Tabellen erstellen oder bearbeiten.

    2. Klicken Sie auf der Registerkarte Datenbanktools in der Gruppe Einblenden/Ausblenden auf Beziehungen.

    3. Wenn Sie noch keine Beziehungen in der Datenbank definiert haben, wird das Dialogfeld Tabelle anzeigen automatisch angezeigt.

      Wenn Sie die Tabellen, die Sie verknüpfen möchten, hinzufügen müssen, und das Dialogfeld Tabelle anzeigen nicht angezeigt wird, rufen Sie es auf: Klicken Sie auf der Registerkarte Entwurf in der Gruppe Einblenden/Ausblenden auf die Schaltfläche Tabelle anzeigen.

    4. Doppelklicken Sie auf die Namen der Tabellen, die Sie miteinander verknüpfen möchten, und schließen Sie dann das Dialogfeld Tabelle anzeigen. Wenn Sie für eine Tabelle eine Beziehung zu sich selbst herstellen möchten, fügen Sie diese Tabelle zweimal hinzu.

    5. Ziehen Sie das zu verknüpfende Feld aus der einen Tabelle zum Detailfeld in der anderen Tabelle.

      Drücken Sie die STRG-TASTE, um mehrere Felder gleichzeitig zu ziehen. Klicken Sie auf die einzelnen Felder, und ziehen Sie sie dann zur neuen Position.

      In den meisten Fällen ziehen Sie das Primärschlüsselfeld (das in fettgesetztem Text angezeigt wird) aus einer Tabelle zu einem ähnlichen Feld (oft mit demselben Namen), das als Fremdschlüssel bezeichnet wird, in der anderen Tabelle.

    6. Das Dialogfeld Beziehungen bearbeiten wird angezeigt. Prüfen Sie, ob die in beiden Spalten angezeigten Feldnamen richtig sind. Sie können sie bei Bedarf ändern.

      Legen Sie ggf. die Beziehungsoptionen fest.

    7. Klicken Sie auf die Schaltfläche Erstellen, um die Beziehung zu erstellen.

    8. Wiederholen Sie die Schritte 4 bis 7 für jedes Paar, für das Sie eine Beziehung erstellen möchten.

      Wenn Sie das Dialogfeld "Beziehungen" schließen, werden Sie in Microsoft Access gefragt, ob Sie das Layout speichern möchten. Unabhängig davon, ob Sie das Layout speichern, werden die erstellten Beziehungen in der Datenbank gespeichert.

    Definieren einer n:n-Beziehung

    1. Erstellen Sie die beiden Tabellen, zwischen denen eine m:n-Beziehung erstellt werden soll.

    2. Erstellen Sie eine dritte Tabelle, eine so genannte Verknüpfungstabelle. Fügen Sie Felder zu dieser Verknüpfungstabelle hinzu, deren Definitionen mit denen der Primärschlüsselfelder aus den beiden anderen Tabellen identisch sind. Die Primärschlüsselfelder in der Verknüpfungstabelle dienen als Fremdschlüssel. Genauso wie jeder anderen Tabelle können Sie der Verknüpfungstabelle auch andere Felder hinzufügen.

    3. Legen Sie den Primärschlüssel der Verknüpfungstabelle auf die Primärschlüsselfelder der beiden anderen Tabellen fest. So besteht z. B. in einer Verknüpfungstabelle Bestelldetails der Primärschlüssel aus den Feldern Bestell-Nr und Artikel-Nr.

      So wird's gemacht

      1. Öffnen Sie die Tabelle in der Entwurfsansicht.

      2. Markieren Sie das Feld bzw. die Felder, das/die Sie als Primärschlüssel definieren möchten.

        Klicken Sie auf den Zeilenmarkierer des gewünschten Felds, um ein einziges Feld zu markieren.

        Halten Sie STRG gedrückt, um mehrere Felder zu markieren, und klicken Sie auf den Zeilenmarkierer jedes einzelnen Felds.

      3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Extras auf Primärschlüssel.

        Hinweis : Wenn die Felder in einem aus mehreren Feldern bestehenden Primärschlüssel in einer anderen Reihenfolge sortiert werden sollen als die Felder in der Tabelle, klicken Sie in der Gruppe Einblenden/Ausblenden auf die Schaltfläche Indizes, um das Fenster "Indizes" anzuzeigen, und sortieren Sie dann die Feldnamen für den Index mit dem Namen Primärschlüssel neu.

    4. Definieren Sie eine 1:n-Beziehung zwischen jeder der beiden Mastertabelle und der Verknüpfungstabelle.

  11. Speichern Sie die neue Datenbank.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×