Hinzufügen oder Entfernen von Add-Ins in Excel

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Add-Ins bieten optionale Befehle und Features für Microsoft Excel. Standardmäßig sind Add-Ins in Excel nicht sofort verfügbar, daher müssen Sie die Add-ins zunächst installieren und (in einigen Fällen) aktivieren, damit Sie Sie verwenden können.

Suchen Sie nach Informationen zu Office-Add-Ins, die auf HTML, CSS und JS basieren? Wenn dies der Fall ist, lesen Sie Abrufen eines Office-Add-Ins für Excel.

Einige Add-Ins sind in Excel integriert, wie Solver und Analyse-Funktionen. Andere Add-Ins stehen im Download Center zur Verfügung und müssen zuerst heruntergeladen und installiert werden. Schließlich gibt es Add-Ins, die von Drittanbietern erstellt werden, beispielsweise ein Programmierer in Ihrer Organisation oder ein Softwarelösungsanbieter. Dies können COM-Add-Ins (Component Object Model), Visual Basic für Applikationen (VBA)-Add-Ins und DLL-Add-ins sein. Diese Add-Ins müssen ebenfalls installiert sein, damit Sie verwendet werden können.

Die meisten Add-Ins können in drei verschiedene Typen kategorisiert werden:

  • Excel-Add-ins    Dazu gehören in der Regel Excel-Add-in (. xlam), Excel 97-2003-Add-in (. xla) oder DLL-Add-in-Dateien (XLL) oder Automatisierungs-Add-Ins. Einige Excel-Add-Ins, wie Solver und Analyse-Funktionen, sind möglicherweise nach der Installation von Excel oder Microsoft Office verfügbar. In der Regel müssen Sie diese Add-Ins nur aktivieren, um Sie zu verwenden.

  • Herunterladbare Add-ins    Weitere Add-Ins für Excel können in Downloads unter Office.com heruntergeladen und installiert werden.

  • Benutzerdefinierte Add-ins    Entwickler und Lösungsanbieter entwerfen in der Regel benutzerdefinierte COM-Add-Ins (Component Object Model), Automatisierungs-Add-Ins, VBA-Add-Ins und XLL-Add-Ins. Diese müssen installiert sein, damit Sie Sie verwenden können.

Nachdem Sie ein Add-in installiert oder aktiviert haben, stehen das Add-in und dessen Befehle möglicherweise an einem der folgenden Speicherorte zur Verfügung:

  • Registerkarte " Daten " Nachdem Sie die Analyse-Funktionen und Solver-Add-Ins installiert und aktiviert haben, stehen die Befehle Datenanalyse und Solver in der Gruppe Analyse zur Verfügung.

    Schaltfläche 'Datenanalyse' in der Gruppe 'Datenanalyse'

  • Registerkarte " Formeln " Nachdem Sie die Euro-Währungs Tools installiert und aktiviert haben, werden die Befehle Euro-Konvertierung und Euro-Formatierung in der Gruppe Lösungen angezeigt.

    'Eurokonvertierung' und 'Euroformatierung'

  • Registerkarte " Add-ins " Auf der Registerkarte Add-ins können weitere Add-Ins hinzugefügt werden. Diese Registerkarte wird dem Menüband hinzugefügt, wenn Sie das erste Add-in installieren und aktivieren, das auf der Registerkarte " Add-ins " angezeigt wird. Wenn die Registerkarte Add-ins nicht angezeigt wird, sollten Sie Excel beenden und neu starten.

Andere Add-Ins, beispielsweise die Registerkarte Erste Schritte , sind an anderen Stellen in Excel verfügbar, beispielsweise eine Registerkarte im Menüband oder über Makros oder angepasste Menüs.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installations-und Entfernungsprogramme für Ihr Add-in entwerfen.

So aktivieren Sie ein Excel-Add-in    

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

    Das Dialogfeld Add-ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-ins das Kontrollkästchen neben dem Add-in, das Sie aktivieren möchten, und klicken Sie dann auf OK.

Wenn Sie das Add-in, das Sie aktivieren möchten, im Feld Verfügbare Add-ins nicht finden können, müssen Sie es möglicherweise installieren.

So installieren Sie ein Excel-Add-in    

  • Wenn Sie ein Add-in installieren möchten, das in der Regel mit Excel installiert ist, wie Solver oder Analyse-Funktionen, führen Sie das Setupprogramm für Excel oder Microsoft Office aus, und wählen Sie die Option ändern aus, um das Add-in zu installieren. Nachdem Sie Excel neu gestartet haben, sollte das Add-in im Feld Verfügbare Add-ins angezeigt werden.

  • Einige Excel-Add-ins befinden sich auf Ihrem Computer und können installiert oder aktiviert werden, indem Sie auf Durchsuchen (im Dialogfeld Add-ins ) klicken, um das Add-in zu suchen, und dann auf OKklicken.

  • Für einige Excel-Add-Ins muss ein Installationspaket ausgeführt werden. Möglicherweise müssen Sie das Installationspaket auf Ihren Computer herunterladen oder kopieren (ein Installationspaket ist in der Regel eine Datei mit der Dateinamenerweiterung MSI), und führen Sie es dann aus.

  • Andere Add-Ins, die auf Ihrem Computer nicht verfügbar sind, können über einen Webbrowser heruntergeladen und von Downloads oder von anderen Websites im Internet oder einem Server in Ihrer Organisation installiert werden. Befolgen Sie die Setupanweisungen für den Download nach Bedarf.

So deaktivieren Sie ein Excel-Add-in    

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

  3. Deaktivieren Sie im Feld Verfügbare Add-ins das Kontrollkästchen neben dem Add-in, das Sie deaktivieren möchten, und klicken Sie dann auf OK.

    Wenn Sie ein Add-in deaktivieren, wird es in vielen Fällen aus seiner Gruppe im Menüband entfernt. In anderen Fällen müssen Sie Excel möglicherweise neu starten, um das Add-in aus dem Menüband zu entfernen.

    Hinweis    Wenn Sie ein Add-in deaktivieren, wird das Add-in nicht von Ihrem Computer entfernt. Wenn Sie das Add-in von Ihrem Computer entfernen möchten, müssen Sie es deinstallieren.

So entfernen Sie ein Excel-Add-in    

Wichtig: Wenn Sie das Excel-Add-in ursprünglich von einem Netzwerkdateiserver oder aus einem freigegebenen Ordner installiert haben, müssen Sie das Add-in möglicherweise von diesem Speicherort entfernen. Wenn Sie das Excel-Add-in von einer CD installiert haben und Ihr CD-Laufwerk nach der Installation des Add-ins einem neuen Laufwerksbuchstaben zugeordnet haben, müssen Sie das Add-in von der CD erneut installieren. Wenn Sie Excel-Add-Ins auf der CD ausführen, müssen Sie die Excel-Add-Ins deinstallieren und dann von der CD erneut installieren.

  1. Klicken Sie auf die Registerkarte Datei , und klicken Sie dann auf Beenden.

  2. Klicken Sie in der Systemsteuerung auf Programme und Funktionen (Windows 7 und Windows Vista) oder Programme hinzufügen/entfernen (Windows XP).

  3. Führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie Excel als Teil von Microsoft Office installiert haben, klicken Sie in der Liste der installierten Programme auf Microsoft Office und dann auf die Schaltfläche ändern .

    • Wenn Sie Excel einzeln installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen des Programms, und klicken Sie dann auf die Schaltfläche ändern .

    • Wenn Sie das Add-in aus dem Download Center installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen des Programms, und klicken Sie dann auf die Schaltfläche " deinstallieren ".

  4. Befolgen Sie die Anweisungen im Installationsprogramm.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installations-und Entfernungsprogramme für Ihr Add-in entwerfen. Wenn Sie kein Entwickler sind, sollten Sie diese Vorgehensweise nicht benötigen. Wenden Sie sich an den System Administrator, der das Add-in bereitgestellt hat, wenn Sie Anweisungen zum Installieren und entfernen wünschen.

Hinzufügen eines COM-Add-ins

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf com-Add-ins, und klicken Sie dann auf Gehezu.

    Das Dialogfeld com-Add-ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-ins das Kontrollkästchen neben dem Add-in, das Sie installieren möchten, und klicken Sie dann auf OK.

    Tipp    Wenn das Add-in, das Sie verwenden möchten, im Feld Verfügbare Add-ins nicht aufgeführt ist, klicken Sie auf Hinzufügen, und suchen Sie das Add-in.

Entfernen eines COM-Add-ins

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf com-Add-ins, und klicken Sie dann auf Gehezu.

    Das Dialogfeld com-Add-ins wird angezeigt.

  3. Deaktivieren Sie im Feld Verfügbare Add-ins das Kontrollkästchen neben dem Add-in, das Sie entfernen möchten, und klicken Sie dann auf OK.

    Hinweis    Dadurch wird das Add-in aus dem Arbeitsspeicher entfernt, der Name bleibt jedoch in der Liste der verfügbaren Add-Ins erhalten. Das Add-in wird nicht von Ihrem Computer gelöscht.

  4. Wenn Sie ein COM-Add-in aus der Liste der verfügbaren Add-ins entfernen und das Add-in von Ihrem Computer löschen möchten, klicken Sie im Feld Verfügbare Add-ins auf seinen Namen, und klicken Sie dann auf Entfernen.

Hinweis: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installations-und Entfernungsprogramme für Ihr Add-in entwerfen. Wenn Sie kein Entwickler sind, sollten Sie diese Vorgehensweise nicht benötigen. Wenden Sie sich an den System Administrator, der das Add-in bereitgestellt hat, wenn Sie Anweisungen zum Installieren und entfernen wünschen.

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

    Das Dialogfeld Add-ins wird angezeigt.

  3. Wenn Sie ein Automatisierungs-Add-in installieren möchten, klicken Sie im Feld Verfügbare Automatisierungsserver auf Automatisierung, und klicken Sie dann auf das gewünschte Add-in.

    Tipp    Wenn das gewünschte Add-in nicht in der Liste enthalten ist, klicken Sie auf Durchsuchen, suchen Sie das Add-in, und klicken Sie dann auf OK.

  4. Wenn Sie ein Automatisierungs-Add-in entfernen möchten, müssen Sie es aus der Registrierung entfernen. Weitere Informationen hierzu erhalten Sie von Ihrem System Administrator.

Einige Add-Ins sind in Excel integriert, wie Solver und Analyse-Funktionen. Andere Add-Ins stehen im Download Center zur Verfügung und müssen zuerst heruntergeladen und installiert werden. Schließlich gibt es Add-Ins, die von Drittanbietern erstellt werden, beispielsweise ein Programmierer in Ihrer Organisation oder ein Softwarelösungsanbieter. Dies können COM-Add-Ins (Component Object Model), Visual Basic für Applikationen (VBA)-Add-Ins und DLL-Add-ins sein. Diese Add-Ins müssen ebenfalls installiert sein, damit Sie verwendet werden können.

Die meisten Add-Ins können in drei verschiedene Typen kategorisiert werden:

  • Excel-Add-ins    Dazu gehören in der Regel Excel-Add-in (. xlam), Excel 97-2003-Add-in (. xla) oder DLL-Add-in-Dateien (XLL) oder Automatisierungs-Add-Ins. Einige Excel-Add-Ins, wie Solver und Analyse-Funktionen, sind möglicherweise nach der Installation von Excel oder Microsoft Office verfügbar. In der Regel müssen Sie diese Add-Ins nur aktivieren, um Sie zu verwenden.

  • Herunterladbare Add-ins    Weitere Add-Ins für Excel können in Downloads unter Office.com heruntergeladen und installiert werden.

  • Benutzerdefinierte Add-ins    Entwickler und Lösungsanbieter entwerfen in der Regel benutzerdefinierte COM-Add-Ins (Component Object Model), Automatisierungs-Add-Ins, VBA-Add-Ins und XLL-Add-Ins. Diese müssen installiert sein, damit Sie Sie verwenden können.

Nachdem Sie ein Add-in installiert oder aktiviert haben, stehen das Add-in und dessen Befehle möglicherweise an einem der folgenden Speicherorte zur Verfügung:

  • Registerkarte " Daten " Nachdem Sie die Analyse-Funktionen und Solver-Add-Ins installiert und aktiviert haben, stehen die Befehle Datenanalyse und Solver auf der Registerkarte Daten im Menüband zur Verfügung.

  • Registerkarte " Start ". Auf der Registerkarte " Start " können weitere Add-Ins hinzugefügt werden.

Andere Add-Ins, beispielsweise die Registerkarte Erste Schritte , sind an anderen Stellen in Excel verfügbar, beispielsweise eine Registerkarte im Menüband oder über Makros oder angepasste Menüs.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installations-und Entfernungsprogramme für Ihr Add-in entwerfen.

So aktivieren Sie ein vorinstalliertes Excel-Add-in    

  1. Wählen Sie im Menü Extras die Option Add-insaus.

  2. Aktivieren Sie im Feld Verfügbare Add-ins das Kontrollkästchen für das Add-in, das Sie aktivieren möchten, und klicken Sie dann auf OK.

So installieren Sie ein Excel-Add-in    

  • Einige Excel-Add-ins befinden sich auf Ihrem Computer und können installiert oder aktiviert werden, indem Sie auf Durchsuchen (im Dialogfeld Add-ins oben) klicken, um das Add-in zu suchen, und dann auf OKklicken.

  • Für einige Excel-Add-Ins muss ein Installationspaket ausgeführt werden. Möglicherweise müssen Sie das Installationspaket auf Ihren Computer herunterladen oder kopieren (ein Installationspaket ist in der Regel eine Datei mit der Dateinamenerweiterung MSI), und führen Sie es dann aus.

  • Andere Add-Ins, die auf Ihrem Computer nicht verfügbar sind, können über einen Webbrowser heruntergeladen und von Downloads oder von anderen Websites im Internet, einem Server in Ihrer Organisation oder mithilfe der integrierten Store -Option in Excel heruntergeladen und installiert werden. Befolgen Sie die Setupanweisungen für den Download nach Bedarf.

    So installieren Sie Add-Ins aus dem Store

    1. Klicken Sie im Menüband auf die Registerkarte Einfügen .

    2. Klicken Sie auf die Schaltfläche Store .

    3. Verwenden Sie das Feld Kategorien oder Suchfeld , um Add-Ins zu finden.

    4. Klicken Sie auf Hinzufügen , um das Add-in zu installieren.

      Hinweis: Einige Add-Ins müssen gekauft werden.

So entfernen Sie ein Excel-Add-in    

  1. Klicken Sie auf die Registerkarte Einfügen , und klicken Sie dann auf Meine Add-ins.

  2. Klicken Sie in Office-Add-insauf das 3-Punkte-Menü neben dem Add-in.

  3. Klicken Sie auf Entfernen.

  4. Lesen Sie den Hinweis zu anderen Geräten, und klicken Sie auf Entfernen.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×