Hinzufügen oder Entfernen von Add-Ins

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Add-Ins bieten optionale Befehle und Features für Microsoft Excel. Add-Ins sind in Excel standardmäßig nicht sofort verfügbar, daher müssen Sie diese Add-Ins (in einigen Fällen) zuerst installieren, bevor sie verwendet werden können.

Suchen Sie nach Informationen zu Office-Add-ins basierend auf HTML, CSS und JS? Wenn Sie sind, finden Sie unter Abrufen einer Office-Add-in für Excel.

Informationen zu Add-Ins

Einige Add-Ins wie Solver und die Analyse-Funktionen sind in Excel integriert. Andere Add-Ins stehen über das Download Center zur Verfügung und müssen zuerst heruntergeladen und installiert werden. Außerdem gibt es noch Add-Ins, die von Drittanbietern erstellt werden, z. B. Programmierern im Unternehmen oder Anbietern von Softwarelösungen. Hierbei kann es sich um COM-Add-Ins (Component Object Model), VBA-Add-Ins (Visual Basic for Applications) und DLL-Add-Ins handeln. Um diese Add-Ins zu verwenden, müssen sie ebenfalls installiert werden.

Die meisten Add-Ins können in drei verschiedene Typen eingestuft werden:

  • Excel-Add-Ins    Diese umfassen normalerweise Excel-Add-Ins (.xlam), Excel 97-2003-Add-Ins (.xla) oder DLL-Add-Ins (.xll), oder es handelt sich um Automatisierungs-Add-Ins. Einige Excel-Add-Ins wie Solver und die Analyse-Funktionen stehen möglicherweise zur Verfügung, nachdem Sie Excel oder Microsoft Office installiert haben. Normalerweise müssen Sie diese Add-Ins nur aktivieren, damit Sie sie verwenden können.

  • Herunterladbare Add-Ins    Zusätzliche Add-Ins für Excel können von Downloads unter Office.com heruntergeladen und installiert werden.

  • Benutzerdefinierte Add-Ins    Entwickler und Lösungsanbieter entwickeln normalerweise benutzerdefinierte COM-Add-Ins (Component Object Model, Automatisierungs-Add-Ins, VBA-Add-Ins und XLL-Add-Ins. Diese müssen installiert werden, damit Sie sie verwenden können.

Nachdem Sie ein Add-In installiert oder aktiviert haben, stehen das Add-In und seine Befehle möglicherweise an einer der folgenden Positionen zur Verfügung:

  • Registerkarte Daten. Nachdem Sie die Add-Ins für Solver und die Analyse-Funktionen installiert und aktiviert haben, stehen die Befehle Datenanalyse und Solver in der Gruppe Analyse zur Verfügung.

    Schaltfläche 'Datenanalyse' in der Gruppe 'Datenanalyse'

  • Registerkarte Formeln. Nachdem Sie die Eurowährungstools installiert und aktiviert haben, werden die Befehle Eurokonvertierung und Euroformatierung in der Gruppe Lösungen angezeigt.

    'Eurokonvertierung' und 'Euroformatierung'

  • Registerkarte Add-Ins. Weitere Add-Ins können zur Registerkarte Add-Ins hinzugefügt werden. Diese Registerkarte wird zum Menüband hinzugefügt, wenn Sie das erste Add-In installieren und aktivieren, das auf der Registerkarte Add-Ins angezeigt wird. Wenn die Registerkarte Add-Ins nicht angezeigt wird, sollten Sie Excel beenden und dann neu starten.

Weitere Add-Ins wie die Registerkarte Erste Schritte stehen an anderen Positionen in Excel zur Verfügung, z. B. als Registerkarte im Menüband oder über Makros oder benutzerdefinierte Menüs.

Seitenanfang

Hinzufügen oder Entfernen von Excel-Add-Ins

Wichtig : Wenn Sie Softwareentwickler sind, können Sie mit dieser Prozedur ein Automatisierungsprogramm installieren oder entfernen, bevor Sie Programme zum Installieren und Entfernen für Ihr Add-In entwickeln.

So aktivieren Sie ein Excel-Add-In    

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf Gehe zu.

    Das Dialogfeld Add-Ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu aktivierenden Add-In, und klicken Sie auf OK.

Wenn Sie das zu aktivierende Add-In im Feld Verfügbare Add-Ins nicht finden können, müssen Sie es möglicherweise installieren.

So installieren Sie ein Excel-Add-In    

  • Zum Installieren eines normalerweise mit Excel installierten Add-Ins wie Solver oder der Analyse-Funktionen führen Sie das Setupprogramm für Excel oder Microsoft Office aus, und wählen die Option Ändern aus, um das Add-In zu installieren. Nach dem Neustart von Excel sollte das Add-In im Feld Verfügbare Add-Ins angezeigt werden.

  • Einige Excel-Add-Ins befinden sich auf dem Computer und können installiert oder aktiviert werden, indem Sie auf die Schaltfläche Durchsuchen klicken (im Dialogfeld Add-Ins), um das Add-In zu suchen. Anschließend klicken Sie auf OK.

  • Einige Excel-Add-Ins erfordern das Ausführen eines Installationspakets. Sie müssen das Installationspaket möglicherweise auf den Computer herunterladen oder kopieren (ein Installationspaket besteht normalerweise aus einer Datei mit der Dateinamenerweiterung MSI) und es dort ausführen.

  • Andere auf dem Computer nicht verfügbare Add-Ins können über einen Webbrowser von Downloads oder von anderen Websites im Internet oder von einem Server im Unternehmen heruntergeladen und installiert werden. Befolgen Sie bei Bedarf die Installationsanweisungen für den Download.

So deaktivieren Sie ein Excel-Add-In    

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf Gehe zu.

  3. Deaktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu deaktivierenden Add-In, und klicken Sie auf OK.

    Wenn Sie ein Add-In deaktivieren, wird es in vielen Fällen aus seiner Gruppe im Menüband entfernt. In anderen Fällen müssen Sie Excel möglicherweise neu starten, um das Add-In vom Menüband zu entfernen.

    Anmerkung    Durch das Deaktivieren eines Add-Ins wird es nicht von Ihrem Computer entfernt. Wenn Sie das Add-In vom Computer entfernen möchten, müssen Sie es deinstallieren.

So entfernen Sie ein Excel-Add-In    

Wichtig : Wenn Sie das Excel-Add-In ursprünglich von einem Netzwerk-Dateiserver oder aus einem freigegebenen Ordner installiert haben, müssen Sie das Add-In möglicherweise von derselben Stelle aus entfernen. Wenn Sie das Excel-Add-In von einer CD installiert haben und Sie Ihrem CD-Laufwerk nach der Installation einen neuen Laufwerksbuchstaben zugewiesen haben, müssen Sie das Add-In erneut von der CD installieren. Wenn Sie Excel-Add-Ins von der CD ausführen, müssen Sie die Excel-Add-Ins deinstallieren und sie dann erneut von der CD installieren.

  1. Klicken Sie auf die Registerkarte Datei und dann auf Beenden.

  2. Klicken Sie in der Systemsteuerung auf Programme und Funktionen (Windows 7 und Windows Vista) oder auf Software (Windows XP).

  3. Führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie Excel als Bestandteil von Microsoft Office installiert haben, klicken Sie in der Liste der installierten Programme auf Microsoft Office, und klicken Sie dann auf die Schaltfläche Ändern.

    • Wenn Sie Excel separat installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen Ihres Programms, und klicken Sie dann auf die Schaltfläche Ändern.

    • Wenn Sie das Add-In aus dem Download Center installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen des Programms, und klicken Sie dann auf die Schaltfläche Deinstallieren.

  4. Folgen Sie den Anweisungen im Installationsprogramm.

Seitenanfang

Hinzufügen oder Entfernen von COM-Add-Ins

Wichtig : Wenn Sie Softwareentwickler sind, können Sie mit dieser Prozedur ein Automatisierungsprogramm installieren oder entfernen, bevor Sie Programme zum Installieren und Entfernen für Ihr Add-In entwickeln. Wenn Sie kein Entwickler sind, brauchen Sie diese Prozedur nicht zu verwenden. Wenden Sie sich an den Systemadministrator, der das Add-In bereitgestellt hat, wenn Sie Anweisungen zum Installieren und Entfernen benötigen.

Hinzufügen eines COM-Add-Ins

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf COM-Add-Ins, und klicken Sie dann auf Gehe zu.

    Das Dialogfeld COM-Add-Ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu installierenden Add-In, und klicken Sie dann auf OK.

    Tipp    Wenn das gewünschte Add-In im Feld Verfügbare Add-Ins nicht angezeigt wird, klicken Sie auf Hinzufügen, um das Add-In zu suchen.

Entfernen eines COM-Add-Ins

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf COM-Add-Ins, und klicken Sie dann auf Gehe zu.

    Das Dialogfeld COM-Add-Ins wird angezeigt.

  3. Deaktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu entfernenden Add-In, und klicken Sie auf OK.

    Hinweis    Daraufhin wird das Add-In aus dem Speicher entfernt, sein Name bleibt jedoch in der Liste der verfügbaren Add-Ins erhalten. Das Add-In wird nicht von Ihrem Computer entfernt.

  4. Wenn Sie ein COM-Add-In aus der Liste der verfügbaren Add-Ins entfernen und das Add-In auf Ihrem Computer löschen möchten, klicken Sie im Feld Verfügbare Add-Ins auf den Namen des Add-Ins, und klicken Sie dann auf Entfernen.

Seitenanfang

Hinzufügen oder Entfernen von Automatisierungs-Add-Ins

Hinweis : Wenn Sie Softwareentwickler sind, können Sie mit dieser Prozedur ein Automatisierungsprogramm installieren oder entfernen, bevor Sie Programme zum Installieren und Entfernen für Ihr Add-In entwickeln. Wenn Sie kein Entwickler sind, brauchen Sie diese Prozedur nicht zu verwenden. Wenden Sie sich an den Systemadministrator, der das Add-In bereitgestellt hat, wenn Sie Anweisungen zum Installieren und Entfernen benötigen.

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf Gehe zu.

    Das Dialogfeld Add-Ins wird angezeigt.

  3. Klicken Sie zum Installieren eines Automatisierungs-Add-Ins im Feld Verfügbare Automatisierungsserver auf Automatisierung, und klicken Sie dann auf das gewünschte Add-In.

    Tipp    Wenn das gewünschte Add-In nicht in der Liste aufgeführt ist, klicken Sie auf Durchsuchen, suchen Sie das Add-In, und klicken Sie dann auf OK.

  4. Wenn Sie ein Automatisierungs-Add-In entfernen möchten, müssen Sie es aus der Registrierung entfernen. Weitere Informationen erhalten Sie vom Systemadministrator.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×